Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Assemblée Générale Ordinaire de Borsalinux-fr de 2021

#1 Re : [Anciennes versions] Support général » [Résolu] Comment supprimer l'utilisateur lamda du groupe apache ? » 05/12/2020 17:28:14

Refuznik a écrit :

Bah oui pourquoi le -D ?
Normalement tu peux faire pour le retirer :

sudo usermod -G apache lamda

ou aussi

gpasswd -d apache lamda

Bonjour Refuznik, merci pour ta réponse,

Effectivement ça a marché avec la commande

gpasswd -d apache lamda

Merci beaucoup

#2 [Anciennes versions] Support général » [Résolu] Comment supprimer l'utilisateur lamda du groupe apache ? » 05/12/2020 13:16:34

fedora23
Réponses : 2

Bonjour,

Quelle commande me permet de supprimer l'utilisateur lamda du groupe apache ?

J'ai fais un test en ajoutant l'utilisateur lamda dans le groupe apache en faisant ceci :

sudo usermod -G apache -a lamda
groups apache
apache : apache lamda

Maintenant j'aimerais supprimer l'utilisataur lamda du groupe apache mais malheureusement l'option suivante n'existe pas :

sudo usermod -G apache -D lamda

avec l'option -D qui n'existe pas bien sûr.


Comment puis-je y remedier ?

Merci d'avance pour vos réponses

#3 Re : [Anciennes versions] Support général » [Résolu] CMS Grav ne fonctionne pas en locale sur fedora 30 LAMP » 12/10/2020 16:46:24

thierryR a écrit :

Tu peux essayer ceci:
Apache peut-il lire le fichier index.php contenant ça:

<?php 
    phpinfo();
 ?>

Pour savoir si apache peut accéder au dossier dans le home :

# su -l apache -c "ls ~mario/grav-admin" -s /bin/bash

Si tu as toujours une page blanche:
tu lances carrément un shell sous apache:

su -l apache -s /bin/bash

puis tu essayes de traverser étape par étape jusqu'à ce que ça bloque:

cd /home
cd mario
cd grav-admin
ls

ça y est ça a l'air de marcher !

voici le récap du problème : visiblement c'est le dézippage du dossier à la windows fait foirer quelque chose je m'explique, j'ai téléchargé grav-admin.xxx.zip, j'ai cliqué droit puis "extraire ici". Tout se passe en environnement graphique mais le dossier ne marche pas.

Solution :

$ unzip grav-admin.xxx.zip -d grav-admin

Ensuite un

$ sudo chown -R mario:apache grav-admin
$ systemctl restart httpd.service 

Ensuite direction navigateur : http://localhost.grav-admin

En tout cas merci thierryR et à tous ceux qui ont répondu, votre aide m'a été très précieuse.

NB : Comme a dit nouvo09 : ne jamais s'amuser avec chmod 777

#4 Re : [Anciennes versions] Support général » [Résolu] CMS Grav ne fonctionne pas en locale sur fedora 30 LAMP » 12/10/2020 13:25:17

thierryR a écrit :

Je sais que ça ne tombe pas du ciel. Mais on va y arriver.
Déjà, il faut que tu t'assures d'avoir une bonne installation.

dnf groupinstall "Serveur Web"

  (install de LAMP)
Ton archive doit être décompressée dans ton /home
Ensuite tu passes ça:

setsebool -P httpd_enable_homedirs 1
chcon -R -t httpd_sys_rw_content_t /home/mario/grav-admin

Les permissions sur mes fichiers n'ont pas changé. Tu devrais avoir mario:mario
Si tu as toujours un acces denied:
1) regarde dans les logs apache
2) regarde dans les logs selinux (/var/log/audit/audit.log)

Je me rappelle aussi avoir fait un chmod 777 sur mes dossiers.

J'ai faits les manip suivantes :

$cd /home/mario
$sudo dnf groupinstall "Serveur Web"
$sudo setsebool -P httpd_enable_homedirs 1
$chcon -R -t httpd_sys_rw_content_t /home/mario/grav-admin

$sudo setenforce 0
$systemctl restart httpd.service


Voici le contenu de /etc/hosts

$ sudo cat /etc/hosts

127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
::1         localhost localhost.localdomain localhost6 localhost6.localdomain6


127.0.0.1   localhost.grav-admin
::1         localhost.grav-admin

Voici le contenu de /etc/httpd/conf.d/grav-admin.conf

$ cat grav-admin.conf 
<VirtualHost *:80>
        # home du site : URL = http://localhost.grav-admin/
        ServerName localhost.grav-admin

        # Dossier contenant les pages
        DocumentRoot /home/mario/grav-admin

        <Directory /home/mario/grav-admin>

                AllowOverride all
                Require all granted

        </Directory>
	
</VirtualHost>

Dans le navigateur je rentre http://localhost.grav-admin

Résultat : PAGE BLANCHE

#5 Re : [Anciennes versions] Support général » [Résolu] CMS Grav ne fonctionne pas en locale sur fedora 30 LAMP » 09/10/2020 13:40:45

cezame a écrit :

Lorsque j'utilise un cms, je l'adresse par localhost/répertoire du cms, ou http://127.0.0.1/répertoire du cms pour autant qu'il soit sur mon poste de travail. A noter que souvent je dois mettre selinux en permissif (setenforce 0)

Bonjour, cezame et merci pour ta réponse.

nouvo09 a écrit :

Tu as pensé à SElinux ?(setenforce 0)

J'ai fais comme cezame avec

setenforce 0

Donc voilà un petit résumé juste pour faire fonctionner un fichier index.php qui ne marche même pas :

1) J'ai modifié le fichier grav-admin.conf comme ceci :

$ cat /etc/httpd/conf.d/grav-admin.conf 
<VirtualHost *:80>

         # Activation des sites de quelques utilisateurs : http://localhost/~mario

         UserDir  enabled  mario
         UserDir  grav-admin
        <Directory /home/*/grav-admin>
                AllowOverride all
                Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
        </Directory>
	
</VirtualHost>

2) le fichier index.php pour faire un test très simplement sans les centaines de fichiers du cms

 cat /home/mario/grav-admin/index.php 

Ceci est le contenu du fichier /home/mario/grav-admin/index.php
<?php
phpinfo();
?>

3) Le fichier /etc/hosts
$ cat /etc/hosts
127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
::1         localhost localhost.localdomain localhost6 localhost6.localdomain6

4) setenforce 0 comme a dit cezame

$ sudo setenforce 0

5) redémarre apache

$ systemctl restart httpd.service 

6) sur le navigateur je tape http://localhost/~mario

Résultat : Page blanche avec les mentions : FORBIDDEN You don't have permission to access this resource.

Quelles sont les permissions correctes ? J'ai essayé ceci :

drwxr-xr-x.  2 apache       apache        4096  9 oct.  10:39  grav-admin/

et ceci :

drwxr-xr-x.  2 mario      apache        4096  9 oct.  10:39  grav-admin/

et ceci :

drwxr-xr-x.  2 mario      mario        4096  9 oct.  10:39  grav-admin/

Mais rien ne fonctionne

#6 Re : [Anciennes versions] Support général » [Résolu] CMS Grav ne fonctionne pas en locale sur fedora 30 LAMP » 09/10/2020 11:42:39

nouvo09 a écrit :
sudo chown -R monnomdeconnexion:apache /var/www/grav-admin/

je ne suis pas sur du tout qu'il soit pertinent d'autoriser ton user à posséder et écrire dans /var

Bonjour nouvo09, merci pour ta réponse,

Effectivement je suis d'accord, mais pour le moment je cherche juste à comprendre comment faire fonctionner ce cms grav en local, dans /var/ ou dans /home/ peu importe, je cherche à comprendre où est-ce que ça bloque ?

#7 Re : [Anciennes versions] Support général » [Résolu] CMS Grav ne fonctionne pas en locale sur fedora 30 LAMP » 09/10/2020 11:35:17

thierryR a écrit :

Pour LAMP tu as une doc qui va t'aider: https://doc.fedora-fr.org/wiki/LAMP
Je ne vois pas pourquoi tu as modifié le fichier hosts.

Bonjour thierryR, merci pour ta réponse,

J'ai modifié le fichier hosts car ayant essayé localbyflywheel (LBF) pour wordpress en local, j'ai constaté ceci :

supposons que je teste le site wordpress en local appelé sitetestun.local, j'ai donc remarqué qu'automatiquement (bien évidemment il me demande l'autorisation) ,LBF configure le fichier /etc/hosts comme ceci :

$cat /etc/hosts

## Local by Flywheel - Start ##
::1 sitetestun.local #Local Site
127.0.0.1 sitetestun.local #Local Site
::1 www.sitetestun.local #Local Site

Je suppose que LBF fait ça afin d'avoir deux manières d'accéder au même dossier en utilisant "www.sitetestun.local" ou "sitetestun.local".

De la même manière, je voulais accéder sur le test du cms grav en tapant l'adresse http://site-grav

#8 [Anciennes versions] Support général » [Résolu] CMS Grav ne fonctionne pas en locale sur fedora 30 LAMP » 08/10/2020 10:52:08

fedora23
Réponses : 13

Bonjour,

J'essaie de faire fonctionner le CMS Grav en locale mais je soupçonne que j'ai un problème de configuration d'Apache que je n'arrive pas à résoudre ou manque de module ?
Voici les différentes manipulations que j'ai effectuées :

1) J'ai téléchargé grav-admin-v1.6.28.zip dans /home/mondossierperso/Téléchargements ensuite je l'ai extrait pour obtenir un dossier dezippé appelé grav-admin

2) Je déplace  grav-admin :

sudo mv /home/mondossierperso/Téléchargements/grav-admin-v1.6.28/grav-admin /var/www/

3) je le change de groupe pour qu'apache puisse avoir les droits dessus :

sudo chown -R monnomdeconnexion:apache /var/www/grav-admin/

4) je configure le virtualhost :

 cat /etc/httpd/conf.d/grav-admin.conf 

<VirtualHost *:80>
        # home du site : URL = http://grav-admin/
        ServerName grav-admin

        # Dossier contenant les pages
        DocumentRoot /var/www/grav-admin

        <Directory /var/www/grav-admin>

                AllowOverride all
                Require all granted

        </Directory>

        ErrorLog /var/log/httpd/error.grav-admin.log
        CustomLog /var/log/httpd/access.grav-admin.log combined
	
</VirtualHost>

5) configuration du fichier /etc/hosts :

cat /etc/hosts
127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
::1         localhost localhost.localdomain localhost6 localhost6.localdomain6

# Pour tester l'URL http://grav-admin
::1 grav-admin
127.0.0.1 grav-admin

6) je redémarre le serveur :

$ systemctl restart httpd.service

7) sur le navigateur je tape http://grav-admin

Résultat : une page blanche où c'est marqué :

Forbidden

You don't have permission to access this resource.Server unable to read htaccess file, denying access to be safe

8) Sur le navigateur j'ai essayé de taper http://admin-grav/admin

Résultat : une page blanche où c'est marqué :

Forbidden

You don't have permission to access this resource.Server unable to read htaccess file, denying access to be safe




Merci d'avance pour votre aide. Juste au passage, peut-on avoir en même temps apache et nginx sur la même machine ?

#9 Re : [Anciennes versions] Support général » [Résolu] LAMP - Comment faire fonctionner en local mon fichier test.php ? » 13/07/2020 17:28:57

Nicosss a écrit :

Si le sujet est résolu alors tu peux cliquer sur le bouton Sujet résolu.

Attention aux droits de tes fichiers aussi quand tu iras plus loin dans tes démarches, surtout si tu donnes accès à internet, voir même sur un intranet.

J'ai passé le sujet en résolu mais visiblement ça ne l'a pas pris en compte avant ton message.

Merci pour tes conseils concernant les droits sur mes fichiers. Je vais certainement avoir des soucis là-dessus mais à ce moment-là j'ouvrirai un nouveau sujet sur le bon forum :)

#10 Re : [Anciennes versions] Support général » [Résolu] LAMP - Comment faire fonctionner en local mon fichier test.php ? » 13/07/2020 10:48:15

fgland a écrit :

la syntaxe de phpinfo n'est pas bonne :
il faut

<?php phpinfo();
?>

ou

<?php 
phpinfo();
?>

il ne faut pas changement de ligne entre <? et php

pour le localhost, il y a toujours le message not found ?

Gérard

Désolé, nous nous sommes loupés à quelques minutes près.
Oui c'était  bien cette erreur de syntaxe la cause du problème.

Et oui, pour http://localhost/site1/test.php  m'affiche sur ma page :

Not Found

The requested URL was not found on this server.

#11 Re : [Anciennes versions] Support général » [Résolu] LAMP - Comment faire fonctionner en local mon fichier test.php ? » 13/07/2020 10:42:24

ça y est ça marche !!! J'ai trouvé l'erreur (très bête) :

Dans mon fichier test.php de base j'avais ceci :

$ cat /var/www/site1/test.php
<?
phpinfo();
?>

car j'ai copier-coller bêtement ce tuto

Or c'est celui-ci qui fonctionne :

$ cat /var/www/site1/test.php
<?php
phpinfo();
?>

Merci à vous tou(te)s pour votre temps et vos réponses, cela m'a beaucoup aidé

#12 Re : [Anciennes versions] Support général » [Résolu] LAMP - Comment faire fonctionner en local mon fichier test.php ? » 13/07/2020 10:07:13

fgland a écrit :
fedora23 a écrit :
http://site1/test.php

donne une page blache vide (Rmq: je tape bien http://site1/test.php mais une fois validée, le "http://" disparaît automatiquement) avant de m'afficher une page blanche vide).

http://localhost/test.php

me retourne une page blanche avec marquée  File not found.

1) si la page est vide sans erreur cela veut dire que le site marche, les navigateurs masquent le http::// masi il est bien là. Essaie d'abord avec une page html simple contenant par exemple

<!DOCTYPE html>
<html>
  <head>
    <title>Test</title>
  </head>
  <body>
    <h1>Test de site 1</h1>
  </body>
</html>

si le texte s'affiche, le problème est du coté du php, il faut regarder les logs

2) normal car le fichier est dans le sous dossier site1, il faut donc metttre http://localhost/site1/test.php, c'est une erreur de ma part
désolé

en regardant le premier message, on voit que la doc suivie est celle d'apache. php a-t-il été installé car il ne fait pas partie d'apache ?

Gérard

1) Pour le simple page html ça marche avec l'adresse http://site1/test.php,
et voici le résultat de

$ sudo cat /var/log/httpd/error_log

[Mon Jul 13 09:46:51.241584 2020] [core:notice] [pid 3516:tid 140540357648704] SELinux policy enabled; httpd running as context system_u:system_r:httpd_t:s0
[Mon Jul 13 09:46:51.354498 2020] [suexec:notice] [pid 3516:tid 140540357648704] AH01232: suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Mon Jul 13 09:46:51.425987 2020] [lbmethod_heartbeat:notice] [pid 3516:tid 140540357648704] AH02282: No slotmem from mod_heartmonitor
[Mon Jul 13 09:46:51.427726 2020] [http2:warn] [pid 3516:tid 140540357648704] AH02951: mod_ssl does not seem to be enabled
[Mon Jul 13 09:46:51.437574 2020] [mpm_event:notice] [pid 3516:tid 140540357648704] AH00489: Apache/2.4.41 (Fedora) configured -- resuming normal operations
[Mon Jul 13 09:46:51.437654 2020] [core:notice] [pid 3516:tid 140540357648704] AH00094: Command line: '/usr/sbin/httpd -D FOREGROUND'

mais je ne sais pas si cela concerne le test avec http://site1/test.php ou avec http://localhost/site1/test.php que j'ai testé ci-dessous (cf. 2))

2) en revanche ça ne marche pas avec http://localhost/site1/test.php
  (probablement à cause de ma config dans mon fichier /etc/httpd/conf.d/test.conf  ?)

Pour ce qui est de php j'ai ceci d'installé :

$ php -v
PHP 7.3.18 (cli) (built: May 12 2020 08:04:33) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.18, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.3.18, Copyright (c) 1999-2018, by Zend Technologies

#13 Re : [Anciennes versions] Support général » [Résolu] LAMP - Comment faire fonctionner en local mon fichier test.php ? » 12/07/2020 23:41:21

fgland a écrit :
fedora23 a écrit :

...
Et enfin quand je tape localhost/site1 dans mon navigateur, ça m'affiche


Not Found

The requested URL was not found on this server.
...
Merci d'avance pour vos réponses et votre temps

Bonjour,

cela me semble tout à fait normal, quand on ne donne pas un nom de fichier au navigateur, il recherche un index.html ou index.php qui ne semble pas exister.
Que donne

http://site1/test.php

Il ne faut pas indiquer le localhost, c’est le fichier hosts qui se charge de la résolution du nom de domaine

ou alors ignorer le virtualhost et taper

http://localhost/test.php

le résultat peut-être différent puisque la racine n’est plus la même

Gérard

http://site1/test.php

donne une page blache vide (Rmq: je tape bien http://site1/test.php mais une fois validée, le "http://" disparaît automatiquement) avant de m'afficher une page blanche vide).

http://localhost/test.php

me retourne une page blanche avec marquée  File not found.

#14 Re : [Anciennes versions] Support général » [Résolu] LAMP - Comment faire fonctionner en local mon fichier test.php ? » 12/07/2020 23:35:35

Nicosss a écrit :

Les droits sont bons ?

Que retourne

$ sudo ll /var/www/site1/test.php
$ sudo ls -lp /var/www/site1/test.php
-rw-r--r--. 1 root root 21 10 juil. 11:59 /var/www/site1/test.php

Quels sont les droits que je dois attribuer à qui ?

#15 Re : [Anciennes versions] Support général » [Résolu] LAMP - Comment faire fonctionner en local mon fichier test.php ? » 12/07/2020 23:33:17

Refuznik a écrit :

Et si tu fais un simple http://site1/test.php que donne-t-il ?

Quand je valide httpd://site1/test.php dans mon navigateur, il devient automatiquement site1/test.php sans le "http://" que j'ai écris au début, puis ça m'affiche une page blanche sans rien d'écrit.

#16 [Anciennes versions] Support général » [Résolu] LAMP - Comment faire fonctionner en local mon fichier test.php ? » 10/07/2020 11:54:30

fedora23
Réponses : 13

Bonjour,

Complètement largué quand il s'agit d'administration système, je viens ici pour solliciter de l'aide.

Objectif : taper l'adresse http://site1/ dans mon navigateur pour executer le fichier test.php en local

Apache est installé, c'est probablement au niveau de la configuration que j'ai un soucis ?
La doc que j'ai suivie se trouve ici.

Pour faire simple je vais résumer chaque contenu de mes fichiers de configurations concernés :

commençons par le fichier test.conf

$ cat /etc/httpd/conf.d/test.conf 
<VirtualHost *:80>
        # home du site : URL = http://site1/
        ServerName   site1

        # Dossier contenant les pages
        DocumentRoot /var/www/site1

        <Directory /var/www/site1>
                Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
                AllowOverride FileInfo AuthConfig Limit
        </Directory>

        # jeu de caractères (UTF-8 par défaut)
        AddDefaultCharset ISO-8859-1
</VirtualHost>
[ajean07fed25@linux conf.d]$ 

ensuite le fichier hosts

$ cat /etc/hosts
127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
::1         localhost localhost.localdomain localhost6 localhost6.localdomain6

# Pour tester l'URL http://site1
::1 site1
127.0.0.1 site1

Et enfin le contenu du fichier test.php

$ cat /var/www/site1/test.php 
<?
php phpinfo();
?>

J'active lance apache

$ systemctl start  httpd.service

Et enfin quand je tape localhost/site1 dans mon navigateur, ça m'affiche


Not Found

The requested URL was not found on this server.



Merci d'avance pour vos réponses et votre temps

#17 Re : [Anciennes versions] Support général » [Résolu] Partitions en mode lecture seule » 02/07/2020 12:06:31

nouvo09 a écrit :
fedora23 a écrit :

Dès fois sans pouvoir l'expliquer, la partition est à nouveau en mode "read-only file system".
Solution, j'ai appliqué la commande proposée par cezame :

C'est une erreur. Si une partition se monte ro, il peut y avoir une raison. Il ne faut pas la remonter rw sans avoir préalablement exécuté un fsck.

Voici le résultat de la commande fsck :

sudo fsck /dev/sda5

fsck de util-linux 2.33.2
Unsupported: replay_log()
Unsupported: check_volume()
Checking 256 MFT records.
Unsupported cases found.
ntfsck was unable to run properly.

Cela m'indique juste les informations sans m'indiquer une solution pour résoudre le problème ?

Par le test suivant, je soupçonne que c'est bien W10 qui est la source du problème :

$ sudo mount /dev/sda5 .
The disk contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Falling back to read-only mount because the NTFS partition is in an
unsafe state. Please resume and shutdown Windows fully (no hibernation
or fast restarting.)

#18 Re : [Anciennes versions] Support général » [Résolu] Partitions en mode lecture seule » 23/06/2020 11:59:46

cezame a écrit :

Une petite documentation pour aider: https://www.linuxtricks.fr/wiki/fstab-e … -structure

Dès fois sans pouvoir l'expliquer, la partition est à nouveau en mode "read-only file system".
Solution, j'ai appliqué la commande proposée par cezame :

sudo mount -o remount,rw /dev/sda5

#19 Re : [Anciennes versions] Support général » LAMP - Travailler sur un dossier dans /home/ et non dans /var/www/ » 08/06/2020 08:38:26

madko a écrit :

Un sudo pour modifier chaque fichier ? La bonne pratique serait d'avoir les bonnes permissions pour que tu puisses modifier les fichier dans /var/www ou /srv/ce que tu veux, /home c'est assez rare.

Après pour un developpeur, on travaille plutôt maintenant avec des conteneurs via podman.

Merci beaucoup  pour les infos, je n'ai jamais utilisé docker ou podman mais ce sera un début, je me pencherai sur le sujet.

#20 Re : [Anciennes versions] Support général » LAMP - Travailler sur un dossier dans /home/ et non dans /var/www/ » 07/06/2020 13:15:26

nouvo09 a écrit :

Perso je pense que développer chez soi pour ensuite mettre en ligne c'est un sacré pari

Chez OVH tu as une offre KIMSUFI à 1,79 € HT /mois. meme sans nom de domaine. Ca semble bon pour des tests grandeur réelle.

Bonjour,

merci pour la réponse, en fait il s'agit d'un site déjà en production que je veux git cloner en local pour fair des modifs ensuite faire un git push vers la prod

#21 Re : [Anciennes versions] Support général » LAMP - Travailler sur un dossier dans /home/ et non dans /var/www/ » 07/06/2020 13:12:31

thierryR a écrit :

ça marche chez moi, mais il faut mettre les mains dans le cambouis.
Comme dit Madko, il te faut déjà choisir la stratégie. Donc je te pose la même question:
Une raison de ne pas travailler dans /var/www ? Ou veux tu rester dans ton /home/ ?

Bonjour,

Merci pour la réponse,

Le problème est résolu mais pour répondre à la question ci-dessus, mon éditeur de texte est ouvert dans /home donc je peux modifier tous les fichiers que je veux dedans. Dans /var/www/

Or, si tous les fichiers concernant wordpress est dans /var/www/ càd /var/www/wordpress/, je dois faire un sudo pour chaque modification de fichier., ce qui n'est pas possible pour devélopper.

L'idée c'est que j'ai fais un "git clone wordpress" (l'entièreté de wordpress en production), je fais les modifs et tests en local (dans /var/www/ si je peux modifier tous les fichiers à l'aide de mon éditeur de texte sans restriction), ensuite faire un "git push wordpress" vers prod.

Quelle serait la bonne pratique plus simple ?

#22 Re : [Anciennes versions] Support général » LAMP - Travailler sur un dossier dans /home/ et non dans /var/www/ » 07/06/2020 13:01:52

Refuznik a écrit :

As tu modifié la configuration d'Apache au moins pour pointer sur ton  /home/mondossierperso/wordpress ?
https://doc.fedora-fr.org/wiki/Installa … d.27Apache

Bonjour,

Merci pour la réponse, j'ai ajouté la directive VirtualHost et ça a marché.

#23 [Anciennes versions] Support général » LAMP - Travailler sur un dossier dans /home/ et non dans /var/www/ » 05/06/2020 12:30:04

fedora23
Réponses : 9

Bonjour,

Veuillez m'excuser si je ne suis pas au bon endroit pour ce sujet.

Situation : je souhaiterai devélopper un site wordpress en local qui sera ensuite destiné à être mis en production.

Ce que j'ai fais :

  1/ j'ai installé wordpress en local mais ça ne me convient pas pour la raison suivante : le fichier de configuration wp-config.php de wordpress est installé dans /etc/wordpress et le reste des fichiers et dossiers de wordpress est installé dans /var/www/html/wordpress et pour chaque modification il faut être en mode sudo donc développement impossible.

  2/ J'ai installé wordpress dans /home/mondossierperso/wordpress donc tous les dossiers et fichiers de wordpress est dedans. Mais quand j'essai d'accéder à la page localhost/wordpress, ça m'affiche "Accès refusé" par le navigateur.
  Pour  faire tourner http://localhost/wordpress il faut absolument que le dossier de wordpress soit dans  /var/www/html/wordpress (c'est la configuration de httpd)

Ma solution souhaitée :
Enregistrer la totalité du dossier wordpress dans /home/mondossierperso/wordpress mais je ne sais pas comment configurer Apache pour cela ?


Merci d'avance pour vos réponses

#24 Re : [Anciennes versions] Support général » [Résolu] Partitions en mode lecture seule » 20/03/2020 17:38:47

Merci à tous pour vos réponses, un truc très BIZARRE, je viens d'allumer le PC pour essayer de résoudre le problème, je n'ai encore fait aucune manipulation, j'ai juste monté chaque partition comme au post #1 (ie. à l'aide de l'interface graphique de gnome, j'ai cliqué droit et comme par miracle les partitions sont à nouveau en mode écriture et lecture !).

Je ne sais pas ce qui a buguer.

En tout cas encore merci à toutes les personnes qui ont pu me répondre :)

#25 Re : [Anciennes versions] Support général » [Résolu] Partitions en mode lecture seule » 18/03/2020 21:49:20

Nednet a écrit :

hello,

je fais un truc du même genre (dual boot, accès aux partitions win depuis Fedo), mais je les monte via fstab, donc elles ne sont pas en "ro" ("read only")

Merci pour la réponse.

Est-ce que je dois alors faire ceci ?

[root@localhost ~]$ mount -a
[root@localhost ~]$ mount -o remount /dev/sda5
[root@localhost ~]$ mount -o remount /dev/sda3

?

Pied de page des forums

Propulsé par FluxBB