Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Stand Fedora-Fr sur Paris Open Source Summit 2019

#1 Re : Le comptoir du libre » [ARTE] Internet ou la révolution du partage » 18/05/2019 14:05:39

Il y a aussi ce plugin pour firefox/chromium qui ajoute directement des boutons sur le site d'Arte :
https://github.com/GuGuss/ARTE-7-Downloader

#2 Re : [F30] Support général » [Résolu]Miseàjour sur config 2 écrans:mon écran principal devient noir » 16/05/2019 21:53:29

Finalement, beaucoup de manipulatons pour rien : c'est un problème matériel.

J'ai débranché et rebranché l'écran et maintenant tout fonctionne bien avec la dernière version du pilote NVIDIA.

hammer

#3 Re : [F30] Support général » [Résolu]Miseàjour sur config 2 écrans:mon écran principal devient noir » 16/05/2019 21:45:18

Tentative de downgrade du paquet kmod-nvidia :

$ sudo dnf --showduplicates list akmod-nvidia
../..
Paquets installés
akmod-nvidia.x86_64        3:418.74-1.fc30         @rpmfusion-nonfree-updates
Paquets disponibles
akmod-nvidia.x86_64        3:418.56-2.fc30         rpmfusion-nonfree         
akmod-nvidia.x86_64        3:418.74-1.fc30         rpmfusion-nonfree-updates

Je remet l'ancien paquet :

$ sudo dnf downgrade akmod-nvidia
../..
Dépendances résolues.
=============================================================================
 Paquet           Architecture
                             Version             Dépôt                 Taille
=============================================================================
Rétrogradation:
 akmod-nvidia     x86_64     3:418.56-2.fc30     rpmfusion-nonfree      26 k

Résumé de la transaction
=============================================================================
Retrograder  1 Paquet

Taille totale des téléchargements : 26 k
Voulez-vous continuer ? [o/N] : o
Téléchargement des paquets :
akmod-nvidia-418.56-2.fc30.x86_64.rpm         71 kB/s |  26 kB     00:00    
-----------------------------------------------------------------------------
Total                                         39 kB/s |  26 kB     00:00     
Test de la transaction en cours
La vérification de la transaction a réussi.
Lancement de la transaction de test
Transaction de test réussie.
Exécution de la transaction
  Préparation en cours  :                                                1/1 
  Rétrogradation        : akmod-nvidia-3:418.56-2.fc30.x86_64            1/2 
  Exécution du scriptlet: akmod-nvidia-3:418.56-2.fc30.x86_64            1/2 
  Nettoyage de          : akmod-nvidia-3:418.74-1.fc30.x86_64            2/2 
  Exécution du scriptlet: akmod-nvidia-3:418.56-2.fc30.x86_64            2/2 
  Vérification de       : akmod-nvidia-3:418.56-2.fc30.x86_64            1/2 
  Vérification de       : akmod-nvidia-3:418.74-1.fc30.x86_64            2/2 

Rétrogradé:
  akmod-nvidia-3:418.56-2.fc30.x86_64                                        

Terminé !

Je reboote la machine...

#4 [F30] Support général » [Résolu]Miseàjour sur config 2 écrans:mon écran principal devient noir » 16/05/2019 19:15:13

Yannick@ekiga
Réponses : 2

Bonjour,

Je fais une mise à jour ce soir et après sur ma config avec 2 écran, mon écran principal devient noir. Je tente sur un ancien noyau qui fonctionnait bien : même soucis.
La mise à jour à changé la version des drivers Nvidia (j'utilise une carte graphique Nvidia), ce qui se répercute aussi sur les anciens noyaux. D'ailleurs, à la mise à jour du noyau pour le pilote Nvidia le système refuse de lancer gdm et reste bloqué sur une console de mise à jour, mais après un reboot ça passe gdm et sur Gnome je n'ai plus qu'un seul écran de fonctionnel (le second).

Des détails sur la mise à jour :
Mise à jour du pilote Nvidia de 418.56-2 vers 418.74-1. (ce qui se vérifie avec l'utilitaire "NVIDIA X Server Settings" qui prouve que le pilote est bien actif)
Pour le moment ma piste seraitun soucis avec ce pilote. Je vais tenter un retour en arrière sur la mise à jour...

$ sudo dnf history list
[sudo] Mot de passe de XXX : 
ID     | Ligne de commande        | Date et heure    | Action(s)      | Modifié
-------------------------------------------------------------------------------
   275 | -y install --disablerepo | 2019-05-16 18:54 | Upgrade        |    1   
   274 | -y install --disablerepo | 2019-05-16 18:39 | Upgrade        |    1   
   273 |                          | 2019-05-16 18:37 | E, I, U        |   66   
 
$ sudo dnf history info 275
Identifiant de transaction : 275
Temps de début    : jeu. 16 mai 2019 18:54:28 CEST
Début de RPMDB    : 3380:5c794a67ca3fd09632491e246e7eb7c58cae5f4d
Temps de fin : jeu. 16 mai 2019 18:54:37 CEST (9 secondes)
Fin de RPMDB : 3380:0508766615ae7c6ad540bc939e000037336b2d52
Utilisateur  : Système <unset>
Code de retour  : Réussi
Releasever     : 30
Ligne de commande : -y install --disablerepo=* /tmp/akmods.GDzcPD3p/results/kmod-nvidia-5.0.14-300.fc30.x86_64-418.74-1.fc30.x86_64.rpm
Paquets modifiés :
    Upgrade  kmod-nvidia-5.0.14-300.fc30.x86_64-3:418.74-1.fc30.x86_64 @@commandline
    Upgraded kmod-nvidia-5.0.14-300.fc30.x86_64-3:418.56-2.fc30.x86_64 @@System
[XXX@YYY ~]$ sudo dnf history info 274
Identifiant de transaction : 274
Temps de début    : jeu. 16 mai 2019 18:39:58 CEST
Début de RPMDB    : 3380:9b88235975cdfb8f9c384b0d021894f933a12304
Temps de fin : jeu. 16 mai 2019 18:40:08 CEST (10 secondes)
Fin de RPMDB : 3380:5c794a67ca3fd09632491e246e7eb7c58cae5f4d
Utilisateur  : Système <unset>
Code de retour  : Réussi
Releasever     : 30
Ligne de commande : -y install --disablerepo=* /tmp/akmods.A6h3Kd1c/results/kmod-nvidia-5.0.16-300.fc30.x86_64-418.74-1.fc30.x86_64.rpm
Paquets modifiés :
    Upgrade  kmod-nvidia-5.0.16-300.fc30.x86_64-3:418.74-1.fc30.x86_64 @@commandline
    Upgraded kmod-nvidia-5.0.16-300.fc30.x86_64-3:418.56-2.fc30.x86_64 @@System
[XXX@YYY ~]$ sudo dnf history info 273
Identifiant de transaction : 273
Temps de début    : jeu. 16 mai 2019 18:37:37 CEST
Début de RPMDB    : 3378:c94c21aa48347c0ef96b3aa666df1fa2e0ec7f6f
Temps de fin : jeu. 16 mai 2019 18:38:22 CEST (45 secondes)
Fin de RPMDB : 3380:9b88235975cdfb8f9c384b0d021894f933a12304
Utilisateur  : root <root>
Code de retour  : Réussi
Releasever     : 
Ligne de commande : 
Paquets modifiés :
    Installer ebtables-compat-2.0.10-35.fc30.x86_64                @updates
    Installer ebtables-legacy-2.0.10-35.fc30.x86_64                @updates
    Installer ebtables-services-2.0.10-35.fc30.x86_64              @updates
    Upgrade   appstream-data-30-6.fc30.noarch                      @updates
    Upgrade   bash-5.0.7-1.fc30.x86_64                             @updates
    Upgrade   boost-atomic-1.69.0-8.fc30.x86_64                    @updates
    Upgrade   boost-chrono-1.69.0-8.fc30.x86_64                    @updates
    Upgrade   boost-date-time-1.69.0-8.fc30.x86_64                 @updates
    Upgrade   boost-filesystem-1.69.0-8.fc30.x86_64                @updates
    Upgrade   boost-iostreams-1.69.0-8.fc30.x86_64                 @updates
    Upgrade   boost-locale-1.69.0-8.fc30.x86_64                    @updates
    Upgrade   boost-program-options-1.69.0-8.fc30.x86_64           @updates
    Upgrade   boost-random-1.69.0-8.fc30.x86_64                    @updates
    Upgrade   boost-regex-1.69.0-8.fc30.x86_64                     @updates
    Upgrade   boost-system-1.69.0-8.fc30.x86_64                    @updates
    Upgrade   boost-thread-1.69.0-8.fc30.x86_64                    @updates
    Upgrade   evince-3.32.0-2.fc30.x86_64                          @updates
    Upgrade   evince-djvu-3.32.0-2.fc30.x86_64                     @updates
    Upgrade   evince-libs-3.32.0-2.fc30.x86_64                     @updates
    Upgrade   evince-nautilus-3.32.0-2.fc30.x86_64                 @updates
    Upgrade   gnome-shell-3.32.2-1.fc30.x86_64                     @updates
    Upgrade   iwl100-firmware-39.31.5.1-96.fc30.noarch             @updates
    Upgrade   iwl1000-firmware-1:39.31.5.1-96.fc30.noarch          @updates
    Upgrade   iwl105-firmware-18.168.6.1-96.fc30.noarch            @updates
    Upgrade   iwl135-firmware-18.168.6.1-96.fc30.noarch            @updates
    Upgrade   iwl2000-firmware-18.168.6.1-96.fc30.noarch           @updates
    Upgrade   iwl2030-firmware-18.168.6.1-96.fc30.noarch           @updates
    Upgrade   iwl3160-firmware-1:25.30.13.0-96.fc30.noarch         @updates
    Upgrade   iwl3945-firmware-15.32.2.9-96.fc30.noarch            @updates
    Upgrade   iwl4965-firmware-228.61.2.24-96.fc30.noarch          @updates
    Upgrade   iwl5000-firmware-8.83.5.1_1-96.fc30.noarch           @updates
    Upgrade   iwl5150-firmware-8.24.2.2-96.fc30.noarch             @updates
    Upgrade   iwl6000-firmware-9.221.4.1-96.fc30.noarch            @updates
    Upgrade   iwl6000g2a-firmware-18.168.6.1-96.fc30.noarch        @updates
    Upgrade   iwl6000g2b-firmware-18.168.6.1-96.fc30.noarch        @updates
    Upgrade   iwl6050-firmware-41.28.5.1-96.fc30.noarch            @updates
    Upgrade   iwl7260-firmware-1:25.30.13.0-96.fc30.noarch         @updates
    Upgrade   libertas-usb8388-firmware-2:20190514-96.fc30.noarch  @updates
    Upgrade   libsmbclient-2:4.10.3-0.fc30.x86_64                  @updates
    Upgrade   libwbclient-2:4.10.3-0.fc30.x86_64                   @updates
    Upgrade   linux-firmware-20190514-96.fc30.noarch               @updates
    Upgrade   linux-firmware-whence-20190514-96.fc30.noarch        @updates
    Upgrade   mutter-3.32.2-1.fc30.x86_64                          @updates
    Upgrade   nim-srpm-macros-2-1.fc30.noarch                      @updates
    Upgrade   perl-libwww-perl-6.39-1.fc30.noarch                  @updates
    Upgrade   samba-client-2:4.10.3-0.fc30.x86_64                  @updates
    Upgrade   samba-client-libs-2:4.10.3-0.fc30.x86_64             @updates
    Upgrade   samba-common-2:4.10.3-0.fc30.noarch                  @updates
    Upgrade   samba-common-libs-2:4.10.3-0.fc30.x86_64             @updates
    Upgrade   samba-common-tools-2:4.10.3-0.fc30.x86_64            @updates
    Upgrade   samba-libs-2:4.10.3-0.fc30.x86_64                    @updates
    Upgrade   samba-winbind-2:4.10.3-0.fc30.x86_64                 @updates
    Upgrade   samba-winbind-clients-2:4.10.3-0.fc30.x86_64         @updates
    Upgrade   samba-winbind-modules-2:4.10.3-0.fc30.x86_64         @updates
    Upgrade   tmux-2.9a-2.fc30.x86_64                              @updates
    Upgrade   akmod-nvidia-3:418.74-1.fc30.x86_64                  @rpmfusion-nonfree-updates
    Upgrade   nvidia-persistenced-3:418.74-1.fc30.x86_64           @rpmfusion-nonfree-updates
    Upgrade   nvidia-settings-3:418.74-1.fc30.x86_64               @rpmfusion-nonfree-updates
    Upgrade   xorg-x11-drv-nvidia-3:418.74-1.fc30.x86_64           @rpmfusion-nonfree-updates
    Upgrade   xorg-x11-drv-nvidia-cuda-3:418.74-1.fc30.x86_64      @rpmfusion-nonfree-updates
    Upgrade   xorg-x11-drv-nvidia-cuda-libs-3:418.74-1.fc30.i686   @rpmfusion-nonfree-updates
    Upgrade   xorg-x11-drv-nvidia-cuda-libs-3:418.74-1.fc30.x86_64 @rpmfusion-nonfree-updates
    Upgrade   xorg-x11-drv-nvidia-kmodsrc-3:418.74-1.fc30.x86_64   @rpmfusion-nonfree-updates
    Upgrade   xorg-x11-drv-nvidia-libs-3:418.74-1.fc30.i686        @rpmfusion-nonfree-updates
    Upgrade   xorg-x11-drv-nvidia-libs-3:418.74-1.fc30.x86_64      @rpmfusion-nonfree-updates
    Removed   ebtables-2.0.10-31.fc30.x86_64                       @@System
    Upgraded  appstream-data-30-5.fc30.noarch                      @@System
    Upgraded  bash-5.0.2-1.fc30.x86_64                             @@System
    Upgraded  boost-atomic-1.69.0-6.fc30.x86_64                    @@System
    Upgraded  boost-chrono-1.69.0-6.fc30.x86_64                    @@System
    Upgraded  boost-date-time-1.69.0-6.fc30.x86_64                 @@System
    Upgraded  boost-filesystem-1.69.0-6.fc30.x86_64                @@System
    Upgraded  boost-iostreams-1.69.0-6.fc30.x86_64                 @@System
    Upgraded  boost-locale-1.69.0-6.fc30.x86_64                    @@System
    Upgraded  boost-program-options-1.69.0-6.fc30.x86_64           @@System
    Upgraded  boost-random-1.69.0-6.fc30.x86_64                    @@System
    Upgraded  boost-regex-1.69.0-6.fc30.x86_64                     @@System
    Upgraded  boost-system-1.69.0-6.fc30.x86_64                    @@System
    Upgraded  boost-thread-1.69.0-6.fc30.x86_64                    @@System
    Upgraded  evince-3.32.0-1.fc30.x86_64                          @@System
    Upgraded  evince-djvu-3.32.0-1.fc30.x86_64                     @@System
    Upgraded  evince-libs-3.32.0-1.fc30.x86_64                     @@System
    Upgraded  evince-nautilus-3.32.0-1.fc30.x86_64                 @@System
    Upgraded  gnome-shell-3.32.1-1.fc30.x86_64                     @@System
    Upgraded  iwl100-firmware-39.31.5.1-95.fc30.noarch             @@System
    Upgraded  iwl1000-firmware-1:39.31.5.1-95.fc30.noarch          @@System
    Upgraded  iwl105-firmware-18.168.6.1-95.fc30.noarch            @@System
    Upgraded  iwl135-firmware-18.168.6.1-95.fc30.noarch            @@System
    Upgraded  iwl2000-firmware-18.168.6.1-95.fc30.noarch           @@System
    Upgraded  iwl2030-firmware-18.168.6.1-95.fc30.noarch           @@System
    Upgraded  iwl3160-firmware-1:25.30.13.0-95.fc30.noarch         @@System
    Upgraded  iwl3945-firmware-15.32.2.9-95.fc30.noarch            @@System
    Upgraded  iwl4965-firmware-228.61.2.24-95.fc30.noarch          @@System
    Upgraded  iwl5000-firmware-8.83.5.1_1-95.fc30.noarch           @@System
    Upgraded  iwl5150-firmware-8.24.2.2-95.fc30.noarch             @@System
    Upgraded  iwl6000-firmware-9.221.4.1-95.fc30.noarch            @@System
    Upgraded  iwl6000g2a-firmware-18.168.6.1-95.fc30.noarch        @@System
    Upgraded  iwl6000g2b-firmware-18.168.6.1-95.fc30.noarch        @@System
    Upgraded  iwl6050-firmware-41.28.5.1-95.fc30.noarch            @@System
    Upgraded  iwl7260-firmware-1:25.30.13.0-95.fc30.noarch         @@System
    Upgraded  libertas-usb8388-firmware-2:20190416-95.fc30.noarch  @@System
    Upgraded  libsmbclient-2:4.10.2-1.1.fc30.x86_64                @@System
    Upgraded  libwbclient-2:4.10.2-1.1.fc30.x86_64                 @@System
    Upgraded  linux-firmware-20190416-95.fc30.noarch               @@System
    Upgraded  linux-firmware-whence-20190416-95.fc30.noarch        @@System
    Upgraded  mutter-3.32.1-1.fc30.x86_64                          @@System
    Upgraded  nim-srpm-macros-1-4.fc30.noarch                      @@System
    Upgraded  perl-libwww-perl-6.38-1.fc30.noarch                  @@System
    Upgraded  samba-client-2:4.10.2-1.1.fc30.x86_64                @@System
    Upgraded  samba-client-libs-2:4.10.2-1.1.fc30.x86_64           @@System
    Upgraded  samba-common-2:4.10.2-1.1.fc30.noarch                @@System
    Upgraded  samba-common-libs-2:4.10.2-1.1.fc30.x86_64           @@System
    Upgraded  samba-common-tools-2:4.10.2-1.1.fc30.x86_64          @@System
    Upgraded  samba-libs-2:4.10.2-1.1.fc30.x86_64                  @@System
    Upgraded  samba-winbind-2:4.10.2-1.1.fc30.x86_64               @@System
    Upgraded  samba-winbind-clients-2:4.10.2-1.1.fc30.x86_64       @@System
    Upgraded  samba-winbind-modules-2:4.10.2-1.1.fc30.x86_64       @@System
    Upgraded  tmux-2.8-3.fc30.x86_64                               @@System
    Upgraded  akmod-nvidia-3:418.56-2.fc30.x86_64                  @@System
    Upgraded  nvidia-persistenced-3:418.56-1.fc30.x86_64           @@System
    Upgraded  nvidia-settings-3:418.56-1.fc30.x86_64               @@System
    Upgraded  xorg-x11-drv-nvidia-3:418.56-1.fc30.x86_64           @@System
    Upgraded  xorg-x11-drv-nvidia-cuda-3:418.56-1.fc30.x86_64      @@System
    Upgraded  xorg-x11-drv-nvidia-cuda-libs-3:418.56-1.fc30.i686   @@System
    Upgraded  xorg-x11-drv-nvidia-cuda-libs-3:418.56-1.fc30.x86_64 @@System
    Upgraded  xorg-x11-drv-nvidia-kmodsrc-3:418.56-1.fc30.x86_64   @@System
    Upgraded  xorg-x11-drv-nvidia-libs-3:418.56-1.fc30.i686        @@System
    Upgraded  xorg-x11-drv-nvidia-libs-3:418.56-1.fc30.x86_64      @@System

Tentative de retour en arrière :

$ sudo dnf history rollback 272

Ça ne fonctionne pas sad

Rollback to transaction 272, from mer. 15 mai 2019 20:33:32 CEST
  Undoing the following transactions: 273, 274, 275
    Upgraded  akmod-nvidia-3:418.56-2.fc30.x86_64                       @@System
    Upgrade   akmod-nvidia-3:418.74-1.fc30.x86_64                       @rpmfusion-nonfree-updates
    Upgraded  appstream-data-30-5.fc30.noarch                           @@System
    Upgrade   appstream-data-30-6.fc30.noarch                           @updates
    Upgraded  bash-5.0.2-1.fc30.x86_64                                  @@System
    Upgrade   bash-5.0.7-1.fc30.x86_64                                  @updates
    Upgraded  boost-atomic-1.69.0-6.fc30.x86_64                         @@System
    Upgrade   boost-atomic-1.69.0-8.fc30.x86_64                         @updates
    Upgraded  boost-chrono-1.69.0-6.fc30.x86_64                         @@System
    Upgrade   boost-chrono-1.69.0-8.fc30.x86_64                         @updates
    Upgraded  boost-date-time-1.69.0-6.fc30.x86_64                      @@System
    Upgrade   boost-date-time-1.69.0-8.fc30.x86_64                      @updates
    Upgraded  boost-filesystem-1.69.0-6.fc30.x86_64                     @@System
    Upgrade   boost-filesystem-1.69.0-8.fc30.x86_64                     @updates
    Upgraded  boost-iostreams-1.69.0-6.fc30.x86_64                      @@System
    Upgrade   boost-iostreams-1.69.0-8.fc30.x86_64                      @updates
    Upgraded  boost-locale-1.69.0-6.fc30.x86_64                         @@System
    Upgrade   boost-locale-1.69.0-8.fc30.x86_64                         @updates
    Upgraded  boost-program-options-1.69.0-6.fc30.x86_64                @@System
    Upgrade   boost-program-options-1.69.0-8.fc30.x86_64                @updates
    Upgraded  boost-random-1.69.0-6.fc30.x86_64                         @@System
    Upgrade   boost-random-1.69.0-8.fc30.x86_64                         @updates
    Upgraded  boost-regex-1.69.0-6.fc30.x86_64                          @@System
    Upgrade   boost-regex-1.69.0-8.fc30.x86_64                          @updates
    Upgraded  boost-system-1.69.0-6.fc30.x86_64                         @@System
    Upgrade   boost-system-1.69.0-8.fc30.x86_64                         @updates
    Upgraded  boost-thread-1.69.0-6.fc30.x86_64                         @@System
    Upgrade   boost-thread-1.69.0-8.fc30.x86_64                         @updates
    Removed   ebtables-2.0.10-31.fc30.x86_64                            @@System
    Installer ebtables-compat-2.0.10-35.fc30.x86_64                     @updates
    Installer ebtables-legacy-2.0.10-35.fc30.x86_64                     @updates
    Installer ebtables-services-2.0.10-35.fc30.x86_64                   @updates
    Upgraded  evince-3.32.0-1.fc30.x86_64                               @@System
    Upgrade   evince-3.32.0-2.fc30.x86_64                               @updates
    Upgraded  evince-djvu-3.32.0-1.fc30.x86_64                          @@System
    Upgrade   evince-djvu-3.32.0-2.fc30.x86_64                          @updates
    Upgraded  evince-libs-3.32.0-1.fc30.x86_64                          @@System
    Upgrade   evince-libs-3.32.0-2.fc30.x86_64                          @updates
    Upgraded  evince-nautilus-3.32.0-1.fc30.x86_64                      @@System
    Upgrade   evince-nautilus-3.32.0-2.fc30.x86_64                      @updates
    Upgraded  gnome-shell-3.32.1-1.fc30.x86_64                          @@System
    Upgrade   gnome-shell-3.32.2-1.fc30.x86_64                          @updates
    Upgraded  iwl100-firmware-39.31.5.1-95.fc30.noarch                  @@System
    Upgrade   iwl100-firmware-39.31.5.1-96.fc30.noarch                  @updates
    Upgraded  iwl1000-firmware-1:39.31.5.1-95.fc30.noarch               @@System
    Upgrade   iwl1000-firmware-1:39.31.5.1-96.fc30.noarch               @updates
    Upgraded  iwl105-firmware-18.168.6.1-95.fc30.noarch                 @@System
    Upgrade   iwl105-firmware-18.168.6.1-96.fc30.noarch                 @updates
    Upgraded  iwl135-firmware-18.168.6.1-95.fc30.noarch                 @@System
    Upgrade   iwl135-firmware-18.168.6.1-96.fc30.noarch                 @updates
    Upgraded  iwl2000-firmware-18.168.6.1-95.fc30.noarch                @@System
    Upgrade   iwl2000-firmware-18.168.6.1-96.fc30.noarch                @updates
    Upgraded  iwl2030-firmware-18.168.6.1-95.fc30.noarch                @@System
    Upgrade   iwl2030-firmware-18.168.6.1-96.fc30.noarch                @updates
    Upgraded  iwl3160-firmware-1:25.30.13.0-95.fc30.noarch              @@System
    Upgrade   iwl3160-firmware-1:25.30.13.0-96.fc30.noarch              @updates
    Upgraded  iwl3945-firmware-15.32.2.9-95.fc30.noarch                 @@System
    Upgrade   iwl3945-firmware-15.32.2.9-96.fc30.noarch                 @updates
    Upgraded  iwl4965-firmware-228.61.2.24-95.fc30.noarch               @@System
    Upgrade   iwl4965-firmware-228.61.2.24-96.fc30.noarch               @updates
    Upgraded  iwl5000-firmware-8.83.5.1_1-95.fc30.noarch                @@System
    Upgrade   iwl5000-firmware-8.83.5.1_1-96.fc30.noarch                @updates
    Upgraded  iwl5150-firmware-8.24.2.2-95.fc30.noarch                  @@System
    Upgrade   iwl5150-firmware-8.24.2.2-96.fc30.noarch                  @updates
    Upgraded  iwl6000-firmware-9.221.4.1-95.fc30.noarch                 @@System
    Upgrade   iwl6000-firmware-9.221.4.1-96.fc30.noarch                 @updates
    Upgraded  iwl6000g2a-firmware-18.168.6.1-95.fc30.noarch             @@System
    Upgrade   iwl6000g2a-firmware-18.168.6.1-96.fc30.noarch             @updates
    Upgraded  iwl6000g2b-firmware-18.168.6.1-95.fc30.noarch             @@System
    Upgrade   iwl6000g2b-firmware-18.168.6.1-96.fc30.noarch             @updates
    Upgraded  iwl6050-firmware-41.28.5.1-95.fc30.noarch                 @@System
    Upgrade   iwl6050-firmware-41.28.5.1-96.fc30.noarch                 @updates
    Upgraded  iwl7260-firmware-1:25.30.13.0-95.fc30.noarch              @@System
    Upgrade   iwl7260-firmware-1:25.30.13.0-96.fc30.noarch              @updates
    Upgraded  kmod-nvidia-5.0.14-300.fc30.x86_64-3:418.56-2.fc30.x86_64 @@System
    Upgrade   kmod-nvidia-5.0.14-300.fc30.x86_64-3:418.74-1.fc30.x86_64 @@commandline
    Upgraded  kmod-nvidia-5.0.16-300.fc30.x86_64-3:418.56-2.fc30.x86_64 @@System
    Upgrade   kmod-nvidia-5.0.16-300.fc30.x86_64-3:418.74-1.fc30.x86_64 @@commandline
    Upgraded  libertas-usb8388-firmware-2:20190416-95.fc30.noarch       @@System
    Upgrade   libertas-usb8388-firmware-2:20190514-96.fc30.noarch       @updates
    Upgraded  libsmbclient-2:4.10.2-1.1.fc30.x86_64                     @@System
    Upgrade   libsmbclient-2:4.10.3-0.fc30.x86_64                       @updates
    Upgraded  libwbclient-2:4.10.2-1.1.fc30.x86_64                      @@System
    Upgrade   libwbclient-2:4.10.3-0.fc30.x86_64                        @updates
    Upgraded  linux-firmware-20190416-95.fc30.noarch                    @@System
    Upgrade   linux-firmware-20190514-96.fc30.noarch                    @updates
    Upgraded  linux-firmware-whence-20190416-95.fc30.noarch             @@System
    Upgrade   linux-firmware-whence-20190514-96.fc30.noarch             @updates
    Upgraded  mutter-3.32.1-1.fc30.x86_64                               @@System
    Upgrade   mutter-3.32.2-1.fc30.x86_64                               @updates
    Upgraded  nim-srpm-macros-1-4.fc30.noarch                           @@System
    Upgrade   nim-srpm-macros-2-1.fc30.noarch                           @updates
    Upgraded  nvidia-persistenced-3:418.56-1.fc30.x86_64                @@System
    Upgrade   nvidia-persistenced-3:418.74-1.fc30.x86_64                @rpmfusion-nonfree-updates
    Upgraded  nvidia-settings-3:418.56-1.fc30.x86_64                    @@System
    Upgrade   nvidia-settings-3:418.74-1.fc30.x86_64                    @rpmfusion-nonfree-updates
    Upgraded  perl-libwww-perl-6.38-1.fc30.noarch                       @@System
    Upgrade   perl-libwww-perl-6.39-1.fc30.noarch                       @updates
    Upgraded  samba-client-2:4.10.2-1.1.fc30.x86_64                     @@System
    Upgrade   samba-client-2:4.10.3-0.fc30.x86_64                       @updates
    Upgraded  samba-client-libs-2:4.10.2-1.1.fc30.x86_64                @@System
    Upgrade   samba-client-libs-2:4.10.3-0.fc30.x86_64                  @updates
    Upgraded  samba-common-2:4.10.2-1.1.fc30.noarch                     @@System
    Upgrade   samba-common-2:4.10.3-0.fc30.noarch                       @updates
    Upgraded  samba-common-libs-2:4.10.2-1.1.fc30.x86_64                @@System
    Upgrade   samba-common-libs-2:4.10.3-0.fc30.x86_64                  @updates
    Upgraded  samba-common-tools-2:4.10.2-1.1.fc30.x86_64               @@System
    Upgrade   samba-common-tools-2:4.10.3-0.fc30.x86_64                 @updates
    Upgraded  samba-libs-2:4.10.2-1.1.fc30.x86_64                       @@System
    Upgrade   samba-libs-2:4.10.3-0.fc30.x86_64                         @updates
    Upgraded  samba-winbind-2:4.10.2-1.1.fc30.x86_64                    @@System
    Upgrade   samba-winbind-2:4.10.3-0.fc30.x86_64                      @updates
    Upgraded  samba-winbind-clients-2:4.10.2-1.1.fc30.x86_64            @@System
    Upgrade   samba-winbind-clients-2:4.10.3-0.fc30.x86_64              @updates
    Upgraded  samba-winbind-modules-2:4.10.2-1.1.fc30.x86_64            @@System
    Upgrade   samba-winbind-modules-2:4.10.3-0.fc30.x86_64              @updates
    Upgraded  tmux-2.8-3.fc30.x86_64                                    @@System
    Upgrade   tmux-2.9a-2.fc30.x86_64                                   @updates
    Upgraded  xorg-x11-drv-nvidia-3:418.56-1.fc30.x86_64                @@System
    Upgrade   xorg-x11-drv-nvidia-3:418.74-1.fc30.x86_64                @rpmfusion-nonfree-updates
    Upgraded  xorg-x11-drv-nvidia-cuda-3:418.56-1.fc30.x86_64           @@System
    Upgrade   xorg-x11-drv-nvidia-cuda-3:418.74-1.fc30.x86_64           @rpmfusion-nonfree-updates
    Upgrade   xorg-x11-drv-nvidia-cuda-libs-3:418.74-1.fc30.i686        @rpmfusion-nonfree-updates
    Upgrade   xorg-x11-drv-nvidia-cuda-libs-3:418.74-1.fc30.x86_64      @rpmfusion-nonfree-updates
    Upgraded  xorg-x11-drv-nvidia-kmodsrc-3:418.56-1.fc30.x86_64        @@System
    Upgrade   xorg-x11-drv-nvidia-kmodsrc-3:418.74-1.fc30.x86_64        @rpmfusion-nonfree-updates
    Upgrade   xorg-x11-drv-nvidia-libs-3:418.74-1.fc30.i686             @rpmfusion-nonfree-updates
    Upgrade   xorg-x11-drv-nvidia-libs-3:418.74-1.fc30.x86_64           @rpmfusion-nonfree-updates
Aucun paquet iwl100-firmware-39.31.5.1-95.fc30.noarch disponible.
Aucun paquet iwl1000-firmware-1:39.31.5.1-95.fc30.noarch disponible.
Aucun paquet iwl105-firmware-18.168.6.1-95.fc30.noarch disponible.
Aucun paquet iwl135-firmware-18.168.6.1-95.fc30.noarch disponible.
Aucun paquet iwl2000-firmware-18.168.6.1-95.fc30.noarch disponible.
Aucun paquet iwl2030-firmware-18.168.6.1-95.fc30.noarch disponible.
Aucun paquet iwl3160-firmware-1:25.30.13.0-95.fc30.noarch disponible.
Aucun paquet iwl3945-firmware-15.32.2.9-95.fc30.noarch disponible.
Aucun paquet iwl4965-firmware-228.61.2.24-95.fc30.noarch disponible.
Aucun paquet iwl5000-firmware-8.83.5.1_1-95.fc30.noarch disponible.
Aucun paquet iwl5150-firmware-8.24.2.2-95.fc30.noarch disponible.
Aucun paquet iwl6000-firmware-9.221.4.1-95.fc30.noarch disponible.
Aucun paquet iwl6000g2a-firmware-18.168.6.1-95.fc30.noarch disponible.
Aucun paquet iwl6000g2b-firmware-18.168.6.1-95.fc30.noarch disponible.
Aucun paquet iwl6050-firmware-41.28.5.1-95.fc30.noarch disponible.
Aucun paquet iwl7260-firmware-1:25.30.13.0-95.fc30.noarch disponible.
Aucun paquet kmod-nvidia-5.0.14-300.fc30.x86_64-3:418.56-2.fc30.x86_64 disponible.
Aucun paquet kmod-nvidia-5.0.16-300.fc30.x86_64-3:418.56-2.fc30.x86_64 disponible.
Aucun paquet libertas-usb8388-firmware-2:20190416-95.fc30.noarch disponible.
Aucun paquet libsmbclient-2:4.10.2-1.1.fc30.x86_64 disponible.
Aucun paquet libwbclient-2:4.10.2-1.1.fc30.x86_64 disponible.
Aucun paquet linux-firmware-20190416-95.fc30.noarch disponible.
Aucun paquet linux-firmware-whence-20190416-95.fc30.noarch disponible.
Aucun paquet samba-client-2:4.10.2-1.1.fc30.x86_64 disponible.
Aucun paquet samba-client-libs-2:4.10.2-1.1.fc30.x86_64 disponible.
Aucun paquet samba-common-2:4.10.2-1.1.fc30.noarch disponible.
Aucun paquet samba-common-libs-2:4.10.2-1.1.fc30.x86_64 disponible.
Aucun paquet samba-common-tools-2:4.10.2-1.1.fc30.x86_64 disponible.
Aucun paquet samba-libs-2:4.10.2-1.1.fc30.x86_64 disponible.
Aucun paquet samba-winbind-2:4.10.2-1.1.fc30.x86_64 disponible.
Aucun paquet samba-winbind-clients-2:4.10.2-1.1.fc30.x86_64 disponible.
Aucun paquet samba-winbind-modules-2:4.10.2-1.1.fc30.x86_64 disponible.
Erreur : aucun paquet correspondant

#5 Re : Actualités » Fedora 30 est disponible » 04/05/2019 11:03:05

steve12l a écrit :

Pour Firefox, il y a un bug connu en cours de résolution : Firefox bug

Merci pour l'info, j'ai la réponse à mon rapport de bug au sujet des extensions qui ne s'installent pas :
https://bugzilla.redhat.com/show_bug.cgi?id=1706311

#6 Re : Actualités » Fedora 30 est disponible » 03/05/2019 09:33:06

ben51 a écrit :

Après la mise à jour le pc reboot avant d'arrivé à grub.

Référence pour ce bug : GRUB boot menu is not populated after an upgrade

If you have a legacy BIOS installation (i.e. not UEFI), it is possible that after the upgrade process the GRUB bootloader will not populate the boot menu, and instead displays a GRUB prompt. This happens on systems that were originally installed using Fedora 20 or older.

Si votre ordinateur démarre avec un BIOS (pas de démarrage en UEFI), il est possible qu'après la mise à jour (vers Fedora 30) le logiciel de démarrage GRUB n'ait pas son menu mis à jour, et qu'en lieu du menu vous ayez l'invite de commande de GRUB. Ceci arrive sur les systèmes qui utilisaient au départ la version Fedora 20 ou une version plus ancienne.

If you hit this issue, the old GRUB configuration is stored in /boot/grub2/grub.cfg.rpmsave. So the system can be recovered by executing the following from the GRUB prompt:

grub> configfile /grub2/grub.cfg.rpmsave

And then execute the grub2-install /dev/X command (where X is the boot device, i.e sda) to update the GRUB core and the modules to the latest version installed by the Paquetgrub2-pc-modules package.

Si votre système est touché par ce bug, l'ancienne configuration de GRUB est stockée dans /boot/grub2/grub.cfg.rpmsave. Votre système peut être restauré en exécutant cette commande depuis l'invite de GRUB :

grub> configfile /grub2/grub.cfg.rpmsave

Puis vous devrez exécuter la commande grub2-install /dev/X (où X est votre disque de démarrage, par exemple sda) pour mettre à jour le noyau de GRUB et ses modules vers la dernière version installée par le paquet Paquetgrub2-pc-modules.

#7 Re : Actualités » Fedora 30 est disponible » 01/05/2019 20:36:37

Salut,

J'ai effectué la mise à jour, version ligne de commande : aucun soucis. big_smile
cf. Upgrading Fedora 29 to Fedora 30

#8 Re : [Anciennes versions] Support général » Comment passer de Fedora 27 à Fedora 28 Beta » 11/08/2018 18:29:02

J'ai le même problème avec nss-pem :

Erreur : 
 Problème: nss-pem-1.0.3-6.fc27.i686 has inferior architecture
  - nss-pem-1.0.3-6.fc27.x86_64 does not belong to a distupgrade repository
  - problem with installed package nss-pem-1.0.3-6.fc27.i686

Ce bug est rapporté ici :
https://bugzilla.redhat.com/show_bug.cgi?id=1553646

Le fix connu et semble-t-il pas trop propre car il va marqué le paquet installé à la main par la suite :

$ sudo dnf install nss-pem-1.0.3-9.fc28 --releasever=28

Après la mise à jour peut se poursuivre.

Peut-être, si c'est encore d'actualité, tu peux juste supprimer le paquet gstreamer qui pose soucis et puis installer le meta paquet multimedia de rpm fusion par la suite, ce qui devrait redonner tous les codecs.

#9 Re : [Anciennes versions] Support général » [Résolu] Écran noir à GDM - startx lance Gnome » 14/07/2018 15:23:29

Beta-Pictoris a écrit :

Tu ne l'as pas précisé dans ton rapport de bogue ?

Cela dit, les paquets nvidia proviennent d'une source externe à l’écosystème fedora. Pas certain que ce soit pris en compte.

Je l'ai rajouté. Merci.

Je pense comme toi que ça ne va pas trop les aider, mais ça peut être utile aux autres utilisateurs de ce dépôt qui cherche la solution à ce problème.

#10 Re : [Anciennes versions] Support général » [Résolu] Écran noir à GDM - startx lance Gnome » 14/07/2018 15:11:17

Beta-Pictoris a écrit :

Tu n'as pas installé le dépôt rpmfusion pour avoir les drivers nvidia propriétaires ?

Non, je suis passé par negativo17 :
https://negativo17.org/nvidia-driver/

#12 Re : [Anciennes versions] Support général » [Résolu] Écran noir à GDM - startx lance Gnome » 14/07/2018 14:41:49

Refuznik a écrit :

Nos posts ce sont croisés lance les deux commandes (en tant que root bien sur) que j'ai donné et ça devrait fonctionner.

C'est ce que j'ai fait et GDM apparait maintenant. Problème résolu.
Merci beaucoup !

Pour info, voici les commandes exactes qui ont résolu le problème (enfin désactivé une sécurité SELinux) :

$ sudo ausearch -c "gnome-session-c" --raw | audit2allow -M my-gnomesessionc
$ sudo semodule -X 300 -i my-gnomesessionc.pp

Il me reste à trouver/reporter upstream...

#13 Re : [Anciennes versions] Support général » [Résolu] Écran noir à GDM - startx lance Gnome » 14/07/2018 14:34:36

Refuznik a écrit :

Sur des mises à jour sous f27 et 28, j'ai souvent rencontré le même problème.
Lance selinux et regarde les journaux pour voir si c'est lui te bloque tout simplement.
../..

Un petit tour sur les alertes SELinux et je trouve ceci qui date de 10h18, soit l'heure de lancement de GDM :

SELinux interdit à gnome-session-c d'utiliser l'accès map sur le chr_file /dev/nvidiactl.

*****  Le greffon catchall (100. de confiance) suggère   *********************

Si vous pensez que gnome-session-c devrait être autorisé à accéder map sur nvidiactl chr_file par défaut.
Alors vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Faire
autoriser cet accès pour le moment en exécutant :
# ausearch -c "gnome-session-c" --raw | audit2allow -M my-gnomesessionc
# semodule -X 300 -i my-gnomesessionc.pp

Informations complémentaires :
Contexte source               system_u:system_r:xdm_t:s0-s0:c0.c1023
Contexte cible                system_u:object_r:xserver_misc_device_t:s0
Objets du contexte            /dev/nvidiactl [ chr_file ]
Source                        gnome-session-c
Chemin de la source           gnome-session-c
Port                          <Inconnu>
Hôte                          [CENSURÉ]
Paquets RPM source            
Paquets RPM cible             
RPM de la statégie            selinux-policy-3.13.1-283.35.fc27.noarch
Selinux activé                True
Type de stratégie             targeted
Mode strict                   Enforcing
Nom de l'hôte                 [CENSURÉ]
Plateforme                    Linux [CENSURÉ] 4.17.3-100.fc27.x86_64 #1 SMP Tue
                              Jun 26 14:19:03 UTC 2018 x86_64 x86_64
Compteur d'alertes            48
Première alerte               2018-07-11 10:18:14 CEST
Dernière alerte               2018-07-14 10:18:33 CEST
ID local                      3048496c-db61-4144-a06b-6930cb650808

Messages d'audit bruts 
type=AVC msg=audit(1531556313.61:214): avc:  denied  { map } for  pid=1505 comm="gnome-session-c" path="/dev/nvidiactl" dev="devtmpfs" ino=19879 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:xserver_misc_device_t:s0 tclass=chr_file permissive=0


Hash: gnome-session-c,xdm_t,xserver_misc_device_t,chr_file,map

Ça sent bien bon le problème entre SELinux et Nvidia !
Je tente les commandes que le robot SELinux me propose et je reboote la machine...

#14 Re : [Anciennes versions] Support général » [Résolu] Écran noir à GDM - startx lance Gnome » 14/07/2018 14:26:40

Beta-Pictoris a écrit :

Tu devrais commencer par virer les drivers propriétaires nvidia et réinstaller le driver libre 'nouveau'.

Le seul véritable problème que je rencontre actuellement c'est mon login de session graphique et j'ai un workaround ; je ne perds donc rien si ce n'est un peu de temps.
Pour la mise à jour F28, là par contre ça me dérange cette situation et ça retarde la M-A-J. C'est pour cela que je suis venu demander de l'aide ici.

Par contre, si je vire le driver proprio/privateur je perds des usages. Donc je suis désolé, mais je ne vais pas suivre ce conseil. Mais merci beaucoup pour ton aide !

#15 Re : [Anciennes versions] Support général » [Résolu] Écran noir à GDM - startx lance Gnome » 14/07/2018 14:02:19

$ systemctl get-default
graphical.target
$ systemctl status graphical.target
● graphical.target - Graphical Interface
   Loaded: loaded (/usr/lib/systemd/system/graphical.target; enabled; vendor preset: disabled)
   Active: active since Sat 2018-07-14 10:18:31 CEST; 3h 36min ago
     Docs: man:systemd.special(7)

juil. 14 10:18:31 [CENSURÉ] systemd[1]: Reached target Graphical Interface.
$ systemctl status display-manager.service
● gdm.service - GNOME Display Manager
   Loaded: loaded (/usr/lib/systemd/system/gdm.service; enabled; vendor preset: disabled)
   Active: active (running) since Sat 2018-07-14 10:18:30 CEST; 3h 37min ago
 Main PID: 1139 (gdm)
    Tasks: 3 (limit: 4915)
   CGroup: /system.slice/gdm.service
           └─1139 /usr/sbin/gdm

juil. 14 10:18:30 [CENSURÉ] systemd[1]: Starting GNOME Display Manager...
juil. 14 10:18:30 [CENSURÉ] systemd[1]: Started GNOME Display Manager.
juil. 14 10:18:31 [CENSURÉ] gdm[1139]: GdmDisplay: display lasted 0,526379 seconds
juil. 14 10:18:31 [CENSURÉ] gdm[1139]: Child process -1280 was already dead.
juil. 14 10:18:31 [CENSURÉ] gdm[1139]: Child process 1176 was already dead.
juil. 14 10:18:31 [CENSURÉ] gdm[1139]: Unable to kill session worker process
Beta-Pictoris a écrit :

Tu n'aurais pas installé plusieurs xdm (lightdm,...) ?

$ dnf list *dm
Dernière vérification de l’expiration des métadonnées effectuée il y a 0:36:57 le sam. 14 juil. 2018 13:23:51 CEST.
Paquets installés
gdm.x86_64                                               1:3.26.2.1-3.fc27                                    @updates
libblockdev-dm.x86_64                                    2.16-1.fc27                                          @updates
mdadm.x86_64                                             4.0-5.fc27                                           @fedora 
Paquets disponibles
../..

#16 [Anciennes versions] Support général » [Résolu] Écran noir à GDM - startx lance Gnome » 14/07/2018 13:27:13

Yannick@ekiga
Réponses : 15

Bonjour,

Depuis une mise à jour récente, lorsque je boot je n'ai plus l'écran GDM pour choisir l'utilisateur et rentrer mon mot de passe pour lancer Gnome. L'écran est noir.

Un petit CTRL-ALT-F2 + login et la commande "startx" me permet de lancer Gnome.

Je ne parviens pas à déterminer où est le problème et comment le résoudre.

Quelques infos :

Kernel :

$ uname -a
Linux [CENSURÉ] 4.17.3-100.fc27.x86_64 #1 SMP Tue Jun 26 14:19:03 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Drivers vidéo Nvidia :

$ dnf info dkms-nvidia
Dernière vérification de l’expiration des métadonnées effectuée il y a 1:00:58 le sam. 14 juil. 2018 12:17:41 CEST.
Paquets installés
Nom          : dkms-nvidia
Époque       : 3
Version      : 396.24
Révision     : 1.fc27
Architecture : x86_64
Taille       : 24 M
Source       : dkms-nvidia-396.24-1.fc27.src.rpm
Dépôt        : @System
Depuis le dé : fedora-multimedia

GDM

$ dnf info gdm
Dernière vérification de l’expiration des métadonnées effectuée il y a 1:03:38 le sam. 14 juil. 2018 12:17:41 CEST.
Paquets installés
Nom          : gdm
Époque       : 1
Version      : 3.26.2.1
Révision     : 3.fc27
Architecture : x86_64
Taille       : 2.2 M
Source       : gdm-3.26.2.1-3.fc27.src.rpm
Dépôt        : @System
Depuis le dé : updates

#17 Re : [Anciennes versions] Matériel » [TUTO] Steam Controller » 22/04/2016 20:43:45

nouvo09 a écrit :

Puis on reboot la machine.

???

Un  simple modprobe du module ne suffit pas, alors qu'un reboot avec la mise en route du module au moment du boot fait l'affaire.

C'est indiqué dans la source et j'en ai fait l'expérience. Je ne comprends pas pourquoi. Mais la solution exposée ci-dessus fonctionne.

#18 [Anciennes versions] Matériel » [TUTO] Steam Controller » 22/04/2016 00:57:59

Yannick@ekiga
Réponses : 2

Tutoriel pour le steam controller avec Fedora 23 :
Cette manette se met à jour toute seule et fonctionne correctement avec steam. Sans steam, la manette ne fait rien.
Mais dès qu'on lance un jeu, elle ne fonctionne pas.

Pour la faire fonctionner dans les jeux steam :
Créer le fichier :
/etc/modules-load.d/uinput.conf
avec comme contenu :

uinput

Puis on reboot la machine.

Source :
cf. https://www.reddit.com/r/linux_gaming/c … roller_on/

Enfin, il existe un pilote pour se servir de cette manette avec son bureau, mais je ne l'ai pas testé :
https://github.com/ynsta/steamcontroller
Cependant, si steam est lancé, on peut utiliser la manette avec son bureau. L'expérience ne m'a pas convaincu.

#19 Re : [Anciennes versions] Support général » [Résolu] Dépendance: kernel-uname-r = 4.1.2 is needed by kmod-nvidia » 27/08/2015 09:18:03

Résolu:
En supprimant kmod-nvidia et le kernel fautif (en précisant bien jusqu'à la fin pour le kernel xxx.x86_64) avec dnf remove, puis en installant akmod-nvidia (tout court, car j'ai une carte nvidia assez récente) en suivant le tuto de rpm fusion au boot suivant ça m'a remis le système en état de marche.

#20 Re : [Anciennes versions] Support général » [Résolu] Dépendance: kernel-uname-r = 4.1.2 is needed by kmod-nvidia » 22/08/2015 16:54:50

@Edouard_le_homard, Oui j'ai déjà tenté le rpm --rebuilddb, et package-cleanup trouve la même erreur...

@hechmi50, j'ai peur qu'il ne puisse pas installer kmod-nvidia correctement :

$ dnf list kernel* | grep fc22
kernel.x86_64                                 4.1.5-200.fc22             @System
kernel-core.x86_64                            4.1.5-200.fc22             @System
kernel-devel.x86_64                           4.1.5-200.fc22             @System
kernel-headers.x86_64                         4.1.5-200.fc22             @System
kernel-modules.x86_64                         4.1.5-200.fc22             @System
kernel-modules-extra.x86_64                   4.1.5-200.fc22             @System
kernel-debug.x86_64                           4.1.5-200.fc22             updates
kernel-debug-core.x86_64                      4.1.5-200.fc22             updates
kernel-debug-devel.x86_64                     4.1.5-200.fc22             updates
kernel-debug-modules.x86_64                   4.1.5-200.fc22             updates
kernel-debug-modules-extra.x86_64             4.1.5-200.fc22             updates
kernel-rpm-macros.noarch                      29-1.fc22                  updates
kernel-tools.x86_64                           4.1.5-200.fc22             updates
kernel-tools-libs.i686                        4.1.5-200.fc22             updates
kernel-tools-libs.x86_64                      4.1.5-200.fc22             updates
kernel-tools-libs-devel.i686                  4.1.5-200.fc22             updates
kernel-tools-libs-devel.x86_64                4.1.5-200.fc22             updates
kernelshark.x86_64                            2.2.1-5.fc22               fedora 

$ dnf list kmod-nvidia* | grep fc22
kmod-nvidia.x86_64                             1:352.30-2.fc22    @System       
kmod-nvidia-4.1.2-200.fc22.x86_64.x86_64       1:352.30-2.fc22    @System       
kmod-nvidia-304xx.x86_64                       304.125-3.fc22.10  rpmfusion-nonfree
kmod-nvidia-304xx-4.0.4-301.fc22.x86_64.x86_64 304.125-3.fc22.10  rpmfusion-nonfree
kmod-nvidia-340xx.x86_64                       1:340.76-3.fc22    rpmfusion-nonfree-updates
kmod-nvidia-340xx-4.0.4-301.fc22.x86_64.x86_64 1:340.76-2.fc22.12 rpmfusion-nonfree
kmod-nvidia-340xx-4.1.3-200.fc22.x86_64.x86_64 1:340.76-3.fc22    rpmfusion-nonfree-updates
kmod-nvidia-4.0.4-301.fc22.x86_64.x86_64       1:346.72-2.fc22.1  rpmfusion-nonfree

Peut-être qu'il suffit juste d'attendre que kmod-nividia se mette à jour pour le kernel actuel ?

#21 [Anciennes versions] Support général » [Résolu] Dépendance: kernel-uname-r = 4.1.2 is needed by kmod-nvidia » 22/08/2015 16:27:33

Yannick@ekiga
Réponses : 5

Bonjour,

Je viens de réaliser la mise à jour de fedora 21 vers 22.

Je me retrouve avec un soucis de dépendance qui m'empêche de faire les mise à jour:

dnf update
../..
Erreur : vérification de transaction contre résolution des dépendances :
kernel-uname-r = 4.1.2-200.fc22.x86_64 is needed by (installed) kmod-nvidia-4.1.2-200.fc22.x86_64-1:352.30-2.fc22.x86_64
Pour diagnostiquer le problème, essayez de lancer : « rpm -Va --nofiles --nodigest ».
You probably have corrupted RPMDB, running 'rpm --rebuilddb' might fix the issue.
The downloaded packages were saved in cache till the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'

Il me semble que le kmod-nividia version 4.1.2 qui est installé a besoin d'un noyau 4.1.2, mais ce noyau n'est pas disponible. Comment puis-je nettoyer cela proprement ?

Pour le moment je suis obligé de lancer un ancien kernel de fedora 21 dans grub pour que ça marche, sinon je me retrouve en ligne de commande avec le kernel de fedora 22...

#22 Re : [Anciennes versions] Installation de Fedora » Fedora 20 sur l'Acer C720P » 16/11/2014 02:37:52

[fr] Bonne nouvelle ! Avec le noyau 3.17.2, on n'a plus besoin de script. Mes tests personnels vont dans ce sens. Toutefois je pense que les configurations pour le pavé tactile et la mise en veille sont toujours utiles.

Je vous encourage à faire la mise à jour si vous êtes toujours en 3.15, ne serait-ce que pour des raisons de sécurité (en particulier le soucis avec le shell bash qui est apparu entre temps)

[en] With kernel 3.17.2, there is no need for a script. I still believe we need some configuration files for touchpad and sleep mode. I advice to update.

#23 Re : [Anciennes versions] Installation de Fedora » Fedora 20 sur l'Acer C720P » 14/11/2014 18:19:05

Bonjour,

Excusez-moi de ne pas avoir fait les mises à jour du script pour le noyaux 3.16 ; j'ai manqué de temps et de motivation.

Le noyau 3.17.2 est maintenant disponible dans les dépôts officiels (mise à jour normale) et d'après mes premiers essais : le pavé tactile, l'écran tactile et la mise en veille marchent. J'ai peu testé et j'ai eu une fois un bug de pavé tactile au ralenti après une mise en veille, mais ça à l'air de bien fonctionner.

Il semble qu'on n'ait plus besoin du script avec cette nouvelle série de noyaux ! Je vais continuer mes tests et si tout va bien, je mettrai à jour le tuto.

#24 Re : [Anciennes versions] Installation de Fedora » Fedora 20 sur l'Acer C720P » 17/09/2014 23:04:00

Je n'ai pas de temps en ce moment pour faire l'update pour le noyau 3.16, mais je crois que ce qui est ici devrait marcher :
https://github.com/masmullin2000/arch-c720p

Et quelqu'un a fait la modif du script pour le 3.16 sur le bug report ici (non testé) :
https://bugzilla.redhat.com/show_bug.cgi?id=1045821

#25 Re : [Anciennes versions] Installation de Fedora » Fedora 20 sur l'Acer C720P » 20/08/2014 00:26:55

L3M a écrit :
zeig a écrit :
L3M a écrit :

Bonjour,
Quelqu'un à réussi à patcher les derniers kernels ( 3.15.8 à 3.15.10 ) pour faire fonctionner le touchpad et le touchscreen ?

Oui, dans le script de Yannick, il faut remplacer l'URL "https://raw.githubusercontent.com/masmu … idrv.patch" (qui n'est plus valide, car pour la version 3.16 du kernel cela ne passera pas par un patch), par celle-ci:

https://raw.githubusercontent.com/masmu … idrv.patch

Merci ça marche impecc :)

Merci !
J'ai mis à jour le script :
https://bugzilla.redhat.com/attachment.cgi?id=928540

Pied de page des forums

Propulsé par FluxBB