Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Clap de fin pour Fedora Linux 35 !

#1 Re : Le comptoir du libre » Intel Hybrid driver: décodage VP9 matériel sous Skylake/Kabylake » 30/08/2017 15:09:54

Petite update:

  • J'ai été sponsorisé et je suis donc maintenant un Packager

  • libva-intel-hybrid-driver est dans updates-testing de F26 et bientôt dans stable.

  • À utiliser conjointement avec libva-intel-driver de RPMFusion pour bénéficier de l'accélération de VP9.

#2 Re : Le comptoir du libre » Intel Hybrid driver: décodage VP9 matériel sous Skylake/Kabylake » 27/07/2017 20:28:04

J'ai proposé mes paquets sur les Packages Review, mais il me faut un sponsor :| Si quelqu'un susceptible de me sponsoriser passe par là… o/

Mes bugs: https://bugzilla.redhat.com/buglist.cgi … id=7644633

#3 Re : Le comptoir du libre » Intel Hybrid driver: décodage VP9 matériel sous Skylake/Kabylake » 21/07/2017 08:45:16

Je ne sais pas trop «quel» Skylake c'est. Mon CPU est un i7-6700HQ et le proc graphique est un HD Graphics 530.
Mon noyau est 4.11.9-300.fc26.x86_64.

#4 Re : Le comptoir du libre » Intel Hybrid driver: décodage VP9 matériel sous Skylake/Kabylake » 20/07/2017 16:14:27

VINDICATORs a écrit :

Faut en faire la demande sur le bugzilla il me semble, après à voir si c'est accepté ou non.

Ça dépend d'un autre package qui n'est pas non plus dans Fedora pour le build.

J'ai lu la procédure pour ajouter un paquet mais ça m'a l'ai fichtrement compliqué, Koji, fedpkg, Bohdi, Pagure… que d'outils que je ne connais pas.

#5 Le comptoir du libre » Intel Hybrid driver: décodage VP9 matériel sous Skylake/Kabylake » 19/07/2017 17:33:01

eclipseo
Réponses : 8

Je suis tombé par hasard sur un post très intéressant aujourd'hui qui expliquait comment activer le décodage matériel de VP9 pour plateforme Skylake (et potentiellement encodage sur Kabylake) : https://gist.github.com/Brainiarc7/24de … 04877239a3

Vu que j'utilise pas mal VP9 au lieu de H.264, et que l'absence de décodage matériel sous Linux me mettait en rogne, je me suis attelé à la compilation selon les instructions données.

Et donc voilà pour vous:  le Intel Hybrid driver, disponible sur mon COPR: https://copr.fedorainfracloud.org/coprs … id-driver/

Il suffit d'abord d'installer intel-hybrid-driver :

  • sudo dnf install intel-hybrid-driver

Puis de mettre à jour le pilote libva:

  • sudo dnf update libva-intel-driver

Le pilote libva est quasiment le même que celui fourni par Fedora (même fichier spec, merci kwizart), mais il est maintenant "lié" au pilote hybride.

Avant:

vainfo: VA-API version: 0.40 (libva )
vainfo: Driver version: Intel i965 driver for Intel(R) Skylake - 1.8.2
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            :	VAEntrypointVLD
      VAProfileMPEG2Simple            :	VAEntrypointEncSlice
      VAProfileMPEG2Main              :	VAEntrypointVLD
      VAProfileMPEG2Main              :	VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline:	VAEntrypointVLD
      VAProfileH264ConstrainedBaseline:	VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline:	VAEntrypointEncSliceLP
      VAProfileH264Main               :	VAEntrypointVLD
      VAProfileH264Main               :	VAEntrypointEncSlice
      VAProfileH264Main               :	VAEntrypointEncSliceLP
      VAProfileH264High               :	VAEntrypointVLD
      VAProfileH264High               :	VAEntrypointEncSlice
      VAProfileH264High               :	VAEntrypointEncSliceLP
      VAProfileH264MultiviewHigh      :	VAEntrypointVLD
      VAProfileH264MultiviewHigh      :	VAEntrypointEncSlice
      VAProfileH264StereoHigh         :	VAEntrypointVLD
      VAProfileH264StereoHigh         :	VAEntrypointEncSlice
      VAProfileVC1Simple              :	VAEntrypointVLD
      VAProfileVC1Main                :	VAEntrypointVLD
      VAProfileVC1Advanced            :	VAEntrypointVLD
      VAProfileNone                   :	VAEntrypointVideoProc
      VAProfileJPEGBaseline           :	VAEntrypointVLD
      VAProfileJPEGBaseline           :	VAEntrypointEncPicture
      VAProfileVP8Version0_3          :	VAEntrypointVLD
      VAProfileVP8Version0_3          :	VAEntrypointEncSlice
      VAProfileHEVCMain               :	VAEntrypointVLD
      VAProfileHEVCMain               :	VAEntrypointEncSlice

Après:

vainfo: VA-API version: 0.40 (libva )
vainfo: Driver version: Intel i965 driver for Intel(R) Skylake - 1.8.3
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            :	VAEntrypointVLD
      VAProfileMPEG2Simple            :	VAEntrypointEncSlice
      VAProfileMPEG2Main              :	VAEntrypointVLD
      VAProfileMPEG2Main              :	VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline:	VAEntrypointVLD
      VAProfileH264ConstrainedBaseline:	VAEntrypointEncSlice
      VAProfileH264ConstrainedBaseline:	VAEntrypointEncSliceLP
      VAProfileH264Main               :	VAEntrypointVLD
      VAProfileH264Main               :	VAEntrypointEncSlice
      VAProfileH264Main               :	VAEntrypointEncSliceLP
      VAProfileH264High               :	VAEntrypointVLD
      VAProfileH264High               :	VAEntrypointEncSlice
      VAProfileH264High               :	VAEntrypointEncSliceLP
      VAProfileH264MultiviewHigh      :	VAEntrypointVLD
      VAProfileH264MultiviewHigh      :	VAEntrypointEncSlice
      VAProfileH264StereoHigh         :	VAEntrypointVLD
      VAProfileH264StereoHigh         :	VAEntrypointEncSlice
      VAProfileVC1Simple              :	VAEntrypointVLD
      VAProfileVC1Main                :	VAEntrypointVLD
      VAProfileVC1Advanced            :	VAEntrypointVLD
      VAProfileNone                   :	VAEntrypointVideoProc
      VAProfileJPEGBaseline           :	VAEntrypointVLD
      VAProfileJPEGBaseline           :	VAEntrypointEncPicture
      VAProfileVP8Version0_3          :	VAEntrypointVLD
      VAProfileVP8Version0_3          :	VAEntrypointEncSlice
      VAProfileHEVCMain               :	VAEntrypointVLD
      VAProfileHEVCMain               :	VAEntrypointEncSlice
      VAProfileVP9Profile0            :	VAEntrypointVLD

Exemple avec un VP9 sous mpv:

$mpv Small\ Arms\ of\ WWI\ Primer\ 055\ -\ French\ Contract\ Winchester\ 1894-l9kPggzvYtg.webm 
Playing: Small Arms of WWI Primer 055 - French Contract Winchester 1894-l9kPggzvYtg.webm
 (+) Video --vid=1 (*) (vp9 1920x1080 29.970fps)
 (+) Audio --aid=1 --alang=eng (*) (opus 2ch 48000Hz)
Using hardware decoding (vaapi).
VO: [opengl] 1920x1080 vaapi[nv12]
AO: [pulse] 48000Hz stereo 2ch float
AV: 00:00:07 / 00:38:54 (0%) A-V:  0.000 Dropped: 2

Et voilà!

Ça serait cool que quelqu'un puisse l'inclure dans les dépôts officiels vu que c'est une licence MIT.

#6 Re : Actualités » Fedora 26 Beta est disponible » 02/07/2017 13:22:40

Pas dans les paquets qu'il me faut:

bob@Themisto ~> dnf info qt5-qtbase
Last metadata expiration check: 21:32:41 ago on sam. 01 juil. 2017 15:44:49 CEST.
Installed Packages
Name         : qt5-qtbase
Version      : 5.7.1
Release      : 15.fc26
Arch         : x86_64
Size         : 8.5 M
Source       : qt5-qtbase-5.7.1-15.fc26.src.rpm
Repo         : @System
From repo    : fedora
Summary      : Qt5 - QtBase components
URL          : http://qt-project.org/
License      : LGPLv2 with exceptions or GPLv3 with exceptions
Description  : Qt is a software toolkit for developing applications.
             : 
             : This package contains base tools, like string, xml, and network
             : handling.

bob@Themisto ~> dnf info qt5-qtquickcontrols2
Last metadata expiration check: 21:34:44 ago on sam. 01 juil. 2017 15:44:49 CEST.
Installed Packages
Name         : qt5-qtquickcontrols2
Version      : 5.7.1
Release      : 4.fc26
Arch         : x86_64
Size         : 2.5 M
Source       : qt5-qtquickcontrols2-5.7.1-4.fc26.src.rpm
Repo         : @System
From repo    : fedora
Summary      : Qt5 - module with set of QtQuick controls for embedded
URL          : http://www.qt.io
License      : GPLv2+ or LGPLv3 and GFDL
Description  : The Qt Labs Controls module provides a set of controls that can be used to
             : build complete interfaces in Qt Quick.
             : 
             : Unlike Qt Quick Controls, these controls are optimized for embedded systems
             : and so are preferred for hardware with limited resources.

Même en activant update-testing. Ils sont disponible sur https://copr.fedorainfracloud.org/coprs … /packages/ mais pour une raison qui m'échappe, les paquets de KDE sont packagés avec une dépendance stricte pour Qt 5.7.1.

#7 Re : Actualités » Fedora 26 Beta est disponible » 02/07/2017 12:59:56

J'ai fait la mise à jour en utilisant le paquet fedora-upgrade en suivant ce guide https://fedoraproject.org/wiki/Upgradin … ra-upgrade . Tout s'est quasiment bien passé sauf que ma partition root n'était pas assez grande pour accueillir tous les paquets et leur décompression. Heureusement j'avais de l'espace non utilisé juste après ma partition ét j'ai pu l'élargir.
Le script fedora-upgrade est très bien fait et simple d'utilisaton.

J'ai fait la mise à jour parce que j'avais besoin de Qt 5.8 pour compiler un programme mais au final, il n'y a même pas Qt5.8 sur Fedora 26 :| C'est étrange car Qt 5.9 et 5.9 sont disponibles sur le copr dur groupe KDE sig. J'espère que ça sera rétroporté assez rapidement.

#8 Re : [Anciennes versions] Support général » [Résolu] bureau KDE » 09/01/2017 19:40:38

Bouton droit sur le bureau > Configurer le Bureau
Dans le menu déroulant "Agencement", choisir "Bureau" au lieu de "Vue dossier"


Le dossier "Bureau" dans le Dossier personnel est un dossier système, je ne pense pas qu'il soit supprimable.

#9 Re : [Anciennes versions] Support général » KDE 5.8.1 freeze » 27/12/2016 15:42:34

Quand ça plante, est-ce que tu peux ouvrir une session console Ctrl+Alt+F2
Si oui, que donne le résultat des commandes 'dmesg' et 'journalctl -b'

#10 Re : [Anciennes versions] Matériel » [Résolu] installation Canon PIXMA MG6650 » 27/12/2016 15:39:13

J'ai la même imprimante, je me suis servi du scanner ce matin et je n'ai eu qu'à installer que Xsane, rien d'autre. Xsane la détectait automatiquement.

#11 Re : [Anciennes versions] Matériel » Asus All-In-One » 14/12/2016 14:40:28

Polux a écrit :

Bonjour à tous,

Je travail sur un Asus ET2410INTS. L’installation se passe bien mais je n'arrive pas à profiter de la fonction tactile de l’écran.

Quelqu'un peut il m'aider.
Merci.

D'après mes recherches l'écran tactile est du type NextWindow qui fonctionne grâce au pilote nwfermi. Il y a peu d'information à son sujet sur les ressources Fedora mais Ubuntu-fr a une page d'aide: https://doc.ubuntu-fr.org/nwfermi
Il y a un paquet Fedora disponible sur le site du projet nwfermi: https://launchpad.net/nwfermi

Donc il faut installer ces paquets :
- dkms
- https://launchpad.net/nwfermi/trunk/0.6 … noarch.rpm
- https://launchpad.net/nwfermi/trunk/0.6 … x86_64.rpm

#12 Re : [Anciennes versions] Installation de Fedora Linux » Fedora 25 - retour d'expérience » 10/12/2016 19:22:55

Après 4 an de Windows, de retour sous Linux avec un nouveau laptop.

- Méthode d'installation :
* Live du spin KDE
* Live Workstation

- Problèmes majeurs :
Le spin KDE boot mais n'arrive pas à l'interface graphique.
Le live Workstation démarre mais kernel panic aléatoirement dans les cinq minutes d'utilisation, ce qui rend l'installation compliquée… après un google du problème, je teste plusieurs options pour désactiver acpi, sans succès. Finalement tout fonctionne avec "nouveau.modeset=0" comme option du noyau.

- Soucis mineurs :
Installer KDE est simple, mais désinstaller tous les programmes GNOME par défaut est toujours compliqué.

- Points positifs :
C'est rapide et peu de chose ont changé en 4 ans.

- Points négatifs
Wayland n'est toujours pas prêt pour la production sous KDE.

#13 Re : [Anciennes versions] Support général » [Résolu] SoundConverter et le format mp3 » 10/12/2016 19:05:39

Neko62 a écrit :

j'ai bien installé :

su -c 'dnf install gstreamer1-plugins-ugly'

mais je n'ai toujours pas de format mp3 en sortie pour SoundConverter malheureusement.

My bad, SoundConverter utilise une ancienne version de GStreamer. Utilise à la place:

su -c 'dnf install gstreamer-plugins-ugly'

#15 Re : [Anciennes versions] Support général » [Résolu] SoundConverter et le format mp3 » 10/12/2016 18:47:36

Sinon OPUS c'est très bien comme codec et c'est libre. À moins d'avoir des exigences matérielles particulières car ce n'est pas encore supporté partout (sur Android ça se lit bien avec VLC).

#16 Re : [Anciennes versions] Installation des programmes » abcmap, erreur d'excéution » 10/12/2016 18:33:21

Le logiciel fournit sa propre version de Java, qui semble chercher des bibliothèques manquantes.

Au lieu d'utiliser le RPM d'Adobe (que je vous conseille de désinstaller), installez celui de Fedora puis lancer le programme:

  1. Installation de Java:

    su -c'dnf install java-1.8.0-openjdk'
  2. Lancement du programme:

    java -Xms512m -Xmx1024m -jar bin/abcmap.jar

    (depuis le dossier où vous avez extrait l'archive).

Vous pouvez réécrire abcmap.sh pour n'avoir qu'à double cliquer dessus:

#!/bin/bash
java -Xms512m -Xmx1024m -jar bin/abcmap.jar

#17 Re : [Anciennes versions] Support général » [Résolu] SoundConverter et le format mp3 » 10/12/2016 18:06:15

SoundConverter utilise les bibliothèques GStreamer pour effectuer le transcodage. FLAC, OGG, WAV sont libres donc founis par défault avec Fedora, mais MP3 est couvert par des brevets logiciels, donc non disponibles dans les dépôts Fedora.
Pour avoir accès au MP3, il vous faut alors installer 'gstreamer1-plugins-ugly' disponible sur les dépôts RPMFusion:

  1. Ajout des dépôts RPMFusion:

    su -c 'dnf install https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm https://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm'
  2. Installation des plugins GStreamer "ugly":

    su -c 'dnf install gstreamer1-plugins-ugly'

#18 Re : Le comptoir du libre » on avance ou on recule? » 12/06/2012 10:10:09

mais expliquez-moi maintenant comment il se fait que pour une distro de linux j'en suis à devoir lancer à la mano le service nfs idmapd

Tu as un message d'erreur pour ce service?

$ systemctl status nfs-idmap.service

En théorie, systemd le onsidère comme une "dépendance" pour lancer nfs-server.

#19 Re : [Anciennes versions] Installation des programmes » [Résolu] texlive - pakage algpseudocode » 07/06/2012 01:27:08

# yum install --nogpgcheck http://jnovy.fedorapeople.org/texlive/2012/packages.fc17/texlive-release.noarch.rpm
# yum install texlive-algorithmicx

#21 Re : [Anciennes versions] Installation de Fedora Linux » INstallation sans médias. » 05/06/2012 14:40:59

Note, il y a aussi la version "je sacrifie ma clef pour la cause". Plus simple mais efface les données de la clef.

Soit une clef USB d'au moins 4Gio sur /dev/sdb

/!\ La manip suivante effacera les partitions et toutes les données sur la clef /!\

# cp Fedora-17-x86_64-DVD.iso /dev/sdb

Bootez ensuite directement depuis la clef USB, en modifiant l'ordre de démarrage dans le BIOS si nécessaire.

#22 Re : [Anciennes versions] Installation de Fedora Linux » INstallation sans médias. » 05/06/2012 11:25:20

En assumant /dev/sda3 soit mon home contenant l'image iso.

# nano /etc/grub.d/35_fromiso
#!/bin/sh
exec tail -n +3 $0
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
menuentry "Fedora Install" {
        loopback loop (hd0,msdos3)/Fedora-17-x86_64-DVD.iso
        linux (loop)/isolinux/vmlinuz repo=hd:sda3:/ rootfstype=auto ro quiet rhgb rd.luks=0 rd.md=0
        initrd (loop)/isolinux/initrd.img
}
# chmod +x /etc/grub.d/35_fromiso
# grub2-mkconfig -o /boot/grub2/grub.cfg

Rebootez et installez.

Addendum: J'ai testé avec une clef formatée en NTFS: ça ne fonctionne pas, le support du ntfs ne doit pas être activé à ce moment. Et la clef où se trouve l'image ISO est toujours considérée comme le premier disque, donc le paramètre est toujours repo=hd:sdaX:/ avec cette méthode.

#23 Re : [Anciennes versions] Installation de Fedora Linux » Fedora 17 : retour d'expérience » 03/06/2012 11:03:52

Hoi, je ne suis pas venu depuis la dernière release mais petit retour d'experience

Méthode d'installation :
- une installation complète depuis le DVD via "loopback" de GRUB2.

Problèmes majeurs :
- Anaconda a bien fonctionné mais a planté après le formatage de mes partitions. Plus de Grub. Oops...

Résultat, j'ai du passer par une installation avec un Live CD KDE sur disque usb. Schade.

- Points négatifs :
Concernant, KDE en lui-même. Il a l'air un peu plus fluide, mais j'ai toujours des plantages aléatoires lorsque j'active les effets graphiques (driver nouveau/NV40). Je ferais bien un rapport de bug mais je ne trouve rien dans les logs.

- Point positifs :
La gestion des profils ICC par colord est bien pratique.
Firefox a un scrolling plus fluide (pourtant c'est la même version… je ne vais pas m'en plaindre).

Note: Le wiki pour les dépôts Texlive n'est pas à jour et j'écrirais bien un tuto pour dnsmasq.

#25 Re : [Anciennes versions] Support général » Problème connexion session en boucle » 14/10/2011 15:13:46

Depuis Windows 7 je ne cris pas, mais tu peux sans doute démarrer en mode rescue depuis le menu de Grub, non ? Tu pourras y consulter les journaux dans /var/log/gdm/ par exemple, et voir s'il y a des infos expliquant la situation.

Pied de page des forums

Propulsé par FluxBB