Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : La nouvelle version de Fedora dite 33 est sortie

#1 12/10/2020 11:19:56

thierryR
Membre
Lieu : Chalons en Champagne
Inscription : 31/01/2011
Messages : 1 310
Site Web

samba pour les null

Bonjour. Je n'arrive pas à mettre en place un serveur samba pour accéder à un PC win10 sur mon LAN. La doc semble obsolète. Pas moyen de voir un service smbd sur mon PC malgré le fait d'avoir installé samba. Ça doit surement être très simple car le dernier message que je trouve ici date de 2013. Je dois m'y prendre comme un manche. J'ai donc cherché sur google, mais je ne trouve que des indications pour ubuntu.

cat /etc/samba/smb.conf
# See smb.conf.example for a more detailed config file or
# read the smb.conf manpage.
# Run 'testparm' to verify the config is correct after
# you modified it.

[global]
        workgroup = WORKGROUP
        security = user

        passdb backend = tdbsam

        printing = cups
        printcap name = cups
        load printers = yes
        cups options = raw


        guest account = nobody
        null passwords = yes
    
[homes]
        comment = Home Directories
        valid users = %S, %D%w%S
        browseable = No
        read only = No
        inherit acls = Yes

[printers]
        comment = All Printers
        path = /var/tmp
        printable = Yes
        create mask = 0600
        browseable = No

[print$]
        comment = Printer Drivers
        path = /var/lib/samba/drivers
        write list = @printadmin root
        force group = @printadmin
        create mask = 0664
        directory mask = 0775

[partage_public]
#chemin local de la ressource
path = /mnt/partage_public
#visible dans la liste des partages
public = yes
#permettre les accès anonyme
guest ok = yes
#autoriser le parcours du partage
browseable = yes
#permettre l'écriture et modification du partage
writeable = yes 

Quand je modifie smb.conf, il faut réinitialiser le service.

sudo service smbd restart
Redirecting to /bin/systemctl restart smbd.service
Failed to restart smbd.service: Unit smbd.service not found.

Voilà où j'en suis. Niveau 0 pour les null.
Mais comment faire chez Fedora ?
Merci de toute aide.


Chalons en Champagne: Au nord, un peu avant la banquise (Ah ben non... Elle a fondu)
Kernel: 5.8.12-200.fc32.x86_64 x86_64 bits: 64 Desktop: KDE Plasma 5.18.5
Type: Desktop Mobo: ASRock model: X470 Gaming-ITX/ac  UEFI: CPU: Topology: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP L2 cache: 4096 KiB

Hors ligne

#2 12/10/2020 11:50:01

fgland
Rédacteur Wiki
Rédacteur Wiki
Lieu : Lituanie
Inscription : 09/08/2004
Messages : 3 042

Re : samba pour les null

je n'ai sans doute pas tout compris, pour accéder un à poste windows, il n'y a pas besoin d'un serveur samba, il suffit du client samba/cif.
Donc précisons bien : linux vers windows ou windows vers linux ?
Gérard

Hors ligne

#3 12/10/2020 12:57:09

thierryR
Membre
Lieu : Chalons en Champagne
Inscription : 31/01/2011
Messages : 1 310
Site Web

Re : samba pour les null

C'est juste du linux vers windows 10


Chalons en Champagne: Au nord, un peu avant la banquise (Ah ben non... Elle a fondu)
Kernel: 5.8.12-200.fc32.x86_64 x86_64 bits: 64 Desktop: KDE Plasma 5.18.5
Type: Desktop Mobo: ASRock model: X470 Gaming-ITX/ac  UEFI: CPU: Topology: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP L2 cache: 4096 KiB

Hors ligne

#4 12/10/2020 14:07:19

fgland
Rédacteur Wiki
Rédacteur Wiki
Lieu : Lituanie
Inscription : 09/08/2004
Messages : 3 042

Re : samba pour les null

il n'y a donc pas besoin de serveur et aucune configuration particulière sur Fedora.
Il faut évidemment qu'il y ait un dossier partagé sous windows et que le port soit ouvert sous windows.
Puisque tu es sous kde, Il suffit de mettre comme adresse dans Dolphin : smb://utilisateur@adresse_ip_windows/dossier_partagé/
On peut facilement mettre ce lien dans le panneau emplacement de Dolphin pour un accès direct.

Gérard

Dernière modification par fgland (12/10/2020 14:07:51)

Hors ligne

#5 12/10/2020 14:38:21

thierryR
Membre
Lieu : Chalons en Champagne
Inscription : 31/01/2011
Messages : 1 310
Site Web

Re : samba pour les null

C'est bizarre, j'ai un mot de passe qui m'est toujours demandé. Le mode anonyme ne fonctionne pas.


Chalons en Champagne: Au nord, un peu avant la banquise (Ah ben non... Elle a fondu)
Kernel: 5.8.12-200.fc32.x86_64 x86_64 bits: 64 Desktop: KDE Plasma 5.18.5
Type: Desktop Mobo: ASRock model: X470 Gaming-ITX/ac  UEFI: CPU: Topology: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP L2 cache: 4096 KiB

Hors ligne

#6 12/10/2020 16:08:40

fgland
Rédacteur Wiki
Rédacteur Wiki
Lieu : Lituanie
Inscription : 09/08/2004
Messages : 3 042

Re : samba pour les null

quel mode anonyme ? il est défini comme tel sur windows ? à priori, c'est le mot de passe de l'utilisateur windows.
Gérard

Hors ligne

#7 12/10/2020 16:46:50

thierryR
Membre
Lieu : Chalons en Champagne
Inscription : 31/01/2011
Messages : 1 310
Site Web

Re : samba pour les null

Le mode anonyme m'est proposé par Dolphin et ne fonctionne pas.
Mon windows n'a pas de mot de passe. Ce doit être ça le problème.


Chalons en Champagne: Au nord, un peu avant la banquise (Ah ben non... Elle a fondu)
Kernel: 5.8.12-200.fc32.x86_64 x86_64 bits: 64 Desktop: KDE Plasma 5.18.5
Type: Desktop Mobo: ASRock model: X470 Gaming-ITX/ac  UEFI: CPU: Topology: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP L2 cache: 4096 KiB

Hors ligne

#8 12/10/2020 18:31:41

Nicosss
Rédacteur Wiki
Rédacteur Wiki
Lieu : Isère
Inscription : 05/03/2007
Messages : 5 934
Site Web

Re : samba pour les null

thierryR a écrit :

Mon windows n'a pas de mot de passe. Ce doit être ça le problème.

Ou la version de SMB utilisée. Tu trouveras des sujets à ce propos sur le forum.


F32_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F32_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F32_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

#9 13/10/2020 17:01:26

fgland
Rédacteur Wiki
Rédacteur Wiki
Lieu : Lituanie
Inscription : 09/08/2004
Messages : 3 042

Re : samba pour les null

thierryR a écrit :

Le mode anonyme m'est proposé par Dolphin et ne fonctionne pas.
Mon windows n'a pas de mot de passe. Ce doit être ça le problème.

Comment as-tu défini le dossier partagé ? Si l'utilisateur n'a pas de mot de passe, cela revient à dire qu'il est accessible à tout le monde. Il faudrait donc définir le partage comme accessible à tout le monde, sur windows bien sûr en utilisant le bouton " partage avancé ".
@Nicosss J'ai un vague souvenir de cette histoire de version mais je ne trouve rien sur le forum

Dernière modification par fgland (13/10/2020 19:03:43)

Hors ligne

#10 15/10/2020 14:46:45

thierryR
Membre
Lieu : Chalons en Champagne
Inscription : 31/01/2011
Messages : 1 310
Site Web

Re : samba pour les null

J'ai partagé "Mes Documents" avec le groupe résidentiel. ( sous windows)
Dans Dolphin j'ai mis:

smb://@192.168.8.17/Utilisateurs/thierry/Bibliothèques/Documents/

Mais pas de connexion possible en anonyme, ni autrement.
j'ai du mal faire un truc.


Chalons en Champagne: Au nord, un peu avant la banquise (Ah ben non... Elle a fondu)
Kernel: 5.8.12-200.fc32.x86_64 x86_64 bits: 64 Desktop: KDE Plasma 5.18.5
Type: Desktop Mobo: ASRock model: X470 Gaming-ITX/ac  UEFI: CPU: Topology: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP L2 cache: 4096 KiB

Hors ligne

#11 15/10/2020 16:21:25

Nicosss
Rédacteur Wiki
Rédacteur Wiki
Lieu : Isère
Inscription : 05/03/2007
Messages : 5 934
Site Web

Re : samba pour les null

Tu as regardé du côté des versions de protocole samba pour le montage comme énoncé plus haut ?


F32_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F32_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F32_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

#12 15/10/2020 16:40:59

thierryR
Membre
Lieu : Chalons en Champagne
Inscription : 31/01/2011
Messages : 1 310
Site Web

Re : samba pour les null

Tu veux dire ceci ?

rpm -qa samba
samba-4.12.7-0.fc32.x86_64

Chalons en Champagne: Au nord, un peu avant la banquise (Ah ben non... Elle a fondu)
Kernel: 5.8.12-200.fc32.x86_64 x86_64 bits: 64 Desktop: KDE Plasma 5.18.5
Type: Desktop Mobo: ASRock model: X470 Gaming-ITX/ac  UEFI: CPU: Topology: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP L2 cache: 4096 KiB

Hors ligne

#13 15/10/2020 17:25:55

Nicosss
Rédacteur Wiki
Rédacteur Wiki
Lieu : Isère
Inscription : 05/03/2007
Messages : 5 934
Site Web

Re : samba pour les null

Non pas du tout.

Je te laisse consulter ces liens pour que tu comprennes un peu mieux d'où peut venir ton problème :
- https://forums.fedora-fr.org/viewtopic.php?id=70816
- https://forums.fedora-fr.org/viewtopic.php?id=70718
- https://forums.fedora-fr.org/viewtopic.php?id=70019


F32_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F32_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F32_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

#14 15/10/2020 17:59:08

fgland
Rédacteur Wiki
Rédacteur Wiki
Lieu : Lituanie
Inscription : 09/08/2004
Messages : 3 042

Re : samba pour les null

thierryR a écrit :

J'ai partagé "Mes Documents" avec le groupe résidentiel. ( sous windows)
Dans Dolphin j'ai mis:

smb://@192.168.8.17/Utilisateurs/thierry/Bibliothèques/Documents/

Mais pas de connexion possible en anonyme, ni autrement.
j'ai du mal faire un truc.

s'il n'y a pas d'utilisateur, il ne faut pas mettre de @.
Bibliothèques est un mot à problème sur le réseau car è doit-être encodé.
Essai avec un partage en dehors des dossiers utilisateur et un chemin sans caractère accentué ou exotique.

J'ai jeté un coup d’œil sur les liens de @Nicosss mais rien qui m'inspire
Je ne rencontre aucun problème sur mon partage avec win10 mais j'ai un mot de passe

Gérard

Hors ligne

#15 15/10/2020 18:28:59

thierryR
Membre
Lieu : Chalons en Champagne
Inscription : 31/01/2011
Messages : 1 310
Site Web

Re : samba pour les null

J'ai essayé:

smb://@192.168.8.17

Mais sans plus de résultat. Aurais tu une ligne exemple de la commande que tu passes sur win10.
Merci.


Chalons en Champagne: Au nord, un peu avant la banquise (Ah ben non... Elle a fondu)
Kernel: 5.8.12-200.fc32.x86_64 x86_64 bits: 64 Desktop: KDE Plasma 5.18.5
Type: Desktop Mobo: ASRock model: X470 Gaming-ITX/ac  UEFI: CPU: Topology: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP L2 cache: 4096 KiB

Hors ligne

#16 15/10/2020 19:27:08

fgland
Rédacteur Wiki
Rédacteur Wiki
Lieu : Lituanie
Inscription : 09/08/2004
Messages : 3 042

Re : samba pour les null

heureusement que je te disais de ne pas mettre l'@
il faut mettre le chemin complet avec le dossier partagé : smb://adresse_ip_windows/dossier_partagé/
as-tu créé un dossier partagé en dehors du répertoire utilisateur ?

Sous windows, dans l'explorateur de fichier, clic droit sur le dossier partagé/Partage, cliquer sur 'Partage avancé' pour donner les droits à tout le monde
Je l'ai déjà dit au #9 mais je le répète !

Gérard

Dernière modification par fgland (15/10/2020 20:46:05)

Hors ligne

#17 15/10/2020 22:50:48

thierryR
Membre
Lieu : Chalons en Champagne
Inscription : 31/01/2011
Messages : 1 310
Site Web

Re : samba pour les null

J'ai répondu sur la 1ere ligne du message #10.
L'@ est mis automatiquement par dolphin. Normalement c'est l'utilisateur qui vient en 1er. S'il n'y est pas, c'est l'utilisateur par défaut qui est utilisé. C'est comme pour SSH. Là où je me pose une question c'est qu'on ne peut pas mettre une adresse du genre: smb://user@adresse_ip_windows/C:/chemin/dossier_partagé/
Dolphin nous redirige vers le navigateur.


Chalons en Champagne: Au nord, un peu avant la banquise (Ah ben non... Elle a fondu)
Kernel: 5.8.12-200.fc32.x86_64 x86_64 bits: 64 Desktop: KDE Plasma 5.18.5
Type: Desktop Mobo: ASRock model: X470 Gaming-ITX/ac  UEFI: CPU: Topology: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP L2 cache: 4096 KiB

Hors ligne

#18 16/10/2020 10:08:15

fgland
Rédacteur Wiki
Rédacteur Wiki
Lieu : Lituanie
Inscription : 09/08/2004
Messages : 3 042

Re : samba pour les null

ce n'est pas un chemin valide. de plus il faut désactiver l'accès par mot de passe dans windows.
Ouvrir le Centre réseau et partage
Cliquer sur 'Modifier les paramètres de partage avancés'
développer la partie masquée de 'Tous les réseaux' en bas de la page
Choisir l'option qui va bien !
J'ai testé, ça marche chez moi en connexion 'anonyme' de Dolphin

Une petite recherche sur le net t'aurais donné la solution

Gérard

Hors ligne

#19 19/10/2020 11:30:36

thierryR
Membre
Lieu : Chalons en Champagne
Inscription : 31/01/2011
Messages : 1 310
Site Web

Re : samba pour les null

fgland a écrit :

Une petite recherche sur le net t'aurais donné la solution

Gérard

Oui surement, mais mes lacunes sont grandes dans ce système. Comme ça ne fonctionne toujours pas, j'essaie aussi avec un win7, mais pas mieux.
Tu pourrais me mettre ta formule dans dolphin: "smb://192.168.?.?/............." Ça m'aiderait peut-être !


Chalons en Champagne: Au nord, un peu avant la banquise (Ah ben non... Elle a fondu)
Kernel: 5.8.12-200.fc32.x86_64 x86_64 bits: 64 Desktop: KDE Plasma 5.18.5
Type: Desktop Mobo: ASRock model: X470 Gaming-ITX/ac  UEFI: CPU: Topology: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP L2 cache: 4096 KiB

Hors ligne

#20 19/10/2020 15:17:44

fgland
Rédacteur Wiki
Rédacteur Wiki
Lieu : Lituanie
Inscription : 09/08/2004
Messages : 3 042

Re : samba pour les null

les modifications sous windows ont été faites ? Pour mon test j'ai activé le partage sans mot de passe sur les dossiers Public et j'ai défini le partage sur le dossier Music.
Le chemin est donc smb://ip_win/Music

Gérard

Hors ligne

#21 19/10/2020 17:33:41

thierryR
Membre
Lieu : Chalons en Champagne
Inscription : 31/01/2011
Messages : 1 310
Site Web

Re : samba pour les null

Merci de ton aide Gérard. Je vais encore essayer....  Tu es bien patient.:-P


Chalons en Champagne: Au nord, un peu avant la banquise (Ah ben non... Elle a fondu)
Kernel: 5.8.12-200.fc32.x86_64 x86_64 bits: 64 Desktop: KDE Plasma 5.18.5
Type: Desktop Mobo: ASRock model: X470 Gaming-ITX/ac  UEFI: CPU: Topology: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP L2 cache: 4096 KiB

Hors ligne

Pied de page des forums