Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora Linux 37 est disponible !

#1 19/11/2022 11:15:08

ptitdernier
Membre
Lieu : de retour en occitanie
Inscription : 19/09/2006
Messages : 1 255

[Résolu] problème installation minidlna

À une époque j'avais utilisé minidlna sur une autre machine. J'avais réussi à le rendre fonctionnel après bien des galères dont je ne me souviens plus.

J'explique ma config
J'ai un NAS Qnap 351-D sur lequel j'ai installé fedora server ; j'ai viré QTS car c'est une vraie usine à gaz dont je n'utilisais que très peu de fonctionnalités.

J'ai un utilisateur nommé serveur qui stocke les sauvegardes de mes divers appareils et qui me sert de serveur multimédia avec ses différents dossiers Images, Vidéos et Musique.

Sur le fichier standard minidlna.conf je ne modifie que l'interface réseau et j'ajoute mes dossiers multimédia ; bien sur je relance le service après avoir configuré le pare-feu.
Le service plante car il n'arrive pas à monter mes dossiers. Je pensais que le service minidlnad se lançait trop tôt, avant le montage de mon dossier utilisateur.
Mais après vérification de minidlnad.service l'exécutable est lancé après montage des dossiers et il s'agit sans doute d'un problème de permissions d'accès au fichiers.

J'ai réessayé en rajoutant l'utilisateur minidlna à mon groupe "serveur". Même soucis.

Changement de stratégie
J'utilise "serveur" comme utilisateur
J'adapte les droits "serveur" à /var/run/minidlna" et à "/var/cache/minidlna".
Si je redémarre mon serveur cela ne marche pas, mais si après le démarrage je lance manuellement le daemon minidlnad cela fonctionne.

J'ai lu sur certains forums qu'utiliser le user root résolvait le problème ; je n'ai pas testé mais cette solution ne me plaît pas trop.


MSI GE60 2PE Apache Pro - 16 Go - Intel core i7 4720 2,6 GHz - nVidia GTX860M - Cinnamon
CM ASUS PRIME B250M-K - Intel core I5-7500 3,4 Ghz - 8 Go DDRA Corsair vengence LPX 2400Mhz

Hors ligne

#2 19/11/2022 11:43:27

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 18 984
Site Web

Re : [Résolu] problème installation minidlna

En désactivant selinux le temps d'analyser ce qui ne vas pas?

sudo setenforce 0

Après tu peux forcer ton service à se lancer avant/après d'autres.

Il faut modifier :

sudo systemctl edit nomduservice

et modifier "After/before" dans [Unit].

Après faut regarder dans les groupes qui a le droit de faire ce genre de chose. Mais je soupçonne selinux quand même à ce niveau...

Dernière modification par VINDICATORs (19/11/2022 11:44:17)


AMD R7 5800x X470 64Go DDR4 3.6Ghz, RX5700XT+AMD R7 2700x A320 + 32Go DDR4 3.2Ghz, rx6500xt 4Go
AMD R5 2600 A320, 32Go DDR4 2.9Ghz,1030GT 2Go + AMD A6 9500 A320, 16Go DDR4 2.1Ghz
ARM Rpi4 4Go, à venir Pine64 2xQuartzB 2/4Go

Hors ligne

#3 19/11/2022 12:42:33

antbel
Membre
Inscription : 03/12/2007
Messages : 1 059

Re : [Résolu] problème installation minidlna

Bonjour
As-tu fait?

$ sudo usermod -a -G minidlna nom_utilisateur

et non l'inverse?.

Dernière modification par antbel (19/11/2022 12:53:53)


Cicéron c'est Poincaré

Hors ligne

#4 20/11/2022 11:48:00

ptitdernier
Membre
Lieu : de retour en occitanie
Inscription : 19/09/2006
Messages : 1 255

Re : [Résolu] problème installation minidlna

antbel a écrit :

Bonjour
As-tu fait?

$ sudo usermod -a -G minidlna nom_utilisateur

et non l'inverse?.

tu as vu juste hammer hammer hammer

je marque "résolu"


MSI GE60 2PE Apache Pro - 16 Go - Intel core i7 4720 2,6 GHz - nVidia GTX860M - Cinnamon
CM ASUS PRIME B250M-K - Intel core I5-7500 3,4 Ghz - 8 Go DDRA Corsair vengence LPX 2400Mhz

Hors ligne

Pied de page des forums