Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora 37 Beta est disponible

#1 11/09/2022 17:42:38

duboutdeloctet
Membre
Inscription : 28/05/2022
Messages : 17

[Résolu] Problème de mises à jour dues

Bonjour,

Depuis quelques jours toutes les mises à jour sont en échec :
avec

dnf -y update
....
La clé GPG https://keyserver.ubuntu.com/pks/lookup?op=get&search=0xc99b11deb97541f0 (0xB97541F0) est déjà installée
Les clés GPG listées pour le dépôt « packages for the GitHub CLI » sont déjà installées mais sont incorrectes pour ce paquet.
Vérifiez que les URL des clés pour ce dépôt soient correctes.. Le paquet en erreur est : gh-2.15.0-1.x86_64
 Les clés GPG sont configurées comme : https://keyserver.ubuntu.com/pks/lookup?op=get&search=0xc99b11deb97541f0
Les paquets téléchargés ont été mis en cache jusqu’à la prochaine transaction réussie.
Vous pouvez supprimer les paquets en cache en exécutant « dnf clean packages ».
Erreur : La vérification GPG a ÉCHOUÉ

avec Packagekit :

<html>Une mauvaise signature GPG a été trouvée:<br/><br/>failed to parse public key for /var/cache/PackageKit/36/metadata/protonvpn-fedora-stable-36-x86_64/public_key.asc</html>

J'ai donc deux problèmes de signatures.
Avez-vous eu ce genre de retour ?
Avez vous une solution ?

Merci de votre aide.

Hors ligne

#2 11/09/2022 18:19:12

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 23 735

Re : [Résolu] Problème de mises à jour dues

Il y a une raison pour que les paquets en cause proviennent d'un dépôt ubuntu ?


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#3 11/09/2022 19:27:44

Nicosss
Rédacteur Wiki
Rédacteur Wiki
Lieu : Isère
Inscription : 05/03/2007
Messages : 7 488
Site Web

Re : [Résolu] Problème de mises à jour dues

gh est dans le dépôt updates. Il y a un intérêt à ce paquet provenant de je ne sais où ?

Que retourne

$ dnf repolist

F36_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F36_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F36_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

#4 11/09/2022 19:35:46

duboutdeloctet
Membre
Inscription : 28/05/2022
Messages : 17

Re : [Résolu] Problème de mises à jour dues

J'ai désactivé mon repo gh-cli.
J'ai pu faire toutes les mises à jour.

En ré-activant le repo gh-cli, j'ai encore la même erreur, mais que pour gh qui a justement le paramètre gpgkey=https://keyserver.ubuntu.com/pks/lookup?op=get&search=0xc99b11deb97541f0.

Je vais laisser désactiver en attendant une mise à jour Fedora pour ce paquet en espérant qu'il n'y a pas de faille ou autres trucs désagréables.

Hors ligne

#5 13/09/2022 09:15:36

duboutdeloctet
Membre
Inscription : 28/05/2022
Messages : 17

Re : [Résolu] Problème de mises à jour dues

nouvo09 a écrit :

Il y a une raison pour que les paquets en cause proviennent d'un dépôt ubuntu ?

C'était une astuce de l'équipe de développeurs de gh, de mémoire, pour assurer la continuité après la décision de l'équipe de git de ne plus proposer d'authentification par mot de passe mais par l'utilisation d'un wallet.

Comme il y a parfois des décalages de versions entre les distributions.

Problème résolu puisque mes mises à jour s'effectuent bien depuis que j'ai désactivé le dépôt et mise à jour du paquet gh-2.15 ce matin : gh-2.15.0-1.fc36.x86_64 .

Merci de votre aide.

Hors ligne

#6 13/09/2022 19:11:29

Nicosss
Rédacteur Wiki
Rédacteur Wiki
Lieu : Isère
Inscription : 05/03/2007
Messages : 7 488
Site Web

Re : [Résolu] Problème de mises à jour dues

Bonne continuation !


F36_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F36_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F36_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

Pied de page des forums