Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora 37 Beta est disponible

#1 17/06/2022 14:45:08

DidierHV
Membre
Inscription : 23/10/2020
Messages : 2

GLPI ne va plus après upgrade de Fedora 34 vers 35

Bonjour,

1°    wink
La mise à jour se passe sans aucun souci.
J'ai malgré tout du réinstaller KDE mais cela n'a pas posé de problème.

sad
J'ai le message d'erreur suivant quand je désire accéder à la page web pour s'identifier sur le programme GLPI (9.5.2).

Cette page n’est pas disponible pour le moment192.168.0.32 ne peut actuellement pas traiter cette demande.
HTTP ERROR 500

Ce n'est pas le message suivant qui apparait :

Not Found
The requested URL was not found on this server.

Ce qui signifie que mon navigateur voit bien qu'il y a un répertoire au nom de glpi mais la page web ne s'affiche pas.

Dans quel sens dois-je chercher la solution à ce problème après mise à jour?

Mon objectif est de passer de la version 34 à la version 36 mais si cela bloque déjà à la version 35, ce n'est pas bien parti.
Je ne compte pas changer la version de GLPI pour l'instant car la version 10.0.1 est 'trop' récente.

Je vous remercie d'avance pour toute l'attention que vous voudrez bien accorder à ma demande.

Didier.

Hors ligne

#2 17/06/2022 15:26:20

remi
Crazy PHP packages monkey... !
Rédacteur Wiki
Lieu : Champagne...
Inscription : 16/10/2004
Messages : 5 598
Site Web

Re : GLPI ne va plus après upgrade de Fedora 34 vers 35

> HTTP ERROR 500

Voir les journaux qui auront l'erreur détaillée ;)
=> /var/log/php-fpm/

Hors ligne

#3 21/06/2022 13:02:37

DidierHV
Membre
Inscription : 23/10/2020
Messages : 2

Re : GLPI ne va plus après upgrade de Fedora 34 vers 35

Merci remi.

En effet, j'ai un fichier avec plein de messages d'erreur mais j'imagine que le premier message doit être le plus important.

Voici le première erreur répertoriée dans le fichier 'www-error.log-20220621' :
[17-Jun-2022 ...] PHP Notice : Undefined index : id in /var/www/html/glpi/inc/auth.class.php on line 880

voici le contenu de la ligne 880 du fichier en question :
User::manageDeletedUserInLdap($this->user->fields["id"]);

Pour faire la mise à jour, la première fois, je l'ai fait directement sur la machine de production dans le domaine.
Vu que cela ne fonctionnait pas alors j'ai restauré ma VM en production.

Pour faire la mise à jour la deuxième fois et ne plus impacter la production, je travaille sur une copie de la VM sur mon PC local hors domaine AD avec Virtual Box.

Je suis un peu confus car je ne vois pas encore la bonne piste à suivre pour résoudre ce problème.

N'hésitez pas à me proposer des solutions avec toutes les informations que j'ai données.

Entre temps, je vais essayez de comprendre les autres erreurs de ce fichier log.

Merci d'avance.

Hors ligne

Pied de page des forums