Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora Linux 36 est disponible !

#1 24/11/2021 11:32:52

talziary
Membre
Inscription : 24/01/2008
Messages : 127

[Résolu] problème de swap ?

Bonjour,

Je rencontre le problème suivant : disparition soudaine de ma seule fenêtre dans laquelle se déroulait un calcul lourd en CPU (les 16 threads possibles en parallèle...) et en mémoire. Le problème est aléatoire et ne se repète pas
au même endroit si on recommence.

Dans les logs je trouve

nov. 24 02:46:08 localhost.localdomain cupsd[1204]: Expiring subscriptions...
nov. 24 02:46:09 localhost.localdomain cupsd[1204]: Expiring subscriptions...
nov. 24 02:46:09 localhost.localdomain systemd-oomd[1011]: Killed /user.slice/user-1000.slice/user@1000.service/app.slice/app-org.gnome.Terminal.slice/vte-spawn-91e562c7-fb98-4422-86fb-3ef9cfa7295a.scope
due to memory pressure for /user.slice/user-1000.slice/user@1000.service being 63.25% > 50.00% for > 20s with reclaim activity
nov. 24 02:46:10 localhost.localdomain cupsd[1204]: Expiring subscriptions...
nov. 24 02:46:11 localhost.localdomain cupsd[1204]: Expiring subscriptions...
nov. 24 02:46:11 localhost.localdomain systemd[2203]: vte-spawn-91e562c7-fb98-4422-86fb-3ef9cfa7295a.scope: systemd-oomd killed 5 process(es) in this unit.
nov. 24 02:46:11 localhost.localdomain systemd[2203]: vte-spawn-91e562c7-fb98-4422-86fb-3ef9cfa7295a.scope: Consumed 1d 7h 52min 5.698s CPU time.
nov. 24 02:46:11 localhost.localdomain systemd[2203]: gnome-terminal-server.service: Consumed 4.138s CPU time.
nov. 24 02:46:12 localhost.localdomain cupsd[1204]: Expiring subscriptions...
nov. 24 02:46:13 localhost.localdomain cupsd[1204]: Expiring subscriptions...

La partie    Consumed 1d 7h 52min 5.698s CPU time  correspond au temps cumulé des 16 threads
Je crois comprendre que le job a été tué pour un problème de ressources sans doute mémoire ???

Si je regarde du coté swap :

 
swapon
NAME           TYPE      SIZE   USED PRIO
/dev/nvme0n1p6 partition  20G 189,8M   -2
/dev/zram0     partition   8G 482,6M  100

Merci d'avance si quelqu'un a des idées sur ce genre de problème

Hors ligne

#2 24/11/2021 12:14:37

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 18 760
Site Web

Re : [Résolu] problème de swap ?

Que retourne :

free -m

A tout les coups tu t'es pris un oomkiller.

Et que retourne :

sysctl --all | grep swap

Dernière modification par VINDICATORs (24/11/2021 12:19:45)


AMD R7 5800x, MSI Pro Carbon X470, 64Go DDR4 3600 Kingston Renegarde C18 (en test), RX5700XT MSI WaterCooling OC, SSD : 1xPNY LXR8 1To + 1x970EVO 500Go + 2x500Go 860EVO, 3x1To 860EVO, HDD WD 2To + 4To Black, 3To Red, BeQuiet Purepower 1000W plat, BSGT Dark 900
AMD R7 2700x + 32Go DDR4 3200Mhz, 1xPNY LXR8 1To, 2x1To 860QVO, BMT MasterBox Q300L
AMD R5 2600, Asus mATX, 32Go DDR4 2933Mhz, 1x250GO SSD, 3x 2To RAID5 WDBlue, BCubes Chieftec + AMD A6 9500, 16Go, SSD 250Go

Hors ligne

#3 24/11/2021 12:45:05

talziary
Membre
Inscription : 24/01/2008
Messages : 127

Re : [Résolu] problème de swap ?

Voila :

 free -m
               total        used        free      shared  buff/cache   available
Mem:           15742        1732        1563         274       12446       13228
Swap:          28671         663       28008
 sysctl --all | grep swap
vm.swappiness = 10

Hors ligne

#4 25/11/2021 13:24:29

talziary
Membre
Inscription : 24/01/2008
Messages : 127

Re : [Résolu] problème de swap ?

J'ai essayé de passer oom_score_adj à -15 sur le PID en question sans succès mais j'avais mal lu car apparemment le oom_score_adj peut varier de -1000 à +1000 donc l'essai de modifier le oom_score_adj est à refaire.

Finalement je m'en suis sorti en passant le swappiness de 10 à 60.

Hors ligne

Pied de page des forums