Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora 34 n'est plus maintenu

#1 07/11/2021 11:24:09

greg0ire
La bonne fée Dora
Inscription : 27/01/2007
Messages : 628
Site Web

Anciens repositories toujours utilisés?

Bonjour, je mets ce sujet dans la rubrique "Installation" car je soupçonne que c'est une installation pas tout à fait terminée.

D'une part, `cat /etc/fedora-release` me confirme que je suis bien en version 35.
D'autre part, quand je lance dnf, je vois la liste de dépôts suivante:


Adobe Systems Incorporated                                                                                                                                    5.0 kB/s | 2.0 kB     00:00    
Docker CE Stable - x86_64                                                                                                                                      31 kB/s | 9.8 kB     00:00    
Fedora 34 - x86_64                                                                                                                                            1.8 MB/s |  74 MB     00:42    
Fedora 34 openh264 (From Cisco) - x86_64                                                                                                                      5.0 kB/s | 2.5 kB     00:00    
Fedora Modular 34 - x86_64                                                                                                                                    1.4 MB/s | 4.9 MB     00:03    
Fedora 34 - x86_64 - Updates                                                                                                                                  1.7 MB/s |  28 MB     00:16    
Fedora Modular 34 - x86_64 - Updates                                                                                                                          1.3 MB/s | 4.2 MB     00:03    
Yet Another Dotfiles Manager (Fedora_32)                                                                                                                      2.5 kB/s | 1.5 kB     00:00    
keybase                                                                                                                                                        26 kB/s |  14 kB     00:00    
RPM Fusion for Fedora 34 - Free                                                                                                                               978 kB/s | 941 kB     00:00    
RPM Fusion for Fedora 34 - Free tainted                                                                                                                        77 kB/s |  28 kB     00:00    
RPM Fusion for Fedora 34 - Free - Updates                                                                                                                     637 kB/s | 382 kB     00:00    
RPM Fusion for Fedora 34 - Nonfree                                                                                                                            442 kB/s | 246 kB     00:00    
RPM Fusion for Fedora 34 - Nonfree - Updates                                                                                                                  177 kB/s |  71 kB     00:00 

Ça ne me semble pas très normal…

Dernière modification par greg0ire (07/11/2021 11:24:33)


profile for greg0ire on Stack Exchange, a network of free, community-driven Q&A sites

Hors ligne

#2 07/11/2021 11:48:08

Nicosss
Rédacteur Wiki
Rédacteur Wiki
Lieu : Isère
Inscription : 05/03/2007
Messages : 7 337
Site Web

Re : Anciens repositories toujours utilisés?


F35_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F36_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F35_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

#3 07/11/2021 12:22:20

greg0ire
La bonne fée Dora
Inscription : 27/01/2007
Messages : 628
Site Web

Re : Anciens repositories toujours utilisés?

Ah effectivement ouhla… merci. Je vais essayer ce que tu as mis dans ce thread.


profile for greg0ire on Stack Exchange, a network of free, community-driven Q&A sites

Hors ligne

#4 07/11/2021 12:25:13

greg0ire
La bonne fée Dora
Inscription : 27/01/2007
Messages : 628
Site Web

Re : Anciens repositories toujours utilisés?

sudo dnf distro-sync --releasever=35
[sudo] password for greg: 
Docker CE Stable - x86_64                                                                                                                                      12 kB/s | 4.5 kB     00:00    
Fedora 35 - x86_64                                                                                                                                            1.5 MB/s |  61 MB     00:40    
Fedora 35 openh264 (From Cisco) - x86_64                                                                                                                      4.0 kB/s | 2.5 kB     00:00    
Fedora Modular 35 - x86_64                                                                                                                                    1.2 MB/s | 2.6 MB     00:02    
Fedora 35 - x86_64 - Updates                                                                                                                                  1.6 MB/s |  10 MB     00:06    
Fedora Modular 35 - x86_64 - Updates                                                                                                                          1.1 MB/s | 3.3 MB     00:03    
keybase                                                                                                                                                        28 kB/s | 3.3 kB     00:00    
RPM Fusion for Fedora 35 - Free                                                                                                                               902 kB/s | 934 kB     00:01    
RPM Fusion for Fedora 35 - Free tainted                                                                                                                        14 kB/s | 6.1 kB     00:00    
RPM Fusion for Fedora 35 - Free - Updates                                                                                                                      30 kB/s |  12 kB     00:00    
RPM Fusion for Fedora 35 - Nonfree                                                                                                                            400 kB/s | 239 kB     00:00    
RPM Fusion for Fedora 35 - Nonfree - Updates                                                                                                                   36 kB/s |  15 kB     00:00    
Error: 
 Problem: The operation would result in removing the following protected packages: dnf, shim-x64, sudo, sudo, systemd, systemd-udev
(try to add '--skip-broken' to skip uninstallable packages)

Ça parle bien de 35 maintenant, mais du coup je suis pas super chaud pour retirer les packages protégés :P


rpm -qa fedora-release\*
fedora-release-identity-workstation-34-37.noarch
fedora-release-workstation-34-37.noarch
fedora-release-common-34-37.noarch
fedora-release-identity-workstation-35-33.noarch
fedora-release-workstation-35-33.noarch
fedora-release-common-35-33.noarch

Je vois aussi que j'ai plein de paquest avec des dépendances pas satisfaites…


sudo dnf repoquery --unsatisfied


keybase                                                                                                                                                        31 kB/s | 3.3 kB     00:00    

 Problem 1: problem with installed package nvidia-settings-3:495.44-1.fc35.x86_64
  - nothing provides nvidia-kmod-common >= 3:495.44 needed by nvidia-settings-3:495.44-1.fc35.x86_64
 Problem 2: package sdl12-compat-0.0.1~git.20210926.c6cfc8f-1.fc35.x86_64 conflicts with SDL < 1.2.50 provided by SDL-1.2.15-46.fc34.i686
  - installed package sdl12-compat-0.0.1~git.20210926.c6cfc8f-1.fc35.x86_64 obsoletes SDL < 1.2.15-47 provided by SDL-1.2.15-46.fc34.i686
  - problem with installed package sdl12-compat-0.0.1~git.20210926.c6cfc8f-1.fc35.x86_64
  - problem with installed package SDL-1.2.15-46.fc34.i686
 Problem 3: cannot install both libavif-0.9.2-2.fc35.i686 and libavif-0.9.0-2.fc34.i686
  - package gd-2.3.2-2.fc34.i686 requires libavif.so.10, but none of the providers can be installed
  - problem with installed package libavif-0.9.2-2.fc35.i686
  - problem with installed package gd-2.3.2-2.fc34.i686
 Problem 4: cannot install both libbrotli-1.0.9-6.fc35.i686 and libbrotli-1.0.9-4.fc34.i686
  - package brotli-1.0.9-4.fc34.i686 requires libbrotli(x86-32) = 1.0.9-4.fc34, but none of the providers can be installed
  - problem with installed package libbrotli-1.0.9-6.fc35.i686
  - problem with installed package brotli-1.0.9-4.fc34.i686
 Problem 5: package mesa-dri-drivers-21.1.8-3.fc34.i686 requires libLLVM-12.so, but none of the providers can be installed
  - package mesa-dri-drivers-21.1.8-3.fc34.i686 requires libLLVM-12.so(LLVM_12), but none of the providers can be installed
  - cannot install both llvm-libs-13.0.0~rc1-1.fc35.i686 and llvm-libs-12.0.1-1.fc34.i686
  - problem with installed package mesa-dri-drivers-21.1.8-3.fc34.i686
  - problem with installed package llvm-libs-13.0.0~rc1-1.fc35.i686
 Problem 6: cannot install both mesa-libglapi-21.2.5-1.fc35.i686 and mesa-libglapi-21.1.8-3.fc34.i686
  - package mesa-libOSMesa-21.1.8-3.fc34.i686 requires mesa-libglapi(x86-32) = 21.1.8-3.fc34, but none of the providers can be installed
  - problem with installed package mesa-libglapi-21.2.5-1.fc35.i686
  - problem with installed package mesa-libOSMesa-21.1.8-3.fc34.i686
 Problem 7: cannot install both nodejs-libs-1:16.11.1-1.fc35.x86_64 and nodejs-libs-1:14.18.1-1.fc34.x86_64
  - package nodejs-1:14.18.1-1.fc34.x86_64 requires libnode.so.83()(64bit), but none of the providers can be installed
  - package nodejs-1:14.18.1-1.fc34.x86_64 requires nodejs-libs(x86-64) = 1:14.18.1-1.fc34, but none of the providers can be installed
  - problem with installed package nodejs-libs-1:16.11.1-1.fc35.x86_64
  - problem with installed package nodejs-1:14.18.1-1.fc34.x86_64
 Problem 8: cannot install both pipewire-libs-0.3.39-1.fc35.x86_64 and pipewire-libs-0.3.39-1.fc34.x86_64
  - package pipewire-0.3.39-1.fc34.x86_64 requires pipewire-libs(x86-64) = 0.3.39-1.fc34, but none of the providers can be installed
  - problem with installed package pipewire-libs-0.3.39-1.fc35.x86_64
  - problem with installed package pipewire-0.3.39-1.fc34.x86_64
 Problem 9: package python3-pysendfile-2.0.1-17.fc33.x86_64 requires python(abi) = 3.9, but none of the providers can be installed
  - cannot install both python3-3.10.0-1.fc35.x86_64 and python3-3.9.7-1.fc34.x86_64
  - problem with installed package python3-pysendfile-2.0.1-17.fc33.x86_64
  - problem with installed package python3-3.10.0-1.fc35.x86_64
 Problem 10: cannot install both qt-common-1:4.8.7-65.fc35.noarch and qt-common-1:4.8.7-61.fc34.noarch
  - package qt-1:4.8.7-61.fc34.i686 requires qt-common = 1:4.8.7-61.fc34, but none of the providers can be installed
  - problem with installed package qt-common-1:4.8.7-65.fc35.noarch
  - problem with installed package qt-1:4.8.7-61.fc34.i686
 Problem 11: cannot install both qt-mobility-common-1.2.2-0.41.20140317git169da60c.fc35.i686 and qt-mobility-common-1.2.2-0.40.20140317git169da60c.fc34.i686
  - package qt-mobility-bearer-1.2.2-0.40.20140317git169da60c.fc34.i686 requires qt-mobility-common(x86-32) = 1.2.2-0.40.20140317git169da60c.fc34, but none of the providers can be installed
  - problem with installed package qt-mobility-common-1.2.2-0.41.20140317git169da60c.fc35.i686
  - problem with installed package qt-mobility-bearer-1.2.2-0.40.20140317git169da60c.fc34.i686
 Problem 12: cannot install both steam-devices-1.0.0.72-1.fc35.i686 and steam-devices-1.0.0.72-1.fc34.i686
  - installed package steam-devices-1.0.0.72-1.fc35.i686 obsoletes steam-devices < 1.0.0.72-1.fc35 provided by steam-devices-1.0.0.72-1.fc34.i686
  - package steam-1.0.0.72-1.fc34.i686 requires steam-devices = 1.0.0.72-1.fc34, but none of the providers can be installed
  - problem with installed package steam-devices-1.0.0.72-1.fc35.i686
  - problem with installed package steam-1.0.0.72-1.fc34.i686
 Problem 13: package vlc-1:3.0.16-1.fc34.x86_64 requires libfluidsynth.so.2()(64bit), but none of the providers can be installed
  - cannot install both fluidsynth-libs-2.2.3-1.fc35.x86_64 and fluidsynth-libs-2.1.8-3.fc34.x86_64
  - problem with installed package vlc-1:3.0.16-1.fc34.x86_64
  - problem with installed package fluidsynth-libs-2.2.3-1.fc35.x86_64
 Problem 14: package vlc-core-1:3.0.16-1.fc34.x86_64 requires libsrt.so.1()(64bit), but none of the providers can be installed
  - cannot install both srt-libs-1.4.4-1.fc35.x86_64 and srt-libs-1.4.2-4.fc34.x86_64
  - problem with installed package vlc-core-1:3.0.16-1.fc34.x86_64
  - problem with installed package srt-libs-1.4.4-1.fc35.x86_64
 Problem 15: cannot install both xorg-x11-drv-nvidia-libs-3:495.44-3.fc35.i686 and xorg-x11-drv-nvidia-libs-3:470.74-1.fc34.i686
  - package xorg-x11-drv-nvidia-libs-3:470.74-1.fc34.x86_64 requires (xorg-x11-drv-nvidia-libs(x86-32) = 3:470.74-1.fc34 if mesa-libGL(x86-32)), but none of the providers can be installed
  - problem with installed package xorg-x11-drv-nvidia-libs-3:495.44-3.fc35.i686
  - problem with installed package xorg-x11-drv-nvidia-libs-3:470.74-1.fc34.x86_64
  - problem with installed package mesa-libGL-21.2.5-1.fc35.i686
 Problem 16: cannot install both llvm-libs-13.0.0~rc1-1.fc35.i686 and llvm-libs-12.0.1-1.fc34.i686
  - package mesa-libxatracker-21.1.8-3.fc34.i686 requires libLLVM-12.so, but none of the providers can be installed
  - package mesa-libxatracker-21.1.8-3.fc34.i686 requires libLLVM-12.so(LLVM_12), but none of the providers can be installed
  - package clang-libs-13.0.0~rc1-1.fc35.i686 requires libLLVM-13.so.0, but none of the providers can be installed
  - package clang-libs-13.0.0~rc1-1.fc35.i686 requires libLLVM-13.so.0(LLVM_13), but none of the providers can be installed
  - problem with installed package mesa-libxatracker-21.1.8-3.fc34.i686
  - problem with installed package clang-libs-13.0.0~rc1-1.fc35.i686
 Problem 17: cannot install both qt-common-1:4.8.7-65.fc35.noarch and qt-common-1:4.8.7-61.fc34.noarch
  - package qt-1:4.8.7-61.fc34.i686 requires qt-common = 1:4.8.7-61.fc34, but none of the providers can be installed
  - package qt-1:4.8.7-65.fc35.x86_64 requires qt-common = 1:4.8.7-65.fc35, but none of the providers can be installed
  - package dbusmenu-qt-0.9.3-0.26.20160218.fc34.i686 requires libQtCore.so.4, but none of the providers can be installed
  - package dbusmenu-qt-0.9.3-0.26.20160218.fc34.i686 requires libQtDBus.so.4, but none of the providers can be installed
  - problem with installed package qt-1:4.8.7-65.fc35.x86_64
  - problem with installed package dbusmenu-qt-0.9.3-0.26.20160218.fc34.i686
 Problem 18: cannot install both qt-common-1:4.8.7-65.fc35.noarch and qt-common-1:4.8.7-61.fc34.noarch
  - package qt-1:4.8.7-65.fc35.x86_64 requires qt-common = 1:4.8.7-65.fc35, but none of the providers can be installed
  - package qt-1:4.8.7-61.fc34.i686 requires qt-common = 1:4.8.7-61.fc34, but none of the providers can be installed
  - package qt-x11-1:4.8.7-65.fc35.x86_64 requires qt(x86-64) = 1:4.8.7-65.fc35, but none of the providers can be installed
  - package qt-mobility-connectivity-1.2.2-0.40.20140317git169da60c.fc34.i686 requires libQtCore.so.4, but none of the providers can be installed
  - package qt-mobility-connectivity-1.2.2-0.40.20140317git169da60c.fc34.i686 requires libQtDBus.so.4, but none of the providers can be installed
  - problem with installed package qt-x11-1:4.8.7-65.fc35.x86_64
  - problem with installed package qt-mobility-connectivity-1.2.2-0.40.20140317git169da60c.fc34.i686

Y a l'air d'y avoir pas mal de packages en double en fait… Je vais essayer de retirer les versions fc34

Dernière modification par greg0ire (07/11/2021 12:40:14)


profile for greg0ire on Stack Exchange, a network of free, community-driven Q&amp;A sites

Hors ligne

#5 07/11/2021 12:53:12

greg0ire
La bonne fée Dora
Inscription : 27/01/2007
Messages : 628
Site Web

Re : Anciens repositories toujours utilisés?

Bon… c'est trop compliqué, je crois que je vais utiliser la même solution que dans l'autre thread: réinstallation du système via une liveUSB T__T


profile for greg0ire on Stack Exchange, a network of free, community-driven Q&amp;A sites

Hors ligne

#6 07/11/2021 14:22:26

Nicosss
Rédacteur Wiki
Rédacteur Wiki
Lieu : Isère
Inscription : 05/03/2007
Messages : 7 337
Site Web

Re : Anciens repositories toujours utilisés?

Je viens de voir que tu as des versions de paquets en "doublon".

Essaye de virer les paquets suivants car je ne les ai plus en F35

$ sudo dnf remove fedora-release-identity-workstation-34-37.noarch fedora-release-workstation-34-37.noarch fedora-release-common-34-37.noarch

F35_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F36_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F35_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

#7 07/11/2021 18:46:24

greg0ire
La bonne fée Dora
Inscription : 27/01/2007
Messages : 628
Site Web

Re : Anciens repositories toujours utilisés?

Ça me donne un résultat similaire (si je réessaie distro-sync, on me propose d'enlever dnf, sudo, systemd… que des trucs importants quoi haha)


profile for greg0ire on Stack Exchange, a network of free, community-driven Q&amp;A sites

Hors ligne

#8 07/11/2021 19:20:23

Nicosss
Rédacteur Wiki
Rédacteur Wiki
Lieu : Isère
Inscription : 05/03/2007
Messages : 7 337
Site Web

Re : Anciens repositories toujours utilisés?

Et en faisant juste

$ sudo dnf clean all
$ sudo dnf upgrade --refresh

Est-ce bien les bons dépôts cette fois ? Et la mise à jour s'effectue-t-elle ?


F35_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F36_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F35_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

#9 07/11/2021 19:25:44

greg0ire
La bonne fée Dora
Inscription : 27/01/2007
Messages : 628
Site Web

Re : Anciens repositories toujours utilisés?

Arf j'ai loupe ton message et tout reinstalle... comme tu peux le voir j'ai plein de chose a reconfigurer (genre les accents en francais haha). Merci pour ton aide en tout cas!


profile for greg0ire on Stack Exchange, a network of free, community-driven Q&amp;A sites

Hors ligne

#10 07/11/2021 19:35:21

Nicosss
Rédacteur Wiki
Rédacteur Wiki
Lieu : Isère
Inscription : 05/03/2007
Messages : 7 337
Site Web

Re : Anciens repositories toujours utilisés?

Pas de souci, jamais 2 sans 3 wink

Même si je ne vois pas pourquoi ce problème se produit pour le moment.

Bonne continuation !


F35_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F36_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F35_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

#11 07/11/2021 20:37:18

greg0ire
La bonne fée Dora
Inscription : 27/01/2007
Messages : 628
Site Web

Re : Anciens repositories toujours utilisés?

J'avais plus beaucoup de place sur mon disque, mais bon j'ai pas eu d'avertissement non plus… je me dis que ça doit être ça, mais c'est pas la première fois que j'upgrade avec quelque centaines de méga de libre au plus. En tout cas, plein de choses fonctionnent du premier coup: alacritty, steam… bref je pense que c'est pas mal de tout réinstaller de temps en temps! Et accessoirement là j'ai 3.1 Go de libre sur ma partition root!

Bonne continuation!


profile for greg0ire on Stack Exchange, a network of free, community-driven Q&amp;A sites

Hors ligne

#12 12/12/2021 12:19:01

binoyte
Membre
Inscription : 19/09/2012
Messages : 43

Re : Anciens repositories toujours utilisés?

Hello !
je suis dans le même cas ! Visiblement ça fini par une réinstallation. C'est vrai que c'est facile et rapide mais bon, le système étant complètement opérationnel, intellectuellement c'est un peu dommage d'en arriver là.

Dans mon cas, je n'ai pas trop suivi la mise à jour, d'habitude ça se passe sans encombre. Mais au reboot après l'application de la mise à jour, j'ai eu un message comme quoi /var était plein. /var/lib/rpm et /var/lib dnf en était la cause. J'ai purgé avec les commandes qui vont bien.

Est-ce la raison pour que les dépôts ne soient pas mis à jour ? J'en doute, vu que c'est justement une des premières opérations il me semble.

N'y a-t-il pas moyen de modifier les dépots à la main pour les faire repointer sur F35 ?

Hors ligne

#13 12/12/2021 13:02:03

Nicosss
Rédacteur Wiki
Rédacteur Wiki
Lieu : Isère
Inscription : 05/03/2007
Messages : 7 337
Site Web

Re : Anciens repositories toujours utilisés?

Que retourne

$ rpm -qa fedora-release\*

F35_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F36_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F35_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

#14 12/12/2021 21:32:33

binoyte
Membre
Inscription : 19/09/2012
Messages : 43

Re : Anciens repositories toujours utilisés?

Bonsoir,

apparemment y'a un mix 34 35 !

$ rpm -qa fedora-release\*
fedora-release-identity-basic-34-39.noarch
fedora-release-common-34-39.noarch
fedora-release-34-39.noarch
fedora-release-identity-basic-35-36.noarch
fedora-release-35-36.noarch
fedora-release-common-35-36.noarch

Hors ligne

#15 12/12/2021 21:39:19

Nicosss
Rédacteur Wiki
Rédacteur Wiki
Lieu : Isère
Inscription : 05/03/2007
Messages : 7 337
Site Web

Re : Anciens repositories toujours utilisés?

Retire les paquets fedora-release-identity-basic-34-39.noarch, fedora-release-common-34-39.noarch et fedora-release-34-39.noarch .


F35_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F36_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F35_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

#16 12/12/2021 22:04:11

binoyte
Membre
Inscription : 19/09/2012
Messages : 43

Re : Anciens repositories toujours utilisés?

# dnf remove fedora-release-identity-basic-34-39 fedora-release-common-34-39 fedora-release-34-39
Dépendances résolues.
=========================================================================================================================================================================
 Paquet                                                   Architecture                      Version                            Dépôt                               Taille
=========================================================================================================================================================================
Suppression:
 fedora-release                                           noarch                            34-39                              @updates                              0  
 fedora-release-common                                    noarch                            34-39                              @updates                             16 k
 fedora-release-identity-basic                            noarch                            34-39                              @updates                            706  
Supprimer des paquets dépendants:
 fedora-repos                                             noarch                            34-2                               @updates                            4.5 k
Suppression des dépendances inutilisées:
 fedora-gpg-keys                                          noarch                            34-2                               @updates                            114 k

Résumé de la transaction
=========================================================================================================================================================================
Supprimer  5 Paquets

Espace libéré : 135 k
Voulez-vous continuer ? [o/N] : 
Test de la transaction
La vérification de la transaction a réussi.
Lancement de la transaction de test
Transaction de test réussie.
Exécution de la transaction
  Préparation           :                                                                                                                                            1/1 
  Suppression de        : fedora-repos-34-2.noarch                                                                                                                   1/5 
  Exécution du scriptlet: fedora-release-34-39.noarch                                                                                                                2/5 
Created symlink /etc/systemd/user/pipewire-session-manager.service → /usr/lib/systemd/user/wireplumber.service.
Created symlink /etc/systemd/user/pipewire.service.wants/wireplumber.service → /usr/lib/systemd/user/wireplumber.service.

  Suppression de        : fedora-release-34-39.noarch                                                                                                                2/5 
  Suppression de        : fedora-release-common-34-39.noarch                                                                                                         3/5 
attention : fichier /usr/lib/swidtag/fedoraproject.org/org.fedoraproject.Fedora-34.swidtag : échec de la suppression : Aucun fichier ou dossier de ce type

  Suppression de        : fedora-release-identity-basic-34-39.noarch                                                                                                 4/5 
  Suppression de        : fedora-gpg-keys-34-2.noarch                                                                                                                5/5 
attention : fichier /etc/pki/rpm-gpg/RPM-GPG-KEY-34-fedora : échec de la suppression : Aucun fichier ou dossier de ce type

  Exécution du scriptlet: fedora-gpg-keys-34-2.noarch                                                                                                                5/5 
  Vérification de       : fedora-gpg-keys-34-2.noarch                                                                                                                1/5 
  Vérification de       : fedora-release-34-39.noarch                                                                                                                2/5 
  Vérification de       : fedora-release-common-34-39.noarch                                                                                                         3/5 
  Vérification de       : fedora-release-identity-basic-34-39.noarch                                                                                                 4/5 
  Vérification de       : fedora-repos-34-2.noarch                                                                                                                   5/5 

Supprimé:
  fedora-gpg-keys-34-2.noarch  fedora-release-34-39.noarch  fedora-release-common-34-39.noarch  fedora-release-identity-basic-34-39.noarch  fedora-repos-34-2.noarch 

Terminé !

j'ai ensuite lancé un dnf update --refresh et effectivement maintenant il cherche dans fc35. Je pense que mon problème est résolu. C'était quand même beaucoup plus rapide que de ton réinstaller :) Merci beaucoup.

Mais une question quand même : c'est quoi le «39» dans les paquets de FC34 que je viens de supprimer ?

Dernière modification par binoyte (12/12/2021 22:04:37)

Hors ligne

#17 12/12/2021 23:55:52

Nicosss
Rédacteur Wiki
Rédacteur Wiki
Lieu : Isère
Inscription : 05/03/2007
Messages : 7 337
Site Web

Re : Anciens repositories toujours utilisés?

C'était les anciens paquets sous F34 et ils avaient dû prévoir de les conserver pour les prochaines versions.

Je n'ai pas regardé le contenu n'ayant pas été touché par ce souci mais je ne sais pas pourquoi certaines migrations sont touchées par ce souci et d'autres non.


F35_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F36_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F35_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

#18 21/05/2022 18:41:29

greg0ire
La bonne fée Dora
Inscription : 27/01/2007
Messages : 628
Site Web

Re : Anciens repositories toujours utilisés?

Je viens de me retaper le même souci avec FC36, et une installation neuve mise à part mon home du coup… la solution de retirer les paquets identity semble fonctionner! C'est cool ce forum! Par contre Fedora là c'est pas génial ce bug, je comprends pas trop que je puisse l'avoir à nouveau ^^'

Dernière modification par greg0ire (21/05/2022 18:41:45)


profile for greg0ire on Stack Exchange, a network of free, community-driven Q&amp;A sites

Hors ligne

#19 22/05/2022 15:15:55

Nicosss
Rédacteur Wiki
Rédacteur Wiki
Lieu : Isère
Inscription : 05/03/2007
Messages : 7 337
Site Web

Re : Anciens repositories toujours utilisés?

greg0ire a écrit :

Je viens de me retaper le même souci avec FC36, et une installation neuve mise à part mon home du coup… la solution de retirer les paquets identity semble fonctionner! C'est cool ce forum! Par contre Fedora là c'est pas génial ce bug, je comprends pas trop que je puisse l'avoir à nouveau ^^'

Quelles étaient les versions de paquets ?


F35_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F36_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F35_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

#20 22/05/2022 16:23:54

greg0ire
La bonne fée Dora
Inscription : 27/01/2007
Messages : 628
Site Web

Re : Anciens repositories toujours utilisés?

Des versions fc35 du coup! Et en fait, en lançant

sudo  dnf repoquery --duplicated

je me suis rendu compte que j'avais énormément de paquets en fc35 et fc36.

J'ai donc retiré les paquets que tu avais conseillé de retirer, et j'ai pu installer des versions fc36. Par contre, je n'arrivait pas à faire la mise à jour de certains paquets à cause de conflits. Je me suis rendu compte qu'en retirant certains paquets fc35, j'arrivais à faire l'upgrade.

En faisant sudo dnf distro-sync, j'ai eu la même proposition que la dernière fois: retirer des paquets ultra-sensible, genre systemd… J'ai retrouvé leur version fc35 dans la liste, je les ai retiré, et là le distro-sync a bien voulu faire son boulot. Il m'a retiré tous les vieux paquets, et maintenant le seul paquet que j'ai en doublon, c'est

emacs-filesystem-1:27.2-9.fc35.noarch

. Bref, je pense qu'à la prochaine upgrade, je tenterai la méthode distro-sync.


profile for greg0ire on Stack Exchange, a network of free, community-driven Q&amp;A sites

Hors ligne

#21 22/05/2022 16:48:13

Nicosss
Rédacteur Wiki
Rédacteur Wiki
Lieu : Isère
Inscription : 05/03/2007
Messages : 7 337
Site Web

Re : Anciens repositories toujours utilisés?

C'est quand même super étrange ce souci à partir d'une installation toute neuve de F36.

A voir si quelqu'un a le même genre de problème.


F35_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F36_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F35_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Pied de page des forums