Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora Linux 36 est disponible !

#1 09/10/2021 10:53:16

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 18 761
Site Web

F35 service rngd.service plante au démarrage

J'ai remarqué que le service "rngd.service" avait un problème pour démarrer correctement :

[    6.669072] systemd[1]: rngd.service: Current command vanished from the unit file, execution of the command list won't be resumed.
● rngd.service - Hardware RNG Entropy Gatherer Daemon
     Loaded: loaded (/usr/lib/systemd/system/rngd.service; enabled; vendor preset: enabled)
     Active: active (running) since Sat 2021-10-09 10:23:04 CEST; 17min ago
   Main PID: 2970 (rngd)
      Tasks: 5 (limit: 38339)
     Memory: 2.4M
        CPU: 20.163s
     CGroup: /system.slice/rngd.service
             └─2970 /usr/sbin/rngd -f -x pkcs11 -x nist

oct. 09 10:23:04 xx.localdomain rngd[2970]: Disabling 7: PKCS11 Entropy generator (pkcs11)
oct. 09 10:23:04 xx.localdomain rngd[2970]: Disabling 5: NIST Network Entropy Beacon (nist)
oct. 09 10:23:04 xx.localdomain rngd[2970]: Initializing available sources
oct. 09 10:23:04 xx.localdomain rngd[2970]: [hwrng ]: Initialized
oct. 09 10:23:04 xx.localdomain rngd[2970]: [rdrand]: Enabling RDSEED rng support
oct. 09 10:23:04 xx.localdomain rngd[2970]: [rdrand]: Initialized
oct. 09 10:23:04 xx.localdomain rngd[2970]: [jitter]: Initializing AES buffer
oct. 09 10:23:05 xx.localdomain rngd[2970]: [jitter]: Enabling JITTER rng support
oct. 09 10:23:05 xx.localdomain rngd[2970]: [jitter]: Initialized
oct. 09 10:23:05 xx.localdomain rngd[2970]: [rtlsdr]: Initialization Failed

Après quelques recherche, j'ai remarqué que la variable :

$RNGD_ARGS

était vide, du coup le service ne pouvait démarrer.

J'ai regardé cette solution : https://www.it-connect.fr/demarrage-com … -centos-7/
Mais cela ne fonctionne pas.

Par contre nous avons un :

/dev/hwrng

Qui me semble fonctionner :

[root@xx ~]# vi /usr/lib/systemd/system/rngd.service 
[root@xx ~]# systemctl daemon-reload 
[root@xx ~]# systemctl restart rngd.service 
[root@xx ~]# systemctl status rngd.service 
● rngd.service - Hardware RNG Entropy Gatherer Daemon
     Loaded: loaded (/usr/lib/systemd/system/rngd.service; enabled; vendor preset: enabled)
     Active: active (running) since Sat 2021-10-09 10:44:31 CEST; 1s ago
   Main PID: 42338 (rngd)
      Tasks: 5 (limit: 38339)
     Memory: 1.9M
        CPU: 7.622s
     CGroup: /system.slice/rngd.service
             └─42338 /usr/sbin/rngd -f -r /dev/hwrng

oct. 09 10:44:31 xx.localdomain systemd[1]: Started Hardware RNG Entropy Gatherer Daemon.
oct. 09 10:44:31 xx.localdomain rngd[42338]: Initializing available sources
oct. 09 10:44:31 xx.localdomain rngd[42338]: [hwrng ]: Initialized
oct. 09 10:44:31 xx.localdomain rngd[42338]: [rdrand]: Enabling RDSEED rng support
oct. 09 10:44:31 xx.localdomain rngd[42338]: [rdrand]: Initialized
oct. 09 10:44:31 xx.localdomain rngd[42338]: [jitter]: Initializing AES buffer

Donc si vous êtes dans le même cas (après avoir sauvegardé le fichier à modifier! comme je fais avec l'exemple ci-dessous!) :

sudo cp -rfp /usr/lib/systemd/system/rngd.service /usr/lib/systemd/system/rngd.service-save && sudo vi /usr/lib/systemd/system/rngd.service 

Modifier la ligne "ExecStart" comme ceci :

ExecStart=/usr/sbin/rngd -f -r /dev/hwrng

Voilà si cela peut aider, a voir si c'est rapporté ou non sur le bugzilla.


AMD R7 5800x, MSI Pro Carbon X470, 64Go DDR4 3.6Ghz Kingston Renegarde C17, RX5700XT MSI OC, SSD : 1xPNY LXR8 1To + 1x970EVO 500Go + 2x500Go 860EVO, 3x1To 860EVO, HDD WD 2To + 4To Black, BeQuiet Dark 900 + Ppower 1kW plat
AMD R7 2700x + 32Go DDR4 3.2Ghz, 1xPNY LXR8 1To, 2x1To 860QVO, rx6500xt 4Go, BMT MBox Q300L
AMD R5 2600, 32Go DDR4 1.8Ghz, 1x250GO SSD, 3x 2To RAID5 WDBlue, 1030GT 2Go, BCubes Chieftec + AMD A6 9500, 16Go DDR4 2.1Ghz, SSD 250Go,3To Red

Hors ligne

#2 09/10/2021 11:09:33

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 18 761
Site Web

Re : F35 service rngd.service plante au démarrage

Bogue rapporté :
https://bugzilla.redhat.com/show_bug.cgi?id=2012425

A voir si cela est normal ou non.

Je vois pour ajouter la variable au système par la suite.


AMD R7 5800x, MSI Pro Carbon X470, 64Go DDR4 3.6Ghz Kingston Renegarde C17, RX5700XT MSI OC, SSD : 1xPNY LXR8 1To + 1x970EVO 500Go + 2x500Go 860EVO, 3x1To 860EVO, HDD WD 2To + 4To Black, BeQuiet Dark 900 + Ppower 1kW plat
AMD R7 2700x + 32Go DDR4 3.2Ghz, 1xPNY LXR8 1To, 2x1To 860QVO, rx6500xt 4Go, BMT MBox Q300L
AMD R5 2600, 32Go DDR4 1.8Ghz, 1x250GO SSD, 3x 2To RAID5 WDBlue, 1030GT 2Go, BCubes Chieftec + AMD A6 9500, 16Go DDR4 2.1Ghz, SSD 250Go,3To Red

Hors ligne

#3 09/10/2021 11:44:12

Refuznik
Membre
Inscription : 31/01/2007
Messages : 8 071

Re : F35 service rngd.service plante au démarrage

J'ai testé ta solution mais elle ne fonctionne pas chez moi :

CGroup: /system.slice/rngd.service
             └─18510 /usr/sbin/rngd -f -r /dev/hwrng

oct. 09 11:38:20 linker rngd[18510]: Initializing available sources
oct. 09 11:38:20 linker rngd[18510]: [hwrng ]: Initialization Failed
oct. 09 11:38:20 linker rngd[18510]: [rdrand]: Enabling RDRAND rng support
oct. 09 11:38:20 linker rngd[18510]: [rdrand]: Initialized
oct. 09 11:38:20 linker rngd[18510]: [jitter]: Initializing AES buffer
oct. 09 11:38:22 linker rngd[18510]: [jitter]: Enabling JITTER rng support
oct. 09 11:38:22 linker rngd[18510]: [jitter]: Initialized
oct. 09 11:38:22 linker rngd[18510]: [pkcs11]: No pkcs11 slots available
oct. 09 11:38:22 linker rngd[18510]: [pkcs11]: Initialization Failed
oct. 09 11:38:23 linker rngd[18510]: [rtlsdr]: Initialization Failed

Par contre bizarrement quant je fais un systemctl --failed il me sort rien.

0 loaded units listed.

Hors ligne

#4 09/10/2021 12:49:15

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 18 761
Site Web

Re : F35 service rngd.service plante au démarrage

Dsl j'ai oublié le :

systemctl daemon-reload

à faire avant.

PS : Ah bien si c'était dans la liste des commandes plus haut...


AMD R7 5800x, MSI Pro Carbon X470, 64Go DDR4 3.6Ghz Kingston Renegarde C17, RX5700XT MSI OC, SSD : 1xPNY LXR8 1To + 1x970EVO 500Go + 2x500Go 860EVO, 3x1To 860EVO, HDD WD 2To + 4To Black, BeQuiet Dark 900 + Ppower 1kW plat
AMD R7 2700x + 32Go DDR4 3.2Ghz, 1xPNY LXR8 1To, 2x1To 860QVO, rx6500xt 4Go, BMT MBox Q300L
AMD R5 2600, 32Go DDR4 1.8Ghz, 1x250GO SSD, 3x 2To RAID5 WDBlue, 1030GT 2Go, BCubes Chieftec + AMD A6 9500, 16Go DDR4 2.1Ghz, SSD 250Go,3To Red

Hors ligne

#5 09/10/2021 13:00:23

Refuznik
Membre
Inscription : 31/01/2007
Messages : 8 071

Re : F35 service rngd.service plante au démarrage

Oui, mais je l'ai fait.

Hors ligne

Pied de page des forums