Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fin de maintenance pour Fedora 32

#1 25/05/2021 11:23:44

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 18 429
Site Web

[Résolu] Serveur DNS non pris en compte

Petit souci depuis la mise en place de mon serveur DNS.

Le resolv.conf retourne ceci :

[root@heracles ~]# cat /etc/resolv.conf 
# This is /run/systemd/resolve/stub-resolv.conf managed by man:systemd-resolved(8).
# Do not edit.
#
# This file might be symlinked as /etc/resolv.conf. If you're looking at
# /etc/resolv.conf and seeing this text, you have followed the symlink.
#
# This is a dynamic resolv.conf file for connecting local clients to the
# internal DNS stub resolver of systemd-resolved. This file lists all
# configured search domains.
#
# Run "resolvectl status" to see details about the uplink DNS servers
# currently in use.
#
# Third party programs should typically not access this file directly, but only
# through the symlink at /etc/resolv.conf. To manage man:resolv.conf(5) in a
# different way, replace this symlink by a static file or a different symlink.
#
# See man:systemd-resolved.service(8) for details about the supported modes of
# operation for /etc/resolv.conf.

nameserver 127.0.0.53
options edns0 trust-ad
search xxxx.xxx lan

configuration du réseau

$ sudo nmcli device show enp34s0 
[sudo] Mot de passe de xxxxxx : 
GENERAL.DEVICE:                         enpXXs0
GENERAL.TYPE:                           ethernet
GENERAL.HWADDR:                         XX:XX:XX:B6:11:CB
GENERAL.MTU:                            1500
GENERAL.STATE:                          100 (connecté)
GENERAL.CONNECTION:                     enp34s0
GENERAL.CON-PATH:                       /org/freedesktop/NetworkManager/ActiveConnection/1
WIRED-PROPERTIES.CARRIER:               marche
IP4.ADDRESS[1]:                         192.168.1.XX/24
IP4.GATEWAY:                            192.168.1.XXX
IP4.ROUTE[1]:                           dst = 0.0.0.0/0, nh = 192.168.1.XXX, mt = 100
IP4.ROUTE[2]:                           dst = 192.168.1.0/24, nh = 0.0.0.0, mt = 100
IP4.DNS[1]:                             192.168.1.XXX
IP4.DNS[2]:                             192.168.1.XX
IP4.DOMAIN[1]:                          lan
IP6.ADDRESS[1]:                         fe80::XXx:XXxx:xxxX:XXxx/64
IP6.GATEWAY:                            --
IP6.ROUTE[1]:                           dst = fe80::/64, nh = ::, mt = 100
 

Comme je sais que l'on a changé de gestionnaire de DNS (utilisation de systemd-resolve), je ne sais pas si il faut utiliser un programme ou faire des modifications à la main dans les fichiers de conf?
C'est un peu pénible, car de base on gère cela avec networkmanager, mais cela ne semble pas être pris en compte...

Normalement FreeIPA-client gère cela, mais même constat, cela ne semble plus être pris en compte sad


AMD R7 5800x, MSI Pro Carbon X470, 32Go DDR4 3200@3400Mhz Gskill TridentZ CL14, RX 5700XT MSI Watercooling OC SSD: 1x970 EVO 500Go + 1xPNY LXR8 NVME 1To + 2x500Go 860 EVO, 3x1To 860 Evo, HDD 1x2To WD black, 1x4to WD Black, 1x3To WD Red, Purepower 1000W 80+ plat, dans un BeQuiet Dark 900
AMD R5 2600, Asus A320, 24Go DDR4 2133Mhz, 1x250GO SSD, 3x 2To RAID 5 WD Blue / AMD R7 2700x + 16Go DDR4 2933Mhz+1 NVME Sandisk XLR8, 2x1To QVO / dans des boitier Cubes Chieftec
AMD A6 9500, 8Go, 250Go SSD

Hors ligne

#2 25/05/2021 11:30:41

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 18 429
Site Web

Re : [Résolu] Serveur DNS non pris en compte

Bon je me répond sans doute à moi même.

Il faudrait gérer cela directement avec systemd-resolve comme cette exemple :

systemd-resolve --set-dns=192.168.1.XX --set-domain=xxxxx.xx  --interface=enpXXs0

Bizarrement le help ne propose pas toujours toutes les options à mettre (exemple "interface"). Mais si il y a un manque dans la commande il le dit.

A voir si cela reste au reboot.


AMD R7 5800x, MSI Pro Carbon X470, 32Go DDR4 3200@3400Mhz Gskill TridentZ CL14, RX 5700XT MSI Watercooling OC SSD: 1x970 EVO 500Go + 1xPNY LXR8 NVME 1To + 2x500Go 860 EVO, 3x1To 860 Evo, HDD 1x2To WD black, 1x4to WD Black, 1x3To WD Red, Purepower 1000W 80+ plat, dans un BeQuiet Dark 900
AMD R5 2600, Asus A320, 24Go DDR4 2133Mhz, 1x250GO SSD, 3x 2To RAID 5 WD Blue / AMD R7 2700x + 16Go DDR4 2933Mhz+1 NVME Sandisk XLR8, 2x1To QVO / dans des boitier Cubes Chieftec
AMD A6 9500, 8Go, 250Go SSD

Hors ligne

#3 13/09/2021 09:14:15

gerard093b
Membre
Inscription : 11/09/2021
Messages : 1

Re : [Résolu] Serveur DNS non pris en compte

Puisque nmcli fonctionne, il suffit de rajouter une propriété
sudo nmcli device modify enp34s0 +ipv4.dns 127.0.0.53
si c'est bien 127.0.0.53 que vous visez comme dns.
Vous pouvez aussi ajouter autant de dns que vous voudrez
sudo nmcli device modify enp34s0 +ipv4.dns xxx.xxx.xxx.xxx
et contrôler votre résultat par
sudo nmcli device show enp34s0

pour savoir quelle interface est active (pour ceux qui utilisent plusieurs interfaces réseaux) taper
sudo nmcli device show
ce n'est pas forcément enp34s0 qui est pertinent, selon que vous utilisez la wifi, le filiaire ou des réseaux virtuels

pour des exemples nmcli
man nmcli

et enfin vous pouvez insérer vos instructions dans un service de démarrage, par exemple votre firewall ... mais c'est un autre sujet

Hors ligne

#4 13/09/2021 10:37:35

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 18 429
Site Web

Re : [Résolu] Serveur DNS non pris en compte

Merci, c'est peut être l'histoire du + qui fait que cela n'était pas pris en compte malgré l'option (j'ai pas vraiment trouvé grand chose à ce sujet sad ).

Après tu peux aussi procéder à l'ajout/modification dans les fichiers du périphérique dans :

/etc/NetworkManager/system-connections/en...nm-connection

Exemple :

[connection]
id=enp00s0
uuid=xxxxx-2bcc-3b88-xxxxx-xxxxxxxxxx
type=ethernet
metered=2
permissions=

[ethernet]
duplex=full
mac-address-blacklist=
speed=1000

[ipv4]
address1=192.168.x.xx/24,192.168.x.x
dns=192.168.x.xx;192.168.x.x;
dns-search=toto.local;lan
may-fail=false
method=manual

[ipv6]
addr-gen-mode=stable-privacy
dns-search=
method=ignore

[proxy]

Et pour prendre en compte :

sudo nmcli connection reload

Voir relancer le service NetworkManager.

Faire aussi un :

sudo systemd-resolve --flush-reload

Pour vider les caches DNS.

PS : J'ai pas mal appris sur les méthodes à employer depuis la date du sujet (j'avais trop l'habitude d'utiliser les anciennes, car je suis aussi pratiquement toute la journée sur du Redhat avec souvent un décalage...). Mais surtout expérimentés des choses encore plus poussé.


AMD R7 5800x, MSI Pro Carbon X470, 32Go DDR4 3200@3400Mhz Gskill TridentZ CL14, RX 5700XT MSI Watercooling OC SSD: 1x970 EVO 500Go + 1xPNY LXR8 NVME 1To + 2x500Go 860 EVO, 3x1To 860 Evo, HDD 1x2To WD black, 1x4to WD Black, 1x3To WD Red, Purepower 1000W 80+ plat, dans un BeQuiet Dark 900
AMD R5 2600, Asus A320, 24Go DDR4 2133Mhz, 1x250GO SSD, 3x 2To RAID 5 WD Blue / AMD R7 2700x + 16Go DDR4 2933Mhz+1 NVME Sandisk XLR8, 2x1To QVO / dans des boitier Cubes Chieftec
AMD A6 9500, 8Go, 250Go SSD

Hors ligne

Pied de page des forums