Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Rétrospective de l'adoption du nouveau logo de Fedora

#1 29/04/2021 10:27:39

kvfy
Membre
Lieu : Bretagne (35)
Inscription : 25/11/2018
Messages : 51

X-Plane 11.53 ne démarre pas sous Fedora 34 Wayland

Bonjour,

Tout est dans le titre : suite à la mise à niveau de Fedora 33 vers 34, X-Plane 11.53 ne démarre plus sous Wayland (ça fonctionnait sous Fedora 33). Je n'ai plus le message exact dans le terminal (je pourrai le poster ce soir), mais ça disait en substance qu'aucun affichage GLX n'avait été trouvé...

Ça fonctionne correctement en rapassant sous X.org. Mis à part lors du premier démarrage de la session X, il n'y avait pas de son (tout le système). En redémarrant, le problème de son était résolu.

Est-ce possible de modifier l'exécutable de X-Plane ou de faire un script pour forcer un démarrage avec XWayland ?

Merci d'avance pour votre aide :)

EDIT : c'est sur ma tour : cf. config en signature, ci-dessous :)

EDIT bis : Voici le message précis (ou pas ^^) que me retourne le terminal :

[kevfloh@tour-kevfloh ~]$ '/home/kevfloh/X-Plane 11/X-Plane-x86_64' 
Whoah -- no matter how hard I tried, I failed to get a GLX visual. Something's seriously wonky on your machine.

Dernière modification par kvfy (29/04/2021 17:41:29)


Tour : Asus Z97-P, Intel Core i5-4590, 16 Go RAM DDR3, AMD Radeon RX 570 (MSI Armor), SSD Crucial MX500 1To
Laptop : Dell Latitude E5470, Intel Core i5-6300U, 8 Go RAM DDR4, SSD Crucial MX500 500 Go

Hors ligne

#2 29/04/2021 11:10:48

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 18 288
Site Web

Re : X-Plane 11.53 ne démarre pas sous Fedora 34 Wayland

Perso je conseil quand même de faire un utilisateur dédié quand tu change de mode (xorg/wayland), car souvent il y a des soucis avec les fichiers de configuration.

Tu peux aussi tester la dernière version de développement de la bibliothèque graphique Mesa à jours disponible ici :
https://doc.fedora-fr.org/wiki/D%C3%A9p … eloppement


AMD R7 2700X, MSI Pro Carbon X470, 32Go DDR4 3200@3333Mhz Gskill TridentZ CL14, RX 5700XT MSI Watercooling OC SSD: 1x 970 EVO NVME 500Go + 2x500Go 860 EVO, 3x1To 860 Evo, HDD 1x2To WD black, 1x4to WD Black, 1x3To WD Red, GMT BeQuiet Dark 900+Purepower 1000W 80+ platinium
AMD R3 2200g, Asus A320, 16Go DDR4 2400@2133Mhz, 1x250GO SSD EVO, 3x 2To RAID 5 WD Blue / AMD R5 2600 + 32Go DDR4 3000@2133Mhz+1xSSD Evo 500Go , 3x1To QVO RAID5 / On Cube Chieftec
AMD A6 9500, 8Go, 500Go SSD MX500

Hors ligne

#3 29/04/2021 17:48:09

kvfy
Membre
Lieu : Bretagne (35)
Inscription : 25/11/2018
Messages : 51

Re : X-Plane 11.53 ne démarre pas sous Fedora 34 Wayland

OK, merci du conseil pour Xorg/Wayland.

Le passage à la version de développement n'a malheuresement rien changé... Tout semble marcher par ailleurs, mais pas X-Plane. D'ailleurs, si jamais je voulais revenir à la version des dépôts Fedora, je fais comment ?


Tour : Asus Z97-P, Intel Core i5-4590, 16 Go RAM DDR3, AMD Radeon RX 570 (MSI Armor), SSD Crucial MX500 1To
Laptop : Dell Latitude E5470, Intel Core i5-6300U, 8 Go RAM DDR4, SSD Crucial MX500 500 Go

Hors ligne

#4 29/04/2021 18:03:57

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 18 288
Site Web

Re : X-Plane 11.53 ne démarre pas sous Fedora 34 Wayland

normalement :
sudo dnf downgrade mesa*

Après c'est basé sur les specs Fedora donc non intrusif.


AMD R7 2700X, MSI Pro Carbon X470, 32Go DDR4 3200@3333Mhz Gskill TridentZ CL14, RX 5700XT MSI Watercooling OC SSD: 1x 970 EVO NVME 500Go + 2x500Go 860 EVO, 3x1To 860 Evo, HDD 1x2To WD black, 1x4to WD Black, 1x3To WD Red, GMT BeQuiet Dark 900+Purepower 1000W 80+ platinium
AMD R3 2200g, Asus A320, 16Go DDR4 2400@2133Mhz, 1x250GO SSD EVO, 3x 2To RAID 5 WD Blue / AMD R5 2600 + 32Go DDR4 3000@2133Mhz+1xSSD Evo 500Go , 3x1To QVO RAID5 / On Cube Chieftec
AMD A6 9500, 8Go, 500Go SSD MX500

Hors ligne

#5 29/04/2021 18:06:55

kvfy
Membre
Lieu : Bretagne (35)
Inscription : 25/11/2018
Messages : 51

Re : X-Plane 11.53 ne démarre pas sous Fedora 34 Wayland

OK merci :)
Mais du coup une idée pour "forcer" le démarrage de X-Plane sous XWayland, en attendant ? :)


Tour : Asus Z97-P, Intel Core i5-4590, 16 Go RAM DDR3, AMD Radeon RX 570 (MSI Armor), SSD Crucial MX500 1To
Laptop : Dell Latitude E5470, Intel Core i5-6300U, 8 Go RAM DDR4, SSD Crucial MX500 500 Go

Hors ligne

#6 29/04/2021 18:35:54

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 18 288
Site Web

Re : X-Plane 11.53 ne démarre pas sous Fedora 34 Wayland

Pas vraiment, fait longtemps que je n'ai pas touché à Xplane (j'ai le 9 ou 10 je sais plus).

Pense à faire un rapport de bogue soit sur le bugzilla de redhat ou mieux sur celui de freedesktop.


AMD R7 2700X, MSI Pro Carbon X470, 32Go DDR4 3200@3333Mhz Gskill TridentZ CL14, RX 5700XT MSI Watercooling OC SSD: 1x 970 EVO NVME 500Go + 2x500Go 860 EVO, 3x1To 860 Evo, HDD 1x2To WD black, 1x4to WD Black, 1x3To WD Red, GMT BeQuiet Dark 900+Purepower 1000W 80+ platinium
AMD R3 2200g, Asus A320, 16Go DDR4 2400@2133Mhz, 1x250GO SSD EVO, 3x 2To RAID 5 WD Blue / AMD R5 2600 + 32Go DDR4 3000@2133Mhz+1xSSD Evo 500Go , 3x1To QVO RAID5 / On Cube Chieftec
AMD A6 9500, 8Go, 500Go SSD MX500

Hors ligne

#7 29/04/2021 20:02:49

kvfy
Membre
Lieu : Bretagne (35)
Inscription : 25/11/2018
Messages : 51

Re : X-Plane 11.53 ne démarre pas sous Fedora 34 Wayland

Mise à jour : je viens de créer une session pour X, et X-Plane ne fonctionne pas non plus dessus. En réessayant avec ma session "principale", pareil ça ne marche plus, ni sous Wayland ni sous X.

J'ai parcouru les forums X-Plane, RAS pour l'instant.

Je ferai donc des rapports de bugs avec les infos que j'ai pour l'instant :)

Merci en tout cas :)


Tour : Asus Z97-P, Intel Core i5-4590, 16 Go RAM DDR3, AMD Radeon RX 570 (MSI Armor), SSD Crucial MX500 1To
Laptop : Dell Latitude E5470, Intel Core i5-6300U, 8 Go RAM DDR4, SSD Crucial MX500 500 Go

Hors ligne

#8 30/04/2021 19:34:04

kvfy
Membre
Lieu : Bretagne (35)
Inscription : 25/11/2018
Messages : 51

Re : X-Plane 11.53 ne démarre pas sous Fedora 34 Wayland

Rapport de bug publié sur le GitLab FreeDesktop (ils n'utilisent plus Bugzilla apparament) : https://gitlab.freedesktop.org/mesa/mesa/-/issues/4720

Wait and see...


Tour : Asus Z97-P, Intel Core i5-4590, 16 Go RAM DDR3, AMD Radeon RX 570 (MSI Armor), SSD Crucial MX500 1To
Laptop : Dell Latitude E5470, Intel Core i5-6300U, 8 Go RAM DDR4, SSD Crucial MX500 500 Go

Hors ligne

#9 30/04/2021 20:28:29

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 18 288
Site Web

Re : X-Plane 11.53 ne démarre pas sous Fedora 34 Wayland

oki fait un moment que j'ai pas suivi.

Après est ce que c'est mieux pour ce genre d'usage (rapport de bogues)... fin bon...


AMD R7 2700X, MSI Pro Carbon X470, 32Go DDR4 3200@3333Mhz Gskill TridentZ CL14, RX 5700XT MSI Watercooling OC SSD: 1x 970 EVO NVME 500Go + 2x500Go 860 EVO, 3x1To 860 Evo, HDD 1x2To WD black, 1x4to WD Black, 1x3To WD Red, GMT BeQuiet Dark 900+Purepower 1000W 80+ platinium
AMD R3 2200g, Asus A320, 16Go DDR4 2400@2133Mhz, 1x250GO SSD EVO, 3x 2To RAID 5 WD Blue / AMD R5 2600 + 32Go DDR4 3000@2133Mhz+1xSSD Evo 500Go , 3x1To QVO RAID5 / On Cube Chieftec
AMD A6 9500, 8Go, 500Go SSD MX500

Hors ligne

#10 06/05/2021 18:26:39

kvfy
Membre
Lieu : Bretagne (35)
Inscription : 25/11/2018
Messages : 51

Re : X-Plane 11.53 ne démarre pas sous Fedora 34 Wayland

Salut :)

Apparament une mise à jour a été faite de Mesa (Vers le rapport de bug), est-ce qu'elle est arrivée dans le dépôt ?

Merci encore pour ton aide


Tour : Asus Z97-P, Intel Core i5-4590, 16 Go RAM DDR3, AMD Radeon RX 570 (MSI Armor), SSD Crucial MX500 1To
Laptop : Dell Latitude E5470, Intel Core i5-6300U, 8 Go RAM DDR4, SSD Crucial MX500 500 Go

Hors ligne

#11 07/05/2021 09:53:40

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 18 288
Site Web

Re : X-Plane 11.53 ne démarre pas sous Fedora 34 Wayland

Pas toujours, car ils privilégient la version "stable" de Mesa et l'on se retrouve avec une à deux version de retard sur les versions "stable" de Fedora.

D'où la version git que je fourni. Même si parfois il y a des soucis d'empaquetage (je fais une version par semaine quand tout vas bien), comme avec la dernière fournée (je regarde si j'arrive à faire quelque chose cette semaine) qui bloque sur un module pour "intel i830"...

Plus d'infos, si cela te dit de suivre, sur ce qui est corrigé au fur et à mesure ici : https://cgit.freedesktop.org/mesa/mesa
En plus il y a tout ce qui est ajouté dans les différentes versions (git, dev, alpha, master ou stable).


AMD R7 2700X, MSI Pro Carbon X470, 32Go DDR4 3200@3333Mhz Gskill TridentZ CL14, RX 5700XT MSI Watercooling OC SSD: 1x 970 EVO NVME 500Go + 2x500Go 860 EVO, 3x1To 860 Evo, HDD 1x2To WD black, 1x4to WD Black, 1x3To WD Red, GMT BeQuiet Dark 900+Purepower 1000W 80+ platinium
AMD R3 2200g, Asus A320, 16Go DDR4 2400@2133Mhz, 1x250GO SSD EVO, 3x 2To RAID 5 WD Blue / AMD R5 2600 + 32Go DDR4 3000@2133Mhz+1xSSD Evo 500Go , 3x1To QVO RAID5 / On Cube Chieftec
AMD A6 9500, 8Go, 500Go SSD MX500

Hors ligne

Pied de page des forums