Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora 35 est disponible sous le nouveau nom de Fedora Linux 35

#1 24/03/2021 11:04:06

chemise
Membre
Inscription : 25/02/2020
Messages : 10

"dual screen" ce comporte en "single wide screen"

Salut

J'ai 2 ecrans (full HD) et j'aimerai que mon "dual screen" ce comporte en "single wide screen".
En gros faire comme si j'avais un ecran de 3840 x 1080 comme un ecran UltraWide.

J'ai trouver une petite application WideGuy qui devrait faire ca mais cela ne marche pas chez moi.
https://openapplibrary.org/project/wideguy
J'ai contacter le coder de wideguy mais pas de reponse.

J'utilise beaucoup Blender et surtout DaVinci Resolve, cela serait vraiment cool d'avoir toute l'interface sur mes 2 ecrans.

Je suis sous Fedora 33 workstation (Gnome 3.38.4) en X11, avec une Nvidia GTX 1080 avec le driver akmod-nvidia.
Si possible j'aimerai rester sous gnome que j'adore.

Quelqu'un aurait-il une idee?

Hors ligne

#2 24/03/2021 11:38:07

Refuznik
Membre
Inscription : 31/01/2007
Messages : 7 992

Re : "dual screen" ce comporte en "single wide screen"

Bizarre, dans Paramètres ou en prenant l'utilitaire de NVidia il me le propose.
Dans l'utilitaire de Nvidia ==> X Server Display Configuration ==> Sélection ==> X Screen0 (ce dernier nom peux changer suivant tes paramètres).

Dans l’utilitaire Paramètres ==> Ecrans ==> Sélectionner Ecran Unique.

WideGui je viens de regarder il a 3 ans quant même et je n'en vois pas l'utilité actuellement (en fait j'ai tellement l'habitude de modifier moi-même mon xorg.conf). C'est surtout pour aider à forcer les appli. à se lancer sur la largeur de tous tes moniteurs.

Hors ligne

#3 25/03/2021 11:27:52

chemise
Membre
Inscription : 25/02/2020
Messages : 10

Re : "dual screen" ce comporte en "single wide screen"

Merci pour ta reponce!
Depuis hier j'essai mais je n'y arrive pas.
Je fait "sudo nvidia-settings"
puis comme tu m'a dit Nvidia ==> X Server Display Configuration ==> Sélection ==> X Screen0
puis Paramètres ==> Ecrans ==> Sélectionner Ecran Unique
mais il me met un ecran unique et eteind l'autre.
Quand je retourne dans le nvidia-settings c'est redevenu comme avant.
J'ai reboot l'ordi aussi mais rien.
Je joint mon xorg.conf peut etre que tu y verra mon probleme?
Aurais-tu une idee?


# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 460.56


Section "ServerLayout"

# Removed Option "Xinerama" "1"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Idek Iiyama PL2590"
    HorizSync       30.0 - 83.0
    VertRefresh     55.0 - 76.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 1080"
EndSection

Section "Screen"

# Removed Option "metamodes" "DP-4: nvidia-auto-select +1920+0, HDMI-0: nvidia-auto-select +0+0"
# Removed Option "metamodes" "HDMI-0: nvidia-auto-select +0+0, DP-4: nvidia-auto-select +1920+0"
# Removed Option "metamodes" "HDMI-0: nvidia-auto-select +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}, DP-4: nvidia-auto-select +1920+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "HDMI-0: nvidia-auto-select +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}, DP-4: nvidia-auto-select +1920+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Hors ligne

#4 25/03/2021 12:52:54

Refuznik
Membre
Inscription : 31/01/2007
Messages : 7 992

Re : "dual screen" ce comporte en "single wide screen"

Si tu fais seulement le nvidia setting sans passer par Paramètres. Déja le fait il correctement sans éteindre l'autre écran lorsque tu cliques sur Apply (si ce dernier est grisé pense à changer les options proposées pour l'avoir et essaie d'avoir son message d'erreur.

Autre question tes écran sont ils identiques en effet il faut qu'ils aient la même résolution, le même dpi et la même fréquence de rafraîchissement pour que ça fonctionne ?

Hors ligne

#5 26/03/2021 04:31:16

chemise
Membre
Inscription : 25/02/2020
Messages : 10

Re : "dual screen" ce comporte en "single wide screen"

Merci pour tout tes conseils!
Mes ecrans sont de la meme marque, meme definition (1920x1080), en 60.00 Hz.
Les differences sont la connectique (1 en HDMI et l'autre en DisplayPort) et la taille physique de l'ecran 25 et 24 pouces (le 25" n'existe plus au catalogue)
Bon ca a l'aire mort, en tout cas je n'y arrive pas.
Je te remercie enormement pour ton aide et ton temps!

Hors ligne

Pied de page des forums