Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora 34 Beta est disponible

#26 03/02/2021 11:48:52

fgland
Rédacteur Wiki
Rédacteur Wiki
Lieu : Lituanie
Inscription : 09/08/2004
Messages : 3 324

Re : [Résolu] Plus de démarrage - problème de carte graphique interne ?

si la carte était morte, le liveUSB ne marcherai pas !
Il faudrait essayer de démarrer en basic graphics mode, mais je me rappelle bien, sur la ligne de boot, il faut mettre : video=vesa
Gérard


F33, Kde/plasma, AMD FX-6300, NVIDIA GM107 [GeForce GTX 750 Ti], 8Go de mémoire

Hors ligne

#27 03/02/2021 18:13:08

bouq's
Membre
Lieu : Isère
Inscription : 08/09/2008
Messages : 142

Re : [Résolu] Plus de démarrage - problème de carte graphique interne ?

merci fgland,

C'est exactement ce que je souhaite faire. Démarrer dans le même mode que le liveUSB en mode rescue (basic graphics mode).

Je viens d'essayer de rajouter video=vesa en fin de ligne linux.....
J'ai le même comportement que sans.

Pour l'histoire de la carte graphique morte (ou partiellement), il me semblait que, en plus de la carte graphique ATI radeon, le CPU intégrait un GPU Intel pour l'affichage basique et sur lequel le pc démarre avant de basculer sur la CG.
Mais je me trompe peut être!

Hors ligne

#28 03/02/2021 18:36:40

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 23 059

Re : [Résolu] Plus de démarrage - problème de carte graphique interne ?

je crois que c est plutot un argument du genre vga= xxxx

il faut tâtonner avec les modes VGA que tu trouveras sur le net, j'ai vu ça :

https://www.careerride.com/view/what-ar … -3467.aspx

mais c'est pas très récent.


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#29 03/02/2021 19:44:17

bouq's
Membre
Lieu : Isère
Inscription : 08/09/2008
Messages : 142

Re : [Résolu] Plus de démarrage - problème de carte graphique interne ?

J'avais déjà essayé un peu de jouer avec les codes vga.

Je viens de refaire le test avec différentes valeurs correspondant à ma résolution 1366x768 mais j'ai le même dysfonctionnement.
Pour les codes vga on en trouve là : https://en.wikipedia.org/wiki/VESA_BIOS … de_numbers
Je n'ai pas trouvé la bonne résolution en premier lieu, mais en mettant un code erroné Grub propose un tableau avec des codes valides pour ma résolution.


Je commence à me demander si ça ne viendrait pas d'autre chose que la CG du genre gestion de l'énergie ou autre.

Faudrait que je trouve dans un log les options de démarrage lorsque ça fonctionne avec le liveUSB en mode rescue (basic graphics mode).

Hors ligne

#30 03/02/2021 19:57:12

bouq's
Membre
Lieu : Isère
Inscription : 08/09/2008
Messages : 142

Re : [Résolu] Plus de démarrage - problème de carte graphique interne ?

Ça y est j'ai trouvé !

En regardant dans le fichier  /var/log/Xorg.0.log (merci fgland) du liveUSB en mode rescue, j'ai vu les options de démarrage.
Sur la ligne Linux..... j'ai remplacé rghb par nomodeset et là bingo ... ça démarre !

Bon maintenant faut que je comprenne à quoi servent ces options.

Merci les gars

Hors ligne

#31 03/02/2021 20:59:57

Nicosss
Rédacteur Wiki
Rédacteur Wiki
Lieu : Isère
Inscription : 05/03/2007
Messages : 6 386
Site Web

Re : [Résolu] Plus de démarrage - problème de carte graphique interne ?

Une petite idée de ce que tu peux faire https://www.kernel.org/doc/html/latest/ … eters.html.


F34_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F33_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F33_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

#32 03/02/2021 21:38:14

bouq's
Membre
Lieu : Isère
Inscription : 08/09/2008
Messages : 142

Re : [Résolu] Plus de démarrage - problème de carte graphique interne ?

Merci à tous pour votre aide.

d'après ce que je comprend, nomodeset impose de ne démarrer qu'avec le GPU intel intégré.

Bon du coup voici comment résoudre le problème d'écran noir au démarrage :

1. à la mise sous tension appuyer sur n'importe quelle touche du clavier pour afficher les différents noyaux
2. choisir le plus récent et appuyer sur E (pour passer en mode "Edit")
3. aller à la fin de la ligne qui commence par linux....
4. rajouter nomodeset=0 (attention clavier US : "m"=",")

linux ($root)/vmlinuz-5.9.16-200.fc33.x86_64.................xxxxxx.................. rhgb quiet nomodeset=0

5. appuyer simultanément sur Ctrl et x

normalement ça doit démarrer.
une fois dans sa session il faut rendre la correction permanente

6. ouvrir un terminal
7. éditer en root le fichier /etc/default/grub avec l'éditeur de votre choix (vi, gvim, gedit, nano... wordpad ahaha)

sudo gvim /etc/default/grub

8. ajouter nomodeset=0 à la fin de la ligne qui commence par GRUB_CMDLINE_LINUX (avant les guillemets)

GRUB_CMDLINE_LINUX="......xxxxxxxxxx.......... rghb quiet nomodeset=0"

9. Sauvegarder et quitter
10.regénérer la configuration de Grub

sudo grub2-mkconfig -o /boot/grub2/grub.cfg

11. redémarrer..... ça devrait fonctionner !

Hors ligne

#33 04/02/2021 00:52:12

Nednet
Membre
Lieu : aux alentours de Toulouse
Inscription : 07/12/2015
Messages : 856

Re : [Résolu] Plus de démarrage - problème de carte graphique interne ?

Merci pour ton retour smile


Il n'y a aucune honte à ne pas savoir
mais beaucoup à ne pas apprendre

Hors ligne

Pied de page des forums