Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fin de maintenance pour Fedora 32

#1 23/11/2020 19:50:08

Solar Eagle
Membre
Lieu : Nord Ardèche
Inscription : 04/10/2009
Messages : 278

NetworkManager crashe

Bonsoir,

J'ai installé il y a un peu plus d'un mois un VPN (ProtonVPN), téléchargé le fichier openvpn proposé par cette dernière entreprise, configuré à l'aide de l'outil en ligne fourni (protonvpn-cli) puis j'ai réglé NetworkManager pour que le VPN démarre avec la connexion Wifi. Premièrement, le PC ne se connecte plus en Wifi à l'ouverture de la session. J'ai lu je ne sais plus où que le réseau démarrerait avec des droits root ou en tout cas autres que ceux de l'utilisateur, et que le problème viendrait de là. C'est le problème numéro 1 mais pas le pire.
Le problème numéro 2, le pire des deux, est que j'ai plusieurs fois par jour la navigation qui se fige, avec le symbole Wifi toujours affiché dans le systray en haut à droite et les pages web qui ne répondent plus. Lancer une nouvelle page web (dans Firefox) ne donne aucune réponse et on reste sur la page courante, que l'on passe par un nouvel onglet ou dans une page déjà ouverte. Par contre, quand j'ouvre les paramètres de Gnome, ce qui peut prendre quelque temps, il m'affiche une erreur avec un message ressemblant au suivant :

Oups, quelque chose s'est mal passé. NetworkManager doit être en fonctionnement.

D'autre part, si j'ouvre le moniteur système, je vois des envois réseau à intervalles réguliers, peut-être des pings, et plus tard quelques pics de retour, mais la connexion reste bloquée.

Relancer NetworkManager dans un terminal grâce à la commande

sudo systemctl restart NetworkManager.service

résout le problème, avec parfois plusieurs dizaines de secondes avant que le service ne redémarre.

Au départ, je pensais à un souci du côté du serveur VPN (je suis en offre payante) mais le souci ne semble pas provenir de leur serveur et plutôt de NetworkManager.

D'autre part, j'ai aussi un troisième problème : des déconnexions brutales du wifi, uniquement sur PC. Mon fournisseur d'accès est Free et dois-je les contacter pour savoir s'ils ne bloqueraient pas ma connexion? Cela m'est arrivé en écrivant ce propre message.

Les second et troisième problème peuvent arriver jusqu'à deux ou trois fois par heure, à n'importe quelle heure. Le pire est que ce problème arrive quand je surfe, ou suis sur YouTube, mais je ne l'ai jamais rencontré sous Teams (plus ou moins imposé par le travail quand je suis en télétravail), alors que j'ai la webcam allumée en permanence pour une heure ou deux.

Aucun de ces deux derniers problèmes n'apparaît quand je me connecte sur le Wifi du travail ou en partage de connexion sur mon téléphone portable avec Android, y compris quand j'ai lancé le VPN sur ce dernier (par l'intermédiaire de l'application de ProtonVPN). Ma femme qui est en télétravail quasi-total ne semble avoir aucun souci, or elle se connecte aussi parfois sur le VPN de son entreprise. Son PC est sous Windows.

Sauriez-vous ce qui se passe, s'il vous plaît?


Portable : Asus UX303U Notebook PC, 8 GO RAM, SSD Samsung 850 EVO 500 Go, Fedora 33 64-bit Gnome 3.38,

Hors ligne

#2 23/11/2020 21:26:45

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 18 317
Site Web

Re : NetworkManager crashe

1 est ce que cela le fait sans VPN?

2 si c'est le cas regarde coté puce réseau (wifi ou autre) si le problème ne vient pas de là (test sur un autre réseau)

3 les logs disent quoi?

4 si c'est un bogue NetworkManager tu peux aussi le rapporter sur le bugzilla redhat (voir la doc à ce sujet).

Perso j'ai mon VPN perso wireguard et je n'ai pas constaté de souci a ce niveau. A voir si ce n'est pas un problème avec openvpn...

Tu peux régler qui peut faire quoi dans les options réseaux. Perso je le fais avec l'interface de KDE et pas de souci.


AMD R7 2700X, MSI Pro Carbon X470, 32Go DDR4 3200@3333Mhz Gskill TridentZ CL14, RX 5700XT MSI Watercooling OC SSD: 1x 970 EVO NVME 500Go + 2x500Go 860 EVO, 3x1To 860 Evo, HDD 1x2To WD black, 1x4to WD Black, 1x3To WD Red, GMT BeQuiet Dark 900+Purepower 1000W 80+ platinium
AMD R3 2200g, Asus A320, 16Go DDR4 2400@2133Mhz, 1x250GO SSD EVO, 3x 2To RAID 5 WD Blue / AMD R5 2600 + 32Go DDR4 3000@2133Mhz+1xSSD Evo 500Go , 3x1To QVO RAID5 / On Cube Chieftec
AMD A6 9500, 8Go, 500Go SSD MX500

Hors ligne

#3 23/11/2020 21:36:55

Refuznik
Membre
Inscription : 31/01/2007
Messages : 7 910

Re : NetworkManager crashe

Quel box free ? Il y a des problème avec la delta https://forum.nextinpact.com/topic/1752 … nt-2916153

Donc quant tu utilises seulement le wifi sans vpn, il coupe au bout d'une 1 ou 2 heures.

Hors ligne

#4 23/11/2020 22:15:29

Solar Eagle
Membre
Lieu : Nord Ardèche
Inscription : 04/10/2009
Messages : 278

Re : NetworkManager crashe

Merci pour vos premières réponses.

Je me connecte à travers une Freebox Mini 4K.

Je suis allé voir ici https://wiki.gnome.org/Projects/Network … /Debugging puis ai lancé la commande

sudo journalctl -u NetworkManager.service 

J'ai noté ceci comme erreur qui revient souvent au démarrage ou peu après (j'ai noté les informations qui me semblent sensibles avec des étoiles) :

nov. 23 09:13:31 localhost.localdomain NetworkManager[877]: <error> [1606119211.1144] vpn-connection[****************************************************************,"fr.protonvpn.com.udp",0]: Failed to request VPN secrets #3: No agents were available>
nov. 23 09:13:31 localhost.localdomain NetworkManager[877]: <info>  [1606119211.1148] device (wlp1s0): state change: secondaries -> failed (reason 'secondary-connection-failed', sys-iface-state: 'managed')
nov. 23 09:13:31 localhost.localdomain NetworkManager[877]: <info>  [1606119211.1154] manager: NetworkManager state is now CONNECTED_GLOBAL
nov. 23 09:13:31 localhost.localdomain NetworkManager[877]: <info>  [1606119211.1306] device (wlp1s0): set-hw-addr: set MAC address to **:**:**:**:**:** (scanning)
nov. 23 09:13:31 localhost.localdomain NetworkManager[877]: <warn>  [1606119211.1448] device (wlp1s0): Activation: failed for connection 'Freebox-********'

De plus l'adresse MAC change à chaque fois.

EDIT : Voici un log nettoyé, obtenu avec la commande :

journalctl -u NetworkManager.service -p 4
-- Logs begin at Thu 2020-11-26 11:09:58 CET, end at Thu 2020-11-26 12:26:43 CET. --
nov. 26 11:10:06 localhost.localdomain NetworkManager[889]: <warn>  [***] sup-iface[***,0,wlp1s0]: call-p2p-cancel: failed with P2P cancel failed
nov. 26 11:10:15 localhost.localdomain NetworkManager[889]: <error> [***] vpn-connection[***,"fr-**.protonvpn.com.udp",0]: Failed to request VPN secrets #3: No agents were available for>
nov. 26 11:10:15 localhost.localdomain NetworkManager[889]: <warn>  [***] device (wlp1s0): Activation: failed for connection 'Freebox-***'
nov. 26 11:10:21 localhost.localdomain NetworkManager[889]: <error> [***] vpn-connection[***,"fr-**.protonvpn.com.udp",0]: Failed to request VPN secrets #3: No agents were available for>
nov. 26 11:10:21 localhost.localdomain NetworkManager[889]: <warn>  [***] device (wlp1s0): Activation: failed for connection 'Freebox-***'
nov. 26 11:10:25 localhost.localdomain NetworkManager[889]: <error> [1606385425.2227] vpn-connection[***,"fr-**.protonvpn.com.udp",0]: Failed to request VPN secrets #3: No agents were available for>
nov. 26 11:10:25 localhost.localdomain NetworkManager[889]: <warn>  [1606385425.2408] device (wlp1s0): Activation: failed for connection 'Freebox-***'
nov. 26 11:10:32 localhost.localdomain NetworkManager[889]: <error> [1606385432.2917] vpn-connection[***,"fr-**.protonvpn.com.udp",0]: Failed to request VPN secrets #3: No agents were available for>
nov. 26 11:10:32 localhost.localdomain NetworkManager[889]: <warn>  [1606385432.2934] device (wlp1s0): Activation: failed for connection 'Freebox-3C9EEC'
nov. 26 11:11:51 localhost.localdomain NetworkManager[889]: <error> [1606385511.1450] vpn-connection[***,"fr-**.protonvpn.com.udp",0]: Failed to request VPN secrets #3: User canceled the secrets re>
nov. 26 11:11:51 localhost.localdomain NetworkManager[889]: <warn>  [1606385511.2123] device (wlp1s0): Activation: failed for connection 'Freebox-3C9EEC'
nov. 26 11:13:36 localhost.localdomain NetworkManager[889]: <warn>  [1606385616.4054] device (wlp1s0): link timed out.
nov. 26 11:13:36 localhost.localdomain NetworkManager[889]: <warn>  [1606385616.4213] device (wlp1s0): Activation: failed for connection 'Redmi'
nov. 26 11:14:16 fedora NetworkManager[889]: <error> [***] vpn-connection[**,"fr-**.protonvpn.com.udp",0]: Failed to request VPN secrets #3: User canceled the secrets request.
nov. 26 11:14:16 fedora NetworkManager[889]: <warn>  [**] device (wlp1s0): Activation: failed for connection 'Freebox-***'
nov. 26 11:20:36 localhost.localdomain nm-openvpn[5633]: NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
nov. 26 11:20:36 localhost.localdomain nm-openvpn[5633]: WARNING: 'link-mtu' is used inconsistently, local='link-mtu 1602', remote='link-mtu 1634'
nov. 26 11:20:36 localhost.localdomain nm-openvpn[5633]: WARNING: 'tun-mtu' is used inconsistently, local='tun-mtu 1500', remote='tun-mtu 1532'
nov. 26 12:20:37 fedora nm-openvpn[5633]: WARNING: 'link-mtu' is used inconsistently, local='link-mtu 1602', remote='link-mtu 1634'
nov. 26 12:20:37 fedora nm-openvpn[5633]: WARNING: 'tun-mtu' is used inconsistently, local='tun-mtu 1500', remote='tun-mtu 1532'

Dernière modification par Solar Eagle (26/11/2020 13:37:43)


Portable : Asus UX303U Notebook PC, 8 GO RAM, SSD Samsung 850 EVO 500 Go, Fedora 33 64-bit Gnome 3.38,

Hors ligne

#5 23/11/2020 22:22:50

Solar Eagle
Membre
Lieu : Nord Ardèche
Inscription : 04/10/2009
Messages : 278

Re : NetworkManager crashe

J'ai vu que le bug n'est pas nouveau. Une solution semble avoir été proposée ici (en fin de page), mais j'ai du mal à la comprendre et elle concerne une ancienne version de Fedora :

https://bugzilla.redhat.com/show_bug.cgi?id=1389913


Portable : Asus UX303U Notebook PC, 8 GO RAM, SSD Samsung 850 EVO 500 Go, Fedora 33 64-bit Gnome 3.38,

Hors ligne

#6 24/11/2020 10:49:03

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 18 317
Site Web

Re : NetworkManager crashe

sudo nmcli --ask connection up wlp1s0

Je dirais...

Après il doit te demander le mot de passe, cela doit permettre de fixer celui-ci pour l'interface.

Si le problème persiste, tu peux rouvrir le bogue en rajoutant aussi tes informations.


AMD R7 2700X, MSI Pro Carbon X470, 32Go DDR4 3200@3333Mhz Gskill TridentZ CL14, RX 5700XT MSI Watercooling OC SSD: 1x 970 EVO NVME 500Go + 2x500Go 860 EVO, 3x1To 860 Evo, HDD 1x2To WD black, 1x4to WD Black, 1x3To WD Red, GMT BeQuiet Dark 900+Purepower 1000W 80+ platinium
AMD R3 2200g, Asus A320, 16Go DDR4 2400@2133Mhz, 1x250GO SSD EVO, 3x 2To RAID 5 WD Blue / AMD R5 2600 + 32Go DDR4 3000@2133Mhz+1xSSD Evo 500Go , 3x1To QVO RAID5 / On Cube Chieftec
AMD A6 9500, 8Go, 500Go SSD MX500

Hors ligne

#7 24/11/2020 11:00:35

Solar Eagle
Membre
Lieu : Nord Ardèche
Inscription : 04/10/2009
Messages : 278

Re : NetworkManager crashe

Merci, la connexion est inconnue pour nmcli. J’ai utilisé nm-connection-editor pour configurer le VPN, l'interface de Gnome ne permettant pas de le faire. Je ferai un rapport de bug ce soir après le travail.


Portable : Asus UX303U Notebook PC, 8 GO RAM, SSD Samsung 850 EVO 500 Go, Fedora 33 64-bit Gnome 3.38,

Hors ligne

#8 26/11/2020 13:12:18

Solar Eagle
Membre
Lieu : Nord Ardèche
Inscription : 04/10/2009
Messages : 278

Re : NetworkManager crashe

J'ai reconfiguré la connexion sur un serveur précis et pour le moment je n'ai pas eu de souci, mais on m'a demandé le mot de passe alors que je l'avais déjà rentré. J'avais déjà eu le souci précédemment.

D'autre part, je paie visiblement un VPN pour rien, vu qu'il y a des fuites DNS qui laissent apparaître mon IP et ma localisation au grand jour. Pourtant systemd-resolved est censé résoudre le problème. J'ai vérifié que le service soit bien activé. J'ai dans un autre sujet que ce changement avait créé des problèmes alors qu'il était sensé les résoudre.

D'autre part, je me demande si le souci ne provient pas du fait que j'ai configuré deux serveurs différents, dont un hors de France. J'ai supprimé ce dernier momentanément. Pour le moment, je n'ai pas eu de déconnexion ni de ralentissement (qui arrivent plutôt en charge ou sur un long téléchargement).

Je vais éditer les logs des messages précédents pour les rendre plus lisibles.

Dernière modification par Solar Eagle (26/11/2020 13:30:23)


Portable : Asus UX303U Notebook PC, 8 GO RAM, SSD Samsung 850 EVO 500 Go, Fedora 33 64-bit Gnome 3.38,

Hors ligne

Pied de page des forums