Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora 31 c'est fini

#1 08/10/2020 10:52:08

fedora23
Membre
Inscription : 21/06/2016
Messages : 75

[Résolu] CMS Grav ne fonctionne pas en locale sur fedora 30 LAMP

Bonjour,

J'essaie de faire fonctionner le CMS Grav en locale mais je soupçonne que j'ai un problème de configuration d'Apache que je n'arrive pas à résoudre ou manque de module ?
Voici les différentes manipulations que j'ai effectuées :

1) J'ai téléchargé grav-admin-v1.6.28.zip dans /home/mondossierperso/Téléchargements ensuite je l'ai extrait pour obtenir un dossier dezippé appelé grav-admin

2) Je déplace  grav-admin :

sudo mv /home/mondossierperso/Téléchargements/grav-admin-v1.6.28/grav-admin /var/www/

3) je le change de groupe pour qu'apache puisse avoir les droits dessus :

sudo chown -R monnomdeconnexion:apache /var/www/grav-admin/

4) je configure le virtualhost :

 cat /etc/httpd/conf.d/grav-admin.conf 

<VirtualHost *:80>
        # home du site : URL = http://grav-admin/
        ServerName grav-admin

        # Dossier contenant les pages
        DocumentRoot /var/www/grav-admin

        <Directory /var/www/grav-admin>

                AllowOverride all
                Require all granted

        </Directory>

        ErrorLog /var/log/httpd/error.grav-admin.log
        CustomLog /var/log/httpd/access.grav-admin.log combined
	
</VirtualHost>

5) configuration du fichier /etc/hosts :

cat /etc/hosts
127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
::1         localhost localhost.localdomain localhost6 localhost6.localdomain6

# Pour tester l'URL http://grav-admin
::1 grav-admin
127.0.0.1 grav-admin

6) je redémarre le serveur :

$ systemctl restart httpd.service

7) sur le navigateur je tape http://grav-admin

Résultat : une page blanche où c'est marqué :

Forbidden

You don't have permission to access this resource.Server unable to read htaccess file, denying access to be safe

8) Sur le navigateur j'ai essayé de taper http://admin-grav/admin

Résultat : une page blanche où c'est marqué :

Forbidden

You don't have permission to access this resource.Server unable to read htaccess file, denying access to be safe




Merci d'avance pour votre aide. Juste au passage, peut-on avoir en même temps apache et nginx sur la même machine ?


Dell Alienware m11x R2, core i5 - NVIDIA Corporation GT215M [GeForce GT 335M] (rev a2)
Dual boot Windows 7 / Linux Fedora 30  v.5.3.6-200.fc30.x86_64 - x86_64 x86_64 x86_64 GNU/Linux

Hors ligne

#2 08/10/2020 11:05:28

thierryR
Membre
Lieu : Chalons en Champagne
Inscription : 31/01/2011
Messages : 1 417

Re : [Résolu] CMS Grav ne fonctionne pas en locale sur fedora 30 LAMP

Pour LAMP tu as une doc qui va t'aider: https://doc.fedora-fr.org/wiki/LAMP
Je ne vois pas pourquoi tu as modifié le fichier hosts.

Dernière modification par thierryR (08/10/2020 11:07:45)


201119024340877569.gifChalons en Champagne: Au nord, un peu avant la banquise (Ah ben non... Elle a fondu)
Kernel: 5.8.18-300.fc33.x86_64 x86_64 bits: 64 Desktop: KDE Plasma 5.19.5
Type: Desktop Mobo: ASRock model: X470 Gaming-ITX/ac  UEFI: CPU: Topology: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP L2 cache: 4096 KiB

Hors ligne

#3 08/10/2020 11:10:07

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 22 702

Re : [Résolu] CMS Grav ne fonctionne pas en locale sur fedora 30 LAMP

sudo chown -R monnomdeconnexion:apache /var/www/grav-admin/

je ne suis pas sur du tout qu'il soit pertinent d'autoriser ton user à posséder et écrire dans /var


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#4 08/10/2020 11:16:57

thierryR
Membre
Lieu : Chalons en Champagne
Inscription : 31/01/2011
Messages : 1 417

Re : [Résolu] CMS Grav ne fonctionne pas en locale sur fedora 30 LAMP

Pour compléter ce que dit nouvo09, tu peux installer ton archive dans ton /home et faire un déclaration à Apache dans /etc/httpd/conf.d/grav-admin.conf.
Chez moi ça donne ça:

<VirtualHost *:80>
         # Activation des sites de quelques utilisateurs : http://localhost/~nomutilisateur
         UserDir  enabled  thierry
         UserDir  public_html
        <Directory /home/*/public_html>
                AllowOverride all
                Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
        </Directory>

201119024340877569.gifChalons en Champagne: Au nord, un peu avant la banquise (Ah ben non... Elle a fondu)
Kernel: 5.8.18-300.fc33.x86_64 x86_64 bits: 64 Desktop: KDE Plasma 5.19.5
Type: Desktop Mobo: ASRock model: X470 Gaming-ITX/ac  UEFI: CPU: Topology: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP L2 cache: 4096 KiB

Hors ligne

#5 09/10/2020 11:35:17

fedora23
Membre
Inscription : 21/06/2016
Messages : 75

Re : [Résolu] CMS Grav ne fonctionne pas en locale sur fedora 30 LAMP

thierryR a écrit :

Pour LAMP tu as une doc qui va t'aider: https://doc.fedora-fr.org/wiki/LAMP
Je ne vois pas pourquoi tu as modifié le fichier hosts.

Bonjour thierryR, merci pour ta réponse,

J'ai modifié le fichier hosts car ayant essayé localbyflywheel (LBF) pour wordpress en local, j'ai constaté ceci :

supposons que je teste le site wordpress en local appelé sitetestun.local, j'ai donc remarqué qu'automatiquement (bien évidemment il me demande l'autorisation) ,LBF configure le fichier /etc/hosts comme ceci :

$cat /etc/hosts

## Local by Flywheel - Start ##
::1 sitetestun.local #Local Site
127.0.0.1 sitetestun.local #Local Site
::1 www.sitetestun.local #Local Site

Je suppose que LBF fait ça afin d'avoir deux manières d'accéder au même dossier en utilisant "www.sitetestun.local" ou "sitetestun.local".

De la même manière, je voulais accéder sur le test du cms grav en tapant l'adresse http://site-grav


Dell Alienware m11x R2, core i5 - NVIDIA Corporation GT215M [GeForce GT 335M] (rev a2)
Dual boot Windows 7 / Linux Fedora 30  v.5.3.6-200.fc30.x86_64 - x86_64 x86_64 x86_64 GNU/Linux

Hors ligne

#6 09/10/2020 11:42:39

fedora23
Membre
Inscription : 21/06/2016
Messages : 75

Re : [Résolu] CMS Grav ne fonctionne pas en locale sur fedora 30 LAMP

nouvo09 a écrit :
sudo chown -R monnomdeconnexion:apache /var/www/grav-admin/

je ne suis pas sur du tout qu'il soit pertinent d'autoriser ton user à posséder et écrire dans /var

Bonjour nouvo09, merci pour ta réponse,

Effectivement je suis d'accord, mais pour le moment je cherche juste à comprendre comment faire fonctionner ce cms grav en local, dans /var/ ou dans /home/ peu importe, je cherche à comprendre où est-ce que ça bloque ?


Dell Alienware m11x R2, core i5 - NVIDIA Corporation GT215M [GeForce GT 335M] (rev a2)
Dual boot Windows 7 / Linux Fedora 30  v.5.3.6-200.fc30.x86_64 - x86_64 x86_64 x86_64 GNU/Linux

Hors ligne

#7 09/10/2020 12:03:27

cezame
Membre
Lieu : Arlon près du triangle BFL
Inscription : 24/10/2016
Messages : 328

Re : [Résolu] CMS Grav ne fonctionne pas en locale sur fedora 30 LAMP

Lorsque j'utilise un cms, je l'adresse par localhost/répertoire du cms, ou http://127.0.0.1/répertoire du cms pour autant qu'il soit sur mon poste de travail. A noter que souvent je dois mettre selinux en permissif (setenforce 0)

Dernière modification par cezame (09/10/2020 12:09:51)

Hors ligne

#8 09/10/2020 12:49:25

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 22 702

Re : [Résolu] CMS Grav ne fonctionne pas en locale sur fedora 30 LAMP

Tu as pensé à SElinux ?


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#9 09/10/2020 13:40:45

fedora23
Membre
Inscription : 21/06/2016
Messages : 75

Re : [Résolu] CMS Grav ne fonctionne pas en locale sur fedora 30 LAMP

cezame a écrit :

Lorsque j'utilise un cms, je l'adresse par localhost/répertoire du cms, ou http://127.0.0.1/répertoire du cms pour autant qu'il soit sur mon poste de travail. A noter que souvent je dois mettre selinux en permissif (setenforce 0)

Bonjour, cezame et merci pour ta réponse.

nouvo09 a écrit :

Tu as pensé à SElinux ?(setenforce 0)

J'ai fais comme cezame avec

setenforce 0

Donc voilà un petit résumé juste pour faire fonctionner un fichier index.php qui ne marche même pas :

1) J'ai modifié le fichier grav-admin.conf comme ceci :

$ cat /etc/httpd/conf.d/grav-admin.conf 
<VirtualHost *:80>

         # Activation des sites de quelques utilisateurs : http://localhost/~mario

         UserDir  enabled  mario
         UserDir  grav-admin
        <Directory /home/*/grav-admin>
                AllowOverride all
                Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
        </Directory>
	
</VirtualHost>

2) le fichier index.php pour faire un test très simplement sans les centaines de fichiers du cms

 cat /home/mario/grav-admin/index.php 

Ceci est le contenu du fichier /home/mario/grav-admin/index.php
<?php
phpinfo();
?>

3) Le fichier /etc/hosts
$ cat /etc/hosts
127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
::1         localhost localhost.localdomain localhost6 localhost6.localdomain6

4) setenforce 0 comme a dit cezame

$ sudo setenforce 0

5) redémarre apache

$ systemctl restart httpd.service 

6) sur le navigateur je tape http://localhost/~mario

Résultat : Page blanche avec les mentions : FORBIDDEN You don't have permission to access this resource.

Quelles sont les permissions correctes ? J'ai essayé ceci :

drwxr-xr-x.  2 apache       apache        4096  9 oct.  10:39  grav-admin/

et ceci :

drwxr-xr-x.  2 mario      apache        4096  9 oct.  10:39  grav-admin/

et ceci :

drwxr-xr-x.  2 mario      mario        4096  9 oct.  10:39  grav-admin/

Mais rien ne fonctionne


Dell Alienware m11x R2, core i5 - NVIDIA Corporation GT215M [GeForce GT 335M] (rev a2)
Dual boot Windows 7 / Linux Fedora 30  v.5.3.6-200.fc30.x86_64 - x86_64 x86_64 x86_64 GNU/Linux

Hors ligne

#10 09/10/2020 22:03:21

thierryR
Membre
Lieu : Chalons en Champagne
Inscription : 31/01/2011
Messages : 1 417

Re : [Résolu] CMS Grav ne fonctionne pas en locale sur fedora 30 LAMP

Je sais que ça ne tombe pas du ciel. Mais on va y arriver.
Déjà, il faut que tu t'assures d'avoir une bonne installation.

dnf groupinstall "Serveur Web"

  (install de LAMP)
Ton archive doit être décompressée dans ton /home
Ensuite tu passes ça:

setsebool -P httpd_enable_homedirs 1
chcon -R -t httpd_sys_rw_content_t /home/mario/grav-admin

Les permissions sur mes fichiers n'ont pas changé. Tu devrais avoir mario:mario
Si tu as toujours un acces denied:
1) regarde dans les logs apache
2) regarde dans les logs selinux (/var/log/audit/audit.log)

Je me rappelle aussi avoir fait un chmod 777 sur mes dossiers.

Dernière modification par thierryR (09/10/2020 22:13:44)


201119024340877569.gifChalons en Champagne: Au nord, un peu avant la banquise (Ah ben non... Elle a fondu)
Kernel: 5.8.18-300.fc33.x86_64 x86_64 bits: 64 Desktop: KDE Plasma 5.19.5
Type: Desktop Mobo: ASRock model: X470 Gaming-ITX/ac  UEFI: CPU: Topology: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP L2 cache: 4096 KiB

Hors ligne

#11 10/10/2020 00:07:39

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 22 702

Re : [Résolu] CMS Grav ne fonctionne pas en locale sur fedora 30 LAMP

Je me rappelle aussi avoir fait un chmod 777 sur mes dossiers.

à ne jamais faire !


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#12 12/10/2020 13:25:17

fedora23
Membre
Inscription : 21/06/2016
Messages : 75

Re : [Résolu] CMS Grav ne fonctionne pas en locale sur fedora 30 LAMP

thierryR a écrit :

Je sais que ça ne tombe pas du ciel. Mais on va y arriver.
Déjà, il faut que tu t'assures d'avoir une bonne installation.

dnf groupinstall "Serveur Web"

  (install de LAMP)
Ton archive doit être décompressée dans ton /home
Ensuite tu passes ça:

setsebool -P httpd_enable_homedirs 1
chcon -R -t httpd_sys_rw_content_t /home/mario/grav-admin

Les permissions sur mes fichiers n'ont pas changé. Tu devrais avoir mario:mario
Si tu as toujours un acces denied:
1) regarde dans les logs apache
2) regarde dans les logs selinux (/var/log/audit/audit.log)

Je me rappelle aussi avoir fait un chmod 777 sur mes dossiers.

J'ai faits les manip suivantes :

$cd /home/mario
$sudo dnf groupinstall "Serveur Web"
$sudo setsebool -P httpd_enable_homedirs 1
$chcon -R -t httpd_sys_rw_content_t /home/mario/grav-admin

$sudo setenforce 0
$systemctl restart httpd.service


Voici le contenu de /etc/hosts

$ sudo cat /etc/hosts

127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
::1         localhost localhost.localdomain localhost6 localhost6.localdomain6


127.0.0.1   localhost.grav-admin
::1         localhost.grav-admin

Voici le contenu de /etc/httpd/conf.d/grav-admin.conf

$ cat grav-admin.conf 
<VirtualHost *:80>
        # home du site : URL = http://localhost.grav-admin/
        ServerName localhost.grav-admin

        # Dossier contenant les pages
        DocumentRoot /home/mario/grav-admin

        <Directory /home/mario/grav-admin>

                AllowOverride all
                Require all granted

        </Directory>
	
</VirtualHost>

Dans le navigateur je rentre http://localhost.grav-admin

Résultat : PAGE BLANCHE


Dell Alienware m11x R2, core i5 - NVIDIA Corporation GT215M [GeForce GT 335M] (rev a2)
Dual boot Windows 7 / Linux Fedora 30  v.5.3.6-200.fc30.x86_64 - x86_64 x86_64 x86_64 GNU/Linux

Hors ligne

#13 12/10/2020 13:59:37

thierryR
Membre
Lieu : Chalons en Champagne
Inscription : 31/01/2011
Messages : 1 417

Re : [Résolu] CMS Grav ne fonctionne pas en locale sur fedora 30 LAMP

Tu peux essayer ceci:
Apache peut-il lire le fichier index.php contenant ça:

<?php 
    phpinfo();
 ?>

Pour savoir si apache peut accéder au dossier dans le home :

# su -l apache -c "ls ~mario/grav-admin" -s /bin/bash

Si tu as toujours une page blanche:
tu lances carrément un shell sous apache:

su -l apache -s /bin/bash

puis tu essayes de traverser étape par étape jusqu'à ce que ça bloque:

cd /home
cd mario
cd grav-admin
ls

Dernière modification par thierryR (12/10/2020 14:04:16)


201119024340877569.gifChalons en Champagne: Au nord, un peu avant la banquise (Ah ben non... Elle a fondu)
Kernel: 5.8.18-300.fc33.x86_64 x86_64 bits: 64 Desktop: KDE Plasma 5.19.5
Type: Desktop Mobo: ASRock model: X470 Gaming-ITX/ac  UEFI: CPU: Topology: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP L2 cache: 4096 KiB

Hors ligne

#14 12/10/2020 16:46:24

fedora23
Membre
Inscription : 21/06/2016
Messages : 75

Re : [Résolu] CMS Grav ne fonctionne pas en locale sur fedora 30 LAMP

thierryR a écrit :

Tu peux essayer ceci:
Apache peut-il lire le fichier index.php contenant ça:

<?php 
    phpinfo();
 ?>

Pour savoir si apache peut accéder au dossier dans le home :

# su -l apache -c "ls ~mario/grav-admin" -s /bin/bash

Si tu as toujours une page blanche:
tu lances carrément un shell sous apache:

su -l apache -s /bin/bash

puis tu essayes de traverser étape par étape jusqu'à ce que ça bloque:

cd /home
cd mario
cd grav-admin
ls

ça y est ça a l'air de marcher !

voici le récap du problème : visiblement c'est le dézippage du dossier à la windows fait foirer quelque chose je m'explique, j'ai téléchargé grav-admin.xxx.zip, j'ai cliqué droit puis "extraire ici". Tout se passe en environnement graphique mais le dossier ne marche pas.

Solution :

$ unzip grav-admin.xxx.zip -d grav-admin

Ensuite un

$ sudo chown -R mario:apache grav-admin
$ systemctl restart httpd.service 

Ensuite direction navigateur : http://localhost.grav-admin

En tout cas merci thierryR et à tous ceux qui ont répondu, votre aide m'a été très précieuse.

NB : Comme a dit nouvo09 : ne jamais s'amuser avec chmod 777


Dell Alienware m11x R2, core i5 - NVIDIA Corporation GT215M [GeForce GT 335M] (rev a2)
Dual boot Windows 7 / Linux Fedora 30  v.5.3.6-200.fc30.x86_64 - x86_64 x86_64 x86_64 GNU/Linux

Hors ligne

Pied de page des forums