Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : La nouvelle version de Fedora dite 33 est sortie

#1 22/09/2020 08:46:43

jpv63
Membre
Inscription : 11/11/2009
Messages : 9

[Résolu] A chaque boot, ma sortie son analogique devient une sortie numérique

Bonjour,
j'utilise Fedora depuis des années et j'utilise Pulseaudio pour le son.  Ma sortie son est normalement analogique.
Depuis quelques jours je 'ai plus de son, que ce soit avec Youtube ou bien avec VLC.  J'ai l'impression que c'est suite à une mise à jour, mais c'est peut-être matériel, comme vous pourrez le constater en fin de ce post.

Lorsque j'ouvre l'outil de contrôle du volume Pulseaudio, je constate que  :
- dans périphérique de sortie, la sortie indiquée est audio interne stéréo numérique (IEC958) et le port est Sortie numérique S/PDIF
- dans Configuration, le profil sélectionné sur audio interne est Sortie Stéreo numérique (IEC958)

La sortie son est donc en numérique, alors qu'elle devrait être analogique.

Pour que le son refonctionne, je dois effectuer les modifs suivantes :
1 - dans Configuration, je sélectionne Sortie stéréo analogique (unplugged) (unavailable)
A ce stase,  dans périphérique de sortie, la sortie est bien Audio interne stéreo analogique, mais le port est casque audio (unplugged)
2 - dans Périphérique de sortie, je choisis Sortie ligne (unplugged)

Ces réglages fonctionnent bien, sauf qu'à chaque boot, ils disparaissent et m'obligent à refaire des modifs.

Pourriez-vous me dire dans quel fichier sont stockés les préférences de réglage de ces paramètres ?

Le plus bizarre est que mon PC dispose d'un double boot Fedora/Windows et que lorsque je lance Windows, ma sortie son est également en sortie numérique, et évidemment ne fonctionne pas. Alors qu'il y a quelques jour il n'y avait aucun problème.
Qu'en pensez-vous ?

Merci par avance pour tous ceux qui pourront m'aider.

Hors ligne

#2 22/09/2020 14:54:06

thierryR
Membre
Lieu : Chalons en Champagne
Inscription : 31/01/2011
Messages : 1 310
Site Web

Re : [Résolu] A chaque boot, ma sortie son analogique devient une sortie numérique

J'ai eu le même genre de problème ici: https://forums.fedora-fr.org/viewtopic.php?id=71617


Chalons en Champagne: Au nord, un peu avant la banquise (Ah ben non... Elle a fondu)
Kernel: 5.8.12-200.fc32.x86_64 x86_64 bits: 64 Desktop: KDE Plasma 5.18.5
Type: Desktop Mobo: ASRock model: X470 Gaming-ITX/ac  UEFI: CPU: Topology: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP L2 cache: 4096 KiB

Hors ligne

#3 25/09/2020 06:36:22

jpv63
Membre
Inscription : 11/11/2009
Messages : 9

Re : [Résolu] A chaque boot, ma sortie son analogique devient une sortie numérique

Bonjour, 
merci pour votre réponse, mais ce n'est pas tout à fait le même problème.

Sans aucune raison, ma sortie haut-parleur classique est devenue une sortie S/PDIF, que ce soit sous Linux ou bien sous Windows.
Sous Windows j'ai  beau désinstaller et réinstaller le driver, rien n'y fait, ça reste S/PDIF et je n'ai donc aucun son.
Sous Fedora, j'arrive en modifiant les réglages pulseaudio à basculer la sortie audio sur les haut-parleurs, mais à chaque redémarrage ce réglage disparaît.

Du coup je cherche toujours !

Hors ligne

#4 25/09/2020 12:37:53

cezame
Membre
Lieu : Arlon près du triangle BFL
Inscription : 24/10/2016
Messages : 315

Re : [Résolu] A chaque boot, ma sortie son analogique devient une sortie numérique

Et dans le bios/uefi il n'y a pas une option ?

Hors ligne

#5 25/09/2020 17:54:20

jpv63
Membre
Inscription : 11/11/2009
Messages : 9

Re : [Résolu] A chaque boot, ma sortie son analogique devient une sortie numérique

cezame a écrit :

Et dans le bios/uefi il n'y a pas une option ?

Non j'avais déjà pensé à regarder.  Il y a juste possibilité d'activer ou désactiver la sortie audio

Hors ligne

#6 27/09/2020 12:45:19

jpv63
Membre
Inscription : 11/11/2009
Messages : 9

Re : [Résolu] A chaque boot, ma sortie son analogique devient une sortie numérique

Bonjour,

j'ai enfin trouvé la solution, qui permet de pallier à ce problème.

J'ai ajouté deux  commandes à lancer lors de l'authentification (fichier autostart) :

1/ la commande pacmd set-card-profile alsa_card.pci-0000_00_1b.0 output:analog-stereo permet de définir comme sortie audio la sortie stéréo analogique (au lieu de la sortie S/PDIF)
2/ la commande pacmd set-sink-port alsa_output.pci-0000_00_1b.0.analog-stereo analog-output-lineout permet de choisir comme prériphérique de sortie le haut-parleur

En espérant que ça puisse servir à quelqu'un.

Après j'ignore pour quelle raison un paramètre tel que la sortie son a changé  du jour au lendemain, sans aucune intervention de ma part.

Hors ligne

#7 28/09/2020 09:23:58

Nednet
Membre
Lieu : aux alentours de Toulouse
Inscription : 07/12/2015
Messages : 663

Re : [Résolu] A chaque boot, ma sortie son analogique devient une sortie numérique

Merci pour ce retour :)
Peux-tu passer le sujet en [résolu] stp (bouton en haut à droite de la conversation) ?


Il n'y a aucune honte à ne pas savoir
mais beaucoup à ne pas apprendre

Hors ligne

Pied de page des forums