Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Rétrospective de l'adoption du nouveau logo de Fedora

#1 16/07/2020 23:32:04

fabrice lambert
Membre
Inscription : 16/07/2020
Messages : 4

Soucis de DNS

Bonjour,

J'ai installé Fedora 23 (Workstation), et je souhaite en faire entre autre un serveur DNS.
J'ai installé et configuré Bind, la résolution de noms s'opère sans problèmes depuis le terminal.

Par contre, depuis mon PC Windows 10, les requêtes DNS échouent, bien que les requêtes ping passent sans problème.

Que puis-je faire ?
Merci.

Hors ligne

#2 17/07/2020 06:00:21

Nicosss
Rédacteur Wiki
Rédacteur Wiki
Lieu : Isère
Inscription : 05/03/2007
Messages : 6 459
Site Web

Re : Soucis de DNS

Je pense que tu as installé Fedora 32 ?

Je port 53 est-il bien ouvert ?

Tu as suivi quelle documentation ?


F34_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F33_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F33_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

#3 26/07/2020 15:14:41

fabrice lambert
Membre
Inscription : 16/07/2020
Messages : 4

Re : Soucis de DNS

Oui, c'est fedora 32 (faute de frappe).

J'ai bel et bien ouvert le port 53 (j'ai ajouté le service DNS dans la config permanente du firewall).

J'ai suivit le tutoriel d'OpenClassRoom: https://openclassrooms.com/fr/courses/8 … ervice-dns

Et pour infos, voici mes fichiers de config:
/etc/named.conf:

//
// named.conf
//
// Provided by Red Hat bind package to configure the ISC BIND named(8) DNS
// server as a caching only nameserver (as a localhost DNS resolver only).
//
// See /usr/share/doc/bind*/sample/ for example named configuration files.
//

options {
	listen-on port 53 { 127.0.0.1; };
	listen-on-v6 port 53 { ::1; };
	directory 	"/var/named";
	dump-file 	"/var/named/data/cache_dump.db";
	statistics-file "/var/named/data/named_stats.txt";
	memstatistics-file "/var/named/data/named_mem_stats.txt";
	secroots-file	"/var/named/data/named.secroots";
	recursing-file	"/var/named/data/named.recursing";
	allow-query     { localhost; };
	allow-recursion { localhost; };
	version "SECRET";

	/* 
	 - If you are building an AUTHORITATIVE DNS server, do NOT enable recursion.
	 - If you are building a RECURSIVE (caching) DNS server, you need to enable 
	   recursion. 
	 - If your recursive DNS server has a public IP address, you MUST enable access 
	   control to limit queries to your legitimate users. Failing to do so will
	   cause your server to become part of large scale DNS amplification 
	   attacks. Implementing BCP38 within your network would greatly
	   reduce such attack surface 
	*/
	recursion yes;

	dnssec-enable yes;
	dnssec-validation yes;

	managed-keys-directory "/var/named/dynamic";
	geoip-directory "/usr/share/GeoIP";

	pid-file "/run/named/named.pid";
	session-keyfile "/run/named/session.key";

	/* https://fedoraproject.org/wiki/Changes/CryptoPolicy */
	include "/etc/crypto-policies/back-ends/bind.config";
};

logging {
        channel default_debug {
                file "data/named.run";
                severity dynamic;
        };
};

zone "." IN {
	type hint;
	file "named.ca";
};

include "/etc/named.rfc1912.zones";
include "/etc/named.root.key";
include "/etc/home.local.zone";

/etc/home.local.zone:

zone "home.local." IN {
	type master;
	file "/etc/db.home.local";
};

zone "0.168.192.in-addr.arpa." {
	type master;
	file "/etc/db.192.168.0";
};

/etc/db.home.local:

$TTL 604800	; 1 semaine
$ORIGIN home.local.
@	IN	SOA	ns.home.local. Fedora.home.local. (
			2020071401	; Serial
			3600		; refresh (1 hour)
			3000		; Retry (50 minutes)
			4619200		; Expire (7 weeks, 4 days, 11 hours, 40 seconds
			604800		; Minimum (1 week)
			)
;
@		IN	NS	ns.home.local.
@		IN	NS	sfr-box.home.local.
ns		IN	A	192.168.0.100
sfr-box		IN	A	192.168.0.1
minecraft	IN	CNAME	ns
Fedora		IN	CNAME	ns

/etc/db.192.168.0

$TTL	604800	; 1 semaine
$ORIGIN 0.168.192.in-addr.arpa.
@	IN	SOA	ns.home.local.	Fedora.home.local. (
			2020071401	; Serial
			3600		; Refresh (1 hour)
			3000		; retry (50 minutes)
			4619200		; Expire (7 weeks, 4 days, 11 hours, 6 minutes, 40 seconds)
			604800	)	; minimum (1 week)
;
@		IN	NS	ns.home.local.
100		IN	PTR	ns.home.local.

Et le message que me retourne nslookup (sous windows):

nslookup Fedora.home.local
DNS request timed out.
    timeout was 2 seconds.
Serveur :   UnKnown
Address:  192.168.0.100

DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
*** Le délai de la requête sur UnKnown est dépassé.

Dernière modification par fabrice lambert (26/07/2020 15:35:02)

Hors ligne

#4 29/07/2020 13:42:55

fabrice lambert
Membre
Inscription : 16/07/2020
Messages : 4

Re : Soucis de DNS

Après plusieurs recherches, il s'avère que la ligne jlisten-on port était incorrecte et que'avait oublié de mettre à jour la ligne allow-query:

listen-on port 53 { localhost; };
allow-query     { 192.168.0.0; };

Hors ligne

Pied de page des forums