Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora 34 Beta est disponible

#1 10/03/2020 15:40:41

econdami
Membre
Inscription : 28/01/2010
Messages : 584

[Résolu] Mise a jour de fc30 a fc31: probleme avec la commande system-upgrade

Bonjour !
Plutot qu'un long discours:

# uname -a
Linux toto-rico 5.5.8-100.fc30.x86_64 #1 SMP Thu Mar 5 21:55:51 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
# dnf upgrade --refresh
Adobe Systems Incorporated                                                                                         25 kB/s | 2.9 kB     00:00    
Fedora Modular 30 - x86_64                                                                                         34 kB/s |  24 kB     00:00    
Fedora Modular 30 - x86_64 - Updates                                                                              113 kB/s |  22 kB     00:00    
Fedora 30 - x86_64 - Updates                                                                                      147 kB/s |  22 kB     00:00    
Fedora 30 - x86_64                                                                                                 55 kB/s |  25 kB     00:00    
RPM Fusion for Fedora 30 - Free - Updates                                                                          39 kB/s | 9.9 kB     00:00    
RPM Fusion for Fedora 30 - Free                                                                                    39 kB/s |  10 kB     00:00    
RPM Fusion for Fedora 30 - Nonfree - Updates                                                                       22 kB/s |  10 kB     00:00    
RPM Fusion for Fedora 30 - Nonfree                                                                                 71 kB/s |  10 kB     00:00    
Sublime Text - x86_64 - Stable                                                                                    6.7 kB/s | 2.9 kB     00:00    
Dependencies resolved.
Nothing to do.
Complete!
# dnf install dnf-plugin-system-upgrade
Last metadata expiration check: 0:00:13 ago on Tue 10 Mar 2020 02:35:26 PM CET.
Package python3-dnf-plugin-system-upgrade-4.0.8-2.fc30.noarch is already installed.
Dependencies resolved.
Nothing to do.
Complete!
# dnf system-upgrade download --releasever=31
Before you continue ensure that your system is fully upgraded by running "dnf --refresh upgrade". Do you want to continue [y/N]: y
Adobe Systems Incorporated                                                                                         12 kB/s | 2.9 kB     00:00    
Fedora Modular 31 - x86_64                                                                                         37 kB/s |  24 kB     00:00    
Fedora Modular 31 - x86_64 - Updates                                                                              150 kB/s |  22 kB     00:00    
Fedora 31 - x86_64 - Updates                                                                                       50 kB/s |  22 kB     00:00    
Fedora 31 - x86_64                                                                                                 55 kB/s |  24 kB     00:00    
RPM Fusion for Fedora 31 - Free - Updates                                                                          20 kB/s | 9.9 kB     00:00    
RPM Fusion for Fedora 31 - Free                                                                                    74 kB/s |  10 kB     00:00    
RPM Fusion for Fedora 31 - Nonfree - Updates                                                                       21 kB/s |  10 kB     00:00    
RPM Fusion for Fedora 31 - Nonfree                                                                                 77 kB/s |  10 kB     00:00    
Sublime Text - x86_64 - Stable                                                                                    7.2 kB/s | 2.9 kB     00:00    
terminate called after throwing an instance of 'libdnf::ModulePackageContainer::EnableMultipleStreamsException'
  what():  Cannot enable multiple streams for module 'gimp'
Aborted (core dumped)

Ca ressemble a un probleme avec une partie en C, nan ?
Naivement j'ai tente de desinstaller gimp, puis de relancer l'upgrade ... mais il y a un autre probleme avec un autre paquet ...

Dernière modification par econdami (10/03/2020 15:41:33)

Hors ligne

#2 11/03/2020 10:40:19

madko
Contributeur Fedora et Linuxé depuis 1994
Modérateur
Lieu : Noisy the Great (9³)
Inscription : 22/12/2006
Messages : 8 472
Site Web

Re : [Résolu] Mise a jour de fc30 a fc31: probleme avec la commande system-upgrade

Bonjour,
Quel est l'autre paquet ?


Linux, ya moins bien, mais c'est plus chèr!!!
Fedora 32 WorkStation sur HP 850 G5
Fedora 32 SilverBlue sur Lenovo Thinkpad Yoga 12

Hors ligne

#3 11/03/2020 10:49:24

econdami
Membre
Inscription : 28/01/2010
Messages : 584

Re : [Résolu] Mise a jour de fc30 a fc31: probleme avec la commande system-upgrade

Bonjour,
Je ne suis pas actuellement devant la station, mais il me semble qu'il s'agit de mavenv (enfin, je suis quasiment sur que c'est ce paquet smile.
J'aurai acces a la station demain matin.
Merci pour toute suggestion !

Hors ligne

#4 12/03/2020 12:29:17

econdami
Membre
Inscription : 28/01/2010
Messages : 584

Re : [Résolu] Mise a jour de fc30 a fc31: probleme avec la commande system-upgrade

Bonjour,
Il s'agit plutot de maven !

# dnf system-upgrade download --releasever=31
Before you continue ensure that your system is fully upgraded by running "dnf --refresh upgrade". Do you want to continue [y/N]: y
Adobe Systems Incorporated                                                                                                                                                              37 kB/s | 2.9 kB     00:00    
Fedora Modular 31 - x86_64                                                                                                                                                             121 kB/s |  24 kB     00:00    
Fedora Modular 31 - x86_64 - Updates                                                                                                                                                    46 kB/s |  22 kB     00:00    
Fedora 31 - x86_64 - Updates                                                                                                                                                            39 kB/s |  18 kB     00:00    
Fedora 31 - x86_64                                                                                                                                                                     137 kB/s |  24 kB     00:00    
RPM Fusion for Fedora 31 - Free - Updates                                                                                                                                               78 kB/s | 9.3 kB     00:00    
RPM Fusion for Fedora 31 - Free                                                                                                                                                         64 kB/s |  10 kB     00:00    
RPM Fusion for Fedora 31 - Nonfree - Updates                                                                                                                                            69 kB/s | 9.4 kB     00:00    
RPM Fusion for Fedora 31 - Nonfree                                                                                                                                                      89 kB/s |  10 kB     00:00    
Sublime Text - x86_64 - Stable                                                                                                                                                         7.1 kB/s | 2.9 kB     00:00    
terminate called after throwing an instance of 'libdnf::ModulePackageContainer::EnableMultipleStreamsException'
  what():  Cannot enable multiple streams for module 'gimp'
Aborted (core dumped)
# dnf remove gimp
Dependencies resolved.
=======================================================================================================================================================================================================================
 Package                                     Architecture                             Version                                                                 Repository                                          Size
=======================================================================================================================================================================================================================
Removing:
 gimp                                        x86_64                                   2:2.10.14-1.module_f30+6995+c35e2138                                    @updates-modular                                   109 M
Removing unused dependencies:
 gimp-libs                                   x86_64                                   2:2.10.14-1.module_f30+6995+c35e2138                                    @updates-modular                                    12 M

Transaction Summary
=======================================================================================================================================================================================================================
Remove  2 Packages

Freed space: 121 M
Is this ok [y/N]: y
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                                                                                                                               1/1 
  Erasing          : gimp-2:2.10.14-1.module_f30+6995+c35e2138.x86_64                                                                                                                                              1/2 
  Erasing          : gimp-libs-2:2.10.14-1.module_f30+6995+c35e2138.x86_64                                                                                                                                         2/2 
  Running scriptlet: gimp-libs-2:2.10.14-1.module_f30+6995+c35e2138.x86_64                                                                                                                                         2/2 
  Verifying        : gimp-2:2.10.14-1.module_f30+6995+c35e2138.x86_64                                                                                                                                              1/2 
  Verifying        : gimp-libs-2:2.10.14-1.module_f30+6995+c35e2138.x86_64                                                                                                                                         2/2 

Removed:
  gimp-2:2.10.14-1.module_f30+6995+c35e2138.x86_64                                                        gimp-libs-2:2.10.14-1.module_f30+6995+c35e2138.x86_64                                                       

Complete!
# dnf system-upgrade download --releasever=31
Before you continue ensure that your system is fully upgraded by running "dnf --refresh upgrade". Do you want to continue [y/N]: y
Adobe Systems Incorporated                                                                                                                                                              43 kB/s | 2.9 kB     00:00    
Fedora Modular 31 - x86_64                                                                                                                                                              48 kB/s |  24 kB     00:00    
Fedora Modular 31 - x86_64 - Updates                                                                                                                                                    36 kB/s |  22 kB     00:00    
Fedora 31 - x86_64 - Updates                                                                                                                                                            38 kB/s |  18 kB     00:00    
Fedora 31 - x86_64                                                                                                                                                                      53 kB/s |  24 kB     00:00    
RPM Fusion for Fedora 31 - Free - Updates                                                                                                                                               19 kB/s | 9.3 kB     00:00    
RPM Fusion for Fedora 31 - Free                                                                                                                                                         67 kB/s |  10 kB     00:00    
RPM Fusion for Fedora 31 - Nonfree - Updates                                                                                                                                            83 kB/s | 9.4 kB     00:00    
RPM Fusion for Fedora 31 - Nonfree                                                                                                                                                      74 kB/s |  10 kB     00:00    
Sublime Text - x86_64 - Stable                                                                                                                                                         7.2 kB/s | 2.9 kB     00:00    
terminate called after throwing an instance of 'libdnf::ModulePackageContainer::EnableMultipleStreamsException'
  what():  Cannot enable multiple streams for module 'maven'
Aborted (core dumped)
# dnf list installed |grep maven

Ce qui est bizarre c'est que maven ne semble pas installe sur cette station ...

Bon il y egalement des problemes avec les import python sur cette station depuis l'upgrade (en fait je suis parti de fc27 si mes souvenirs sont bons). Je crois que suite a cette mise a jour c'est un peu le merdier dans la config ... Je vais deja regarder pour python et je regarderai ensuite pour les paquets geres par dnf. Toutes suggestions est bien sur bienvenue !

Hors ligne

#5 12/03/2020 13:21:08

econdami
Membre
Inscription : 28/01/2010
Messages : 584

Re : [Résolu] Mise a jour de fc30 a fc31: probleme avec la commande system-upgrade

Bon pour python ca semble maintenant regle.
Je suis moins a l'aise avec les paquets systeme, donc comme la station semble tourner correctement par ailleurs et qu'il y a d'autres urgences a gerer pas sur que j'investisse beaucoup de temps sur cette histoire tant qu'il n'y aura pas de gros probleme ...
Il y a un moyen de nettoyer la config pour dnf ? J'ai essaye d'installer maven pour voir et ca installe des paquets qui sont, j'ai l'impression, pour fc29 alors que cette station est maintenant en fc30 ...
Y a des trucs zarrbi sur cette station ..

# dnf install maven
Last metadata expiration check: 1:00:48 ago on Thu 12 Mar 2020 11:17:04 AM CET.
Dependencies resolved.
====================================================================================================================
 Package                                 Arch   Version                                       Repository       Size
====================================================================================================================
Installing:
 maven                                   noarch 1:3.5.4-5.module_f29+6921+ca3ed728            updates-modular  11 k
Installing dependencies:
 aopalliance                             noarch 1.0-17.module_f29+6921+ca3ed728               updates-modular  14 k
 apache-commons-cli                      noarch 1.4-4.module_f29+6921+ca3ed728                updates-modular  70 k
 apache-commons-codec                    noarch 1.11-3.module_f29+6921+ca3ed728               updates-modular 281 k
 apache-commons-io                       noarch 1:2.6-3.module_f29+6921+ca3ed728              updates-modular 219 k
 apache-commons-lang3                    noarch 3.7-3.module_f29+6921+ca3ed728                updates-modular 479 k
 apache-commons-logging                  noarch 1.2-13.module_f29+6921+ca3ed728               updates-modular  78 k
 atinject                                noarch 1-28.20100611svn86.module_f29+6921+ca3ed728   updates-modular  16 k
 cdi-api                                 noarch 1.2-8.1.module_f29+6921+ca3ed728              updates-modular  66 k
 geronimo-annotation                     noarch 1.0-23.module_f29+6921+ca3ed728               updates-modular  22 k
 google-guice                            noarch 4.1-11.module_f29+6921+ca3ed728               updates-modular 463 k
 guava20                                 noarch 20.0-8.module_f29+6921+ca3ed728               updates-modular 2.1 M
 httpcomponents-client                   noarch 4.5.5-4.module_f29+6921+ca3ed728              updates-modular 711 k
 httpcomponents-core                     noarch 4.4.10-3.module_f29+6921+ca3ed728             updates-modular 631 k
 jcl-over-slf4j                          noarch 1.7.25-4.module_f29+6921+ca3ed728             updates-modular  23 k
 jsoup                                   noarch 1.11.3-3.module_f29+6921+ca3ed728             updates-modular 382 k
 maven-lib                               noarch 1:3.5.4-5.module_f29+6921+ca3ed728            updates-modular 1.4 M
 maven-resolver-api                      noarch 1:1.1.1-2.module_f29+6921+ca3ed728            updates-modular 136 k
 maven-resolver-connector-basic          noarch 1:1.1.1-2.module_f29+6921+ca3ed728            updates-modular  49 k
 maven-resolver-impl                     noarch 1:1.1.1-2.module_f29+6921+ca3ed728            updates-modular 175 k
 maven-resolver-spi                      noarch 1:1.1.1-2.module_f29+6921+ca3ed728            updates-modular  38 k
 maven-resolver-transport-wagon          noarch 1:1.1.1-2.module_f29+6921+ca3ed728            updates-modular  37 k
 maven-resolver-util                     noarch 1:1.1.1-2.module_f29+6921+ca3ed728            updates-modular 146 k
 maven-shared-utils                      noarch 3.2.1-0.1.module_f29+6921+ca3ed728            updates-modular 161 k
 maven-wagon-file                        noarch 3.1.0-1.module_f29+6921+ca3ed728              updates-modular  19 k
 maven-wagon-http                        noarch 3.1.0-1.module_f29+6921+ca3ed728              updates-modular  20 k
 maven-wagon-http-shared                 noarch 3.1.0-1.module_f29+6921+ca3ed728              updates-modular  42 k
 maven-wagon-provider-api                noarch 3.1.0-1.module_f29+6921+ca3ed728              updates-modular  56 k
 plexus-cipher                           noarch 1.7-14.module_f29+6921+ca3ed728               updates-modular  25 k
 plexus-classworlds                      noarch 2.5.2-9.module_f29+6921+ca3ed728              updates-modular  59 k
 plexus-containers-component-annotations noarch 1.7.1-8.module_f29+6921+ca3ed728              updates-modular  17 k
 plexus-interpolation                    noarch 1.22-9.module_f29+6921+ca3ed728               updates-modular  75 k
 plexus-sec-dispatcher                   noarch 1.4-26.module_f29+6921+ca3ed728               updates-modular  33 k
 plexus-utils                            noarch 3.1.0-3.module_f29+6921+ca3ed728              updates-modular 253 k
 publicsuffix-list                       noarch 20190128-2.fc30                               fedora           77 k
 sisu-inject                             noarch 1:0.3.3-6.module_f29+6921+ca3ed728            updates-modular 331 k
 sisu-plexus                             noarch 1:0.3.3-6.module_f29+6921+ca3ed728            updates-modular 173 k
 slf4j                                   noarch 1.7.25-4.module_f29+6921+ca3ed728             updates-modular  68 k
Installing weak dependencies:
 java-1.8.0-openjdk-devel                x86_64 1:1.8.0.242.b08-0.fc30                        updates         9.7 M

Transaction Summary
====================================================================================================================
Install  39 Packages

Total download size: 18 M
Installed size: 52 M
Is this ok [y/N]: y
Downloading Packages:
(1/39): apache-commons-cli-1.4-4.module_f29+6921+ca3ed728.noarch.rpm                2.5 MB/s |  70 kB     00:00    
(2/39): aopalliance-1.0-17.module_f29+6921+ca3ed728.noarch.rpm                      425 kB/s |  14 kB     00:00    
(3/39): apache-commons-io-2.6-3.module_f29+6921+ca3ed728.noarch.rpm                 7.8 MB/s | 219 kB     00:00    
(4/39): apache-commons-codec-1.11-3.module_f29+6921+ca3ed728.noarch.rpm             4.7 MB/s | 281 kB     00:00    
(5/39): apache-commons-logging-1.2-13.module_f29+6921+ca3ed728.noarch.rpm            12 MB/s |  78 kB     00:00    
(6/39): atinject-1-28.20100611svn86.module_f29+6921+ca3ed728.noarch.rpm             1.3 MB/s |  16 kB     00:00    
(7/39): cdi-api-1.2-8.1.module_f29+6921+ca3ed728.noarch.rpm                         6.7 MB/s |  66 kB     00:00    
(8/39): geronimo-annotation-1.0-23.module_f29+6921+ca3ed728.noarch.rpm              2.3 MB/s |  22 kB     00:00    
(9/39): apache-commons-lang3-3.7-3.module_f29+6921+ca3ed728.noarch.rpm              5.5 MB/s | 479 kB     00:00    
(10/39): google-guice-4.1-11.module_f29+6921+ca3ed728.noarch.rpm                    8.9 MB/s | 463 kB     00:00    
(11/39): httpcomponents-core-4.4.10-3.module_f29+6921+ca3ed728.noarch.rpm            11 MB/s | 631 kB     00:00    
(12/39): guava20-20.0-8.module_f29+6921+ca3ed728.noarch.rpm                          19 MB/s | 2.1 MB     00:00    
(13/39): jcl-over-slf4j-1.7.25-4.module_f29+6921+ca3ed728.noarch.rpm                2.3 MB/s |  23 kB     00:00    
(14/39): maven-3.5.4-5.module_f29+6921+ca3ed728.noarch.rpm                          2.0 MB/s |  11 kB     00:00    
(15/39): httpcomponents-client-4.5.5-4.module_f29+6921+ca3ed728.noarch.rpm          7.6 MB/s | 711 kB     00:00    
(16/39): jsoup-1.11.3-3.module_f29+6921+ca3ed728.noarch.rpm                          10 MB/s | 382 kB     00:00    
(17/39): maven-resolver-api-1.1.1-2.module_f29+6921+ca3ed728.noarch.rpm             5.4 MB/s | 136 kB     00:00    
(18/39): maven-resolver-connector-basic-1.1.1-2.module_f29+6921+ca3ed728.noarch.rpm 5.0 MB/s |  49 kB     00:00    
(19/39): maven-resolver-spi-1.1.1-2.module_f29+6921+ca3ed728.noarch.rpm             3.0 MB/s |  38 kB     00:00    
(20/39): maven-resolver-impl-1.1.1-2.module_f29+6921+ca3ed728.noarch.rpm             12 MB/s | 175 kB     00:00    
(21/39): maven-resolver-transport-wagon-1.1.1-2.module_f29+6921+ca3ed728.noarch.rpm 5.9 MB/s |  37 kB     00:00    
(22/39): maven-lib-3.5.4-5.module_f29+6921+ca3ed728.noarch.rpm                       22 MB/s | 1.4 MB     00:00    
(23/39): maven-wagon-file-3.1.0-1.module_f29+6921+ca3ed728.noarch.rpm               3.5 MB/s |  19 kB     00:00    
(24/39): maven-shared-utils-3.2.1-0.1.module_f29+6921+ca3ed728.noarch.rpm            11 MB/s | 161 kB     00:00    
(25/39): maven-wagon-http-3.1.0-1.module_f29+6921+ca3ed728.noarch.rpm               3.3 MB/s |  20 kB     00:00    
(26/39): maven-wagon-http-shared-3.1.0-1.module_f29+6921+ca3ed728.noarch.rpm        7.0 MB/s |  42 kB     00:00    
(27/39): maven-resolver-util-1.1.1-2.module_f29+6921+ca3ed728.noarch.rpm            5.3 MB/s | 146 kB     00:00    
(28/39): maven-wagon-provider-api-3.1.0-1.module_f29+6921+ca3ed728.noarch.rpm       9.5 MB/s |  56 kB     00:00    
(29/39): plexus-cipher-1.7-14.module_f29+6921+ca3ed728.noarch.rpm                   4.4 MB/s |  25 kB     00:00    
(30/39): plexus-containers-component-annotations-1.7.1-8.module_f29+6921+ca3ed728.n 2.8 MB/s |  17 kB     00:00    
(31/39): plexus-classworlds-2.5.2-9.module_f29+6921+ca3ed728.noarch.rpm             5.9 MB/s |  59 kB     00:00    
(32/39): plexus-interpolation-1.22-9.module_f29+6921+ca3ed728.noarch.rpm            8.0 MB/s |  75 kB     00:00    
(33/39): plexus-sec-dispatcher-1.4-26.module_f29+6921+ca3ed728.noarch.rpm           5.6 MB/s |  33 kB     00:00    
(34/39): sisu-plexus-0.3.3-6.module_f29+6921+ca3ed728.noarch.rpm                    9.7 MB/s | 173 kB     00:00    
(35/39): sisu-inject-0.3.3-6.module_f29+6921+ca3ed728.noarch.rpm                     16 MB/s | 331 kB     00:00    
(36/39): slf4j-1.7.25-4.module_f29+6921+ca3ed728.noarch.rpm                          11 MB/s |  68 kB     00:00    
(37/39): plexus-utils-3.1.0-3.module_f29+6921+ca3ed728.noarch.rpm                   6.9 MB/s | 253 kB     00:00    
(38/39): publicsuffix-list-20190128-2.fc30.noarch.rpm                               848 kB/s |  77 kB     00:00    
(39/39): java-1.8.0-openjdk-devel-1.8.0.242.b08-0.fc30.x86_64.rpm                    35 MB/s | 9.7 MB     00:00    
--------------------------------------------------------------------------------------------------------------------
Total                                                                                12 MB/s |  18 MB     00:01     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                                            1/1 
  Installing       : plexus-utils-3.1.0-3.module_f29+6921+ca3ed728.noarch                                      1/39 
  Installing       : maven-resolver-api-1:1.1.1-2.module_f29+6921+ca3ed728.noarch                              2/39 
  Installing       : maven-wagon-provider-api-3.1.0-1.module_f29+6921+ca3ed728.noarch                          3/39 
  Installing       : maven-resolver-spi-1:1.1.1-2.module_f29+6921+ca3ed728.noarch                              4/39 
  Installing       : maven-resolver-util-1:1.1.1-2.module_f29+6921+ca3ed728.noarch                             5/39 
  Installing       : slf4j-1.7.25-4.module_f29+6921+ca3ed728.noarch                                            6/39 
  Installing       : httpcomponents-core-4.4.10-3.module_f29+6921+ca3ed728.noarch                              7/39 
  Installing       : atinject-1-28.20100611svn86.module_f29+6921+ca3ed728.noarch                               8/39 
  Installing       : plexus-containers-component-annotations-1.7.1-8.module_f29+6921+ca3ed728.noarch           9/39 
  Installing       : plexus-classworlds-2.5.2-9.module_f29+6921+ca3ed728.noarch                               10/39 
  Installing       : plexus-cipher-1.7-14.module_f29+6921+ca3ed728.noarch                                     11/39 
  Installing       : guava20-20.0-8.module_f29+6921+ca3ed728.noarch                                           12/39 
  Installing       : apache-commons-io-1:2.6-3.module_f29+6921+ca3ed728.noarch                                13/39 
  Installing       : maven-shared-utils-3.2.1-0.1.module_f29+6921+ca3ed728.noarch                             14/39 
  Installing       : plexus-sec-dispatcher-1.4-26.module_f29+6921+ca3ed728.noarch                             15/39 
  Installing       : cdi-api-1.2-8.1.module_f29+6921+ca3ed728.noarch                                          16/39 
  Installing       : sisu-inject-1:0.3.3-6.module_f29+6921+ca3ed728.noarch                                    17/39 
  Installing       : sisu-plexus-1:0.3.3-6.module_f29+6921+ca3ed728.noarch                                    18/39 
  Installing       : jcl-over-slf4j-1.7.25-4.module_f29+6921+ca3ed728.noarch                                  19/39 
  Installing       : maven-resolver-impl-1:1.1.1-2.module_f29+6921+ca3ed728.noarch                            20/39 
  Installing       : plexus-interpolation-1.22-9.module_f29+6921+ca3ed728.noarch                              21/39 
  Installing       : geronimo-annotation-1.0-23.module_f29+6921+ca3ed728.noarch                               22/39 
  Installing       : apache-commons-logging-1.2-13.module_f29+6921+ca3ed728.noarch                            23/39 
  Installing       : apache-commons-lang3-3.7-3.module_f29+6921+ca3ed728.noarch                               24/39 
  Installing       : apache-commons-codec-1.11-3.module_f29+6921+ca3ed728.noarch                              25/39 
  Installing       : apache-commons-cli-1.4-4.module_f29+6921+ca3ed728.noarch                                 26/39 
  Installing       : aopalliance-1.0-17.module_f29+6921+ca3ed728.noarch                                       27/39 
  Installing       : google-guice-4.1-11.module_f29+6921+ca3ed728.noarch                                      28/39 
  Installing       : maven-lib-1:3.5.4-5.module_f29+6921+ca3ed728.noarch                                      29/39 
  Installing       : maven-resolver-connector-basic-1:1.1.1-2.module_f29+6921+ca3ed728.noarch                 30/39 
  Installing       : maven-resolver-transport-wagon-1:1.1.1-2.module_f29+6921+ca3ed728.noarch                 31/39 
  Installing       : maven-wagon-file-3.1.0-1.module_f29+6921+ca3ed728.noarch                                 32/39 
  Installing       : publicsuffix-list-20190128-2.fc30.noarch                                                 33/39 
  Installing       : httpcomponents-client-4.5.5-4.module_f29+6921+ca3ed728.noarch                            34/39 
  Installing       : java-1.8.0-openjdk-devel-1:1.8.0.242.b08-0.fc30.x86_64                                   35/39 
  Running scriptlet: java-1.8.0-openjdk-devel-1:1.8.0.242.b08-0.fc30.x86_64                                   35/39 
  Installing       : jsoup-1.11.3-3.module_f29+6921+ca3ed728.noarch                                           36/39 
  Installing       : maven-wagon-http-shared-3.1.0-1.module_f29+6921+ca3ed728.noarch                          37/39 
  Installing       : maven-wagon-http-3.1.0-1.module_f29+6921+ca3ed728.noarch                                 38/39 
  Installing       : maven-1:3.5.4-5.module_f29+6921+ca3ed728.noarch                                          39/39 
  Running scriptlet: maven-1:3.5.4-5.module_f29+6921+ca3ed728.noarch                                          39/39 
  Running scriptlet: java-1.8.0-openjdk-devel-1:1.8.0.242.b08-0.fc30.x86_64                                   39/39 
  Running scriptlet: maven-1:3.5.4-5.module_f29+6921+ca3ed728.noarch                                          39/39 
  Verifying        : aopalliance-1.0-17.module_f29+6921+ca3ed728.noarch                                        1/39 
  Verifying        : apache-commons-cli-1.4-4.module_f29+6921+ca3ed728.noarch                                  2/39 
  Verifying        : apache-commons-codec-1.11-3.module_f29+6921+ca3ed728.noarch                               3/39 
  Verifying        : apache-commons-io-1:2.6-3.module_f29+6921+ca3ed728.noarch                                 4/39 
  Verifying        : apache-commons-lang3-3.7-3.module_f29+6921+ca3ed728.noarch                                5/39 
  Verifying        : apache-commons-logging-1.2-13.module_f29+6921+ca3ed728.noarch                             6/39 
  Verifying        : atinject-1-28.20100611svn86.module_f29+6921+ca3ed728.noarch                               7/39 
  Verifying        : cdi-api-1.2-8.1.module_f29+6921+ca3ed728.noarch                                           8/39 
  Verifying        : geronimo-annotation-1.0-23.module_f29+6921+ca3ed728.noarch                                9/39 
  Verifying        : google-guice-4.1-11.module_f29+6921+ca3ed728.noarch                                      10/39 
  Verifying        : guava20-20.0-8.module_f29+6921+ca3ed728.noarch                                           11/39 
  Verifying        : httpcomponents-client-4.5.5-4.module_f29+6921+ca3ed728.noarch                            12/39 
  Verifying        : httpcomponents-core-4.4.10-3.module_f29+6921+ca3ed728.noarch                             13/39 
  Verifying        : jcl-over-slf4j-1.7.25-4.module_f29+6921+ca3ed728.noarch                                  14/39 
  Verifying        : jsoup-1.11.3-3.module_f29+6921+ca3ed728.noarch                                           15/39 
  Verifying        : maven-1:3.5.4-5.module_f29+6921+ca3ed728.noarch                                          16/39 
  Verifying        : maven-lib-1:3.5.4-5.module_f29+6921+ca3ed728.noarch                                      17/39 
  Verifying        : maven-resolver-api-1:1.1.1-2.module_f29+6921+ca3ed728.noarch                             18/39 
  Verifying        : maven-resolver-connector-basic-1:1.1.1-2.module_f29+6921+ca3ed728.noarch                 19/39 
  Verifying        : maven-resolver-impl-1:1.1.1-2.module_f29+6921+ca3ed728.noarch                            20/39 
  Verifying        : maven-resolver-spi-1:1.1.1-2.module_f29+6921+ca3ed728.noarch                             21/39 
  Verifying        : maven-resolver-transport-wagon-1:1.1.1-2.module_f29+6921+ca3ed728.noarch                 22/39 
  Verifying        : maven-resolver-util-1:1.1.1-2.module_f29+6921+ca3ed728.noarch                            23/39 
  Verifying        : maven-shared-utils-3.2.1-0.1.module_f29+6921+ca3ed728.noarch                             24/39 
  Verifying        : maven-wagon-file-3.1.0-1.module_f29+6921+ca3ed728.noarch                                 25/39 
  Verifying        : maven-wagon-http-3.1.0-1.module_f29+6921+ca3ed728.noarch                                 26/39 
  Verifying        : maven-wagon-http-shared-3.1.0-1.module_f29+6921+ca3ed728.noarch                          27/39 
  Verifying        : maven-wagon-provider-api-3.1.0-1.module_f29+6921+ca3ed728.noarch                         28/39 
  Verifying        : plexus-cipher-1.7-14.module_f29+6921+ca3ed728.noarch                                     29/39 
  Verifying        : plexus-classworlds-2.5.2-9.module_f29+6921+ca3ed728.noarch                               30/39 
  Verifying        : plexus-containers-component-annotations-1.7.1-8.module_f29+6921+ca3ed728.noarch          31/39 
  Verifying        : plexus-interpolation-1.22-9.module_f29+6921+ca3ed728.noarch                              32/39 
  Verifying        : plexus-sec-dispatcher-1.4-26.module_f29+6921+ca3ed728.noarch                             33/39 
  Verifying        : plexus-utils-3.1.0-3.module_f29+6921+ca3ed728.noarch                                     34/39 
  Verifying        : sisu-inject-1:0.3.3-6.module_f29+6921+ca3ed728.noarch                                    35/39 
  Verifying        : sisu-plexus-1:0.3.3-6.module_f29+6921+ca3ed728.noarch                                    36/39 
  Verifying        : slf4j-1.7.25-4.module_f29+6921+ca3ed728.noarch                                           37/39 
  Verifying        : java-1.8.0-openjdk-devel-1:1.8.0.242.b08-0.fc30.x86_64                                   38/39 
  Verifying        : publicsuffix-list-20190128-2.fc30.noarch                                                 39/39 

Installed:
  aopalliance-1.0-17.module_f29+6921+ca3ed728.noarch                                                                
  apache-commons-cli-1.4-4.module_f29+6921+ca3ed728.noarch                                                          
  apache-commons-codec-1.11-3.module_f29+6921+ca3ed728.noarch                                                       
  apache-commons-io-1:2.6-3.module_f29+6921+ca3ed728.noarch                                                         
  apache-commons-lang3-3.7-3.module_f29+6921+ca3ed728.noarch                                                        
  apache-commons-logging-1.2-13.module_f29+6921+ca3ed728.noarch                                                     
  atinject-1-28.20100611svn86.module_f29+6921+ca3ed728.noarch                                                       
  cdi-api-1.2-8.1.module_f29+6921+ca3ed728.noarch                                                                   
  geronimo-annotation-1.0-23.module_f29+6921+ca3ed728.noarch                                                        
  google-guice-4.1-11.module_f29+6921+ca3ed728.noarch                                                               
  guava20-20.0-8.module_f29+6921+ca3ed728.noarch                                                                    
  httpcomponents-client-4.5.5-4.module_f29+6921+ca3ed728.noarch                                                     
  httpcomponents-core-4.4.10-3.module_f29+6921+ca3ed728.noarch                                                      
  java-1.8.0-openjdk-devel-1:1.8.0.242.b08-0.fc30.x86_64                                                            
  jcl-over-slf4j-1.7.25-4.module_f29+6921+ca3ed728.noarch                                                           
  jsoup-1.11.3-3.module_f29+6921+ca3ed728.noarch                                                                    
  maven-1:3.5.4-5.module_f29+6921+ca3ed728.noarch                                                                   
  maven-lib-1:3.5.4-5.module_f29+6921+ca3ed728.noarch                                                               
  maven-resolver-api-1:1.1.1-2.module_f29+6921+ca3ed728.noarch                                                      
  maven-resolver-connector-basic-1:1.1.1-2.module_f29+6921+ca3ed728.noarch                                          
  maven-resolver-impl-1:1.1.1-2.module_f29+6921+ca3ed728.noarch                                                     
  maven-resolver-spi-1:1.1.1-2.module_f29+6921+ca3ed728.noarch                                                      
  maven-resolver-transport-wagon-1:1.1.1-2.module_f29+6921+ca3ed728.noarch                                          
  maven-resolver-util-1:1.1.1-2.module_f29+6921+ca3ed728.noarch                                                     
  maven-shared-utils-3.2.1-0.1.module_f29+6921+ca3ed728.noarch                                                      
  maven-wagon-file-3.1.0-1.module_f29+6921+ca3ed728.noarch                                                          
  maven-wagon-http-3.1.0-1.module_f29+6921+ca3ed728.noarch                                                          
  maven-wagon-http-shared-3.1.0-1.module_f29+6921+ca3ed728.noarch                                                   
  maven-wagon-provider-api-3.1.0-1.module_f29+6921+ca3ed728.noarch                                                  
  plexus-cipher-1.7-14.module_f29+6921+ca3ed728.noarch                                                              
  plexus-classworlds-2.5.2-9.module_f29+6921+ca3ed728.noarch                                                        
  plexus-containers-component-annotations-1.7.1-8.module_f29+6921+ca3ed728.noarch                                   
  plexus-interpolation-1.22-9.module_f29+6921+ca3ed728.noarch                                                       
  plexus-sec-dispatcher-1.4-26.module_f29+6921+ca3ed728.noarch                                                      
  plexus-utils-3.1.0-3.module_f29+6921+ca3ed728.noarch                                                              
  publicsuffix-list-20190128-2.fc30.noarch                                                                          
  sisu-inject-1:0.3.3-6.module_f29+6921+ca3ed728.noarch                                                             
  sisu-plexus-1:0.3.3-6.module_f29+6921+ca3ed728.noarch                                                             
  slf4j-1.7.25-4.module_f29+6921+ca3ed728.noarch                                                                    

Complete!

Hors ligne

#6 12/03/2020 14:50:51

econdami
Membre
Inscription : 28/01/2010
Messages : 584

Re : [Résolu] Mise a jour de fc30 a fc31: probleme avec la commande system-upgrade

vraiment zarbi:

# cat /etc/redhat-release
Fedora release 30 (Thirty)
# dnf list installed | grep lm-sensors
Modular dependency problem:

 Problem: conflicting requests
  - nothing provides module(platform:f31) needed by module gimp:2.10:3120191106095052:f636be4b-0.x86_64

Hors ligne

#7 12/03/2020 15:25:26

econdami
Membre
Inscription : 28/01/2010
Messages : 584

Re : [Résolu] Mise a jour de fc30 a fc31: probleme avec la commande system-upgrade

Bon, j'ai pas eu le temps de tout lire et comprendre mais il semble qu'il y a un probleme sur cette station avec les modules, pour (seulement Ouf !) gimp et maven.
J'ai donc fait:

# dnf module reset gimp
Last metadata expiration check: 0:04:17 ago on Thu 12 Mar 2020 02:12:36 PM CET.
Dependencies resolved.
========================================================================================================================================================================================
 Package                                     Architecture                               Version                                       Repository                                   Size
========================================================================================================================================================================================
Resetting modules:
 gimp                                                                                                                                                                                  

Transaction Summary
========================================================================================================================================================================================

Is this ok [y/N]: y
Complete!
# dnf module reset maven
Last metadata expiration check: 0:05:48 ago on Thu 12 Mar 2020 02:12:36 PM CET.
Dependencies resolved.
========================================================================================================================================================================================
 Package                                     Architecture                               Version                                       Repository                                   Size
========================================================================================================================================================================================
Resetting modules:
 maven                                                                                                                                                                                 

Transaction Summary
========================================================================================================================================================================================

Is this ok [y/N]: y
Complete!

et maintenant

dnf system-upgrade download --refresh --releasever=31

semble marcher !
je lance le truc et je reviens au rapport !

Dernière modification par econdami (12/03/2020 15:26:34)

Hors ligne

#8 12/03/2020 16:52:56

econdami
Membre
Inscription : 28/01/2010
Messages : 584

Re : [Résolu] Mise a jour de fc30 a fc31: probleme avec la commande system-upgrade

ca y est je suis sous f31 !
sujet resolu !

Hors ligne

#9 13/03/2020 01:19:12

Nednet
Membre
Lieu : aux alentours de Toulouse
Inscription : 07/12/2015
Messages : 855

Re : [Résolu] Mise a jour de fc30 a fc31: probleme avec la commande system-upgrade

ravi pour toi et merci pour ces retours


Il n'y a aucune honte à ne pas savoir
mais beaucoup à ne pas apprendre

Hors ligne

Pied de page des forums