Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora 30 est mort ce soir

#1 12/01/2020 15:54:14

ghiom
Membre
Inscription : 12/01/2020
Messages : 11

[Résolu] ecran noir après installation akmod-nvidia

Bonjour Hier j'ai installé et mis à jour Fedora.
Dans mon boot , j'avais fedora 5.3 que je lance ce matin, tout vas pas trop mal.
Sauf que meme avec Akmod mon driver de GPU reste nouveau au lieu de nvidia. ( j'ai 2 1080 et une 2080 )
Donc ce matin au lancement de fedora, en dessous de l'heure j'ai un message, mise a jour importante, redemarrer et installer, je dit OUI

l'installation de cette mise a jours semble bien fonctionner, sauf que maintenant au boot, si je choisi fedora5.4 j'ai un ecran noir au lieu de l'ecran de login.
Si je choisi 5.3 j'ai l'ecran de login mais des message d'erreur sur un fichier boot et toujours le driver Nouveau au lieu de Nvida que j'ai installé en suivant les procédure Akmod.
quand je reessaye akmod, le terminal me dit que tout est déjà bien installé.

Je suis un gros débutant en linux ( 1 petite journée seulement ) alors que j'ai plus de 25ans d'experience windows. Sans aide pour débuter je n'y arriverai certainement pas :/

A l'aide ... :)

Dernière modification par ghiom (13/01/2020 12:45:29)

Hors ligne

#2 12/01/2020 16:10:26

madko
Contributeur Fedora et Linuxé depuis 1994
Modérateur
Lieu : Noisy the Great (9³)
Inscription : 22/12/2006
Messages : 8 458
Site Web

Re : [Résolu] ecran noir après installation akmod-nvidia

Bonjour,

me semble que nvidia et kernel 5.4 ont déjà été évoqué sur le forum. Mais j'en sais pas plus. As tu fais une recherche sur le forum avant de poser ta question ?


Linux, ya moins bien, mais c'est plus chèr!!!
Fedora 32 WorkStation sur HP 850 G5
Fedora 32 SilverBlue sur Lenovo Thinkpad Yoga 12

Hors ligne

#3 12/01/2020 16:17:20

ghiom
Membre
Inscription : 12/01/2020
Messages : 11

Re : [Résolu] ecran noir après installation akmod-nvidia

madko a écrit :

Bonjour,

me semble que nvidia et kernel 5.4 ont déjà été évoqué sur le forum. Mais j'en sais pas plus. As tu fais une recherche sur le forum avant de poser ta question ?

++


Bonjour Madkp, merci de me venir en aide, comme je l'ai dit je suis un très gros débutant linux. Je n'ai pas fais la recherche avec kernel car je n'en ai aucune notion. j'ai cherché nvidia ecran noir, mais ça me donne trop d'entrées et de pistes différentes. Le peu de connaissance que j'ai actuellement ne m'a pas permis de faire le trie.

Hors ligne

#4 12/01/2020 16:23:21

madko
Contributeur Fedora et Linuxé depuis 1994
Modérateur
Lieu : Noisy the Great (9³)
Inscription : 22/12/2006
Messages : 8 458
Site Web

Re : [Résolu] ecran noir après installation akmod-nvidia

Et oui les joies d'avoir des pilotes proprio. Je pense avoir trouvé le sujet en question https://forums.fedora-fr.org/viewtopic.php?id=69950&p=2

Tu arrives quand même à te connecter en texte pour taper des commandes ? L'idée serait de lancer la commande pour construire les pilotes via akmod


Linux, ya moins bien, mais c'est plus chèr!!!
Fedora 32 WorkStation sur HP 850 G5
Fedora 32 SilverBlue sur Lenovo Thinkpad Yoga 12

Hors ligne

#5 12/01/2020 16:28:53

ghiom
Membre
Inscription : 12/01/2020
Messages : 11

Re : [Résolu] ecran noir après installation akmod-nvidia

Je n'ai accé a rien si je selectionne 5.4 au démarrage, du coup je demarre avec 5.3 et j'ai des messages d'erreur du type :
le systeme a rzncotré une erreur et n'a pas pu la reparer , Nom Kernel-core version 5.4.8
et un autre identique mais avec en plus ABRT server

Hors ligne

#6 13/01/2020 12:39:59

ghiom
Membre
Inscription : 12/01/2020
Messages : 11

Re : [Résolu] ecran noir après installation akmod-nvidia

Aujourd'hui j'ai tout recommencé à 0

Boot sur USB, installation de fedora en supprimant tout ce qu'il y avait avant
redemarrage ( en 5.3 )
Updates de fedora
redemarage ( en 5.4 )
installation des rpm fusion
redemarage ( en 5.4 )
installation akmod-nvidia
redémarage  ( en 5.4 )
ecran noir ...

on m' a suggéré de faire ctrl+ALT+F1 jusque F6 de manière à tenter d'ouvrir un terminal, mais sans succé, les ecrans sont éteint.

Hors ligne

#7 13/01/2020 13:58:12

ghiom
Membre
Inscription : 12/01/2020
Messages : 11

Re : [Résolu] ecran noir après installation akmod-nvidia

J'essaye d'installer le driver dans la 5.3 mais au redemarage il me dit que le kernel de nvidia n'est pas là et qu'il repasse en NOUVEAU

J'ai un démarrage en UEFI que je ne peux pas désactivé, sinon mon boot sous W10 qui m'est nécessaire ne fonctionnera plus.

Hors ligne

#8 13/01/2020 14:08:07

madko
Contributeur Fedora et Linuxé depuis 1994
Modérateur
Lieu : Noisy the Great (9³)
Inscription : 22/12/2006
Messages : 8 458
Site Web

Re : [Résolu] ecran noir après installation akmod-nvidia

A priori que ça ne marche pas en 5.4 c'est connu, mais ça devrait aller en 5.3 tout de même. L'UEFI ne gêne pas, sauf si tu as secure boot d'activé, car me semble qu'il peut bloquer le chargement de pilotes propriétaires car non signés. Tu as secure boot ?


Linux, ya moins bien, mais c'est plus chèr!!!
Fedora 32 WorkStation sur HP 850 G5
Fedora 32 SilverBlue sur Lenovo Thinkpad Yoga 12

Hors ligne

#9 13/01/2020 14:20:26

ghiom
Membre
Inscription : 12/01/2020
Messages : 11

Re : [Résolu] ecran noir après installation akmod-nvidia

madko a écrit :

A priori que ça ne marche pas en 5.4 c'est connu, mais ça devrait aller en 5.3 tout de même. L'UEFI ne gêne pas, sauf si tu as secure boot d'activé, car me semble qu'il peut bloquer le chargement de pilotes propriétaires car non signés. Tu as secure boot ?

oui j'ai secure uefi , je l'ai désactivé, mais mon ordi ne trouve plus de bootable.

Hors ligne

#10 13/01/2020 14:55:15

madko
Contributeur Fedora et Linuxé depuis 1994
Modérateur
Lieu : Noisy the Great (9³)
Inscription : 22/12/2006
Messages : 8 458
Site Web

Re : [Résolu] ecran noir après installation akmod-nvidia

euh je vois pas pourquoi ça l'empecherait de trouver un boot, à moins que ça n'ai rien a voir avec "secure boot"
C'est quoi comme portable ?


Linux, ya moins bien, mais c'est plus chèr!!!
Fedora 32 WorkStation sur HP 850 G5
Fedora 32 SilverBlue sur Lenovo Thinkpad Yoga 12

Hors ligne

#11 13/01/2020 14:58:57

ghiom
Membre
Inscription : 12/01/2020
Messages : 11

Re : [Résolu] ecran noir après installation akmod-nvidia

un Vortex VIII de chez pcspecialist.. en gros c'est une portable d'assembleur ou tu choisi tes composants comme une tour, à base de matériel CLEVO ( chinois )
un i7 8700k , 64go RAM , ecrans 17" 4K , Dual 1080, 4,5 To de SSD dont 2To en Nvme j'y ajoute un Razor 2 avec une 2080 en thunderbolt.

Hors ligne

#12 13/01/2020 16:37:29

madko
Contributeur Fedora et Linuxé depuis 1994
Modérateur
Lieu : Noisy the Great (9³)
Inscription : 22/12/2006
Messages : 8 458
Site Web

Re : [Résolu] ecran noir après installation akmod-nvidia

J'ai recherché clevo, est-ce que ton bios ressemble à celui là http://gja.frndz.pagesperso-orange.fr/u … levo01.htm ? Car là y'a bien secure boot (qui est peut être différente de ton option secure uefi)


Linux, ya moins bien, mais c'est plus chèr!!!
Fedora 32 WorkStation sur HP 850 G5
Fedora 32 SilverBlue sur Lenovo Thinkpad Yoga 12

Hors ligne

#13 13/01/2020 16:42:38

ghiom
Membre
Inscription : 12/01/2020
Messages : 11

Re : [Résolu] ecran noir après installation akmod-nvidia

madko a écrit :

J'ai recherché clevo, est-ce que ton bios ressemble à celui là http://gja.frndz.pagesperso-orange.fr/u … levo01.htm ? Car là y'a bien secure boot (qui est peut être différente de ton option secure uefi)

ce secure boot est bien sur disabled.

Hors ligne

#14 14/01/2020 15:53:08

ghiom
Membre
Inscription : 12/01/2020
Messages : 11

Re : [Résolu] ecran noir après installation akmod-nvidia

Avec l'aide de connaissances , j'ai suivi une nouvelle procédure sur une nouvelle installation toute propre.

Installer fedora ( 5.3 )
sudo dnf update > 5.4
demarrage 5.4

puis
download du fichier nvidia-linux-x86_64-440.44.run et copie dans home
Terminal : sudo chmod a+rw NVIDIA-Linux-x86_64-440.44.run
CTRL+ALT+F3
terminal : login en root
terminal : systemctl isolate multi-user.target
terminal : login a nouveau en root
terminal : modprobe -r nvidia-drm , il ne trouve rien normal puisque je n'ai pas encore installé nvidia
terminal : sudo sh ./home/user/NVIDIA-Linux-x86_64-440.44.run

là il lance l'installation mais me dit que nouveau est charé et qu'il faut le bypass ou un truc dans le genre ( j'ai du mal à lire, c'est ecrit vraiment très petit , ecran de plus de 4K en 17" .... ) donc il me propose de modifier un fichier pour ajouter une commande pour interdire nouveau si je comprend bien je dit ok, il me demande de redémarrer.

je redémarre et je relance l'nstallation dans un terminal
sudo sh /NVIDIA-Linux-x86_64-440.44.run
ERROR : you appear running an x server ...

a nouveau CTRL+ALT+F3
login en root
systemctl isolate multi-user.target
login en root
cd /home/user
sudo sh ./Nvidia ..run
Error : le driver NOUVEAU est en cours d'utilisation et n'es pas compatible il faut le desactiver, vérifier d'avoir redémarré etc..

j'essaye ensuite une procédure lu ici https://www.if-not-true-then-false.com/ … dia-guide/
j'installe tout ce qui est demandé : dnf install kernel-devel kernel-headers gcc make dkms acpid libglvnd-glx libglvnd-opengl libglvnd-devel pkgconfig
ensuite echo "blacklist nouveau" >> /etc/modprobe.d/blacklist.conf
jusque là tout va bien
ensuite je dois ajouter du texte à la fin d'une ligne dans le fichier grub, mais je n'arrive pas à enregistrer celui ci .

donc je bloque là : Append ‘rd.driver.blacklist=nouveau’ to end of ‘GRUB_CMDLINE_LINUX=”…”‘.

## Example row ##
GRUB_CMDLINE_LINUX="rd.lvm.lv=fedora/swap rd.lvm.lv=fedora/root rhgb quiet rd.driver.blacklist=nouveau"

Dernière modification par ghiom (14/01/2020 16:19:34)

Hors ligne

#15 14/01/2020 16:45:05

ghiom
Membre
Inscription : 12/01/2020
Messages : 11

Re : [Résolu] ecran noir après installation akmod-nvidia

Je me suis dit que puisque j'avais installé tout un paquet de truc kernel .. ( dnf install kernel-devel kernel-headers gcc make dkms acpid libglvnd-glx libglvnd-opengl libglvnd-devel pkgconfig ) peut etre que je pourrais essayer à nouveau d'installer akmod-nvidia.

donc j'install les rpm fusion puis je lance la procédure d'installation akmod-nvidia.
je redémarre , je m'attend à un ecran noir comme à chaque fois que j'utilise akmod sous le kernel 5.4
ET non !!
cette fois j'ai le meme message qu'en 5.3 , module kernel nvidia is missing, back to nouveau ..
j'ai meme doit à une petite nouveauté, mon ecran n'est plus en size 200% , me permettant de le lire , mais en 100% ce qui le rend très douloureux pour moi . . j'arrive à le remettre en 200% , les texte sont lisibles, mais je n'ai toujours pas mes drivers de carte 3D...
c'est plutot embettant pour un pc de 3D et FX ..

est-ce que touts ces infos vous aides à comprendre ce que je fais de mal ?

Hors ligne

#16 14/01/2020 17:23:42

ghiom
Membre
Inscription : 12/01/2020
Messages : 11

Re : [Résolu] ecran noir après installation akmod-nvidia

YOU WIN !!! enfin moi je win pour le coup :)

j'ai trouvé une solution, j'ai enfin le panneau nvidia qui s'ouvre , donc je pense que le driver est opérationnel.

j'ai lu plein de truc sur le net et notemment qu'il existait un lib de driver negativo
je me suis remis en root ctrl-alt-F3 ..
j'ai donc installé ça dnf config-manager --add-repo=https://negativo17.org/repos/fedora-nvidia.repo
puis j'ai efface tout ce que j'avais installé de nvidia jusque là avec cette commande : yum -y remove *nvidia*
puis j'ai installé le driver : dnf -y install nvidia-driver nvidia-settings
un shutdown now
appui sur le bouton power
ça demarre, je sert les doigts, croise les fesses
fedora ecrit en petit, noir, encore ecrit en petit, normalement il passe ensuite en gros et là .. bamm !! l'ecran de login
of je file sur l'utilitaire nvidia je le lance et Hop le voilà pour la premiere fois !!

donc RPMFusion > à marche pas chez moi
le drivers nvidia de chez nvidia > idem
le negativo17 > yu win .. ok cool mais je sais pas pourquoi.

Question : est-ce suffisant pour mes softs 3D et compo ? ou dois je ajouter CUDA à part pour profiter des perfs de rendus 3D en rendu GPU CUDA, simulation OPENCL CUDA libré tout ça ?

Hors ligne

Pied de page des forums