Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora 29 tire sa révérence

#1 23/11/2019 18:33:59

Yurelovna
Membre
Inscription : 21/11/2019
Messages : 7

Problème ouverture War Thunder Steam

Bonjour,

Je me tourne vers vous car je viens de faire l'installation de War Thunder depuis Steam mais impossible de le lancer.
Lorsque je lance le jeu, j'ai une fenêtre "Settings" qui s'ouvre et se ferme directement puis rien ne se passe.
J'ai aussi fait un test en lançant le jeux directement depuis le launcher dans le dossier Steam et là, la fenêtre "Settings" s'ouvre aussi et reste présente mais toujours le même problème (rien ne se passe).

J'ai fait quelques recherche sur Internet mais je ne trouve rien qui corrige mon problème.

Je ne vous cache pas que je suis pas très à l'aise avec Linux pour le moment je viens de débuter.
Pourriez-vous m'indiquer les informations dont vous avez besoin afin de m'aider à diagnostiquer / corriger mon problème ?

Merci d'avance big_smile

Hors ligne

#2 23/11/2019 18:52:41

Refuznik
Membre
Inscription : 31/01/2007
Messages : 7 431

Re : Problème ouverture War Thunder Steam

Salut, alors première chose as tu la configuration nécessaire pour faire tourner war thunder ?
Quels carte graphique as tu ? Bref, nous donnez la configuration peu quant même aider.
Dernière chose à savoir sous linux, les drivers libres des cartes graphiques installé par défaut font bien le job mais pour le jeux franchement, je préconise d'installer les drivers proprio. et de tourner sous xorg.

Hors ligne

#3 23/11/2019 19:15:18

Yurelovna
Membre
Inscription : 21/11/2019
Messages : 7

Re : Problème ouverture War Thunder Steam

Au niveau de la config, je tourne sur un PC portable avec une GTX950M pour la RAM j'ai 8Go. Je sais que le jeu tourne sans problème avec la config car quand j'étais sous Win10 je ne rencontré aucun problème pour le faire tourner.

Pour info je viens de faire un test sur CSGO, je ne rencontre pas trop de soucis.

En ce qui concerne les drivers, j'ai suivis une installation sur internet et au final j'ai donc entrée uniquement la commande suivante :

dnf install xorg-x11-drv-nvidia akmod-nvidia

Car si j'ai bien compris je dispose d'une CG avec la technologie Optimus qui permet de switch automatiquement entre le chipset et la CG.

Hors ligne

#4 23/11/2019 20:11:13

Refuznik
Membre
Inscription : 31/01/2007
Messages : 7 431

Re : Problème ouverture War Thunder Steam

Alors tu peux compléter en installant le paquet suivant :

dnf install xorg-x11-drv-nvidia-libs kernel-devel kernel-headers gcc dkms acpid

As tu vérifier si le driver libre Nouveau est bien désactivé avec la commande :

lsmod | grep nouveau

Dernière chose utilise xorg au lieu de wayland, tu peux le sélectionner au démarrage de ta session lors de rentrer ton mot de passe tu as une petit roue crantée et tu choisis le bureau gnome xorg.

Hors ligne

#5 23/11/2019 23:30:43

Yurelovna
Membre
Inscription : 21/11/2019
Messages : 7

Re : Problème ouverture War Thunder Steam

Le problème est toujours présent même en complétant l'installation des paquets manquant.

Par contre, en voulant passé sur xorg, je me suis aperçu qu'il n'était plus présent dans la liste.
Sur le forum j'ai donc trouvé une info qui disait qu'il fallait supprimer les pilotes graphique prioritaire et renommer le fichier xorg.conf.old afin de pouvoir switch de wayland vers xorg.
J'ai donc désinstallé le pilote prioritaire mais le fichier xorg.conf n'était pas présent dans /etc/ X11/.

Bref, comme j'avais aussi un petit problème au démarrage j'ai tout repris à zéro (fresh install)
En utilisant le pilote libre nouveau et Wayland pour la technologie Optimus qu'il gère de façon native (d'après ce que j'ai compris) avec Prime.

Réinstallation de War Thunder, problème identique. J'ai donc fait de nouveau un test sur CS GO tout en vérifiant que la carte dédiée était bien fonctionnelle.

D'après ce que je comprend en faisant la commande suivante :

# cat /sys/kernel/debug/vgaswitcheroo/switch

La commande me retourne :

0:IGD:+:Pwr:0000:00:02.0
1:DIS: :DynPwr:0000:01:00.0
2:DIS-Audio: :DynOff:0000:01:00.1

Donc si je comprends bien la carte dédiée (GTX950M) et bien en fonction.
D'ailleurs pas de problèmes notable sur le jeu (CS GO).

Je me demande si le problème ne vient pas directement de War Thunder.

Hors ligne

#6 24/11/2019 01:13:50

Yurelovna
Membre
Inscription : 21/11/2019
Messages : 7

Re : Problème ouverture War Thunder Steam

[Mise à jour du post]

Après plusieurs tentatives / manipulations avec le pilote libre nouveau sans succès, j'ai donc relancé une installation du pilote nvidia avec la commande suivante :

# dnf install akmod-nvidia

Toutes les dépendances ont été installées.
HS : Sur CS GO j'ai d'ailleurs de meilleurs performances avec le pilote nvidia

Nouvelles tentative d’exécution de War Thunder j'ai toujours le même problème.
Je tiens à noté que lors que la fenêtre "Settings" du jeu est lancé j'ai pas mal de ralentissent comme si le jeux était lancé mais qu'il ne s'affiche pas.

Pour info : une fois l'installation du pilote nvidia effectué, je perds la possibilité de démarrer avec xorg (il n'est plus présent dans le choix au démarrage).

Hors ligne

#7 24/11/2019 10:25:29

madko
Contributeur Fedora et Linuxé depuis 1994
Modérateur
Lieu : Noisy the Great (9³)
Inscription : 22/12/2006
Messages : 7 659
Site Web

Re : Problème ouverture War Thunder Steam

je pense que c'est normal car le pilote nvidia n'est pas encore compatible wayland. L'installation de ce dernier passe WaylandEnable à false dans /etc/gdm/custom.conf. C'est donc normal.

Hors ligne

#8 24/11/2019 12:24:41

Refuznik
Membre
Inscription : 31/01/2007
Messages : 7 431

Re : Problème ouverture War Thunder Steam

Bon c'est pas window pas besoin de ré-installer l'Os à tout bout de champs.
Sinon comme je t'avais demandé que renvoi la commande :

lsmod | grep nouveau

Hors ligne

#9 24/11/2019 15:52:04

Yurelovna
Membre
Inscription : 21/11/2019
Messages : 7

Re : Problème ouverture War Thunder Steam

Pour la commande, elle ne me renvoi rien.

Hier j'ai reussi à lancer le jeu.
dans les options de lancement du jeu dans Steam j'ai ajouté l'option suivant : XMODIFIERS="" %command%
Avec ça j'ai bien la fenêtre qui "Setting" qui reste mais vide.

2019-11-24-14-46.png

Connaissant le launcher j'ai donc cliqué à l'endroit ou est logiquement présent le bouton "Play".

play.png

J'ai donc bien le jeu qui se lance et qui fonctionne.
En revanche je ne comprend pas pourquoi le Launcher n'affiche rien.

Hors ligne

Pied de page des forums