Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora 29 tire sa révérence

#1 31/07/2019 23:07:11

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 22 028

pilote pour chipset ethernet RTL 8153

Salut
j'ai acheté un adaptateur usb/ethernet.

lsusb renvoie:

Bus 001 Device 006: ID 0bda:8153 Realtek Semiconductor Corp. RTL8153 Gigabit Ethernet Adapter

Je n'ai aucun module rtlXXXX dans le système:

/lib/modules/5.1.20-200.fc29.i686 $ ls -l  | grep rtl
.... rien

quelqu'un saurait quel module/paquet installer pour faire fonctionner ce chipset ?

merci


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#2 31/07/2019 23:43:18

Refuznik
Membre
Inscription : 31/01/2007
Messages : 7 436

Re : pilote pour chipset ethernet RTL 8153

Après une rapide recherche je n'ai pas trouvé de paquet pour le rtl8153.
Par contre voici la page pour le driver de realtek https://www.realtek.com/en/component/zo … 0-software

Pour l'installation du module, j'ai trouvé cette page (bon c'est pour ubuntu mais tu peux adapter) https://www.pcsuggest.com/install-rtl8153-driver-linux/

N'oublie pas de lire les commentaires il y a peut-être des pistes si ça ne fonctionne pas.

Hors ligne

#3 01/08/2019 07:56:01

madko
Contributeur Fedora et Linuxé depuis 1994
Modérateur
Lieu : Noisy the Great (9³)
Inscription : 22/12/2006
Messages : 7 679
Site Web

Re : pilote pour chipset ethernet RTL 8153

Rien dans /lib/modules/5.1.20-300.fc30.x86_64/kernel/drivers/net/wireless/realtek/ ?

Le paquet kernel-modules est bien installé ?

Après je n'y vois pas spécifiquement du rtl8153 mais il y a bien plein de rtlXXXX.

Hors ligne

#4 01/08/2019 08:47:21

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 22 028

Re : pilote pour chipset ethernet RTL 8153

Alors je suis en i686 mais ça ne change rien

$ rpm -qa | grep 5.1.20
kernel-core-5.1.20-200.fc29.i686
kernel-modules-5.1.20-200.fc29.i686
kernel-modules-extra-5.1.20-200.fc29.i686
kernel-5.1.20-200.fc29.i686

donc hormis kernel-devel et kernel-headers il y a tout

l'adaptateur étant un filaire j'ai cherché et voilà ce que je trouve:

[Dell F29]/lib/modules/5.1.20-200.fc29.i686/kernel/drivers/net/ethernet/realtek $ ll

-rw-r--r--. 1 root root 12796 26 juil. 17:46 8139cp.ko.xz
-rw-r--r--. 1 root root 14356 26 juil. 17:46 8139too.ko.xz
-rw-r--r--. 1 root root  6468 26 juil. 17:46 atp.ko.xz
-rw-r--r--. 1 root root 30080 26 juil. 17:46 r8169.ko.xz

J'essaie le module r8169 avec modprobe. Il se charge mais ne gère pas ce chipset. Et Realtek sur son site ne propose en binaire que le pilote pour les noyaux 4.xx


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#5 01/08/2019 09:06:04

madko
Contributeur Fedora et Linuxé depuis 1994
Modérateur
Lieu : Noisy the Great (9³)
Inscription : 22/12/2006
Messages : 7 679
Site Web

Re : pilote pour chipset ethernet RTL 8153

D'après les sources du kernel c'est le r8152.ko qui gère le 8153.

https://github.com/torvalds/linux/blame … 8152.c#L35

t'as tenté un modprobe r8152 suivi d'un dmesg ?

/usr/sbin/modinfo r8152
filename:       /lib/modules/5.1.20-300.fc30.x86_64/kernel/drivers/net/usb/r8152.ko.xz
version:        v1.09.9
license:        GPL
description:    Realtek RTL8152/RTL8153 Based USB Ethernet Adapters
author:         Realtek linux nic maintainers <nic_swsd@realtek.com>
srcversion:     DDC489B016448B7AE88BF6F

Hors ligne

#6 01/08/2019 13:06:11

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 22 028

Re : pilote pour chipset ethernet RTL 8153

Bah je l'ai trouvé, je l'ai chargé avec modprobe et ça ne change rien.

Il faut peut-être rebooter, je verrai

Merci en tous cas


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#7 01/08/2019 23:33:35

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 22 028

Re : pilote pour chipset ethernet RTL 8153

Alors pour revenir sur cette question:

1) ce module est-il censé rester chargé une fois qu'on l'a chargé manuellement une première fois ?
2) sinon est-il censé en tant que périphérique usb, être chargé à l'insertion dans le pc ?

merci d'avance


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#8 02/08/2019 07:44:49

madko
Contributeur Fedora et Linuxé depuis 1994
Modérateur
Lieu : Noisy the Great (9³)
Inscription : 22/12/2006
Messages : 7 679
Site Web

Re : pilote pour chipset ethernet RTL 8153

1) si tu fais un modprobe Driver il va rester chargé tant que tu ne reboot pas. Tu peux le vérifier avec la commande lsmod

2) Oui normalement au branchement d'un périphérique USB cet évènement déclenche le chargement du module. C'est normalement géré par udev.

Tu a plusieurs fichiers qui peuvent bloquer ça dans /etc/modprobe.d et /etc/modules-load.d.

Car si tu le charge à la main ça fonctionne ?

Hors ligne

#9 02/08/2019 08:22:43

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 22 028

Re : pilote pour chipset ethernet RTL 8153

Non ça ne fonctionne pas mais comme j'ai une autre carte ethernet sur ce laptop, je me demande si ça ne crée pas conflit, s'il ne faut pas que je désactive la carte intégrée si je veux activer l'adaptateur usb et surtout comment je dois procéder pour que -si j'insère un module avec modprobe- il soit écrit qu'il doit  se charger dorénavant à chaque boot.

Si je charge à la main ce module, il apparait bien dans lsmod, mais si j'essaie de créer une nouvelle connexion filaire, il ne m'est pas proposé dans les "devices" disponibles. :'(


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#10 02/08/2019 08:41:55

Nicosss
Membre
Lieu : Isère
Inscription : 05/03/2007
Messages : 5 210
Site Web

Re : pilote pour chipset ethernet RTL 8153

Dans les logs système, quelles sont les lignes qui apparaissent au moment du branchement de l'adaptateur USB/Ethernet ?

# journalctl -f

Adaptateur USB/Ethernet branché, que retourne

# lsusb -t
# lsusb -v -d 0bda:8153

F31_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F31_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F31_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

#11 02/08/2019 09:17:19

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 22 028

Re : pilote pour chipset ethernet RTL 8153

Bon, la lumière fut :

En fait cet adaptateur usb/ethernet est connecté au travers d'un hub usb. J'ai eu l'idée de changer de prise et tout fonctionne à présent parfaitement, module chargé à l'insertion, reconnaissance par le réseau.

Il s'agit probablement d'un défaut de câblage de ce hub, et pourtant sous windows cet inconvénient n'apparaissait pas .

Merci à tous en tous cas et navré pour le dérangement.


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#12 02/08/2019 11:36:27

Nicosss
Membre
Lieu : Isère
Inscription : 05/03/2007
Messages : 5 210
Site Web

Re : pilote pour chipset ethernet RTL 8153

Du coup les retours de mes 2 dernières commandes donnent quoi pour voir le pilote utilisé ?


F31_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F31_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F31_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

#13 02/08/2019 13:57:27

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 22 028

Re : pilote pour chipset ethernet RTL 8153

A noter d'abord que si l'adaptateur est connecté pendant le boot, il n'est pas reconnu et ne fonctionne pas. Donc je l'ai débranché et rebranché. Voilà les résultats demandés:

$ lsusb -t
/:  Bus 05.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
/:  Bus 04.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
/:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/8p, 480M
    |__ Port 3: Dev 2, If 0, Class=Hub, Driver=hub/4p, 480M
        |__ Port 2: Dev 3, If 0, Class=Human Interface Device, Driver=usbhid, 1.5M
        |__ Port 3: Dev 6, If 0, Class=Vendor Specific Class, Driver=r8152, 480M
        |__ Port 4: Dev 5, If 0, Class=Mass Storage, Driver=usb-storage, 480M
$ lsusb -v -d 0bda:8153

Bus 001 Device 006: ID 0bda:8153 Realtek Semiconductor Corp. RTL8153 Gigabit Ethernet Adapter
Couldn't open device, some information will be missing
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.10
  bDeviceClass            0 
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0        64
  idVendor           0x0bda Realtek Semiconductor Corp.
  idProduct          0x8153 RTL8153 Gigabit Ethernet Adapter
  bcdDevice           30.00
  iManufacturer           1 
  iProduct                2 
  iSerial                 3 
  bNumConfigurations      2
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength       0x0027
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0xa0
      (Bus Powered)
      Remote Wakeup
    MaxPower              100mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           3
      bInterfaceClass       255 Vendor Specific Class
      bInterfaceSubClass    255 Vendor Specific Subclass
      bInterfaceProtocol      0 
      iInterface              0 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x02  EP 2 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x83  EP 3 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0002  1x 2 bytes
        bInterval               8
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength       0x0050
    bNumInterfaces          2
    bConfigurationValue     2
    iConfiguration          0 
    bmAttributes         0xa0
      (Bus Powered)
      Remote Wakeup
    MaxPower              100mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           1
      bInterfaceClass         2 Communications
      bInterfaceSubClass      6 Ethernet Networking
      bInterfaceProtocol      0 
      iInterface              5 
      CDC Header:
        bcdCDC               1.10
      CDC Union:
        bMasterInterface        0
        bSlaveInterface         1 
      CDC Ethernet:
        iMacAddress                      3 (??)
        bmEthernetStatistics    0x00000000
        wMaxSegmentSize               1514
        wNumberMCFilters            0x0000
        bNumberPowerFilters              0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x83  EP 3 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0010  1x 16 bytes
        bInterval               8
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        1
      bAlternateSetting       0
      bNumEndpoints           0
      bInterfaceClass        10 CDC Data
      bInterfaceSubClass      0 
      bInterfaceProtocol      0 
      iInterface              0 
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        1
      bAlternateSetting       1
      bNumEndpoints           2
      bInterfaceClass        10 CDC Data
      bInterfaceSubClass      0 
      bInterfaceProtocol      0 
      iInterface              4 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x02  EP 2 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval   

C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#14 02/08/2019 14:55:34

Nicosss
Membre
Lieu : Isère
Inscription : 05/03/2007
Messages : 5 210
Site Web

Re : pilote pour chipset ethernet RTL 8153

Du coup ça utilise bien le module r8152. La seconde commande était bien à passer avec des droits administrateur sinon il manque des infos (Couldn't open device, some information will be missing).

Il doit peut-être y avoir une règle udev qui empêche le montage du périphérique lors du boot pour une question de sécurité.


F31_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F31_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F31_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

#15 02/08/2019 15:35:13

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 22 028

Re : pilote pour chipset ethernet RTL 8153

Bizarre en tous cas je creuserai du côté de journalctl parce que ça m'intrigue.

Encore merci en tous cas.


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#16 02/08/2019 16:18:48

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 22 028

Re : pilote pour chipset ethernet RTL 8153

Et dans les boots précédents je vois cette erreur:

thunar-volman: Périphérique USB de type « r8152 » non pris en charge.

avant de débrancher/rebrancher.


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#17 02/08/2019 16:41:03

Nicosss
Membre
Lieu : Isère
Inscription : 05/03/2007
Messages : 5 210
Site Web

Re : pilote pour chipset ethernet RTL 8153

Hum, ce n'est pas le gestionnaire de volume ??? Etrange pour un adaptateur réseau.


F31_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F31_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F31_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

#18 02/08/2019 17:28:09

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 22 028

Re : pilote pour chipset ethernet RTL 8153

Si tout à fait. Je suis aussi perplexe que toi. Mais le problème n'étant pas trop pénalisant, je vais avancer. Il reste un dernier essai à faire: brancher l'adaptateur directement dans le laptop sans passer par le hub, et voir ce qui va se passer.


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

Pied de page des forums