Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Arrêt de maintenance pour Fedora 28

#1 13/05/2019 21:46:21

c4-53
Membre
Inscription : 18/07/2018
Messages : 76

[Résolu] virtualbox

Personne n'a de problème avec virtualbox?

 Problème: problem with installed package virtualbox-guest-additions-6.0.6-1.fc30.x86_64
  - package virtualbox-guest-additions-6.0.6-1.fc30.x86_64 conflicts with VirtualBox-server > 6.0.6-1.fc30 provided by VirtualBox-server-6.0.6-3.fc30.x86_64
  - package virtualbox-guest-additions-6.0.4-2.fc30.x86_64 conflicts with VirtualBox-server > 6.0.4-2.fc30 provided by VirtualBox-server-6.0.6-3.fc30.x86_64
  - package VirtualBox-6.0.6-3.fc30.x86_64 requires VirtualBox-server = 6.0.6, but none of the providers can be installed
  - cannot install the best candidate for the job
Saut des paquets en conflit :
(ajouter « --best --allowerasing » à la ligne de commande pour forcer leur mise à niveau):
 VirtualBox-server                       x86_64              6.0.6-3.fc30                                           rpmfusion-free-updates               40 M
 virtualbox-guest-additions              x86_64              6.0.4-2.fc30                                           fedora                              1.3 M
Saut des paquets ayant des dépendances cassées :
 VirtualBox                              x86_64              6.0.6-3.fc30                                           rpmfusion-free-updates              2.1 M

J'ai essayé avec le « --best --allowerasing », mais après avoir essayé "sofware" ne fonctionnait plus, à moins que  ce soit les flatpak mais ça dépasse mes connaissances.

Dernière modification par c4-53 (27/05/2019 23:42:24)


gigabyte 970a-ds3p - fx8300 - 16Go - radeon rx550 - iiyama prolite xub2792qsu-b1 - rme hdsp9632 - focusrite octopre mk2
utilisateur de fedora / centos / debian / arch / ...

Hors ligne

#2 13/05/2019 21:54:31

Heldwin
Gilets jaunes
Inscription : 07/10/2008
Messages : 4 200

Re : [Résolu] virtualbox

Bonjour,

Nope, je n'en ai pas en tout cas, mais je pense que c'est parce que je n'ai jamais essayé d'installer les guest-additions sur l'hôte.

Pour moi, c'est un peu comme si un invité était invité mais voulait agir comme l'inviteur et plus l'invité ^^ -> conflit

Dernière modification par Heldwin (13/05/2019 21:57:34)


"The only way to achieve the impossible is to believe it’s possible"

Hors ligne

#3 13/05/2019 21:59:08

Nicosss
Membre
Lieu : Isère
Inscription : 05/03/2007
Messages : 4 854
Site Web

Re : [Résolu] virtualbox

Tu as regardé ce que la commande retirait comme paquets ?


F30_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F30_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F30_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

#4 13/05/2019 22:11:34

c4-53
Membre
Inscription : 18/07/2018
Messages : 76

Re : [Résolu] virtualbox

[bertrand@localhost ~]$ sudo dnf install VirtualBox
[sudo] Mot de passe de bertrand : 
Dernière vérification de l’expiration des métadonnées effectuée il y a 0:37:40 le lun. 13 mai 2019 21:02:17 CEST.
Dépendances résolues.

 Problème: problem with installed package virtualbox-guest-additions-6.0.6-1.fc30.x86_64
  - package virtualbox-guest-additions-6.0.6-1.fc30.x86_64 conflicts with VirtualBox-server > 6.0.6-1.fc30 provided by VirtualBox-server-6.0.6-3.fc30.x86_64
  - package virtualbox-guest-additions-6.0.4-2.fc30.x86_64 conflicts with VirtualBox-server > 6.0.4-2.fc30 provided by VirtualBox-server-6.0.6-3.fc30.x86_64
  - package VirtualBox-6.0.6-3.fc30.x86_64 requires VirtualBox-server = 6.0.6, but none of the providers can be installed
  - cannot install the best candidate for the job
==============================================================================================================================================================
 Paquet                                  Architecture        Version                                                Dépôt                               Taille
==============================================================================================================================================================
Installation:
 VirtualBox                              x86_64              6.0.4-2.fc30                                           rpmfusion-free                      2.1 M
Installation des dépendances:
 elfutils-libelf-devel                   x86_64              0.176-2.fc30                                           updates                              23 k
 kernel-devel                            x86_64              5.0.13-300.fc30                                        updates                              13 M
 rust-srpm-macros                        noarch              9-1.fc30                                               updates                             9.2 k
 zstd                                    x86_64              1.4.0-1.fc30                                           updates                             366 k
 akmods                                  noarch              0.5.6-19.fc30                                          fedora                               23 k
 annobin                                 x86_64              8.71-1.fc30                                            fedora                              188 k
 dwz                                     x86_64              0.12-10.fc30                                           fedora                              102 k
 efi-srpm-macros                         noarch              4-2.fc30                                               fedora                               23 k
 fakeroot                                x86_64              1.23-3.fc30                                            fedora                               96 k
 fakeroot-libs                           x86_64              1.23-3.fc30                                            fedora                               30 k
 fpc-srpm-macros                         noarch              1.2-1.fc30                                             fedora                              7.5 k
 gc                                      x86_64              7.6.4-5.fc30                                           fedora                               93 k
 ghc-srpm-macros                         noarch              1.4.2-9.fc30                                           fedora                              7.6 k
 gnat-srpm-macros                        noarch              4-9.fc30                                               fedora                              8.5 k
 go-srpm-macros                          noarch              2-19.fc30                                              fedora                               11 k
 guile22                                 x86_64              2.2.4-3.fc30                                           fedora                              6.4 M
 kmodtool                                noarch              1-33.fc30                                              fedora                               13 k
 libatomic_ops                           x86_64              7.6.6-2.fc30                                           fedora                               34 k
 make                                    x86_64              1:4.2.1-13.fc30                                        fedora                              482 k
 nim-srpm-macros                         noarch              1-4.fc30                                               fedora                              8.1 k
 ocaml-srpm-macros                       noarch              5-5.fc30                                               fedora                              7.7 k
 openblas-srpm-macros                    noarch              2-5.fc30                                               fedora                              7.3 k
 patch                                   x86_64              2.7.6-9.fc30                                           fedora                              123 k
 perl-srpm-macros                        noarch              1-29.fc30                                              fedora                              8.2 k
 python-srpm-macros                      noarch              3-42.fc30                                              fedora                               11 k
 qt5-srpm-macros                         noarch              5.12.1-1.fc30                                          fedora                              9.1 k
 redhat-rpm-config                       noarch              128-1.fc30                                             fedora                               60 k
 rpm-build                               x86_64              4.14.2.1-4.fc30.1                                      fedora                              113 k
 rpmdevtools                             noarch              8.10-8.fc30                                            fedora                               91 k
 xemacs-filesystem                       noarch              21.5.34-33.20190323hgc0ed7ef9a5a1.fc30                 fedora                               10 k
 zlib-devel                              x86_64              1.2.11-15.fc30                                         fedora                               46 k
 VirtualBox-kmodsrc                      noarch              6.0.6-3.fc30                                           rpmfusion-free-updates              856 k
 akmod-VirtualBox                        x86_64              6.0.4-4.fc30                                           rpmfusion-free                       46 k
 VirtualBox-server                       x86_64              6.0.4-2.fc30                                           rpmfusion-free                       61 M
Saut des paquets en conflit :
(ajouter « --best --allowerasing » à la ligne de commande pour forcer leur mise à niveau):
 VirtualBox-server                       x86_64              6.0.6-3.fc30                                           rpmfusion-free-updates               40 M
 virtualbox-guest-additions              x86_64              6.0.4-2.fc30                                           fedora                              1.3 M
Saut des paquets ayant des dépendances cassées :
 VirtualBox                              x86_64              6.0.6-3.fc30                                           rpmfusion-free-updates              2.1 M

Résumé de la transaction
==============================================================================================================================================================
Installer  35 Paquets
Ignorer     3 Paquets

Taille totale des téléchargements : 85 M
Taille des paquets installés : 232 M
Voulez-vous continuer ? [o/N] : n
Opération avortée.

Dernière modification par c4-53 (27/05/2019 23:42:59)


gigabyte 970a-ds3p - fx8300 - 16Go - radeon rx550 - iiyama prolite xub2792qsu-b1 - rme hdsp9632 - focusrite octopre mk2
utilisateur de fedora / centos / debian / arch / ...

Hors ligne

#5 13/05/2019 22:26:33

didierg
Modérateur
Modérateur
Inscription : 11/07/2005
Messages : 4 874

Re : [Résolu] virtualbox

c4-53 a écrit :

Personne n'a de problème avec virtualbox?

Je n'ai aucun problème mais j'utilise la version disponible sur le site https://www.virtualbox.org/ et non la version disponible sur https://rpmfusion.org/

Hors ligne

#6 13/05/2019 22:30:40

Heldwin
Gilets jaunes
Inscription : 07/10/2008
Messages : 4 200

Re : [Résolu] virtualbox

Là ça sent le bug de dépendances, car il ne devrait pas y avoir une installation des guest-additions...

En regardant les dépôts:

dnf repoquery --whatrequires virtualbox-guest-additions

akmod-VirtualBox-0:6.0.4-4.fc30.x86_64
akmod-VirtualBox-0:6.0.6-3.fc30.x86_64

C'est bizarre en effet.

# rpm -qa | grep -i virtualbox
VirtualBox-6.0.6-3.fc30.x86_64
VirtualBox-server-6.0.6-3.fc30.x86_64
kmod-VirtualBox-5.0.9-300.fc30.x86_64-6.0.6-3.fc30.x86_64
akmod-VirtualBox-6.0.6-3.fc30.x86_64
VirtualBox-kmodsrc-6.0.6-3.fc30.noarch
kmod-VirtualBox-5.0.14-300.fc30.x86_64-6.0.6-3.fc30.x86_64

Surtout que si j'essaye d'install les guest-additions, il me remet la version 6.0.4 de virtualbox, puis crash si je fais une mise à jour.
(avec la même erreur que toi)

Et pour m'en sortir:

dnf remove virtualbox-guest-additions
dnf upgrade

Perso, chez toi, j'essayerai:

dnf install VirtualBox --exclude=virtualbox-guest-additions

EDIT:

Et si je supprime VirtualBox et tous les paquets ayant virtualbox dans le nom, il ne cherche pas à me mettre les guest-additions.

Dernière modification par Heldwin (13/05/2019 22:51:29)


"The only way to achieve the impossible is to believe it’s possible"

Hors ligne

#7 13/05/2019 23:09:30

c4-53
Membre
Inscription : 18/07/2018
Messages : 76

Re : [Résolu] virtualbox

En fait, j'ai refait une install toute propre en catastrophe dimanche matin. (j'étais parti pour installer une Arch et puis ma régulière avait besoin du pc sous linux, bizarre!) Ça commençait à me casser les pieds, mon fichier user.dirs et logiciel en carafe, pas moyen de faire des essais en VM, c'est quoi ce bronx?

Avant mon passage à fedora30, j'avais quelques soucis avec ma 29 (par ma faute), j'ai une mise à niveau en passant par logiciel. Ça a fonctionné, mis à part quelques extensions gnome. Je profite toujours d'une nouvelle version pour faire une install propre. (je salis tout ce que je touche) J'ai du faire quatre installations avec net/everything et un live et j'ai planté à chaque fois logiciel et Vbox. Donc j'ai laissé tombé, je suis resté avec ma "fc30 live install" toujours en travaux. 
J'avais installé Virtualbox et je n'utilisais pas aussitôt l'application et à la mise à jour il me proposait d'ajouter deux option "--best --allowerasing" et une autre que j'ai oublier et ça fonctionnait plus ou moins.

Dernière modification par c4-53 (13/05/2019 23:10:57)


gigabyte 970a-ds3p - fx8300 - 16Go - radeon rx550 - iiyama prolite xub2792qsu-b1 - rme hdsp9632 - focusrite octopre mk2
utilisateur de fedora / centos / debian / arch / ...

Hors ligne

#8 13/05/2019 23:46:22

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 21 751

Re : [Résolu] virtualbox

didierg a écrit :
c4-53 a écrit :

Personne n'a de problème avec virtualbox?

Je n'ai aucun problème mais j'utilise la version disponible sur le site https://www.virtualbox.org/ et non la version disponible sur https://rpmfusion.org/

+1


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#9 14/05/2019 00:02:34

c4-53
Membre
Inscription : 18/07/2018
Messages : 76

Re : [Résolu] virtualbox

Elle n'est pas restée en fedora29?


gigabyte 970a-ds3p - fx8300 - 16Go - radeon rx550 - iiyama prolite xub2792qsu-b1 - rme hdsp9632 - focusrite octopre mk2
utilisateur de fedora / centos / debian / arch / ...

Hors ligne

#10 14/05/2019 10:55:52

didierg
Modérateur
Modérateur
Inscription : 11/07/2005
Messages : 4 874

Re : [Résolu] virtualbox

c4-53 a écrit :

Elle n'est pas restée en fedora29?

Le rpm disponible actuellement sur le site de https://www.virtualbox.org/ est effectivement pour Fedora 29 mais il fonctionne parfaitement avec Fedora 30.

Pour éviter un message d'erreur lors de dnf upgrade il suffit de modifier le fichier /etc/yum.repos.d/virtualbox.repo pour remplacer

baseurl=http://download.virtualbox.org/virtualbox/rpm/fedora/$releasever/$basearch

par

baseurl=http://download.virtualbox.org/virtualbox/rpm/fedora/29/$basearch

Voir: https://www.virtualbox.org/ticket/18636

Hors ligne

#11 14/05/2019 13:05:26

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 21 751

Re : [Résolu] virtualbox

Tiens chez moi c'est bien la release 130049 qui est installée sur F29 mais elle est étiquetée FC26 !!


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#12 15/05/2019 01:29:52

didierg
Modérateur
Modérateur
Inscription : 11/07/2005
Messages : 4 874

Re : [Résolu] virtualbox

Il suffisait de demander en fournissant un retour d'expérience !

Sur le site https://www.virtualbox.org/ le repo pour Fedora 30 vient d'être créé même si celui-ci contient  encore un rpm étiqueté fc29:

VirtualBox-6.0-6.0.8_130520_fedora29-1.x86_64

L'extension pack sur la page https://www.virtualbox.org/wiki/Downloads est au même niveau 6.0.8_130520.

Je n'ai pas trouvé le changelog entre VirtualBox-6.0-6.0.6_130049 et VirtualBox-6.0-6.0.8_130520.

Hors ligne

Pied de page des forums