Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Venez tester Fedora 30 Beta !

#1 02/11/2018 16:25:02

moudur
Membre
Inscription : 22/03/2014
Messages : 152

[Résolu] Erreurs lors du dnf system-upgrade download

Bonjour,

Voyant arriver la version 29 de Fedora, j'ai voulu passer de la 27 à la 28.
Malheureusement, j'ai les erreurs suivantes lorsque je tape la commande : "dnf system-upgrade download --releasever 28"

Erreur : 
 Problème 1: nss-pem-1.0.3-6.fc27.i686 has inferior architecture
  - nss-pem-1.0.3-6.fc27.x86_64 does not belong to a distupgrade repository
  - problem with installed package nss-pem-1.0.3-6.fc27.i686
 Problème 2: package poppler-demos-0.57.0-10.fc27.x86_64 requires libpoppler.so.68()(64bit), but none of the providers can be installed
  - poppler-0.57.0-10.fc27.x86_64 does not belong to a distupgrade repository
  - problem with installed package poppler-demos-0.57.0-10.fc27.x86_64

Vous auriez une idée pour corriger ces deux problèmes ?

NB : J'ai bien fait le "dnf --refresh upgrade" avant le dnf system-upgrade download --releasever 28...

Hors ligne

#2 02/11/2018 16:32:12

moudur
Membre
Inscription : 22/03/2014
Messages : 152

Re : [Résolu] Erreurs lors du dnf system-upgrade download

Il y a un très long fil sur ce sujet ici :
https://bugzilla.redhat.com/show_bug.cgi?id=1553646

Mais je n'ai pas compris si il y une solution et ce qu'on peut faire...

Hors ligne

#3 02/11/2018 17:04:06

Nicosss
Membre
Lieu : Isère
Inscription : 05/03/2007
Messages : 4 533
Site Web

Re : [Résolu] Erreurs lors du dnf system-upgrade download

Je supprimerai le paquet 32bits de nss-pem ainsi que le paquet package poppler-demos.

A voir si au niveau des dépendances ça ne fait pas trop de ménage.


F29_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F29_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F29_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

#4 02/11/2018 22:23:53

moudur
Membre
Inscription : 22/03/2014
Messages : 152

Re : [Résolu] Erreurs lors du dnf system-upgrade download

Nicosss a écrit :

[...]
A voir si au niveau des dépendances ça ne fait pas trop de ménage.

Pour poppler, c'est bon, par contre, nss-pem, ça traine pas mal de dépendances, non ? (voir ci-dessous)

# dnf remove nss-pem-1.0.3-6.fc27.i686
Dépendances résolues.
================================================================================
 Paquet              Architecture
                          Version                                Dépôt    Taille
================================================================================
Suppression :
 nss-pem             i686 1.0.3-6.fc27                           @updates 215 k
Supprimer des paquets dépendants:
 armadillo           i686 9.100.5-1.fc27                         @updates  72 k
 gdal-libs           i686 2.1.4-6.1.fc27                         @updates  18 M
 libcurl             i686 7.55.1-14.fc27                         @updates 585 k
 libdap              i686 3.18.3-4.fc27                          @fedora  2.1 M
 libgphoto2          i686 2.5.16-1.fc27                          @updates 6.1 M
 libspatialite       i686 4.3.0a-6.fc27                          @fedora   13 M
 netcdf              i686 4.4.1.1-6.fc27                         @fedora  2.3 M
 nss                 i686 3.39.0-1.0.fc27                        @updates 2.0 M
 opencv              i686 3.2.0-15.fc27                          @updates  10 M
 opencv-contrib      i686 3.2.0-15.fc27                          @updates 6.5 M
 opencv-core         i686 3.2.0-15.fc27                          @updates  11 M
 opencv-devel        i686 3.2.0-15.fc27                          @updates 4.2 M
 openldap            i686 2.4.45-4.fc27                          @updates 1.0 M
 poppler             i686 0.57.0-10.fc27                         @updates 2.4 M
 postgresql-libs     i686 9.6.10-3.fc27                          @updates 766 k
 qt5-qtbase-gui      i686 5.9.6-4.fc27                           @updates  18 M
 raptor2             i686 2.0.15-10.fc27                         @fedora  545 k
 rasqal              i686 0.9.33-5.fc27                          @fedora  860 k
 redland             i686 1.0.17-12.fc27                         @fedora  485 k
 soprano             i686 2.9.4-17.fc27                          @fedora  2.0 M
 tesseract           i686 3.05.02-1.fc27                         @updates  40 M
 xcb-util-image      i686 0.4.0-8.fc27                           @fedora   21 k
Suppression des dépendances inutilisées:
 SuperLU             i686 5.2.0-4.fc27                           @fedora  486 k
 arpack              i686 3.5.0-4.fc27                           @fedora  316 k
 cfitsio             i686 3.370-10.fc27                          @fedora  1.8 M
 clucene-core        i686 2.3.3.4-29.20130812.e8e3d20git.fc27    @fedora  1.7 M
 cyrus-sasl-lib      i686 2.1.26-34.fc27                         @fedora  387 k
 freexl              i686 1.0.5-1.fc27                           @updates  65 k
 geos                i686 3.6.1-4.fc27                           @fedora  1.9 M
 json-c              i686 0.12.1-5.fc27                          @updates  45 k
 lapack              i686 3.8.0-9.fc27                           @updates  14 M
 leptonica           i686 1.74.4-5.fc27                          @updates 2.7 M
 libexif             i686 0.6.21-14.fc27                         @updates 1.8 M
 libgeotiff          i686 1.4.0-11.fc27                          @fedora  5.3 M
 libgta              i686 1.0.7-6.fc27                           @fedora   77 k
 libkml              i686 1.3.0-8.fc27                           @fedora  1.2 M
 libpsl              i686 0.18.0-3.fc27                          @updates  55 k
 libssh2             i686 1.8.0-5.fc27                           @fedora  197 k
 libucil             i686 0.9.10-15.fc27                         @fedora  189 k
 libunicap           i686 0.9.12-20.fc27                         @fedora  396 k
 libxkbcommon-x11    i686 0.8.2-1.fc27                           @updates  31 k
 minizip             i686 1.2.11-4.fc27                          @fedora   54 k
 mpfr                i686 3.1.6-1.fc27                           @updates 511 k
 ogdi                i686 3.2.0-3.fc27                           @fedora  725 k
 openblas-openmp     i686 0.3.2-3.fc27                           @updates  22 M
 openjpeg2           i686 2.3.0-9.fc27                           @updates 370 k
 openni              i686 1.5.7.10-11.fc27                       @fedora  1.3 M
 tbb                 i686 2017.7-3.fc27                          @fedora  621 k
 tinyxml             i686 2.6.2-14.fc27                          @fedora  122 k
 uriparser           i686 0.8.5-1.fc27                           @updates 141 k
 xcb-util            i686 0.4.0-8.fc27                           @fedora   21 k
 xcb-util-keysyms    i686 0.4.0-6.fc27                           @fedora   12 k
 xcb-util-renderutil i686 0.3.9-9.fc27                           @fedora   19 k
 xcb-util-wm         i686 0.4.1-11.fc27                          @fedora   87 k
 xerces-c            i686 3.1.4-4.fc27                           @fedora  3.7 M
 yajl                i686 2.1.0-8.fc27                           @fedora   71 k

Résumé de la transaction
================================================================================
Supprimer  57 Paquets

Espace libéré : 206 M
Voulez-vous continuer ? [o/N] :N
Opération avortée.

Hors ligne

#5 03/11/2018 00:04:00

Nicosss
Membre
Lieu : Isère
Inscription : 05/03/2007
Messages : 4 533
Site Web

Re : [Résolu] Erreurs lors du dnf system-upgrade download

Si tu as un système en 64 bits alors tu peux les supprimer, sauf si tu en as un besoin vraiment particulier.


F29_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F29_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F29_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

#6 10/11/2018 13:43:38

rodyste
Utilisateur GNU/Linux convaincu!
Lieu : Jura/Suisse
Inscription : 13/02/2010
Messages : 189

Re : [Résolu] Erreurs lors du dnf system-upgrade download

Bonjour à vous,

j'ai exactement le même problème.

Moudur, avez-vous pu le résoudre sans enlever toutes ces dépendances?


avant dnf , j'utilisais la l'option --nodep pour ne pas supprimer les dépendances. Il semble qu'avec dnf cela ne fonction plus?

Connaissez-vous une option qui la remplace ? Merci

Rodyste


Exister, c'est aussi s'opposer, ne pas toujours suivre l'opinion générale.  [Christophe Malavoy]

Hors ligne

#7 10/11/2018 13:49:46

Nicosss
Membre
Lieu : Isère
Inscription : 05/03/2007
Messages : 4 533
Site Web

Re : [Résolu] Erreurs lors du dnf system-upgrade download

Si tu es en 64bits et que ce sont des dépendances 32bits alors quel est ton souci ?

Tu aurais le retour exact de la commande pour pouvoir comprendre.


F29_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F29_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F29_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

#8 10/11/2018 14:37:38

rodyste
Utilisateur GNU/Linux convaincu!
Lieu : Jura/Suisse
Inscription : 13/02/2010
Messages : 189

Re : [Résolu] Erreurs lors du dnf system-upgrade download

Voici le retour de la commande :

# dnf remove nss-pem-1.0.3-6.fc27.i686 
Dépendances résolues.
====================================================================================================================================================================================
 Paquet                                                    Architecture                      Version                                      Dépôt                               Taille
====================================================================================================================================================================================
Suppression :
 nss-pem                                                   i686                              1.0.3-6.fc27                                 @updates                            215 k
Supprimer des paquets dépendants:
 nss                                                       i686                              3.39.0-1.0.fc27                              @updates                            2.0 M
 openldap                                                  i686                              2.4.45-4.fc27                                @updates                            1.0 M
 samba-common-tools                                        x86_64                            2:4.7.10-1.fc27                              @updates                            1.1 M
 samba-libs                                                x86_64                            2:4.7.10-1.fc27                              @updates                            740 k
 samba-winbind                                             x86_64                            2:4.7.10-1.fc27                              @updates                            1.5 M
 samba-winbind-clients                                     x86_64                            2:4.7.10-1.fc27                              @updates                            132 k
 samba-winbind-modules                                     x86_64                            2:4.7.10-1.fc27                              @updates                             79 k
 sane-backends-drivers-cameras                             i686                              1.0.27-17.fc27                               @updates                             47 k
 sane-backends-drivers-scanners                            i686                              1.0.27-17.fc27                               @updates                            9.9 M
 sane-backends-libs                                        i686                              1.0.27-17.fc27                               @updates                            197 k
 wine                                                      x86_64                            3.18-1.fc27                                  @updates                              0  
 wine-cms                                                  i686                              3.18-1.fc27                                  @updates                            130 k
 wine-ldap                                                 i686                              3.18-1.fc27                                  @updates                            360 k
 wine-opencl                                               i686                              3.18-1.fc27                                  @updates                            110 k
 wine-pulseaudio                                           i686                              3.18-1.fc27                                  @updates                            170 k
 wine-twain                                                i686                              3.18-1.fc27                                  @updates                            225 k
Suppression des dépendances inutilisées:
 cyrus-sasl-lib                                            i686                              2.1.26-34.fc27                               @fedora                             387 k
 lcms2                                                     i686                              2.8-6.fc27                                   @updates                            399 k
 libdb                                                     i686                              5.3.28-27.fc27                               @updates                            1.9 M
 libieee1284                                               i686                              0.2.11-23.fc27                               @fedora                              80 k
 mingw32-wine-gecko                                        noarch                            2.47-2.fc26                                  @fedora                              48 M
 ocl-icd                                                   i686                              2.2.12-1.fc27                                @updates                            147 k
 python2-talloc                                            x86_64                            2.1.13-1.fc27                                @updates                             27 k 
 wine-alsa                                                 i686                              3.18-1.fc27                                  @updates                            195 k 
 wine-capi                                                 i686                              3.18-1.fc27                                  @updates                             83 k 
 wine-fonts                                                noarch                            3.18-1.fc27                                  @updates                              0   
 wine-ldap                                                 x86_64                            3.18-1.fc27                                  @updates                            411 k 
 wine-openal                                               i686                              3.18-1.fc27                                  @updates                            114 k 
                                                                                                                                                                                    
Résumé de la transaction
====================================================================================================================================================================================
Supprimer  29 Paquets

Espace libéré : 69 M
Voulez-vous continuer ? [o/N] :

Donc, d'une part il y a quelques paquets en 64 bits et d'autre part il ya des paquets wine. Justement j'utilise un peu wine et j'ignore absolument si ces paquets son important.

A+
merci


Exister, c'est aussi s'opposer, ne pas toujours suivre l'opinion générale.  [Christophe Malavoy]

Hors ligne

#9 10/11/2018 15:27:53

Nicosss
Membre
Lieu : Isère
Inscription : 05/03/2007
Messages : 4 533
Site Web

Re : [Résolu] Erreurs lors du dnf system-upgrade download

Que retourne

$ rpm -qa nss\*
$ rpm -qa wine\*

Mais à mon avis tu avais installé les paquets 32bits et 64bits par mégarde.


F29_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F29_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F29_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

#10 10/11/2018 17:44:28

rodyste
Utilisateur GNU/Linux convaincu!
Lieu : Jura/Suisse
Inscription : 13/02/2010
Messages : 189

Re : [Résolu] Erreurs lors du dnf system-upgrade download

Nicosss a écrit :

Mais à mon avis tu avais installé les paquets 32bits et 64bits par mégarde.

Il ne peuvent s’être installé avec WINE ?

et voilà les retours :

$ rpm -qa nss\*
nss-pem-1.0.3-6.fc27.i686
nss-pem-1.0.3-6.fc27.x86_64
nss-softokn-3.39.0-1.0.fc27.x86_64
nss-util-3.39.0-1.0.fc27.x86_64
nss-3.39.0-1.0.fc27.x86_64
nss-softokn-freebl-3.39.0-1.0.fc27.i686
nss-softokn-freebl-3.39.0-1.0.fc27.x86_64
nss-mdns-0.14.1-1.fc27.i686
nss-3.39.0-1.0.fc27.i686
nss-sysinit-3.39.0-1.0.fc27.x86_64
nss-util-3.39.0-1.0.fc27.i686
nss-mdns-0.14.1-1.fc27.x86_64
nss-tools-3.39.0-1.0.fc27.x86_64
nss-softokn-3.39.0-1.0.fc27.i686
$ rpm -qa wine\*
wine-symbol-fonts-3.18-1.fc27.noarch
wine-ldap-3.18-1.fc27.i686
wine-capi-3.18-1.fc27.x86_64
wine-marlett-fonts-3.18-1.fc27.noarch
wine-twain-3.18-1.fc27.i686
wine-openal-3.18-1.fc27.x86_64
wine-arial-fonts-3.18-1.fc27.noarch
winetricks-20180603-1.fc27.noarch
wine-core-3.18-1.fc27.x86_64
wine-times-new-roman-fonts-3.18-1.fc27.noarch
wine-common-3.18-1.fc27.noarch
wine-cms-3.18-1.fc27.x86_64
wine-fixedsys-fonts-3.18-1.fc27.noarch
wine-alsa-3.18-1.fc27.i686
wine-3.18-1.fc27.x86_64
wine-opencl-3.18-1.fc27.x86_64
wine-system-fonts-3.18-1.fc27.noarch
wine-fonts-3.18-1.fc27.noarch
wine-cms-3.18-1.fc27.i686
wine-pulseaudio-3.18-1.fc27.x86_64
wine-ms-sans-serif-fonts-3.18-1.fc27.noarch
wine-tahoma-fonts-system-3.18-1.fc27.noarch
wine-opencl-3.18-1.fc27.i686
wine-tahoma-fonts-3.18-1.fc27.noarch
wine-ldap-3.18-1.fc27.x86_64
wine-systemd-3.18-1.fc27.noarch
wine-courier-fonts-3.18-1.fc27.noarch
wine-pulseaudio-3.18-1.fc27.i686
wine-filesystem-3.18-1.fc27.noarch
wine-twain-3.18-1.fc27.x86_64
wine-mono-4.7.3-1.fc27.noarch
wine-core-3.18-1.fc27.i686
wine-wingdings-fonts-3.18-1.fc27.noarch
wine-desktop-3.18-1.fc27.noarch
wine-capi-3.18-1.fc27.i686
wine-alsa-3.18-1.fc27.x86_64
wine-small-fonts-3.18-1.fc27.noarch
wine-wingdings-fonts-system-3.18-1.fc27.noarch
wine-openal-3.18-1.fc27.i686

Merci pour ton aide


Exister, c'est aussi s'opposer, ne pas toujours suivre l'opinion générale.  [Christophe Malavoy]

Hors ligne

#11 10/11/2018 21:25:58

Nicosss
Membre
Lieu : Isère
Inscription : 05/03/2007
Messages : 4 533
Site Web

Re : [Résolu] Erreurs lors du dnf system-upgrade download

Tu peux faire le ménage, au pire tu réinstalleras Wine après la migration.


F29_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F29_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F29_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

#12 11/11/2018 17:33:33

rodyste
Utilisateur GNU/Linux convaincu!
Lieu : Jura/Suisse
Inscription : 13/02/2010
Messages : 189

Re : [Résolu] Erreurs lors du dnf system-upgrade download

Bonjour,
merci Nicosss, mon ordi tourne avec Fedora 28.

J'ai effectivement dû réinstaller Wine.

A+


Exister, c'est aussi s'opposer, ne pas toujours suivre l'opinion générale.  [Christophe Malavoy]

Hors ligne

#13 11/11/2018 19:26:58

Nicosss
Membre
Lieu : Isère
Inscription : 05/03/2007
Messages : 4 533
Site Web

Re : [Résolu] Erreurs lors du dnf system-upgrade download

Très bien. Reste à passer sous F29 maintenant wink


F29_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F29_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F29_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

Pied de page des forums