Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Un nouveau logo pour Fedora ?

#1 30/10/2018 20:39:06

carabao
Membre
Lieu : Wallonie, Europe
Inscription : 04/07/2004
Messages : 111

F28 vers F29, erreur de dépendences

Bonjour,

J'ai essayé de mettre à jour ma F28 vers F29 en suivant la méthode suivante: https://doc.fedora-fr.org/wiki/Mise_%C3 … _de_Fedora

# dnf install dnf-plugin-system-upgrade
# dnf upgrade && dnf clean all
# dnf system-upgrade download --releasever=29

J'ai obtenu deux erreurs, l'une pour VLC que j'ai résolu en le supprimant de F28
et la deuxième


Erreur : 
 Problème: problem with installed package pycryptopp-0.6.0.1206569328141510525648634803928199668821045408958-15.fc28.x86_64
  - package pycryptopp-0.6.0.1206569328141510525648634803928199668821045408958-15.fc29.x86_64 requires libcryptopp.so.6()(64bit), but none of the providers can be installed
  - pycryptopp-0.6.0.1206569328141510525648634803928199668821045408958-15.fc28.x86_64 does not belong to a distupgrade repository
  - cryptopp-6.1.0-2.fc28.x86_64 does not belong to a distupgrade repository

Pas encore fait

# dnf system-upgrade reboot

Sortie un peu trop fraiche, je suppose ?

Dernière modification par carabao (30/10/2018 20:45:40)


Système: Fedora 29 (x86_64) ~ workstation Processeur: Intel I5-7300HQ (4) @ 3.500GHz, RAM: 8 GB, SSD: 256 GB (samsung), HDD: 1 TB (hitachi), Graphique:  Optimus ~ Intel + 1050 TI - GP107M (Nvidia), Son: HD HD Audio (Intel), Réseau: RJ45 (Qualcomm), Wifi (Intel), usb: V3, V2 (Intel)

Hors ligne

#2 30/10/2018 20:43:49

madko
Contributeur Fedora et Linuxé depuis 1994
Modérateur
Lieu : Noisy the Great (9³)
Inscription : 22/12/2006
Messages : 6 629
Site Web

Re : F28 vers F29, erreur de dépendences

F29 vers F29 ?

Bon sinon pycryptopp est en voie de disparition en tout cas il n'existera plus sur F30. Tu en as besoin ?

Pour pycryptopp j'ai cette version de disponible sur ma Fedora 30 0.6.0.1206569328141510525648634803928199668821045408958-15.fc29
Par contre cryptopp dnf ne me le trouve qu'en version 7.0.0-1.fc29

Je suppose que tu as essayé de les supprimer aussi mais que ça tire trop de dépendances ?


Linux, ya moins bien, mais c'est plus chèr!!!
Fedora 29 x86_64 sur HP 850 G5 et Dell Latitude E5440

Hors ligne

#3 30/10/2018 20:47:58

carabao
Membre
Lieu : Wallonie, Europe
Inscription : 04/07/2004
Messages : 111

Re : F28 vers F29, erreur de dépendences

Corrigé pour la coquille, F28 vers F29 bien sûr

pycryptopp, à quoi il sert ?

Je l'ai supprimé sans problème.

Dernière modification par carabao (30/10/2018 21:00:07)


Système: Fedora 29 (x86_64) ~ workstation Processeur: Intel I5-7300HQ (4) @ 3.500GHz, RAM: 8 GB, SSD: 256 GB (samsung), HDD: 1 TB (hitachi), Graphique:  Optimus ~ Intel + 1050 TI - GP107M (Nvidia), Son: HD HD Audio (Intel), Réseau: RJ45 (Qualcomm), Wifi (Intel), usb: V3, V2 (Intel)

Hors ligne

#4 31/10/2018 01:25:27

KuroNeko
Membre
Inscription : 29/01/2010
Messages : 19

Re : F28 vers F29, erreur de dépendences

- Méthode d'installation :

Via le terminal :

# dnf system-upgrade download --releasever=29
# dnf system-upgrade reboot

- Problèmes majeurs :

J'ai été obligé de désinstaller Vlc et Remmina pour effectuer la mise à jour


- Soucis mineurs :

Pas de plugins st pour remmina (Je le dis juste pour le dire, je m'en sers pas.)
Impossible de réinstaller Vlc

Thunderbird en anglais

- Points positifs :

Système toujours aussi stable
Plus rapide au démarrage


- Points négatifs :

Comme dit précédemment pas de Vlc pour le moment.
Beaucoup de régresssions même si dans le fond c'est pas nécessairement handicapant.


- Portable Lenovo YOGA 520 -
Proc: Intel® Core™ i5-7200U CPU @ 2.50GHz × 4  - RAM: 8Go
Graphique: Intel HD Graphics 620

Hors ligne

#5 31/10/2018 01:46:45

didierg
Modérateur
Modérateur
Inscription : 11/07/2005
Messages : 4 656

Re : F28 vers F29, erreur de dépendences

KuroNeko a écrit :

Impossible de réinstaller Vlc

Pas de problème avec vlc-3.0.5-3.fc29.x86_64

Hors ligne

#6 31/10/2018 01:55:39

didierg
Modérateur
Modérateur
Inscription : 11/07/2005
Messages : 4 656

Re : F28 vers F29, erreur de dépendences

carabao a écrit :

pycryptopp, à quoi il sert ?

Avant de le supprimer tu aurais pu faire un:

sudo dnf repoquery --installed --whatrequires pycryptopp

Tu peux aussi faire un:

sudo dnf info pycryptopp

Hors ligne

#7 31/10/2018 04:39:06

KuroNeko
Membre
Inscription : 29/01/2010
Messages : 19

Re : F28 vers F29, erreur de dépendences

didierg a écrit :
KuroNeko a écrit :

Impossible de réinstaller Vlc

Pas de problème avec vlc-3.0.5-3.fc29.x86_64


Ben ça a marché cette fois.

J'ai du faire la mise à jour trop tôt.

EN faisant, à l'instant, un :

dnf upgrade

Tous mes paquets rétrogradés se sont mis à jour.

Du coup que du bonheur pour moi. Tout fonctionne et en français.


- Portable Lenovo YOGA 520 -
Proc: Intel® Core™ i5-7200U CPU @ 2.50GHz × 4  - RAM: 8Go
Graphique: Intel HD Graphics 620

Hors ligne

#8 31/10/2018 08:16:51

madko
Contributeur Fedora et Linuxé depuis 1994
Modérateur
Lieu : Noisy the Great (9³)
Inscription : 22/12/2006
Messages : 6 629
Site Web

Re : F28 vers F29, erreur de dépendences

Ya usurpation d'identité ? Pourquoi KuroNeko tu t'es incrusté dans ce sujet ?


Linux, ya moins bien, mais c'est plus chèr!!!
Fedora 29 x86_64 sur HP 850 G5 et Dell Latitude E5440

Hors ligne

#9 31/10/2018 11:50:02

ben51
Attention derrière toi ! un canard !
Lieu : Bordeaux
Inscription : 24/03/2008
Messages : 1 018

Re : F28 vers F29, erreur de dépendences

KuroNeko a écrit :

Thunderbird en anglais.

on est pas aussi repassé à la version 52  ?

Hors ligne

#10 31/10/2018 12:27:24

didierg
Modérateur
Modérateur
Inscription : 11/07/2005
Messages : 4 656

Re : F28 vers F29, erreur de dépendences

ben51 a écrit :

on est pas aussi repassé à la version 52  ?

La version thunderbird-60.3.0-1.fc29.x86_64 est disponible sur koji et elle résout les problèmes de franglais. Voir: https://forums.fedora-fr.org/viewtopic. … 86#p590986

Un dnf distro-sync propose la version 60.2.1-2.fc29 qui est donc la version qui doit actuellement être installée après un dnf upgrade

Dernière modification par didierg (31/10/2018 12:27:59)

Hors ligne

#11 31/10/2018 14:17:58

carabao
Membre
Lieu : Wallonie, Europe
Inscription : 04/07/2004
Messages : 111

Re : F28 vers F29, erreur de dépendences

didierg a écrit :
carabao a écrit :

pycryptopp, à quoi il sert ?

Avant de le supprimer tu aurais pu faire un:

sudo dnf repoquery --installed --whatrequires pycryptopp

Tu peux aussi faire un:

sudo dnf info pycryptopp

Merci pour ces deux commandes.  Je suis encore en mode découverte avec les commandes DNF après quelques années avec les commandes APT.


Système: Fedora 29 (x86_64) ~ workstation Processeur: Intel I5-7300HQ (4) @ 3.500GHz, RAM: 8 GB, SSD: 256 GB (samsung), HDD: 1 TB (hitachi), Graphique:  Optimus ~ Intel + 1050 TI - GP107M (Nvidia), Son: HD HD Audio (Intel), Réseau: RJ45 (Qualcomm), Wifi (Intel), usb: V3, V2 (Intel)

Hors ligne

#12 31/10/2018 14:19:58

madko
Contributeur Fedora et Linuxé depuis 1994
Modérateur
Lieu : Noisy the Great (9³)
Inscription : 22/12/2006
Messages : 6 629
Site Web

Re : F28 vers F29, erreur de dépendences

Tu peux en découvrir encore plein d'autres ici https://doc.fedora-fr.org/wiki/DNF,_le_ … _de_Fedora


Linux, ya moins bien, mais c'est plus chèr!!!
Fedora 29 x86_64 sur HP 850 G5 et Dell Latitude E5440

Hors ligne

Pied de page des forums