Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Clap de fin pour Fedora 27

#1 11/10/2018 12:08:27

inxto
etat = actif | inactif
Lieu : Bouches-du-Rhône
Inscription : 30/09/2018
Messages : 21

[Résolu] Problème avec rtkit

Bonjour,

Aujourd'hui, j'ai voulu vérifier les paquets installés sur le système avec :

rpm -Va

La sortie de cette commande afficha deux lignes qui ont attiré mon attention :

S.5......    /usr/libexec/rtkit-daemon
S.5......    /usr/sbin/rtkitctl

Ces lignes indiquent, sauf erreur de ma part, des modifications sur des binaires système, affectant leur taille et leur somme de contrôle.
Cela me semble suspect, dois-je m'en inquiéter ?

Dernière modification par inxto (12/10/2018 00:30:40)

Hors ligne

#2 11/10/2018 13:11:35

madko
Contributeur Fedora et Linuxé depuis 1994
Modérateur
Lieu : Noisy the Great (9³)
Inscription : 22/12/2006
Messages : 6 429
Site Web

Re : [Résolu] Problème avec rtkit

Bonjour,

oui ça peut être inquiétant. Ce n'est pas normal qu'un binaire change de contenu. Reinstalle vite le paquet qui fournit ces binaires et voit si c'est toujours le cas. Tu n'as que ces 2 là ?

Il me semble qu'il y a prelink qui peut "fausser" la somme de contrôle mais rpm en tient compte ou le précise si c'est le cas. En tout cas reinstalle le paquet tu verras après.

A voir si c'est pas le programme qui se met à jour de lui même, mais c'est moyen, et ça casse le fait qu'il soit packager via RPM (et donc avec une version précise).


Linux, ya moins bien, mais c'est plus chèr!!!
Fedora 29 x86_64 sur Samsung NP740 et Dell Latitude E5440

Hors ligne

#3 12/10/2018 00:30:00

inxto
etat = actif | inactif
Lieu : Bouches-du-Rhône
Inscription : 30/09/2018
Messages : 21

Re : [Résolu] Problème avec rtkit

Il s'agit bien d'une anomalie touchant la version rtkit 0.11.19.

Les erreurs sont apparemment liées à une entrée dupliquée dans la base de données rpm.
J'ai rencontré quelques difficultés pour supprimer le paquet, à cause des conflits engendrés, mais cela peut se résoudre avec :

rpm -e --nodeps --justdb <package>

Le problème disparait en rétrogradant sur la version 0.11.18 (F28), ou bien en mettant à jour vers la version 0.11.20 (F29).

Hors ligne

Pied de page des forums