Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Rencontrez Borsalinux-fr aux RMLL à Strasbourg du 7 au 12 juillet

#1 27/08/2018 20:01:04

blackoutsystem
Membre
Inscription : 14/10/2006
Messages : 133

Problème d'affichage après login nvidia

Bonjour,

J'ai une comportement bizarre lié à l'affichage.

j'ai une carte graphique nvidia GeForce GTX 770
installée avec le pilote propriétaire fourni par RPMFusion version 396.45

Lorsque je démarre et que j'arrive sur l'accueil du login tout va bien et lorsque je me logue soudainement plus rien un écran noire même plus d'accès à la console terminale.
Ce symptôme est aléatoire car après plusieurs redémarrage cela fini quand même par fonctionner normalement.
Ce problème ne se présente pas avec le driver nouveau.

Es-ce que quelqu'un a une explication ?

En vous remerciant pour vos suggestions.
Mr. Black

Hors ligne

#2 27/08/2018 20:35:03

Nicosss
Membre
Lieu : Isère
Inscription : 05/03/2007
Messages : 3 990
Site Web

Re : Problème d'affichage après login nvidia

On aurait pu penser à l'effet Wayland au début mais ça reste aléatoire. Du coup du tu utilises quoi comme serveur d'affichage et environnement de bureau ?

Sinon il faudrait jeter un coup d'oeil dans les log pour savoir ce qu'il se passe.

Edit : Correction faute de frappe

Dernière modification par Nicosss (27/08/2018 22:07:02)


F28_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5570 Fanless - 8Go RAM /&/ F28_64 Gnome-Shell - GA-M55S-S3 - Athlon 64 X2 4200+ - GeminII - Ati HD5750 Fanless - 3Go RAM
F28_32 - 939A785GMH/128M - Athlon 64 4000+ - 2Go RAM /&/ F28_32 Gnome-Shell - EeePC 701 - 2Go RAM

Hors ligne

#3 27/08/2018 21:38:12

Refuznik
Membre
Inscription : 31/01/2007
Messages : 6 959

Re : Problème d'affichage après login nvidia

Tu utilises bien xorg au moins (lorsque tu tapes ton mot de passe, la petite roue crantée te donne le choix).

Dernière modification par Refuznik (27/08/2018 22:27:07)

Hors ligne

#4 28/08/2018 17:21:31

pierrotlalune
Membre
Lieu : Estal (46)
Inscription : 31/10/2011
Messages : 625

Re : Problème d'affichage après login nvidia

Bonjour blackoutsystem,
que retourne la commande:

inxi -G

?
Amicalement.
pll

Hors ligne

#5 28/08/2018 18:16:21

chepioq
FEDORA FOR EVER
Lieu : a l'est de marseille
Inscription : 07/06/2006
Messages : 7 201

Re : Problème d'affichage après login nvidia

Ta carte n'est pas supportée par le driver 396.45 (voir ici : https://www.nvidia.fr/Download/driverRe … /137435/fr ).
Il te faut le pilote 390.48 qui est dans les dépôts rpmfusion.


Tout est dans tout... et réciproquement...
C'est quoi un chalumeau??? C'est un dromaludaire à deux bosses...
Quand le sage montre la lune l'imbécile regarde le doigt...
1277887812.gif

Hors ligne

#6 28/08/2018 18:26:28

chepioq
FEDORA FOR EVER
Lieu : a l'est de marseille
Inscription : 07/06/2006
Messages : 7 201

Re : Problème d'affichage après login nvidia

Pourtant quand je regarde ici : https://www.nvidia.fr/download/driverRe … /136246/fr je vois que ta carte est supportée par le 396.45...
Le problème est peut-être ailleurs.


Tout est dans tout... et réciproquement...
C'est quoi un chalumeau??? C'est un dromaludaire à deux bosses...
Quand le sage montre la lune l'imbécile regarde le doigt...
1277887812.gif

Hors ligne

#7 28/08/2018 23:58:52

blackoutsystem
Membre
Inscription : 14/10/2006
Messages : 133

Re : Problème d'affichage après login nvidia

Nicosss a écrit :

On aurait pu penser à l'effet Wayland au début mais ça reste aléatoire. Du coup du tu utilises quoi comme serveur d'affichage et environnement de bureau ?

Sinon il faudrait jeter un coup d'oeil dans les log pour savoir ce qu'il se passe.

Edit : Correction faute de frappe

comment savoir si c'est Wayland ou X11 ? le bureau c'est gnome
Je trouve a quel endroit le log ?

Hors ligne

#8 29/08/2018 00:03:06

blackoutsystem
Membre
Inscription : 14/10/2006
Messages : 133

Re : Problème d'affichage après login nvidia

pierrotlalune a écrit :

Bonjour blackoutsystem,
que retourne la commande:

inxi -G

?
Amicalement.
pll

Graphics:
  Card-1: NVIDIA GK104 [GeForce GTX 770] driver: nvidia v: 396.45
  Display: x11 server: Fedora Project X.org 11.0 driver: nvidia
  resolution: 1920x1080~60Hz
  OpenGL: renderer: GeForce GTX 770/PCIe/SSE2 v: 4.6.0 NVIDIA 396.45

Hors ligne

#9 29/08/2018 07:16:07

Nicosss
Membre
Lieu : Isère
Inscription : 05/03/2007
Messages : 3 990
Site Web

Re : Problème d'affichage après login nvidia

Que retourne

$ echo $WAYLAND_DISPLAY

Si tu n'as rien alors c'est bien X qui tourne sinon tu auras wayland-0.


F28_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5570 Fanless - 8Go RAM /&/ F28_64 Gnome-Shell - GA-M55S-S3 - Athlon 64 X2 4200+ - GeminII - Ati HD5750 Fanless - 3Go RAM
F28_32 - 939A785GMH/128M - Athlon 64 4000+ - 2Go RAM /&/ F28_32 Gnome-Shell - EeePC 701 - 2Go RAM

Hors ligne

#10 03/09/2018 22:10:01

blackoutsystem
Membre
Inscription : 14/10/2006
Messages : 133

Re : Problème d'affichage après login nvidia

Nicosss a écrit :

Que retourne

$ echo $WAYLAND_DISPLAY

Si tu n'as rien alors c'est bien X qui tourne sinon tu auras wayland-0.

Effectivement la commande ne me retourne rien donc je dois avoir x
Comment installé wayland ?

Hors ligne

#11 03/09/2018 22:33:31

Nicosss
Membre
Lieu : Isère
Inscription : 05/03/2007
Messages : 3 990
Site Web

Re : Problème d'affichage après login nvidia

Je ne suis pas bien sûr que le pilote propriétaire Nvidia fasse bon ménage avec Wayland pour le moment.

Il faut consulter les logs pour savoir ce qui ne va pas.


F28_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5570 Fanless - 8Go RAM /&/ F28_64 Gnome-Shell - GA-M55S-S3 - Athlon 64 X2 4200+ - GeminII - Ati HD5750 Fanless - 3Go RAM
F28_32 - 939A785GMH/128M - Athlon 64 4000+ - 2Go RAM /&/ F28_32 Gnome-Shell - EeePC 701 - 2Go RAM

Hors ligne

#12 04/09/2018 23:12:39

blackoutsystem
Membre
Inscription : 14/10/2006
Messages : 133

Re : Problème d'affichage après login nvidia

Nicosss a écrit :

Je ne suis pas bien sûr que le pilote propriétaire Nvidia fasse bon ménage avec Wayland pour le moment.

Il faut consulter les logs pour savoir ce qui ne va pas.

dans quel emplacement je peux trouver les logs ?

Hors ligne

#13 05/09/2018 06:10:14

Nicosss
Membre
Lieu : Isère
Inscription : 05/03/2007
Messages : 3 990
Site Web

Re : Problème d'affichage après login nvidia

Il faut que tu utilises la commande journalctl en tant que root ou installer gnome-logs pour avoir une interface graphique si tu n'es pas trop à l'aise avec le terminal.

Par exemple

# journalctl --since "2018-09-05 05:30:00" --until "2018-09-05 05:40:00"

F28_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5570 Fanless - 8Go RAM /&/ F28_64 Gnome-Shell - GA-M55S-S3 - Athlon 64 X2 4200+ - GeminII - Ati HD5750 Fanless - 3Go RAM
F28_32 - 939A785GMH/128M - Athlon 64 4000+ - 2Go RAM /&/ F28_32 Gnome-Shell - EeePC 701 - 2Go RAM

Hors ligne

#14 08/09/2018 14:27:25

blackoutsystem
Membre
Inscription : 14/10/2006
Messages : 133

Re : Problème d'affichage après login nvidia

Nicosss a écrit :

Il faut que tu utilises la commande journalctl en tant que root ou installer gnome-logs pour avoir une interface graphique si tu n'es pas trop à l'aise avec le terminal.

Par exemple

# journalctl --since "2018-09-05 05:30:00" --until "2018-09-05 05:40:00"

ok j'ai lancé gnome-logs mais je sais pas vraiment ce que je dois rechercher comme type de message lié à l'affichage et sous quel rubrique ?

Hors ligne

#15 08/09/2018 15:28:00

Nicosss
Membre
Lieu : Isère
Inscription : 05/03/2007
Messages : 3 990
Site Web

Re : Problème d'affichage après login nvidia

Commence par cibler la tranche horaire dans laquelle il y a eu un souci.


F28_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5570 Fanless - 8Go RAM /&/ F28_64 Gnome-Shell - GA-M55S-S3 - Athlon 64 X2 4200+ - GeminII - Ati HD5750 Fanless - 3Go RAM
F28_32 - 939A785GMH/128M - Athlon 64 4000+ - 2Go RAM /&/ F28_32 Gnome-Shell - EeePC 701 - 2Go RAM

Hors ligne

#16 09/09/2018 13:57:41

Refuznik
Membre
Inscription : 31/01/2007
Messages : 6 959

Re : Problème d'affichage après login nvidia

Pour information les messages de log et d'erreurs pour xorg la partie graphique sont dans ton dossier .local/share/xorg/

Hors ligne

#17 11/09/2018 20:10:36

blackoutsystem
Membre
Inscription : 14/10/2006
Messages : 133

Re : Problème d'affichage après login nvidia

Merci pour vos suggestions je vais regarder ceci dès que j'aurais un peu de temps

Mr. Black

Dernière modification par blackoutsystem (11/09/2018 20:10:51)

Hors ligne

Pied de page des forums