Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : [Appel à participation] Paris Open Source Summit 2018

#1 10/08/2018 12:08:10

HeyHoLet'sGo
Membre
Lieu : Abilly (37)
Inscription : 05/10/2007
Messages : 155

[Résolu] bug au démarage /dev/fedora/root does not exist

Bonjour à tous

Hier, tout allait bien.
Ce matin, en démarant le système, ça va plutôt mal (heureusement, j'ai un vieil ordi portable préhistorique qui me permet de communiquer avec le monde extérieur)
Voici donc ce que j'ai au démarage après de longues minutes d'attente :

Warning : /dev/fedora/root does not exist
Warning : /dev/mapper/fedora-root does not existe

je n'ai pourtant - à priori - rien fait pour mériter ça : pas de bidouille en root ni dans le bios, ni ailleurs.
Quitte à paraitre idiot ; je ne sais pas comment faire une sauvegarde de /run/initramfs/rdosreport.txt sur une clé usb ou dans /boot comme c'est demandé.

J'ai alors quitté le shell et là :

Warning not all disks have been found
Warning : You might want to regenerate your initramfs

J'ai cherché - peut-être mal - sur le forum mais je n'ai pas trouvé
J'ai bien trouvé ceci   sur gogol mais je ne suis pas plus aidé pour autant. Et je n'ai jamais eu un dual boot windows.

Que faire ?

Merci de votre aide

Dernière modification par HeyHoLet'sGo (10/08/2018 12:08:39)


" En essayant continuellement, on finit par réussir. Donc plus ça rate, plus il y a de chances pour que ça marche "

Hors ligne

#2 10/08/2018 12:34:47

Refuznik
Membre
Inscription : 31/01/2007
Messages : 7 011

Re : [Résolu] bug au démarage /dev/fedora/root does not exist

Mouais c'est pas jojo.
Quant tu es dans le shell commence par vérifier tes disques et partitions sous root avec les commandes :

df 
fdisk -l
et un petit fsck pour la route

Une fois que ça c'est fait et que tu n'as pas d'erreur physique sur ton ou tes disques.
Vérifie ton fichier fstab correspond bien à la ligne /dev/fedora/root
Pour regénérer le initramfs la commande est :

dracut --regenerate-all --force

Il faudra peut-être regénérer le grub avec la commande :

grub2-mkconfig --output=/boot/grub2/grub.cfg

Voilou en espérant que tu arrives à t'en sortir.

Dernière modification par Refuznik (10/08/2018 12:38:08)

Hors ligne

#3 10/08/2018 13:36:28

HeyHoLet'sGo
Membre
Lieu : Abilly (37)
Inscription : 05/10/2007
Messages : 155

Re : [Résolu] bug au démarage /dev/fedora/root does not exist

Merci pour ta réponse.
Mais ça commence mal. J'ai peut-être loupé quelque chose.

Voilà ce que j'ai fait :
Redémarage du PC et je laisse faire...
Bien sur, ça bloque toujours et j'attends jusqu'à accéder au shell
Je me retrouve sous

dracut:/#

j'exécute la première commande

df

et j'ai

sh: df command not found

idem avec fdisk -l

dois-je m'inquiéter ?


" En essayant continuellement, on finit par réussir. Donc plus ça rate, plus il y a de chances pour que ça marche "

Hors ligne

#4 10/08/2018 14:09:44

Refuznik
Membre
Inscription : 31/01/2007
Messages : 7 011

Re : [Résolu] bug au démarage /dev/fedora/root does not exist

Ok, donc tu es sous dracut, je n'avais pas tilté.
Donc essaie de démarrer sous un ancien noyau ou avec l'option rescue pour voir si tu y arrives et lance les commandes donné ou autrement un live cd ou une clef usb.
Ah et rajoutes la commande

lsblk --fs

C'est pour récupérer l'uuid de ta partition /root à comparer avec l'uuid du fichier /etc/fstab.

Dernière modification par Refuznik (10/08/2018 14:19:39)

Hors ligne

#5 10/08/2018 15:24:09

HeyHoLet'sGo
Membre
Lieu : Abilly (37)
Inscription : 05/10/2007
Messages : 155

Re : [Résolu] bug au démarage /dev/fedora/root does not exist

Alors :

[root@localhost-live ~]# df
Filesystem          1K-blocks    Used Available Use% Mounted on
devtmpfs              1978272       0   1978272   0% /dev
tmpfs                 2003932       4   2003928   1% /dev/shm
tmpfs                 2003932    1356   2002576   1% /run
tmpfs                 2003932       0   2003932   0% /sys/fs/cgroup
/dev/sr0              1599512 1599512         0 100% /run/initramfs/live
/dev/mapper/live-rw   6126976 4463120   1647472  74% /
tmpfs                 2003932      28   2003904   1% /tmp
vartmp                2003932       0   2003932   0% /var/tmp
tmpfs                  400784      24    400760   1% /run/user/1000
[root@localhost-live ~]# fdisk -l
Disk /dev/sda: 111.8 GiB, 120034123776 bytes, 234441648 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0xcc25b330

Device     Boot     Start       End   Sectors  Size Id Type
/dev/sda1            2048 218030079 218028032  104G 83 Linux
/dev/sda2       218030080 226334719   8304640    4G 82 Linux swap / Solaris


Disk /dev/sdb: 465.8 GiB, 500107862016 bytes, 976773168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 29BFDCEC-A0E3-4C4E-9A30-DCD5FA4CAB89

Device       Start       End   Sectors   Size Type
/dev/sdb1     2048    432127    430080   210M EFI System
/dev/sdb2   432128   2775039   2342912   1.1G Linux filesystem
/dev/sdb3  2775040 976773119 973998080 464.4G Linux filesystem


The primary GPT table is corrupt, but the backup appears OK, so that will be used.
Disk /dev/sdc: 55.9 GiB, 60022480896 bytes, 117231408 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: C37B9FE9-7F2E-4713-9242-094F5ACD1890

Device     Start       End   Sectors  Size Type
/dev/sdc1   2048 117229567 117227520 55.9G Linux LVM


Disk /dev/loop0: 1.4 GiB, 1543462912 bytes, 3014576 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop1: 6 GiB, 6444548096 bytes, 12587008 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/loop2: 32 GiB, 34359738368 bytes, 67108864 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/mapper/live-rw: 6 GiB, 6444548096 bytes, 12587008 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/mapper/live-base: 6 GiB, 6444548096 bytes, 12587008 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
[root@localhost-live ~]# lsblk --fs
NAME FSTYPE LABEL              UUID                                 MOUNTPOINT
loop0
     squash                                                         
loop1
    ext4   Anaconda           22dab16e-0798-40a2-9c52-fa30c2154313 /
live-base
     ext4   Anaconda           22dab16e-0798-40a2-9c52-fa30c2154313 
loop2
    ext4   TRANSIT SSD120     9590456c-9426-485c-ab8f-264e8d9600a7 
sda2
 swap                      a7cd8763-3611-4b17-ae9b-4e64c1ed7e56 [SWAP]
sdb                                                                 
sdb1
    ext4                      28135b43-fe3b-4126-912f-4b5f6fd06bec 
sdb3
     ext4                      170476d1-86f2-49cb-9e08-d33923d55d2f 
sdc                                                                 
sr0  iso966 Fedora-Cinnamon-Live-27-1-6
                               2017-11-05-07-37-09-00               /run/initr

" En essayant continuellement, on finit par réussir. Donc plus ça rate, plus il y a de chances pour que ça marche "

Hors ligne

#6 10/08/2018 22:55:49

HeyHoLet'sGo
Membre
Lieu : Abilly (37)
Inscription : 05/10/2007
Messages : 155

Re : [Résolu] bug au démarage /dev/fedora/root does not exist

j'ai essayé

dracut --regenerate-all --force

et

grub2-mkconfig --output=/boot/grub2/grub.cfg

retour à la case départ:-(

par contre, j'ai remarqué çà suite à la commande fdisk -l

The primary GPT table is corrupt, but the backup appears OK, so that will be used.

visiblement, ça concerne sdc, mon disque système

C'est confirmé avec gparted

Mes ennuis ne viendraient t'ils pas de là ? et si oui, il y a un moyen de réparer ?

Dernière modification par HeyHoLet'sGo (10/08/2018 23:12:57)


" En essayant continuellement, on finit par réussir. Donc plus ça rate, plus il y a de chances pour que ça marche "

Hors ligne

#7 11/08/2018 11:40:17

HeyHoLet'sGo
Membre
Lieu : Abilly (37)
Inscription : 05/10/2007
Messages : 155

Re : [Résolu] bug au démarage /dev/fedora/root does not exist

Bon, au lieu de tourner autour du pot, je réinstalle.
C'est peut-être ce que j'aurais du faire tout de suite.
Merci tout de même  ; même si je pense qu'il aurait été interressant de savoir si une manip' était possible pour utiliser le backup proposé plus haut.


" En essayant continuellement, on finit par réussir. Donc plus ça rate, plus il y a de chances pour que ça marche "

Hors ligne

#8 11/08/2018 11:57:04

Refuznik
Membre
Inscription : 31/01/2007
Messages : 7 011

Re : [Résolu] bug au démarage /dev/fedora/root does not exist

Tu n'es pas joueur ;)

Hors ligne

#9 11/08/2018 17:12:51

didierg
Modérateur
Modérateur
Inscription : 11/07/2005
Messages : 4 549

Re : [Résolu] bug au démarage /dev/fedora/root does not exist

HeyHoLet'sGo a écrit :

par contre, j'ai remarqué çà suite à la commande fdisk -l

As-tu essayé de voir ce que disait gdisk ?

Hors ligne

#10 13/08/2018 09:30:46

HeyHoLet'sGo
Membre
Lieu : Abilly (37)
Inscription : 05/10/2007
Messages : 155

Re : [Résolu] bug au démarage /dev/fedora/root does not exist

Refuznik a écrit :

Tu n'es pas joueur ;)

ben j'aurais essayé mais il arrive un moment il ou faut savoir s'arrêter  surtout quand on a pas de chance au jeu...

didierg a écrit :

As-tu essayé de voir ce que disait gdisk ?

malheureusement, c'est trop tard, j'ai tout réinstallé. Je sais, c'est la solution de facilité, mais je repars sur du "propre" et tout refonctionne à merveille
.
Cela dit, merci pour votre aide.

Reste une question en suspend (des fois que) :

The primary GPT table is corrupt, but the backup appears OK, so that will be used.

Un conseil  ?


" En essayant continuellement, on finit par réussir. Donc plus ça rate, plus il y a de chances pour que ça marche "

Hors ligne

#11 13/08/2018 10:00:29

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 17 186
Site Web

Re : [Résolu] bug au démarage /dev/fedora/root does not exist

Fait quand même une vérification de l'état de tes unités de stockages avec smartctl disponible dans le paquet smartmontools .

Cela ne mange pas de pain et évitera sans doute des surprises si tes soucis ne sont pas venue de là.

en root (ou avec sudo) :

smartctl -A /dev/sdX

Tu remplace X par la lettre de l'unité de stockage à vérifier.

Tu peux le voir avec gdisk aussi... mais bon.


AMD Ryzen 7 2700X + MSI Gaming Pro Carbon X470, 32Go de RAM DDR4 3000Mhz Gskill Ageia C16, ATI R9 290x 4Go GDDR5
SSD Samsung : 1x 970 NVME (PCI-express 3.0x4) 500Go + 1x 850 EVO 250Go + 2x 860 EVO 500Go / HDD : 1x2To WD black 64Mo + 1x4to WD Black 128Mo + 3To WD red
Boitier GMT Bequiet Dark 900 + Lepa 800W 80+gold

Hors ligne

#12 13/08/2018 11:02:42

HeyHoLet'sGo
Membre
Lieu : Abilly (37)
Inscription : 05/10/2007
Messages : 155

Re : [Résolu] bug au démarage /dev/fedora/root does not exist

voilà le résultat sur le disque système (qui ne contient rien d'autre)

=== START OF READ SMART DATA SECTION ===
SMART Attributes Data Structure revision number: 10
Vendor Specific SMART Attributes with Thresholds:
ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
  1 Raw_Read_Error_Rate     0x0032   120   120   050    Old_age   Always       -       0/0
  5 Retired_Block_Count     0x0033   100   100   003    Pre-fail  Always       -       0
  9 Power_On_Hours_and_Msec 0x0032   088   088   000    Old_age   Always       -       10671h+44m+51.930s
 12 Power_Cycle_Count       0x0032   098   098   000    Old_age   Always       -       2311
171 Program_Fail_Count      0x000a   100   100   000    Old_age   Always       -       0
172 Erase_Fail_Count        0x0032   100   100   000    Old_age   Always       -       0
174 Unexpect_Power_Loss_Ct  0x0030   000   000   000    Old_age   Offline      -       64
177 Wear_Range_Delta        0x0000   000   000   000    Old_age   Offline      -       98
181 Program_Fail_Count      0x000a   100   100   000    Old_age   Always       -       0
182 Erase_Fail_Count        0x0032   100   100   000    Old_age   Always       -       0
187 Reported_Uncorrect      0x0012   100   100   000    Old_age   Always       -       0
189 Airflow_Temperature_Cel 0x0000   026   036   000    Old_age   Offline      -       26 (Min/Max 15/36)
194 Temperature_Celsius     0x0022   026   036   000    Old_age   Always       -       26 (Min/Max 15/36)
195 ECC_Uncorr_Error_Count  0x001c   120   120   000    Old_age   Offline      -       0/0
196 Reallocated_Event_Count 0x0033   100   100   003    Pre-fail  Always       -       0
201 Unc_Soft_Read_Err_Rate  0x001c   120   120   000    Old_age   Offline      -       0/0
204 Soft_ECC_Correct_Rate   0x001c   120   120   000    Old_age   Offline      -       0/0
230 Life_Curve_Status       0x0013   100   100   000    Pre-fail  Always       -       100
231 SSD_Life_Left           0x0013   099   099   010    Pre-fail  Always       -       1
233 SandForce_Internal      0x0032   000   000   000    Old_age   Always       -       1439
234 SandForce_Internal      0x0032   000   000   000    Old_age   Always       -       2313
241 Lifetime_Writes_GiB     0x0032   000   000   000    Old_age   Always       -       2313
242 Lifetime_Reads_GiB      0x0032   000   000   000    Old_age   Always       -       5860

et le résultat pour le disque ou sont /boot/efi  ;  /boot  et ma partition home

ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
  1 Raw_Read_Error_Rate     0x000b   100   100   016    Pre-fail  Always       -       0
  2 Throughput_Performance  0x0005   133   133   054    Pre-fail  Offline      -       138
  3 Spin_Up_Time            0x0007   131   131   024    Pre-fail  Always       -       259 (Average 326)
  4 Start_Stop_Count        0x0012   099   099   000    Old_age   Always       -       4802
  5 Reallocated_Sector_Ct   0x0033   100   100   005    Pre-fail  Always       -       0
  7 Seek_Error_Rate         0x000b   100   100   067    Pre-fail  Always       -       0
  8 Seek_Time_Performance   0x0005   131   131   020    Pre-fail  Offline      -       29
  9 Power_On_Hours          0x0012   097   097   000    Old_age   Always       -       26182
 10 Spin_Retry_Count        0x0013   100   100   060    Pre-fail  Always       -       0
 12 Power_Cycle_Count       0x0032   099   099   000    Old_age   Always       -       4070
192 Power-Off_Retract_Count 0x0032   096   096   000    Old_age   Always       -       4925
193 Load_Cycle_Count        0x0012   096   096   000    Old_age   Always       -       4925
194 Temperature_Celsius     0x0002   200   200   000    Old_age   Always       -       30 (Min/Max 14/46)
196 Reallocated_Event_Count 0x0032   100   100   000    Old_age   Always       -       0
197 Current_Pending_Sector  0x0022   100   100   000    Old_age   Always       -       0
198 Offline_Uncorrectable   0x0008   100   100   000    Old_age   Offline      -       0
199 UDMA_CRC_Error_Count    0x000a   200   200   000    Old_age   Always       

" En essayant continuellement, on finit par réussir. Donc plus ça rate, plus il y a de chances pour que ça marche "

Hors ligne

#13 13/08/2018 16:15:44

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 17 186
Site Web

Re : [Résolu] bug au démarage /dev/fedora/root does not exist

Oki donc tes disques sont considéré comme sain.

Il y a sans doute eu des soucis à un instant T. Cela arrive parfois, voir un souci dans /etc/fstab. Perso je fais toujours une copie de sauvegarde ayant pas mal tendance à y faire des modifications.

le
/dev/mapper/live-rw   6126976 4463120   1647472  74% /
alors que tu dis au début qu'il cherche :
Warning : /dev/fedora/root does not exist
me fait penser à cela... ou alors je le confond avec le lecteur cd?


AMD Ryzen 7 2700X + MSI Gaming Pro Carbon X470, 32Go de RAM DDR4 3000Mhz Gskill Ageia C16, ATI R9 290x 4Go GDDR5
SSD Samsung : 1x 970 NVME (PCI-express 3.0x4) 500Go + 1x 850 EVO 250Go + 2x 860 EVO 500Go / HDD : 1x2To WD black 64Mo + 1x4to WD Black 128Mo + 3To WD red
Boitier GMT Bequiet Dark 900 + Lepa 800W 80+gold

Hors ligne

#14 13/08/2018 20:28:21

HeyHoLet'sGo
Membre
Lieu : Abilly (37)
Inscription : 05/10/2007
Messages : 155

Re : [Résolu] bug au démarage /dev/fedora/root does not exist

Ok.

VINDICATORSs a écrit :

Il y a sans doute eu des soucis à un instant T

Je suis de ton avis. Les mauvais esprits sans doute big_smile

Merci à tous


" En essayant continuellement, on finit par réussir. Donc plus ça rate, plus il y a de chances pour que ça marche "

Hors ligne

Pied de page des forums