Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Rencontrez Borsalinux-fr aux RMLL à Strasbourg du 7 au 12 juillet

#1 07/08/2018 15:57:23

nanou38
Membre
Lieu : Isère
Inscription : 28/02/2008
Messages : 277

[Résolu] vlc : l'image ne défile pas !

Bonjour,

Je viens d'installer vlc.
Avec certaines vidéos, le son défile correctement mais l'image est bloquée sur la première.
Pourtant avec d'autres vidéos (certaines plus grosses et de même format mp4 ou mpg), tout fonctionne correctement.
Je n'ai donc pas l'impression que ça dépende de leur taille ni de leur format.
J'ai appliqué les instructions suivantes et je ne sais plus quoi faire.

# dnf install https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm
# dnf install http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm
# dnf install -y vlc
# dnf install gstreamer-plugins-{bad,ugly} gstreamer-ffmpeg

Est-ce que quelqu'un a une idée de l'origine du problème ?
Je le ou la remercie par avance.
Nanou

Hors ligne

#2 07/08/2018 20:01:33

fedoix
Membre
Inscription : 26/07/2010
Messages : 103
Site Web

Re : [Résolu] vlc : l'image ne défile pas !

Lancer VLC en invite de commande (mode utilisateur) puis rapporter les logs.


Great ! We have snakes under crack !

Hors ligne

#3 07/08/2018 21:10:56

nanou38
Membre
Lieu : Isère
Inscription : 28/02/2008
Messages : 277

Re : [Résolu] vlc : l'image ne défile pas !

Il apparaît cela :

VLC media player 3.0.3 Vetinari (revision 3.0.2-225-gc9e3360dd4)
[000055afc0ddc590] main libvlc: Lancement de vlc avec l'interface par défaut. Utilisez « cvlc » pour démarrer VLC sans interface.
[000055afc0de0550] main playlist: playlist is empty
Gtk-Message: 21:07:42.072: GtkDialog mapped without a transient parent. This is discouraged.
libva info: VA-API version 1.1.0
libva info: va_getDriverName() returns -1
libva error: va_getDriverName() failed with unknown libva error,driver_name=(null)
[00007f4ed414bce0] glconv_vaapi_x11 gl error: vaInitialize: unknown libva error
libva info: VA-API version 1.1.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib64/dri/i965_drv_video.so
libva info: va_openDriver() returns -1
[00007f4ed414bce0] glconv_vaapi_drm gl error: vaInitialize: unknown libva error
libva info: VA-API version 1.1.0
libva info: va_getDriverName() returns 1
libva error: va_getDriverName() failed with operation failed,driver_name=i965
[00007f4ed414bce0] glconv_vaapi_drm gl error: vaInitialize: operation failed
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
[00007f4ee4efd650] avcodec decoder error: more than 5 seconds of late video -> dropping frame (computer too slow ?)
[00007f4ee4efd650] avcodec decoder error: more than 5 seconds of late video -> dropping frame (computer too slow ?)
[00007f4ee4efd650] avcodec decoder error: more than 5 seconds of late video -> dropping frame (computer too slow ?)
QObject::~QObject: Timers cannot be stopped from another thread

Hors ligne

#4 07/08/2018 21:15:07

didierg
Modérateur
Modérateur
Inscription : 11/07/2005
Messages : 4 486

Re : [Résolu] vlc : l'image ne défile pas !

Quelle est ta carte graphique ?

lspci | grep -i vga

Hors ligne

#5 07/08/2018 21:28:11

fedoix
Membre
Inscription : 26/07/2010
Messages : 103
Site Web

Re : [Résolu] vlc : l'image ne défile pas !

Désactiver Wayland.


Great ! We have snakes under crack !

Hors ligne

#6 07/08/2018 23:10:09

nanou38
Membre
Lieu : Isère
Inscription : 28/02/2008
Messages : 277

Re : [Résolu] vlc : l'image ne défile pas !

Voilà ce qui s'affiche pour la carte graphique :

00:02.0 VGA compatible controller: Intel Corporation Device 5a85 (rev 0b)

Hors ligne

#7 07/08/2018 23:14:50

nanou38
Membre
Lieu : Isère
Inscription : 28/02/2008
Messages : 277

Re : [Résolu] vlc : l'image ne défile pas !

Je ne sais pas comment faire pour désactiver Wayland...

dnf remove wayland

????

Hors ligne

#8 08/08/2018 12:32:19

madko
Contributeur Fedora et Linuxé depuis 1994
Modérateur
Lieu : Noisy the Great (9³)
Inscription : 22/12/2006
Messages : 5 911
Site Web

Re : [Résolu] vlc : l'image ne défile pas !

Au login de ta session graphique, tu peux choisir normalement wayland ou xorg (désolé j'ai plus le nom exacte, une recherche dans le forum sinon). Faut cliquer sur la roue dentée...


Linux, ya moins bien, mais c'est plus chèr!!!
Ingénieur Systèmes&Réseaux dans l'OpenSource depuis + de 10 ans

Hors ligne

#9 08/08/2018 13:02:14

didierg
Modérateur
Modérateur
Inscription : 11/07/2005
Messages : 4 486

Re : [Résolu] vlc : l'image ne défile pas !

nanou38 a écrit :

Voilà ce qui s'affiche pour la carte graphique :

00:02.0 VGA compatible controller: Intel Corporation Device 5a85 (rev 0b)

Les paquets libva et libva-intel-hybrid-driver sont-ils installés ?

Il faudrait commencer par faire disparaitre ces erreurs pour avoir le décodage matériel:

libva info: VA-API version 1.1.0
libva info: va_getDriverName() returns -1
libva error: va_getDriverName() failed with unknown libva error,driver_name=(null)
[00007f4ed414bce0] glconv_vaapi_x11 gl error: vaInitialize: unknown libva error

libva info: VA-API version 1.1.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib64/dri/i965_drv_video.so
libva info: va_openDriver() returns -1
[00007f4ed414bce0] glconv_vaapi_drm gl error: vaInitialize: unknown libva error

libva info: VA-API version 1.1.0
libva info: va_getDriverName() returns 1
libva error: va_getDriverName() failed with operation failed,driver_name=i965
[00007f4ed414bce0] glconv_vaapi_drm gl error: vaInitialize: operation failed
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory

Pour vérifier que tout est correct tu peux installer le paquet libva-utils et utiliser la commande vainfo. Cette commande ne doit pas te retourner d'erreur.

Hors ligne

#10 08/08/2018 15:00:05

nanou38
Membre
Lieu : Isère
Inscription : 28/02/2008
Messages : 277

Re : [Résolu] vlc : l'image ne défile pas !

Merci pour votre aide.
Je suis partie quelques jours sans mon ordinateur mais dès mon retour j'essaie les solutions proposées.
Nanou

Hors ligne

#11 08/08/2018 15:06:05

didierg
Modérateur
Modérateur
Inscription : 11/07/2005
Messages : 4 486

Re : [Résolu] vlc : l'image ne défile pas !

nanou38 a écrit :

Merci pour votre aide.
Je suis partie quelques jours sans mon ordinateur mais dès mon retour j'essaie les solutions proposées.
Nanou

On ne doit jamais partir sans son ordinateur !

Bonne vacances !

Hors ligne

#12 09/08/2018 09:45:35

winmandrake
Membre
Inscription : 08/07/2008
Messages : 895

Re : [Résolu] vlc : l'image ne défile pas !

fedoix a écrit :

Désactiver Wayland.

VLC fonctionne parfaitement sous wayland.
A vérifier si tes drivers fonctionnent et éventuellement les options de décodage vidéo dans vlc.


Mon pc : CM GA-970A-UD3P v2 (Gigabyte), AMD FX8320E (4.2Ghz), 24 Go de ram, SSD Samsung 850 EVO (250 Go) + black caviar de 1To et ATI R9 380 2G.

Hors ligne

#13 09/08/2018 14:26:37

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 16 982
Site Web

Re : [Résolu] vlc : l'image ne défile pas !

Astuce qui fonctionne aussi pour les intels : https://doc.fedora-fr.org/wiki/Carte_gr … .C3.A9riel


Intel i7 4771 + MSI Z87-GD65 Gaming, 24Go de RAM DDR3 1866Mhz@2200Mhz Corsair Vengeance C9, ATI R9 290x 4Go GDDR5
Lepa800W 80+gold, SSD Samsung 850 EVO 250Go + 2x2To RAID1 WD black 64Mo + 1x2to WD black 64Mo + 1x4to WD Black 128Mo + 3To WD red

Hors ligne

#14 09/08/2018 16:39:30

tetedecrocro
Membre
Inscription : 09/06/2006
Messages : 107

Re : [Résolu] vlc : l'image ne défile pas !

Bonjour.

Tu peux essayé une modification de configuration dans VLC :
outils > préférences > vidéo > sortie > indiquer X11 (XCB) au lieu de "automatique".


Fedora 28 XFCE
Linux c'est comme visiter une galaxie de planètes mais on ne connait jamais tout, c'est trop vaste.

Hors ligne

#15 Hier 17:04:35

nanou38
Membre
Lieu : Isère
Inscription : 28/02/2008
Messages : 277

Re : [Résolu] vlc : l'image ne défile pas !

Bonjour,

J'ai essayé ceci :

Tu peux essayé une modification de configuration dans VLC :
outils > préférences > vidéo > sortie > indiquer X11 (XCB) au lieu de "automatique".

et maintenant ça marche. lol
Je n'aurais jamais imaginé cette solution toute seule, surtout que sur mon ancien ordinateur la sortie est en automatique et tout fonctionne correctement.

Sinon, pour information, voilà ce que j'ai comme réponse à l'instruction vainfo :

libva info: VA-API version 1.1.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib64/dri/i965_drv_video.so
libva info: va_openDriver() returns -1
vaInitialize failed with error code -1 (unknown libva error),exit

Je ne sais pas trop à quoi ça correspond mais je suppose que tout va bien.
Je vais pouvoir utiliser mon nouvel ordinateur avec la nouvelle version de fedora. lol

Merci à toutes celles et tous ceux qui m'ont aidée sur ce forum.
Nanou

Hors ligne

Pied de page des forums