Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Rencontrez Borsalinux-fr aux RMLL à Strasbourg du 7 au 12 juillet

#1 22/07/2018 12:46:24

gaia
Membre
Inscription : 01/04/2007
Messages : 286
Site Web

[Resolu] spip: page blanche

Salut à tous
J'ai un soucis pour installer spip 3.2.1 sur fedora 28 server.

J'ai telechargé spip 3.2.1 ( ici: https://files.spip.net/spip/stable/spip … 1532186654 ). J'ai lancé l'installation, il me demande ma langue. Ensuite l'accès aux repertoires. Jusque là tout est ok. Mais après cette étape la page est blanche:

http://madns/ulcgtcognac/ecrire/?exec=install

J'ai aussi essayé l'installation à partir de spip loader, avec les trois versions proposées, c'est le même résultat.

Quand je vais sur la page:

http://madns

La page est aussi blanche. Aucune indication "site en travaux".

J'ai utilisé ce contexte SELinux:

#chcon -R -t httpd_sys_rw_content_t tmp/ IMG/ local/ config/

Retour de quelques commandes:

# dnf list php
Dernière vérification de l’expiration des métadonnées effectuée il y a 0:19:21 le dim. 22 juil. 2018 12:08:33 CEST.
Paquets installés
php.i686                                                                                     7.2.7-1.fc28                                                                                     @updates
# dnf list mariadb
Dernière vérification de l’expiration des métadonnées effectuée il y a 0:19:43 le dim. 22 juil. 2018 12:08:33 CEST.
Paquets installés
mariadb.i686                                                                             3:10.2.16-1.fc28                                                                               @updates
# getenforce
Enforcing
#ls -ltotal 120
drwxrwxrwx.  2 apache apache    50 22 juil. 12:07 config
-rw-r--r--.  1 apache apache 35147 22 juil. 12:07 COPYING.txt
drwxr-xr-x. 21 apache apache  4096 22 juil. 12:07 ecrire
-rw-r--r--.  1 apache apache  5243 22 juil. 12:07 htaccess.txt
drwxrwxrwx.  2 apache apache    24 22 juil. 12:07 IMG
-rw-r--r--.  1 apache apache    42 22 juil. 12:07 index.php
-rw-r--r--.  1 apache apache   425 22 juil. 12:07 INSTALL.txt
drwxrwxrwx.  2 apache apache    44 22 juil. 12:07 local
drwxr-xr-x. 27 apache apache  4096 22 juil. 12:07 plugins-dist
drwxr-xr-x. 12 apache apache  4096 22 juil. 12:07 prive
-rwxrwxrwx.  1 apache apache 38495 22 juil. 12:03 spip_loader.php
-rw-r--r--.  1 apache apache  1097 22 juil. 12:07 spip.php
-rw-r--r--.  1 apache apache  1212 22 juil. 12:07 spip.png
drwxr-xr-x. 10 apache apache  4096 22 juil. 12:07 squelettes-dist
-rw-r--r--.  1 apache apache   301 22 juil. 12:07 svn.revision
drwxrwxrwx.  4 apache apache    68 22 juil. 12:31 tmp

J'ai essayé avant de désactiver SElinux, désactiver le pare feux, lancer l'installation en local. Même problème rencontré.
Tout est réactivé. Problème indentique.

Qu'aurais je oublié selon vous?

Cordialement

Dernière modification par gaia (22/07/2018 16:46:58)

Hors ligne

#2 22/07/2018 13:11:00

Nicosss
Membre
Lieu : Isère
Inscription : 05/03/2007
Messages : 3 922
Site Web

Re : [Resolu] spip: page blanche

Le serveur web et la base de données sont démarrés ?

Les logs indiquent quoi ?


F28_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5570 Fanless - 8Go RAM /&/ F27_64 Gnome-Shell - GA-M55S-S3 - Athlon 64 X2 4200+ - GeminII - Ati HD5750 Fanless - 3Go RAM
F27_32 - 939A785GMH/128M - Athlon 64 4000+ - 2Go RAM /&/ F27_32 Gnome-Shell - EeePC 701 - 2Go RAM

Hors ligne

#3 22/07/2018 13:54:54

gaia
Membre
Inscription : 01/04/2007
Messages : 286
Site Web

Re : [Resolu] spip: page blanche

Salut oui ils sont lancés, sinon je n'aurais pas pu commencer le début de l'installation et mon serveur héberge d'autres sites qui fonctionnent actuellement (utilisant PHP, mariadb).



après avoir rechargé la page à 13H38 et 13H40:

Retour httpd/acces_log

192.168.1.xx - - [22/Jul/2018:13:38:53 +0200] "GET /ulcgtcognac/ecrire/?exec=install HTTP/1.1" 500 - "-" "Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0"
192.168.1.xx - - [22/Jul/2018:13:40:27 +0200] "GET /ulcgtcognac/ecrire/?exec=install HTTP/1.1" 500 - "-" "Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0"

rien de nouveau ici:

retour httpd/error_log

[Sun Jul 22 12:02:07.228694 2018] [core:notice] [pid 1035:tid 3078785024] SELinux policy enabled; httpd running as context system_u:system_r:httpd_t:s0
[Sun Jul 22 12:02:07.268500 2018] [suexec:notice] [pid 1035:tid 3078785024] AH01232: suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
AH00558: httpd: Could not reliably determine the server's fully qualified domain name, using localhost.localdomain. Set the 'ServerName' directive globally to suppress this message
[Sun Jul 22 12:02:07.428602 2018] [lbmethod_heartbeat:notice] [pid 1035:tid 3078785024] AH02282: No slotmem from mod_heartmonitor
[Sun Jul 22 12:02:07.467048 2018] [mpm_event:notice] [pid 1035:tid 3078785024] AH00489: Apache/2.4.33 (Fedora) OpenSSL/1.1.0h-fips mod_perl/2.0.10 Perl/v5.26.2 configured -- resuming normal operations
[Sun Jul 22 12:02:07.467174 2018] [core:notice] [pid 1035:tid 3078785024] AH00094: Command line: '/usr/sbin/httpd -D FOREGROUND'

retour mariadb/mariadb.log

2018-07-22 12:02:23 3074061952 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2018-07-22 12:02:23 3074061952 [Note] InnoDB: Uses event mutexes
2018-07-22 12:02:23 3074061952 [Note] InnoDB: Compressed tables use zlib 1.2.11
2018-07-22 12:02:23 3074061952 [Note] InnoDB: Using Linux native AIO
2018-07-22 12:02:23 3074061952 [Note] InnoDB: Number of pools: 1
2018-07-22 12:02:23 3074061952 [Note] InnoDB: Using generic crc32 instructions
2018-07-22 12:02:23 3074061952 [Note] InnoDB: Initializing buffer pool, total size = 128M, instances = 1, chunk size = 128M
2018-07-22 12:02:23 3074061952 [Note] InnoDB: Completed initialization of buffer pool
2018-07-22 12:02:23 2662800192 [Note] InnoDB: If the mysqld execution user is authorized, page cleaner thread priority can be changed. See the man page of setpriority().
2018-07-22 12:02:23 3074061952 [Note] InnoDB: Highest supported file format is Barracuda.
2018-07-22 12:02:23 3074061952 [Note] InnoDB: 128 out of 128 rollback segments are active.
2018-07-22 12:02:23 3074061952 [Note] InnoDB: Creating shared tablespace for temporary tables
2018-07-22 12:02:23 3074061952 [Note] InnoDB: Setting file './ibtmp1' size to 12 MB. Physically writing the file full; Please wait ...
2018-07-22 12:02:23 3074061952 [Note] InnoDB: File './ibtmp1' size is now 12 MB.
2018-07-22 12:02:23 3074061952 [Note] InnoDB: Waiting for purge to start
2018-07-22 12:02:23 3074061952 [Note] InnoDB: 5.7.22 started; log sequence number 1620127
2018-07-22 12:02:23 2650499904 [Note] InnoDB: Loading buffer pool(s) from /var/lib/mysql/ib_buffer_pool
2018-07-22 12:02:23 2650499904 [Note] InnoDB: Buffer pool(s) load completed at 180722 12:02:23
2018-07-22 12:02:23 3074061952 [Note] Plugin 'FEEDBACK' is disabled.
2018-07-22 12:02:23 3074061952 [Warning] mysqld: GSSAPI plugin : default principal 'mariadb/localhost@' not found in keytab
2018-07-22 12:02:23 3074061952 [ERROR] mysqld: Server GSSAPI error (major 851968, minor 2529639093) : gss_acquire_cred failed -Unspecified GSS failure.  Minor code may provide more information. Keytab FILE:/etc/krb5.keytab is nonexistent or empty. 
2018-07-22 12:02:23 3074061952 [ERROR] Plugin 'gssapi' init function returned error.
2018-07-22 12:02:23 3074061952 [Note] Server socket created on IP: '::'.
2018-07-22 12:02:23 3074061952 [Note] Reading of all Master_info entries succeded
2018-07-22 12:02:23 3074061952 [Note] Added new Master_info '' to hash table
2018-07-22 12:02:23 3074061952 [Note] /usr/libexec/mysqld: ready for connections.
Version: '10.2.16-MariaDB'  socket: '/var/lib/mysql/mysql.sock'  port: 3306  MariaDB Server

La page blanche inspire un problème avec PHP!!!! Mais je n'arrive pas à voir où cela pourrait être. L'installation démarre correctement. C'est à la deuxième page que tout deviens blanc. Les autres pages php de mon serveur sont ok. Une partie du retour du phpinfo() :

PHP Version 7.2.7
System|Linux localhost.localdomain 4.16.3-301.fc28.i686 #1 SMP Mon Apr 23 22:00:42 UTC 2018 i686
Build Date|Jun 19 2018 14:40:10
Server API|FPM/FastCGI
Virtual Directory Support|disabled
Configuration File (php.ini) Path|/etc
Loaded Configuration File|/etc/php.ini
Scan this dir for additional .ini files|/etc/php.d
Additional .ini files parsed|/etc/php.d/20-bz2.ini, /etc/php.d/20-calendar.ini, /etc/php.d/20-ctype.ini, /etc/php.d/20-curl.ini, /etc/php.d/20-exif.ini, /etc/php.d/20-fileinfo.ini, /etc/php.d/20-ftp.ini, /etc/php.d/20-gettext.ini, /etc/php.d/20-iconv.ini, /etc/php.d/20-ldap.ini, /etc/php.d/20-mysqlnd.ini, /etc/php.d/20-pdo.ini, /etc/php.d/20-phar.ini, /etc/php.d/20-sockets.ini, /etc/php.d/20-sqlite3.ini, /etc/php.d/20-tokenizer.ini, /etc/php.d/30-mysqli.ini, /etc/php.d/30-pdo_mysql.ini, /etc/php.d/30-pdo_sqlite.ini
PHP API|20170718
PHP Extension|20170718
Zend Extension|320170718
Zend Extension Build|API320170718,NTS
PHP Extension Build|API20170718,NTS
Debug Build|no
Thread Safety|disabled
Zend Signal Handling|enabled
Zend Memory Manager|enabled
Zend Multibyte Support|disabled
IPv6 Support|enabled
DTrace Support|available, disabled
Registered PHP Streams|https, ftps, compress.zlib, php, file, glob, data, http, ftp, compress.bzip2, phar
Registered Stream Socket Transports|tcp, udp, unix, udg, ssl, sslv3, tls, tlsv1.0, tlsv1.1, tlsv1.2
Registered Stream Filters|zlib.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, dechunk, bzip2.*, convert.iconv.*

Hors ligne

#4 22/07/2018 15:23:47

Nicosss
Membre
Lieu : Isère
Inscription : 05/03/2007
Messages : 3 922
Site Web

Re : [Resolu] spip: page blanche

Désolé pour la question un peu bateau mais je voulais m'assurer qu'à la base tout était fonctionnel.

Tu n'aurais pas une extension ou un paramétrage de ton navigateur web qui empêcherait l'affichage à tout hasard ?


F28_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5570 Fanless - 8Go RAM /&/ F27_64 Gnome-Shell - GA-M55S-S3 - Athlon 64 X2 4200+ - GeminII - Ati HD5750 Fanless - 3Go RAM
F27_32 - 939A785GMH/128M - Athlon 64 4000+ - 2Go RAM /&/ F27_32 Gnome-Shell - EeePC 701 - 2Go RAM

Hors ligne

#5 22/07/2018 15:56:08

gaia
Membre
Inscription : 01/04/2007
Messages : 286
Site Web

Re : [Resolu] spip: page blanche

J'ai essayé avec Midori de mon pc et directement sur le serveur avec Lynx, c'est pareil.

Je sèche complétement.

Je suis sure que c'est lié à mon installation, bien que classique. Mais je ne vois pas où.

Hors ligne

#6 22/07/2018 16:27:39

Refuznik
Membre
Inscription : 31/01/2007
Messages : 6 920

Re : [Resolu] spip: page blanche

Dans ton Retour httpd/acces_log tu as une erreur 500.
Tu utilises php 7.2.7 qui n'est pas compatible spip 3.2 voir ici ==> https://www.spip.net/fr_article4351.html

Hors ligne

#7 22/07/2018 16:46:35

gaia
Membre
Inscription : 01/04/2007
Messages : 286
Site Web

Re : [Resolu] spip: page blanche

Après avoir installé php-xml tout est ok.

Toutefois je reviendrais dans ce poste pour donner quelques détails, car installer spip avec Fedora n'est pas d'une simplicitée enfantine.

Je ne suis pas arrivé à activer spip_loader, j'ai due telecharger le zip.
J'ai fais des test à part, pour que spip_loader fonctionne, j'ai due mettre selinux en permissive. Mais l'idéal serait quand même de créer le bon profile selinux. si quelqu'un le connais, je suis peneur.

Hors ligne

#8 22/07/2018 16:48:21

gaia
Membre
Inscription : 01/04/2007
Messages : 286
Site Web

Re : [Resolu] spip: page blanche

merci à refuznik et nicoss

Hors ligne

Pied de page des forums