Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : [Appel à participation] Paris Open Source Summit 2018

#1 23/05/2018 15:34:09

pplemoco
Membre
Inscription : 29/01/2018
Messages : 39

problème de connexion avec wayland

bonjour
depuis la mise à jour faite le 21 mai (arrivée du kernel 4.16.9), impossible de se connecter avec gnome wayland : après la saisie du mot de passe, ça fige un moment puis ça revient à l'écran de connexion.
si je choisi la version avec x.org, ça marche.
aujourd'hui, il y a eu une nouvelle maj, qui ne résoud pas le problème, donc je le signale.
mais même si je choisi de booter avec le précédent, le 4.16.8, ça ne marche pas en wayland, alors que ça marchait avant la maj du 21.
suis je le seul à avoir ce petit souci ?

Hors ligne

#2 23/05/2018 15:45:55

madko
Contributeur Fedora et Linuxé depuis 1994
Modérateur
Lieu : Noisy the Great (9³)
Inscription : 22/12/2006
Messages : 6 177
Site Web

Re : problème de connexion avec wayland

Bonjour,

tu l'as signalé sur le bugzilla redhat c'est ça ?

En tout cas pas de soucis ici. Quelle carte graphique ?


Linux, ya moins bien, mais c'est plus chèr!!!
Ingénieur Systèmes&Réseaux dans l'OpenSource depuis + de 10 ans

Hors ligne

#3 23/05/2018 15:59:33

pplemoco
Membre
Inscription : 29/01/2018
Messages : 39

Re : problème de connexion avec wayland

madko a écrit :

Bonjour,

tu l'as signalé sur le bugzilla redhat c'est ça ?

En tout cas pas de soucis ici. Quelle carte graphique ?

Non, je le signale juste ici, le bugzilla de redhat, je ne le connais pas!
J'imagine qu'il doit falloir être inscrit et décrire le problème en anglais!
la carte vidéo est NVIDIA G94 GeForce 9600GS

Hors ligne

#4 23/05/2018 16:09:39

madko
Contributeur Fedora et Linuxé depuis 1994
Modérateur
Lieu : Noisy the Great (9³)
Inscription : 22/12/2006
Messages : 6 177
Site Web

Re : problème de connexion avec wayland

En effet, il faut être inscrit et écrire le rapport en anglais pour que les développeurs/packagers puissent comprendre quelques chose. https://doc.fedora-fr.org/wiki/Apprendr … r_un_bogue


Linux, ya moins bien, mais c'est plus chèr!!!
Ingénieur Systèmes&Réseaux dans l'OpenSource depuis + de 10 ans

Hors ligne

#5 23/05/2018 16:25:58

pplemoco
Membre
Inscription : 29/01/2018
Messages : 39

Re : problème de connexion avec wayland

Ok merci pour le lien!
mais maintenant, j'ai pas le temps de me plonger là dedans, d'autant que c'est pas bloquant!
en fait, wayland ou x.org, je ne vois pas la différence;
une prochaine maj règlera peut être le problème!
sinon, je regarderais la chose plus en détails plus tard!

Hors ligne

#6 23/05/2018 16:40:41

madko
Contributeur Fedora et Linuxé depuis 1994
Modérateur
Lieu : Noisy the Great (9³)
Inscription : 22/12/2006
Messages : 6 177
Site Web

Re : problème de connexion avec wayland

je comprend. Peut-être que d'autres sur le forum auront le même soucis aussi on verra. On croise les doigts pour que ça soit vite régler quand même.


Linux, ya moins bien, mais c'est plus chèr!!!
Ingénieur Systèmes&Réseaux dans l'OpenSource depuis + de 10 ans

Hors ligne

#7 23/05/2018 19:27:10

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 17 186
Site Web

Re : problème de connexion avec wayland

Je dirais fichier de configuration utilisateur foireux... Test avec un nouvel autre utilisateur et regarde si c'est toujours le cas.

Si c'est ok, tu renomme les répertoires de configuration de l'utilisateur .config et .local en autre chose (SUPPRIME PAS! Tu peux les copier ailleurs en gardant les permission avec l'option "-p" de cp par exemple) et relance ta session avec cet utilisateur. Cela vas recréer les fichiers de configuration, il suffira de recopier ce dont tu as besoin et qui est sauvegardé dans ces répertoires de configuration tout beau tout neuf.


AMD Ryzen 7 2700X + MSI Gaming Pro Carbon X470, 32Go de RAM DDR4 3000Mhz Gskill Ageia C16, ATI R9 290x 4Go GDDR5
SSD Samsung : 1x 970 NVME (PCI-express 3.0x4) 500Go + 1x 850 EVO 250Go + 2x 860 EVO 500Go / HDD : 1x2To WD black 64Mo + 1x4to WD Black 128Mo + 3To WD red
Boitier GMT Bequiet Dark 900 + Lepa 800W 80+gold

Hors ligne

#8 23/05/2018 23:17:57

pplemoco
Membre
Inscription : 29/01/2018
Messages : 39

Re : problème de connexion avec wayland

Bien vu Vindicators

avec un nouveau user, ça marche;
donc, c'est surement une extensions gnome qui doit poser problème, le tout est de découvrir laquelle;

merci pour la réponse

Hors ligne

#9 24/05/2018 07:31:53

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 17 186
Site Web

Re : problème de connexion avec wayland

N'hésite pas à suivre la procédure que je t'ai indiqué.
Tu recopie petit à petit les fichiers/dossier de conf qui te servent des différents répertoires si besoin. Cela peut t'amener à croiser le fichier incriminé, mais bon il vaut mieux refaire les réglages que de reprendre ce qui était fait avant.

Dernière modification par VINDICATORs (24/05/2018 07:32:43)


AMD Ryzen 7 2700X + MSI Gaming Pro Carbon X470, 32Go de RAM DDR4 3000Mhz Gskill Ageia C16, ATI R9 290x 4Go GDDR5
SSD Samsung : 1x 970 NVME (PCI-express 3.0x4) 500Go + 1x 850 EVO 250Go + 2x 860 EVO 500Go / HDD : 1x2To WD black 64Mo + 1x4to WD Black 128Mo + 3To WD red
Boitier GMT Bequiet Dark 900 + Lepa 800W 80+gold

Hors ligne

#10 27/05/2018 16:30:56

Franck35
Membre
Lieu : Rennes
Inscription : 23/11/2017
Messages : 60

Re : problème de connexion avec wayland

Bonjour,

Je rencontre un soucis similaire au tien, en fait en connexion multi utilisateur impossible de reconnecter sur un ID ca fige et reviens à l'invite de connexion
J'ai désinstallé toutes les extensions sans aucuns résultats ...

A tu toi de ton coté pu trouver une solution ?

Merci de ta réponse,
Franck

pplemoco a écrit :

bonjour
depuis la mise à jour faite le 21 mai (arrivée du kernel 4.16.9), impossible de se connecter avec gnome wayland : après la saisie du mot de passe, ça fige un moment puis ça revient à l'écran de connexion.
si je choisi la version avec x.org, ça marche.
aujourd'hui, il y a eu une nouvelle maj, qui ne résoud pas le problème, donc je le signale.
mais même si je choisi de booter avec le précédent, le 4.16.8, ça ne marche pas en wayland, alors que ça marchait avant la maj du 21.
suis je le seul à avoir ce petit souci ?

Hors ligne

#11 28/05/2018 14:56:02

pplemoco
Membre
Inscription : 29/01/2018
Messages : 39

Re : problème de connexion avec wayland

Bonjour
comme ça marchait avec x.org, je me suis pas trop énervé, et puis j'avais d'autre truc à faire;
hier nouvelle maj, avec le kernel 4.16.11 (j'ai du rater le 10 ou alors on est passé de 9 à 11 directement?)

toujours le même problème, connection avec mon UID impossible en wayland mais possible avec x.org et aussi possible en wayland avec une UID toute neuve;

j'ai désactivé 2 extensions dont je ne me sert pas en fait via le tweaktool rebaptisé Ajustement;
puis dans .local/share/gnome-shell/extensions, j'ai fait du ménage, soit supprimé 5 dossiers avec la commande "rm -rf le_nom_de_l_extension";
(les 2 désactivées et 3 autres déjà désactivées avant)
toujours le même problème!
MAIS
logé avec le user de secours avec wayland, au lieu de rebooter j'ai juste changé de session avec mon UID, et là ça marche avec wayland;
et aujourd'hui, j'ai démarré directement avec mon UID en wayland et ça marche!

j'ai pas bien compris pourquoi ni comment!
en passant par l'UID de secours et un changement de session ça a remis les choses en ordre!

Hors ligne

#12 06/06/2018 13:22:33

pplemoco
Membre
Inscription : 29/01/2018
Messages : 39

Re : problème de connexion avec wayland

Bonjour
ça a remis les choses en ordre, provisoirement;
avec l'arrivée du nouveau noyau, 4.16.13, rebelote!
la connexion avec mon user est impossible, mais en passant par le user de secours, ça marche, puis en faisant une fermeture de session, alors la connexion avec mon user est possible;
c'est pas bien grave puisque j'ai une solution de contournement facile, mais ça reste un problème!
bonne journée

Hors ligne

#13 06/06/2018 13:31:43

Franck35
Membre
Lieu : Rennes
Inscription : 23/11/2017
Messages : 60

Re : problème de connexion avec wayland

Bonjour, merci pour tes retours

qu'entends tu par user de secours ??? le compte root ?

J'ai tenté ce que tu avais fait et pour moi aucune amélioration, plus de session multiples ...
si je ferme les sessions aucuns soucis par contre si j'ouvre deux cessions simultanément à la reconnexion de l'une d'elle je ne peux plus me reconnecter sur aucune ... reboot obligatoire



pplemoco a écrit :

Bonjour
ça a remis les choses en ordre, provisoirement;
avec l'arrivée du nouveau noyau, 4.16.13, rebelote!
la connexion avec mon user est impossible, mais en passant par le user de secours, ça marche, puis en faisant une fermeture de session, alors la connexion avec mon user est possible;
c'est pas bien grave puisque j'ai une solution de contournement facile, mais ça reste un problème!
bonne journée

Hors ligne

#14 06/06/2018 14:19:36

pplemoco
Membre
Inscription : 29/01/2018
Messages : 39

Re : problème de connexion avec wayland

par user de secours, j'entends simplement un user normal, sans droits particuliers, que j'ai appelé "pompier", il a son /home/pompier, vide puisque je ne m'en sert que pour ça!
j'ai aussi un vrai compte "root", puisque je suis de l'ancienne mode (on n'est pas sur ubuntu mdr !), avec son propre password;
et je ne m'en sert qu'en "terminal"; je n'utilise jamais le "sudo";

par contre, je n'ai jamais lancé plusieurs session différentes en même temps ? je ne comprends pas ?
je me loge avec "pompier", puis je ferme la session (avec gnome), je me retrouve sur gdm le loggin, et je me loge avec mon user habituel;

Hors ligne

#15 06/06/2018 14:22:17

Franck35
Membre
Lieu : Rennes
Inscription : 23/11/2017
Messages : 60

Re : problème de connexion avec wayland

Ok,

J'ai tenté avec un user normal que j'ai recrée en utilisateur normal aussi et moi j'ai le même phénomène ...

Merci pour ta réponse ...

j'attends un correctif avec impatience ...

pplemoco a écrit :

par user de secours, j'entends simplement un user normal, sans droits particuliers, que j'ai appelé "pompier", il a son /home/pompier, vide puisque je ne m'en sert que pour ça!
j'ai aussi un vrai compte "root", puisque je suis de l'ancienne mode (on n'est pas sur ubuntu mdr !), avec son propre password;
et je ne m'en sert qu'en "terminal"; je n'utilise jamais le "sudo";

par contre, je n'ai jamais lancé plusieurs session différentes en même temps ? je ne comprends pas ?
je me loge avec "pompier", puis je ferme la session (avec gnome), je me retrouve sur gdm le loggin, et je me loge avec mon user habituel;

Hors ligne

#16 06/06/2018 15:01:57

pplemoco
Membre
Inscription : 29/01/2018
Messages : 39

Re : problème de connexion avec wayland

continuations ...
depuis peu, je me suis rendu compte del'apparition d'une version "wayland" de firefox;
comme j'utilise gnome en wayland, je me suis dit je vais l'adopter;
et il me semble d'ailleurs que c'est plus réactif, l'ensemble gnome + firefox, tout deux en wayland;

seulement voilà, tant que j'ai utilisé le firefox classique, le passage par "pompier", le user de secours n'était nécessaire qu'une seule fois; ça réparait le truc de façon pérenne, jusqu'à la nouvelle arrivée d'un kernel;
mais, ce coup ci, ça n'a pas réparré, il m'a fallu repasser chaque fois par "pompier" pour pouvoir me logger en wayland avec mon user;
je me suis dit, tient ce nouveau firefox a modifié le comportement;
donc, j'ai lancé une navigation avec l'ancien firefox;
puis j'ai rebooté, et la connexion directe avec mon user a été possible;
pas besoin ce coup là de passer par "pompier";
conclusions :
après l'arrivée d'un nouveau noyau, la connexion en wayland à mon compte est impossible : ça fige!
si je me connecte avec un user de secours normal, ça marche, il me suffit ensuite de faire une fermeture de session et de me relogger avec mon user;
ET
si j'utilise firefox ancien, la réparation est pérenne, tant que l'on ne change pas de kernel; ça veut dire qu'ensuite je peut me logger directement avec mon user normal;
mais si j'utilise firefox - wayland alors, il me faut systématiquement passer par le user de secours, la connexion avec mon user étant toujours impossible.

voilà ce que j'ai remarqué, si ça peut aider!

Hors ligne

#17 05/10/2018 22:21:52

pplemoco
Membre
Inscription : 29/01/2018
Messages : 39

Re : problème de connexion avec wayland

bonjour
je relance ce post parce que le problème demeure;
agacé par les soucis relatés plus haut, j'étais resté sur X.org et tout fonctionne;
hier avec l'arrivée du noyau 4.18.10; au reboot, je me suis dis : "si je testais avec wayland pour voir";
ça fige au niveau de gdm, après l'entrée du password;
je n'ai pas tenté la manip avec "pompier", j'ai juste repassé sur X.org, puisque ça marche ainsi.

de toute façon, côté firefox, il n'y en plus qu'un (la période où il y avait le choix fut de courte durée), et il marche bien avec X.org.

bonne soirée

Hors ligne

#18 06/10/2018 05:42:58

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 17 186
Site Web

Re : problème de connexion avec wayland

A part au niveau pilotes graphique, le noyau n'a rien a voir avec wayland.


AMD Ryzen 7 2700X + MSI Gaming Pro Carbon X470, 32Go de RAM DDR4 3000Mhz Gskill Ageia C16, ATI R9 290x 4Go GDDR5
SSD Samsung : 1x 970 NVME (PCI-express 3.0x4) 500Go + 1x 850 EVO 250Go + 2x 860 EVO 500Go / HDD : 1x2To WD black 64Mo + 1x4to WD Black 128Mo + 3To WD red
Boitier GMT Bequiet Dark 900 + Lepa 800W 80+gold

Hors ligne

Pied de page des forums