Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Rencontrez Borsalinux-fr aux RMLL à Strasbourg du 7 au 12 juillet

#1 06/05/2018 12:47:09

tosca
Membre
Lieu : Cévennes
Inscription : 08/09/2010
Messages : 1 649
Site Web

[Résolu] Pas/plus de connexion entre applications Android et Fedora

Bonjour,

J'expose ici 2 problèmes dont je ne sais si ils sont vraiment liés. Mais, vu de ma fenêtre, ils semblent relever de processus similaires, bien que les applications et appareils mobiles soient différents.

1. La connexion de Calibre Companion avec Calibre laptop ne se fait plus

Calibre Companion est installé sur une tablette Kodak 7" sous Android
Calibre sur l'ordinateur sous Fedora (F26 jusqu'à hier, et F27 maintenant).

Ça faisait un moment que je n'avais pas utilisé la connexion entre les 2 applis, mais elle avait toujours fonctionné sans problème ... jusqu'à il y a 2 jours, où je me suis retrouvée en "Echec de connexion" :
message Calibre Companion

Vu du côté Calibre :

paramètres Calibre

Quelques recherches en ligne m'ont convaincues que la première des choses à faire était de disposer de la dernière version de Calibre, d'où upgrade hier vers F27, qui n'a rien résolu pour ce qui concerne ce défaut de connexion.


2. Clementine Remote ne se connecte pas avec Clementine

J'ai installé hier Clementine (en liaison avec l'upgrade F27, car Gmusicbrowser n'était plus supporté) sous Fedora
et, dans la foulée, Clementine Remote sur mon smartphone Android.

Là encore, problème de connexion avec le laptop, sans que je comprenne pourquoi :

problème connexion Clementine Remote

et le paramétrage côté Clementine :

paramètres Clementine


Je suis preneuse de toute piste, car je n'ai pas trouvé beaucoup d'infos en ligne pour des processus qui seraient apparemment évidents ! roll

Merci pour votre aide.


Toshiba 64 bits sous Fedora27 - Cinnamon
Mon principal site : Photographe en Cévennes

Hors ligne

#2 06/05/2018 12:49:31

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 16 914
Site Web

Re : [Résolu] Pas/plus de connexion entre applications Android et Fedora

Ce n'est pas simplement un problème de certificat?

Et en renommant le répertoire/fichiers de configuration?


Intel i7 4771 + MSI Z87-GD65 Gaming, 24Go de RAM DDR3 1866Mhz@2200Mhz Corsair Vengeance C9, ATI R9 290x 4Go GDDR5
Lepa800W 80+gold, SSD Samsung 850 EVO 250Go + 2x2To RAID1 WD black 64Mo + 1x2to WD black 64Mo + 1x4to WD Black 128Mo + 3To WD red

Hors ligne

#3 06/05/2018 13:12:46

tosca
Membre
Lieu : Cévennes
Inscription : 08/09/2010
Messages : 1 649
Site Web

Re : [Résolu] Pas/plus de connexion entre applications Android et Fedora

VINDICATORs a écrit :

Ce n'est pas simplement un problème de certificat?

Et en renommant le répertoire/fichiers de configuration?

Pas compris de quoi tu parles. Ça se trouve où ? Ça s'appelle comment ?


Toshiba 64 bits sous Fedora27 - Cinnamon
Mon principal site : Photographe en Cévennes

Hors ligne

#4 06/05/2018 13:58:05

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 16 914
Site Web

Re : [Résolu] Pas/plus de connexion entre applications Android et Fedora

Normalement c'est dans les fichiers cachés (suffit de les afficher).
Voir .config ou .locale (voir les deux). Suffit de renommer ce qui concerne "Clementine" et refaire la configuration/synchro.

Pense à renommer plutôt que supprimer, cela permettra de revenir en arrière si besoin.


Intel i7 4771 + MSI Z87-GD65 Gaming, 24Go de RAM DDR3 1866Mhz@2200Mhz Corsair Vengeance C9, ATI R9 290x 4Go GDDR5
Lepa800W 80+gold, SSD Samsung 850 EVO 250Go + 2x2To RAID1 WD black 64Mo + 1x2to WD black 64Mo + 1x4to WD Black 128Mo + 3To WD red

Hors ligne

#5 06/05/2018 16:25:07

tosca
Membre
Lieu : Cévennes
Inscription : 08/09/2010
Messages : 1 649
Site Web

Re : [Résolu] Pas/plus de connexion entre applications Android et Fedora

VINDICATORs a écrit :

Voir .config ou .locale (voir les deux). Suffit de renommer ce qui concerne "Clementine" et refaire la configuration/synchro.

Je l'ai fait pour les 2 logiciels dans .config, et ça ne marche ni pour l'un, ni pour l'autre. Dans .local, il n'y a rien pour aucun des deux.


Toshiba 64 bits sous Fedora27 - Cinnamon
Mon principal site : Photographe en Cévennes

Hors ligne

#6 06/05/2018 17:33:34

madko
Contributeur Fedora et Linuxé depuis 1994
Modérateur
Lieu : Noisy the Great (9³)
Inscription : 22/12/2006
Messages : 5 857
Site Web

Re : [Résolu] Pas/plus de connexion entre applications Android et Fedora

Peut être le parefeu qui bloquerait ça?


Linux, ya moins bien, mais c'est plus chèr!!!
Ingénieur Systèmes&Réseaux dans l'OpenSource depuis + de 10 ans

Hors ligne

#7 06/05/2018 19:32:13

tosca
Membre
Lieu : Cévennes
Inscription : 08/09/2010
Messages : 1 649
Site Web

Re : [Résolu] Pas/plus de connexion entre applications Android et Fedora

madko a écrit :

Peut être le parefeu qui bloquerait ça?

Je ne sais pas à quoi ça ressemble ... en tout cas, je n'ai jamais activé un tel truc volontairement.
Que peut-on vérifier, et comment ?
Est-ce qu'il n'y aurait pas de message d'erreur si le blocage venait de là ?


Toshiba 64 bits sous Fedora27 - Cinnamon
Mon principal site : Photographe en Cévennes

Hors ligne

#8 06/05/2018 19:49:06

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 16 914
Site Web

Re : [Résolu] Pas/plus de connexion entre applications Android et Fedora

Dans les logs.

sinon tu tape exactement :

su -lc 'systemctl stop firewalld'

Et tu test.

Si cela ne fait rien tu tape la même chose, mais avec start à la place de stop.


Intel i7 4771 + MSI Z87-GD65 Gaming, 24Go de RAM DDR3 1866Mhz@2200Mhz Corsair Vengeance C9, ATI R9 290x 4Go GDDR5
Lepa800W 80+gold, SSD Samsung 850 EVO 250Go + 2x2To RAID1 WD black 64Mo + 1x2to WD black 64Mo + 1x4to WD Black 128Mo + 3To WD red

Hors ligne

#9 06/05/2018 20:41:23

tosca
Membre
Lieu : Cévennes
Inscription : 08/09/2010
Messages : 1 649
Site Web

Re : [Résolu] Pas/plus de connexion entre applications Android et Fedora

VINDICATORs a écrit :
su -lc 'systemctl stop firewalld'

Et tu test.

Ça le fait ! Aussi bien pour Clementine que pour Calibre. big_smile

Comment fait-on pour résoudre ça de manière plus pérenne, sans devoir systématiquement arrêter le firewall ?
Sachant que dans les logs de firewalld, je trouve ceci :

2018-05-06 16:01:44 WARNING: FedoraServer: INVALID_SERVICE: cockpit

(répété à peu près autant de fois que j'ai du essayer d'établir une connexion pour l'un ou l'autre des programmes).


Toshiba 64 bits sous Fedora27 - Cinnamon
Mon principal site : Photographe en Cévennes

Hors ligne

#10 06/05/2018 21:20:06

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 16 914
Site Web

Re : [Résolu] Pas/plus de connexion entre applications Android et Fedora

Parce que cockpit (pour gérer le système à distance, mais bon là ont parle d'administration système) n'est pas là mais que le service est activé.

Du coup il faut trouver les ports exploité par clementine/calibre pour les ouvrir.

Il me semble que c'est le 8080 : https://manual.calibre-ebook.com/server.html

Du coup tu peux voir avec :

su -lc 'firewall-cmd --permanent --add-service=jenkins && firewall-cmd --reload'

Car il ouvre le port 8080.

Pour désactiver cockpit déjà regarde si il est lancé :

systemctl status cockpit

Si ce n'est pas le cas tu peux désactiver la règle du pare feu :

su -lc 'firewall-cmd --permanent --delete-service=cockpit && firewall-cmd --reload'

Pour information, cockpit utilise par défaut le port 9090.

Tu peux bien sur utiliser l'outil graphique du pare feu, mais n'oublie pas d'utiliser "permanent" si tu veux que la règle reste en permanence, sinon elle sera supprimé si tu relance l'ordi ou le service.

Dernière modification par VINDICATORs (06/05/2018 21:32:04)


Intel i7 4771 + MSI Z87-GD65 Gaming, 24Go de RAM DDR3 1866Mhz@2200Mhz Corsair Vengeance C9, ATI R9 290x 4Go GDDR5
Lepa800W 80+gold, SSD Samsung 850 EVO 250Go + 2x2To RAID1 WD black 64Mo + 1x2to WD black 64Mo + 1x4to WD Black 128Mo + 3To WD red

Hors ligne

#11 07/05/2018 11:02:23

madko
Contributeur Fedora et Linuxé depuis 1994
Modérateur
Lieu : Noisy the Great (9³)
Inscription : 22/12/2006
Messages : 5 857
Site Web

Re : [Résolu] Pas/plus de connexion entre applications Android et Fedora

Si ton PC est toujours derrière une BOX, et que tu n'as pas d'IPV6 publique, tu peux couper le parefeu:

sudo systemctl disable firewalld

Sinon le plus simple c'est de trouver en effet les ports utilisés par tes appli:

sudo lsof -i

Tu devrais y voir les process et leurs ports en écoute.

Ensuite ajouter les ports (plutôt que des services difficile à deviner car sans rapport):

sudo firewall-cmd --add-port=8080/tcp

(ici avec le port 8080)
Si ça fonctionne, tu peux rendre la règle permanente en la retapant avec l'option --permanent en plus:

sudo firewall-cmd --add-port=8080/tcp --permanent

Dans la section doc ya un gros article sur firewalld. Il doit y avoir une interface graphique mais je ne la connais pas.


Linux, ya moins bien, mais c'est plus chèr!!!
Ingénieur Systèmes&Réseaux dans l'OpenSource depuis + de 10 ans

Hors ligne

#12 07/05/2018 11:47:58

Refuznik
Membre
Inscription : 31/01/2007
Messages : 6 884

Re : [Résolu] Pas/plus de connexion entre applications Android et Fedora

L'interface graphique c'est firewall-config tout simplement.
Mais il suffit de taper firewall dans l'outil de recherche et il te le sort.

Hors ligne

#13 07/05/2018 11:52:41

tosca
Membre
Lieu : Cévennes
Inscription : 08/09/2010
Messages : 1 649
Site Web

Re : [Résolu] Pas/plus de connexion entre applications Android et Fedora

madko a écrit :

Si ton PC est toujours derrière une BOX, et que tu n'as pas d'IPV6 publique, tu peux couper le parefeu:

sudo systemctl disable firewalld

Ça me va très bien comme solution. C'est pérenne, ou il faut le refaire après chaque redémarrage du système ?


Toshiba 64 bits sous Fedora27 - Cinnamon
Mon principal site : Photographe en Cévennes

Hors ligne

#14 07/05/2018 11:56:20

tosca
Membre
Lieu : Cévennes
Inscription : 08/09/2010
Messages : 1 649
Site Web

Re : [Résolu] Pas/plus de connexion entre applications Android et Fedora

C'est normal cette réponse ?

# systemctl disable firewalld
Removed /etc/systemd/system/dbus-org.fedoraproject.FirewallD1.service.
Removed /etc/systemd/system/basic.target.wants/firewalld.service.

Toshiba 64 bits sous Fedora27 - Cinnamon
Mon principal site : Photographe en Cévennes

Hors ligne

#15 07/05/2018 11:58:25

tosca
Membre
Lieu : Cévennes
Inscription : 08/09/2010
Messages : 1 649
Site Web

Re : [Résolu] Pas/plus de connexion entre applications Android et Fedora

Refuznik a écrit :

L'interface graphique c'est firewall-config tout simplement.
Mais il suffit de taper firewall dans l'outil de recherche et il te le sort.

C'est aussi accessible via le menu Paramètre système de l'utilisateur (sous Cinnamon) mais ça ne rend pas l'outil plus simple à utiliser pour autant !


Toshiba 64 bits sous Fedora27 - Cinnamon
Mon principal site : Photographe en Cévennes

Hors ligne

#16 07/05/2018 14:08:56

madko
Contributeur Fedora et Linuxé depuis 1994
Modérateur
Lieu : Noisy the Great (9³)
Inscription : 22/12/2006
Messages : 5 857
Site Web

Re : [Résolu] Pas/plus de connexion entre applications Android et Fedora

Pour le retour de ta commande systemctl disable firewalld oui c'est normal. Il supprime les liens symboliques, du coup c'est pérenne et le service ne démarrera plus au boot.

Pour faire un retour arrière (on sait jamais):

sudo systemctl enable firewalld

(bon c'est assez evident mais ça coûte rien de l’écrire)


Linux, ya moins bien, mais c'est plus chèr!!!
Ingénieur Systèmes&Réseaux dans l'OpenSource depuis + de 10 ans

Hors ligne

#17 07/05/2018 14:12:34

tosca
Membre
Lieu : Cévennes
Inscription : 08/09/2010
Messages : 1 649
Site Web

Re : [Résolu] Pas/plus de connexion entre applications Android et Fedora

madko a écrit :

Pour le retour de ta commande systemctl disable firewalld oui c'est normal. Il supprime les liens symboliques, du coup c'est pérenne et le service ne démarrera plus au boot.

Pour faire un retour arrière (on sait jamais):

sudo systemctl enable firewalld

(bon c'est assez evident mais ça coûte rien de l’écrire)

Merci pour tes précisions. wink


Toshiba 64 bits sous Fedora27 - Cinnamon
Mon principal site : Photographe en Cévennes

Hors ligne

Pied de page des forums