Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Venez essayer Fedora 29 en version finale

#1 16/03/2018 09:14:50

omer666
Membre
Inscription : 17/07/2009
Messages : 85

[Résolu] Problème de suivi des modifications de fichiers

Bonjour,

J'ai remarqué il y a peu que les fichiers modifiés ne se mettent plus à jour en temps réel. Par exemple, dans une fenêtre de Nautilus, si je télécharge un fichier dans un répertoire déjà ouvert, il faut que j'actualise le répertoire pour qu'il apparaisse une fois le téléchargement terminé.

Dans le doute j'ai désinstallé Inkscape dont gamin est une dépendance, dans le but d'éviter un éventuel conflit. J'ai également fait un

dnf groupinstall Fedora \Workstation

pour être sûr qu'il ne manque aucun paquet par rapport à la configuration d'origine, mais rien n'y fait.

D'ailleurs, je n'ai pas réussi à savoir quel système d'event est utilisé par GNOME (fam, gamin, inotify, etc...)

Ce n'est pas un problème grave mais j'y perds énormément en confort d'utilisation. Quelqu'un a-t-il le même problème ? Quelles pistes s'offrent à moi ?
Merci d'avance,

Hors ligne

#2 16/03/2018 11:05:59

didierg
Modérateur
Modérateur
Inscription : 11/07/2005
Messages : 4 596

Re : [Résolu] Problème de suivi des modifications de fichiers

J'ai aussi occasionnellement et depuis quelques temps un problème d'actualisation du contenu du répertoire ouvert dans Nautilus....

Une piste....
https://askubuntu.com/questions/665521/ … untu-14-04
https://github.com/guard/listen/wiki/In … y-watchers


Actuellement sur mon système Fedora 27:

$ cat /proc/sys/fs/inotify/max_user_watches
8192

Dernière modification par didierg (16/03/2018 11:06:20)

Hors ligne

#3 16/03/2018 11:33:09

didierg
Modérateur
Modérateur
Inscription : 11/07/2005
Messages : 4 596

Re : [Résolu] Problème de suivi des modifications de fichiers

Donc j'ai....

Vérifié l'ancienne valeur

$ cat /proc/sys/fs/inotify/max_user_watches
8192

Edité le fichier /etc/sysctl.conf pour y ajouter une ligne fs.inotify.max_user_watches=65536

$ sudo vi /etc/sysctl.conf

Nouveau contenu

$ sudo cat sysctl.conf
# sysctl settings are defined through files in
# /usr/lib/sysctl.d/, /run/sysctl.d/, and /etc/sysctl.d/.
#
# Vendors settings live in /usr/lib/sysctl.d/.
# To override a whole file, create a new file with the same in
# /etc/sysctl.d/ and put new settings there. To override
# only specific settings, add a file with a lexically later
# name in /etc/sysctl.d/ and put new settings there.
#
# For more information, see sysctl.conf(5) and sysctl.d(5).
fs.inotify.max_user_watches=65536

Activé le changement

$ sudo sysctl -p

Vérifié que la nouvelle valeur avait été prise en compte:

$ cat /proc/sys/fs/inotify/max_user_watches
65536

Hors ligne

#4 09/04/2018 21:24:11

omer666
Membre
Inscription : 17/07/2009
Messages : 85

Re : [Résolu] Problème de suivi des modifications de fichiers

Merci beaucoup,

Désolé pour la réponse tardive mais je voulais inspecter tous les tenants et les aboutissants de ce phénomène qui est arrivé somme toutes assez subitement.

Du coup j'ai résolu le problème en entrant une valeur de 16384, ce qui double la capacité d'inotify.

Dernière modification par omer666 (09/04/2018 21:24:19)

Hors ligne

Pied de page des forums