Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora 30 est mort ce soir

#1 03/03/2018 16:17:48

PapsOu
Developpeur PHP7 Symfony3
Rédacteur Wiki
Lieu : Quimper
Inscription : 27/11/2009
Messages : 1 849
Site Web

[Résolu] écran noir pendant le boot sur kernel 4.15.4 ou supérieur

Bonjour à tous,

Cela faisait un moment que je ne m'étais pas rendu sur le forum.

Ayant acquis récemment un pc portable ASUS FX503VD ayant une CG nVidia GeForce GTX 1050 :

lspci |grep -E "VGA|3D"
00:02.0 VGA compatible controller: Intel Corporation Device 591b (rev 04)
01:00.0 3D controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile] (rev a1)

J'ai du obligatoirement installer les pilotes propriétaires (dépôt rpmfusion) puisque nouveau ne supporte pas encore cette carte (architecture trop récente semble-t-il).

Sur le kernel 4.15.3-300 tout tourne normalement (même si le switching de CG ne semble pas fonctionner, mais je ne me suis pas trop attardé sur ce point)

Depuis une semaine ou deux, les kernels 4.15.4-300 et 4.14.6-300 semblent poser problème. Le pc boot et d'un coup l'écran s'éteint (pendant le défilement des [OK] lors de l'appuis sur Echap).

A l'aveugle, je peux accéder à un tty une fois que le témoin de disque dur à fini de s’exciter, et faire un reboot (j'ai tenté un # akmods --force mais le kmod est bien compilé pour le noyau).

akmods --kernel 4.15.6-300.fc27.x86_64 --force
Checking kmods exist for 4.15.6-300.fc27.x86_64            [  OK  ]

Vous pouvez trouver le dmesg ici https://gist.github.com/PapsOu/fc443c3e … 3d833e0e9d

Avez-vous vent d'un dysfonctionnement avec le pilote nvidia ?

D'autres infos si besoin :

dnf list --installed \*nvidia\*
Paquets installés
akmod-nvidia.x86_64                                                                                                                      3:390.25-3.fc27                                                                                                @rpmfusion-nonfree-updates
kmod-nvidia-4.15.3-300.fc27.x86_64.x86_64                                                                                                3:390.25-3.fc27                                                                                                @@commandline             
kmod-nvidia-4.15.4-300.fc27.x86_64.x86_64                                                                                                3:390.25-3.fc27                                                                                                @@commandline             
kmod-nvidia-4.15.6-300.fc27.x86_64.x86_64                                                                                                3:390.25-3.fc27                                                                                                @@commandline             
nvidia-settings.x86_64                                                                                                                   390.25-1.fc27                                                                                                  @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia.x86_64                                                                                                               3:390.25-4.fc27                                                                                                @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-kmodsrc.x86_64                                                                                                       3:390.25-4.fc27                                                                                                @rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-libs.x86_64                                                                                                          3:390.25-4.fc27                                                                                                @rpmfusion-nonfree-updates

Dernière modification par PapsOu (28/03/2018 21:17:45)

Hors ligne

#2 03/03/2018 17:21:26

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 22 409

Re : [Résolu] écran noir pendant le boot sur kernel 4.15.4 ou supérieur

Et que raconte journactl à propos des problèmes de démarrage ?


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#3 03/03/2018 18:17:18

Edouard_le_homard
Membre
Lieu : Sous un rocher noir
Inscription : 24/03/2012
Messages : 3 543

Re : [Résolu] écran noir pendant le boot sur kernel 4.15.4 ou supérieur

> puisque nouveau ne supporte pas encore cette carte (architecture trop récente semble-t-il).
ça me semble inexact :
https://www.phoronix.com/scan.php?page= … umer-Accel

Regarde la doc sur Prime par contre :
https://doc.fedora-fr.org/wiki/Prime


Asus VivoBook S 15 Fedora 31 x86_64 KDE

Hors ligne

#4 03/03/2018 22:43:04

PapsOu
Developpeur PHP7 Symfony3
Rédacteur Wiki
Lieu : Quimper
Inscription : 27/11/2009
Messages : 1 849
Site Web

Re : [Résolu] écran noir pendant le boot sur kernel 4.15.4 ou supérieur

@nouvo09: voila le journalctl --boot=-1 (j'ai bien entendu booté sur le 4.14.6-300 avant de revenir sur le 4.14.3-300 actuellement)

https://pastebin.com/raw/kusxk33Y

@Edouard_le_homard: J'avais vu la doc mais vu que nouveau ne fonctionne pas avec ma carte graphique actuellement je n'ai pas pu aller bien loin. J'ai du faire l'installation avec le paramètre nomodeset=1 sur le live USB car sinon aucun affichage. J'en déduis donc qu'out of the box, nouveau ne prends pas en charge cette CG.

Hors ligne

#5 04/03/2018 10:36:22

Edouard_le_homard
Membre
Lieu : Sous un rocher noir
Inscription : 24/03/2012
Messages : 3 543

Re : [Résolu] écran noir pendant le boot sur kernel 4.15.4 ou supérieur

> nouveau ne fonctionne pas avec ma carte graphique
Peux tu élaborer ? as tu vérifié qu'il n'y avait pas un blacklist nouveau qui restait quelque part ?


Asus VivoBook S 15 Fedora 31 x86_64 KDE

Hors ligne

#6 04/03/2018 11:30:27

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 22 409

Re : [Résolu] écran noir pendant le boot sur kernel 4.15.4 ou supérieur

PapsOu a écrit :

@nouvo09: voila le journalctl --boot=-1 (j'ai bien entendu booté sur le 4.14.6-300 avant de revenir sur le 4.14.3-300 actuellement)

https://pastebin.com/raw/kusxk33Y

Merci mais tu pourrais jeter toi-même un coup d'oeil dessus et essayer de déceler une éventuelle anomalie.

De plus si tu soupçonnes un problème lié à la session graphique, je ne t'apprendrai surement pas qu'il faut aussi consulter le fichier /var/log/Xorg.0.log


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#7 04/03/2018 15:20:09

PapsOu
Developpeur PHP7 Symfony3
Rédacteur Wiki
Lieu : Quimper
Inscription : 27/11/2009
Messages : 1 849
Site Web

Re : [Résolu] écran noir pendant le boot sur kernel 4.15.4 ou supérieur

@Edouard_le_homard : Un peu plus de précisions : J'ai pas de fichier /etc/modprobe.d/blacklist.conf, la ligne grub est la suivante :

BOOT_IMAGE=/vmlinuz-4.15.6-300.fc27.x86_64 root=UUID=ddd08e52-cd2a-43b1-a5b6-ea41ed6b1f2e ro rhgb quiet LANG=fr_FR.UTF-8 rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1

Je l'ai retouchée comme cela :

BOOT_IMAGE=/vmlinuz-4.15.3-300.fc27.x86_64 root=UUID=ddd08e52-cd2a-43b1-a5b6-ea41ed6b1f2e ro rhgb quiet LANG=fr_FR.UTF-8 nvidia-drm.modeset=1

Selon la doc Prime, nouveau est sensé « cohabiter » avec le driver proprio nvidia. J'ai pas non plus de fichier /sys/kernel/debug/vgaswitcheroo/switch

Mais bon pour la partie Bumblebee / Prime, on verra ces points dans un fil dédié si tu n'y vois pas d'inconvénients (que j'ouvrirai plus tard probablement).

@nouvo09 : J'ai bien entendu relu rapidement le dmesg mais je n'ai pas vu d'erreur fatale criantes.

Par contre, je suis sous gnome wayland, donc pas de  fichier /var/log/Xorg.0.log (enfin juste pour les rares fois où j'ai lancé une session gnome sous X).

Là l'écran s'éteint bien avant d'arriver sur GDM. Donc je pense que cela n'a rien à voir avec la session graphique, mais plutôt avec le pilote et son intégration au noyau.

Hors ligne

#8 06/03/2018 18:09:50

PapsOu
Developpeur PHP7 Symfony3
Rédacteur Wiki
Lieu : Quimper
Inscription : 27/11/2009
Messages : 1 849
Site Web

Re : [Résolu] écran noir pendant le boot sur kernel 4.15.4 ou supérieur

Quelqu'un rencontre-t-il un problème similaire avec une carte nvidia (optimus) ?

Hors ligne

#9 06/03/2018 18:33:10

Edouard_le_homard
Membre
Lieu : Sous un rocher noir
Inscription : 24/03/2012
Messages : 3 543

Re : [Résolu] écran noir pendant le boot sur kernel 4.15.4 ou supérieur

Non (GT540M)


Asus VivoBook S 15 Fedora 31 x86_64 KDE

Hors ligne

#10 06/03/2018 18:39:15

ZeSmoke
Membre
Lieu : Paris
Inscription : 04/11/2006
Messages : 252

Re : [Résolu] écran noir pendant le boot sur kernel 4.15.4 ou supérieur

Bonjour,

j'ai constaté de mon côté que les nouveaux noyaux n'aimaient pas l'option nvidia-drm.modeset=1. J'avais des symptômes équivalents avec le 4.15.
En enlevant cette option de la ligne de démarrage plus d'écran noir chez moi. Faire un test au lancement avec ctrl-e pour éditer la ligne pourrait valoir le coup.


Fred "ZeSmoke"
Take care ! Evil penguins laugh and dance !!

Hors ligne

#11 07/03/2018 09:56:46

PapsOu
Developpeur PHP7 Symfony3
Rédacteur Wiki
Lieu : Quimper
Inscription : 27/11/2009
Messages : 1 849
Site Web

Re : [Résolu] écran noir pendant le boot sur kernel 4.15.4 ou supérieur

@ZeSmoke : Merci pour le tuyau, mais cela ne fonctionne pas pour mon cas malheureusement.

Hors ligne

#12 07/03/2018 11:58:00

AshCampbell
Membre
Lieu : Breizh
Inscription : 08/02/2018
Messages : 43

Re : [Résolu] écran noir pendant le boot sur kernel 4.15.4 ou supérieur

Bonjour,
Je dis peut être (sûrement) une connerie mais cette ligne dans ton journal :

systemd[1]: Received SIGRTMIN+21 from PID 333 (plymouthd)

Cela signifie t'il qu'il y a un problème avec plymouth ?

Désolé si mon intervention ne sers à rien, mais je ne suis pas très compétent sur ce coup là. Je me posais juste la question pour pouvoir t'aider.


Acer Aspire CPU: Intel Celeron N3050 @ 2x 2.16GHz
GPU: Intel HD Graphics (i915)
RAM: 4 Gio  // Fedora 27

Hors ligne

#13 07/03/2018 12:12:06

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 22 409

Re : [Résolu] écran noir pendant le boot sur kernel 4.15.4 ou supérieur

Ca signifie que lorsque le processus de boot est terminé, on passe à autre chose.


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#14 07/03/2018 12:34:01

AshCampbell
Membre
Lieu : Breizh
Inscription : 08/02/2018
Messages : 43

Re : [Résolu] écran noir pendant le boot sur kernel 4.15.4 ou supérieur

Merci, c'est juste que j'ai vu cette ligne revenir souvent dans certains rapports de bug sur plymouth.
Désolé de ne pas pouvoir aider.


Acer Aspire CPU: Intel Celeron N3050 @ 2x 2.16GHz
GPU: Intel HD Graphics (i915)
RAM: 4 Gio  // Fedora 27

Hors ligne

#15 07/03/2018 13:22:08

PapsOu
Developpeur PHP7 Symfony3
Rédacteur Wiki
Lieu : Quimper
Inscription : 27/11/2009
Messages : 1 849
Site Web

Re : [Résolu] écran noir pendant le boot sur kernel 4.15.4 ou supérieur

Merci @AshCampbell pour ton aide big_smile

Hors ligne

#16 13/03/2018 22:06:57

PapsOu
Developpeur PHP7 Symfony3
Rédacteur Wiki
Lieu : Quimper
Inscription : 27/11/2009
Messages : 1 849
Site Web

Re : [Résolu] écran noir pendant le boot sur kernel 4.15.4 ou supérieur

Bon il semblerai que le kernel 4.15 et nVidia aient quelques « incompatibilités » : https://bbs.archlinux.org/viewtopic.php?id=234241&p=8

Je ne suis donc pas le seul à avoir un problème avec le pilote nVidia propriétaire.

Hors ligne

#17 15/03/2018 21:58:10

PapsOu
Developpeur PHP7 Symfony3
Rédacteur Wiki
Lieu : Quimper
Inscription : 27/11/2009
Messages : 1 849
Site Web

Re : [Résolu] écran noir pendant le boot sur kernel 4.15.4 ou supérieur

Je reviens aux nouvelles au sujet de ce bug.

Il semblerai que le touchpad du pc portable pose quelques problèmes...

C'est en désactivant dans l'EFI le touchpad que j'arrive désormais à booter sans ce fameux écran noir.

Le problème dépend donc de la résolution de ce bug https://bugzilla.redhat.com/show_bug.cgi?id=1543769 qui est toujours en cours.

Hors ligne

#18 27/03/2018 13:25:45

PapsOu
Developpeur PHP7 Symfony3
Rédacteur Wiki
Lieu : Quimper
Inscription : 27/11/2009
Messages : 1 849
Site Web

Re : [Résolu] écran noir pendant le boot sur kernel 4.15.4 ou supérieur

Juste pour info dans l'éventualité où quelqu'un rencontrerai le même problème que moi.

On est en train d'investiguer pour le bug de touchpad et on vient de reproduire le problème de l'écran noir. Je suis quasi certain que c'est le patch en question qui provoque cet écran noir, on est dessus.

https://bugzilla.redhat.com/show_bug.cgi?id=1543769#c55

Je marque ce fil en résolu même si le bug en question ne l'est pas encore.

Dernière modification par PapsOu (27/03/2018 13:26:43)

Hors ligne

Pied de page des forums