Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Arrêt de maintenance pour Fedora 28

#1 29/11/2017 03:57:16

didierg
Modérateur
Modérateur
Inscription : 11/07/2005
Messages : 4 874

[Résolu] Migration F26->F27 : Problème avec grub2

Bonjour,

J'essaie d'upgrader mon portable de Fedora 26 à Fedora27 mais je rencontre l'erreur suivante sur grub2

$ sudo dnf --refresh upgrade
Fedora 26 - x86_64 - Updates                    1.4 MB/s |  17 MB     00:12    
Dernière vérification de l’expiration des métadonnées effectuée il y a 0:00:00 le mer. 29 nov. 2017 02:44:33 CET.
Dépendances résolues.
Rien à faire.
Terminé !

$ sudo dnf system-upgrade download --releasever=27
Before you continue ensure that your system is fully upgraded by running "dnf --refresh upgrade". Do you want to continue [y/N]: y
Fedora 27 - x86_64 - Updates                    1.0 MB/s | 9.8 MB     00:09    
Échec de la synchronisation du cache pour le dépôt « thecubic-SABnzbd », désactivation.
Dernière vérification de l’expiration des métadonnées effectuée il y a 0:00:00 le mer. 29 nov. 2017 02:45:12 CET.
Erreur : 
 Problème: package grub2-efi-modules-1:2.02-0.40.fc26.x86_64 requires grub2-tools = 1:2.02-0.40.fc26, but none of the providers can be installed
  - grub2-tools-1:2.02-0.40.fc26.x86_64 does not belong to a distupgrade repository
  - problem with installed package grub2-efi-modules-1:2.02-0.40.fc26.x86_64
$ 

Les rpm grub2 actuellement installés:

$ rpm -qa grub2* | sort
grub2-2.02-0.40.fc26.x86_64
grub2-efi-2.02-0.40.fc26.x86_64
grub2-efi-modules-2.02-0.40.fc26.x86_64
grub2-tools-2.02-0.40.fc26.x86_64

Any help ?




EDIT: Je ne suis pas tout seul: https://bugzilla.redhat.com/show_bug.cgi?id=1506704

Dernière modification par didierg (29/11/2017 04:00:57)

Hors ligne

#2 29/11/2017 06:03:31

didierg
Modérateur
Modérateur
Inscription : 11/07/2005
Messages : 4 874

Re : [Résolu] Migration F26->F27 : Problème avec grub2

Après avoir lu le message https://bugzilla.redhat.com/show_bug.cgi?id=1506704 j'ai vérifié qu'aucun package ne dépendait de  grub2-efi-modules-1:2.02-0.40.fc26.x86_64 puis je l'ai supprimé ce qui m'a permis de faire mon upgrade sans problème.

Hors ligne

#3 29/11/2017 06:20:21

Nicosss
Membre
Lieu : Isère
Inscription : 05/03/2007
Messages : 4 854
Site Web

Re : [Résolu] Migration F26->F27 : Problème avec grub2

Les paquets grub2-efi-modules ont été dissociés par architecture, le souci doit venir de là. J'ai souvenir d'un échange sur le sujet mais je ne sais plus où et la personne a retiré le paquet pour faire l'upgrade vers F27 sous souci.
Les cas sont peut-être particuliers par contre.

Edit : J'ai tardé à répondre, j'avais perdu ma connexion internet...

Dernière modification par Nicosss (29/11/2017 06:21:12)


F30_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F30_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F30_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

#4 29/11/2017 07:49:49

didierg
Modérateur
Modérateur
Inscription : 11/07/2005
Messages : 4 874

Re : [Résolu] Migration F26->F27 : Problème avec grub2

Effectivement après upgrade en Fedora 27 pas mal de changement:

$ rpm -qa grub2* | sort
grub2-common-2.02-19.fc27.noarch
grub2-efi-x64-2.02-19.fc27.x86_64
grub2-pc-2.02-19.fc27.x86_64
grub2-pc-modules-2.02-19.fc27.noarch
grub2-tools-2.02-19.fc27.x86_64
grub2-tools-efi-2.02-19.fc27.x86_64
grub2-tools-extra-2.02-19.fc27.x86_64
grub2-tools-minimal-2.02-19.fc27.x86_64

Dernière modification par didierg (29/11/2017 07:50:46)

Hors ligne

Pied de page des forums