Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Rencontrez Borsalinux-fr aux RMLL à Strasbourg du 7 au 12 juillet

#1 14/11/2017 20:31:47

Davdux
Membre
Inscription : 20/03/2017
Messages : 203
Site Web

[Résolu] «Le système n’est pas prêt pour la mise à niveau» (au secours)

Bonjour à tous

Voici ma mésaventure du jour...

# dnf system-upgrade reboot
Erreur : le système n’est pas prêt pour la mise à niveau

Que faire ?

J'ai vidé mes caches, rien n'y fait...

Merci!

Dernière modification par Davdux (15/11/2017 08:32:53)


Fedora 26 -  XPS 13 9360 - BIOS version: 1.2.3
Mes aventures de néo-linuxien: http://www.davduf.net/+-linux-+

Hors ligne

#2 14/11/2017 21:01:40

chepioq
FEDORA FOR EVER
Lieu : a l'est de marseille
Inscription : 07/06/2006
Messages : 7 128

Re : [Résolu] «Le système n’est pas prêt pour la mise à niveau» (au secours)

As-tu fait un

dnf system-upgrade download --releasever=27

avant de lancer cette commande ?


Tout est dans tout... et réciproquement...
C'est quoi un chalumeau??? C'est un dromaludaire à deux bosses...
Quand le sage montre la lune l'imbécile regarde le doigt...
1277887812.gif

Hors ligne

#3 14/11/2017 21:32:29

Davdux
Membre
Inscription : 20/03/2017
Messages : 203
Site Web

Re : [Résolu] «Le système n’est pas prêt pour la mise à niveau» (au secours)

Oui, oui smile

[root@linux fedorax]# dnf system-upgrade download --releasever=27
Before you continue ensure that your system is fully upgraded by running "dnf --refresh upgrade". Do you want to continue [y/N]: y
QOwnNotes (Fedora_26)                                                                                          9.2 kB/s | 2.6 kB     00:00    
Copr repo for gradio owned by heikoada                                                                         6.5 kB/s |  16 kB     00:02    
Copr repo for nixnote2 owned by nunodias                                                                       1.4 kB/s | 2.8 kB     00:01    
Adobe Systems Incorporated                                                                                     1.6 kB/s | 1.9 kB     00:01    
Fedora 27 - x86_64 - Updates                                                                                   597 kB/s | 6.3 MB     00:10    
Fedora 27 - x86_64                                                                                             595 kB/s |  58 MB     01:40    
isv:ownCloud:desktop (Fedora_26)                                                                               168 kB/s | 169 kB     00:01    
RPM Fusion for Fedora 27 - Nonfree - Updates                                                                   1.1 kB/s | 1.1 kB     00:01    
RPM Fusion for Fedora 27 - Nonfree                                                                             594 kB/s | 163 kB     00:00    
skype (stable)                                                                                                  38 kB/s | 3.3 kB     00:00    
Sublime Text - x86_64 - Stable                                                                                 1.6 kB/s | 1.4 kB     00:00    
WineHQ packages (Fedora 25)                                                                                    607 kB/s | 4.8 MB     00:08    
Échec de la synchronisation du cache pour le dépôt « mosquito-brackets », désactivation.
Échec de la synchronisation du cache pour le dépôt « rabiny-albert », désactivation.
Échec de la synchronisation du cache pour le dépôt « region51-chrome-gnome-shell », désactivation.
Échec de la synchronisation du cache pour le dépôt « insync », désactivation.
Dernière vérification de l’expiration des métadonnées effectuée il y a 0:00:00 le mar. 14 nov. 2017 20:30:13 CET.
Erreur : 
 Problème 1: package chromium-libs-media-freeworld-61.0.3163.100-1.fc26.x86_64 requires chromium-libs(x86-64) = 61.0.3163.100-1.fc26, but none of the providers can be installed
  - chromium-libs-61.0.3163.100-1.fc26.x86_64 does not belong to a distupgrade repository
  - problem with installed package chromium-libs-media-freeworld-61.0.3163.100-1.fc26.x86_64
 Problème 2: nss-pem-1.0.3-3.fc26.i686 has inferior architecture
  - nss-pem-1.0.3-3.fc26.x86_64 does not belong to a distupgrade repository
  - problem with installed package nss-pem-1.0.3-3.fc26.i686
 Problème 3: package vlc-core-3.0.0-0.37.git20171009.fc26.x86_64 requires libprotobuf-lite.so.12()(64bit), but none of the providers can be installed
  - protobuf-lite-3.2.0-4.fc26.x86_64 does not belong to a distupgrade repository
  - problem with installed package vlc-core-3.0.0-0.37.git20171009.fc26.x86_64
[root@linux fedorax]# dnf system-upgrade reboot
Erreur : le système n’est pas prêt pour la mise à niveau

Hum...

Dernière modification par Davdux (14/11/2017 21:34:00)


Fedora 26 -  XPS 13 9360 - BIOS version: 1.2.3
Mes aventures de néo-linuxien: http://www.davduf.net/+-linux-+

Hors ligne

#4 14/11/2017 22:19:49

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 16 847
Site Web

Re : [Résolu] «Le système n’est pas prêt pour la mise à niveau» (au secours)

Pourtant c'est explicite, ta des paquets et dépôts qui posent problème.

Désactive les et ajoutes les options "--allowerasing --best":

dnf system-upgrade download --releasever=27 --allowerasing --best

Voir supprime les paquets incriminé en attendant tu les remettra plus tard.


Intel i7 4771 + MSI Z87-GD65 Gaming, 24Go de RAM DDR3 1866Mhz@2200Mhz Corsair Vengeance C9, ATI R9 290x 4Go GDDR5
Lepa800W 80+gold, SSD Samsung 850 EVO 250Go + 2x2To RAID1 WD black 64Mo + 1x2to WD black 64Mo + 1x4to WD Black 128Mo + 3To WD red

Hors ligne

#5 14/11/2017 23:04:23

Davdux
Membre
Inscription : 20/03/2017
Messages : 203
Site Web

Re : [Résolu] «Le système n’est pas prêt pour la mise à niveau» (au secours)

Pardon pardon, j'essaye de comprendre mais...


Par ex, ici, si je veux enelver chromium, je rencontre un probleme:

[root@linux fedorax]# dnf remove chromium
Dépendances résolues.
===============================================================================================================================================
 Paquet                         Architecture                 Version                                      Dépôt                          Taille
===============================================================================================================================================
Suppression :
 chromium                       x86_64                       61.0.3163.100-1.fc26                         @updates                        98 M

Résumé de la transaction
===============================================================================================================================================
Supprimer  1 Paquet

Espace libéré : 98 M
Voulez-vous continuer ? [o/N] :o
Test de la transaction en cours
La vérification de la transaction a réussi.
Lancement de la transaction de test
Transaction de test réussie.
Exécution de la transaction
Impossible d’obtenir le verrou de transaction (utilisateur : root).
Erreur : Impossible d’exécuter la transaction.

Si je saisis bien, il faudrait que je parvienne à enlever:
- crhomium
- nss
- vlc

Mais... comment faire ?
Et pour les dépots, que dois je faire ?

Est ce bien :

# dnf config-manager --set-disabled  nom-du-dépôt

Merci!


Fedora 26 -  XPS 13 9360 - BIOS version: 1.2.3
Mes aventures de néo-linuxien: http://www.davduf.net/+-linux-+

Hors ligne

#6 14/11/2017 23:50:46

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 21 009

Re : [Résolu] «Le système n’est pas prêt pour la mise à niveau» (au secours)

Tu es sur que ce message ne s'affiche pas parce qu'il y a une autre instance de dnf en cours et que le système n'en autorise qu'une ?(ce qui semble logique)


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#7 15/11/2017 08:24:47

Davdux
Membre
Inscription : 20/03/2017
Messages : 203
Site Web

Re : [Résolu] «Le système n’est pas prêt pour la mise à niveau» (au secours)

Oulala... ce matin, catastrophe: Fedora ne demarre plus...
Le logo Fedora se remplit (en blnac) mais pas jusqu a la fin.

J ecris ici depuis une USB Live
Je vois que toutes mes partitions sont presentes mais je suis bien incapables d<avoir acces a mes fichiers et, plus encore, de reparer les choses.

Puis je essayer de le faire par des lignes de commande ^
Dans ce cas: lesquelles^

Au secours smile

(pardon pour les fautes de frappe, clavier mal reconnu)


Fedora 26 -  XPS 13 9360 - BIOS version: 1.2.3
Mes aventures de néo-linuxien: http://www.davduf.net/+-linux-+

Hors ligne

#8 15/11/2017 08:49:48

Fifi
Membre
Lieu : Belgique
Inscription : 22/05/2006
Messages : 5 234

Re : [Résolu] «Le système n’est pas prêt pour la mise à niveau» (au secours)

Davdux a écrit :

Pardon pardon, j'essaye de comprendre mais...

Perso, ce que je ne comprend pas, c'est, qu'avec ton niveau d'expérience sur Fedora, tu installes autant de dépôts "exotiques" ... mais bon...


Fedora 27-x86_64 - KDE 5 - Plasma 5.10 - ASUS M3A32-MVP Deluxe - AMD Phenom 8650 X3 - Nvidia GTX 260 ( avec le driver proprio Nvidia 340xx ) - 4 Go RAM Corsair - 1 disque dur WD de 1 To en Sata3 et un SSD Crucial de 256 Go ( disque de boot )
Multiboot Fedora - Centos 7.0  -  Windows 10 Pro - Systemrescuecd
firefox-56.0-5.fc26.x86_64  -  thunderbird-52.5.0-1.fc27.x86_64

Hors ligne

#9 15/11/2017 08:57:35

Davdux
Membre
Inscription : 20/03/2017
Messages : 203
Site Web

Re : [Résolu] «Le système n’est pas prêt pour la mise à niveau» (au secours)

Ce n est pas par exotisme, crois le bien.
Chromium, j en avais besoin pour Flash et une extension dispo uniquement sur Chromium
Albert: parce que j ai besoin de raccourcis clavier
Etc

La, le gros gros hic, c est que je donne des cours dans deux heures et que je n ai plus acces a mes fichiers.

Comment mettre a jour depuis la cle mon Fedora ^

merci merci

Dernière modification par Davdux (15/11/2017 08:57:48)


Fedora 26 -  XPS 13 9360 - BIOS version: 1.2.3
Mes aventures de néo-linuxien: http://www.davduf.net/+-linux-+

Hors ligne

#10 15/11/2017 09:30:49

Nicosss
Membre
Lieu : Isère
Inscription : 05/03/2007
Messages : 3 845
Site Web

Re : [Résolu] «Le système n’est pas prêt pour la mise à niveau» (au secours)

Au boot dans le Grub retire les options rhgb et quiet, le démarrage sera plus verbeux et tu sauras sur quoi tu bloques.


F28_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5570 Fanless - 8Go RAM /&/ F27_64 Gnome-Shell - GA-M55S-S3 - Athlon 64 X2 4200+ - GeminII - Ati HD5750 Fanless - 3Go RAM
F27_32 - 939A785GMH/128M - Athlon 64 4000+ - 2Go RAM /&/ F27_32 Gnome-Shell - EeePC 701 - 2Go RAM

Hors ligne

#11 15/11/2017 09:47:56

Davdux
Membre
Inscription : 20/03/2017
Messages : 203
Site Web

Re : [Résolu] «Le système n’est pas prêt pour la mise à niveau» (au secours)

Voici désormais le message d’erreur qui apparaît au démarrage:

Failed to load SELinux policy. 
Freezing execution."

Merci smile


Fedora 26 -  XPS 13 9360 - BIOS version: 1.2.3
Mes aventures de néo-linuxien: http://www.davduf.net/+-linux-+

Hors ligne

#12 15/11/2017 09:50:58

Nicosss
Membre
Lieu : Isère
Inscription : 05/03/2007
Messages : 3 845
Site Web

Re : [Résolu] «Le système n’est pas prêt pour la mise à niveau» (au secours)

Au niveau des options que tu as retirés dans le Grub, ajoute selinux=0 pour voir si ça va plus loin.

Dernière modification par Nicosss (15/11/2017 09:51:18)


F28_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5570 Fanless - 8Go RAM /&/ F27_64 Gnome-Shell - GA-M55S-S3 - Athlon 64 X2 4200+ - GeminII - Ati HD5750 Fanless - 3Go RAM
F27_32 - 939A785GMH/128M - Athlon 64 4000+ - 2Go RAM /&/ F27_32 Gnome-Shell - EeePC 701 - 2Go RAM

Hors ligne

#13 15/11/2017 09:51:57

Edouard_le_homard
Membre
Lieu : Sous un rocher noir
Inscription : 24/03/2012
Messages : 3 352

Re : [Résolu] «Le système n’est pas prêt pour la mise à niveau» (au secours)

> La, le gros gros hic, c est que je donne des cours dans deux heures et que je n ai plus acces a mes fichiers.
Bon déjà on évite de faire une upgrade dans ces conditions...

> Failed to load SELinux policy.
Google ?


Asus N73S - Fedora 27 x86_64 KDE, offloading grâce à Prime+nouveau
Au travail tour Fujitsu Esprimo E720 avec GeForce 605 -  Fedora 27 x86_64 KDE, pilote nouveau

Hors ligne

#14 15/11/2017 11:03:08

Davdux
Membre
Inscription : 20/03/2017
Messages : 203
Site Web

Re : [Résolu] «Le système n’est pas prêt pour la mise à niveau» (au secours)

Nicosss a écrit :

Au niveau des options que tu as retirés dans le Grub, ajoute selinux=0 pour voir si ça va plus loin.

Un immense merci à toi: ça vient de passer!

Je viens de récupérer ma session (encore que sur xorg, ça ne s'ouvrait pas).

Le cours va pouvoir commencer smile

Ensuite, il va me falloir modifier définitivement le démarrage (je dois remettre l’optIon selinux=0 à chaque fois)

Merci encore infiniment


Fedora 26 -  XPS 13 9360 - BIOS version: 1.2.3
Mes aventures de néo-linuxien: http://www.davduf.net/+-linux-+

Hors ligne

#15 15/11/2017 11:13:09

Nicosss
Membre
Lieu : Isère
Inscription : 05/03/2007
Messages : 3 845
Site Web

Re : [Résolu] «Le système n’est pas prêt pour la mise à niveau» (au secours)

Non il va falloir comprendre l'origine du problème avec SELinux maintenant.
Là c'est juste pour te dépanner.

Tu nous donneras le retour de

$ rpm -qa selinux\*
$ sestatus

F28_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5570 Fanless - 8Go RAM /&/ F27_64 Gnome-Shell - GA-M55S-S3 - Athlon 64 X2 4200+ - GeminII - Ati HD5750 Fanless - 3Go RAM
F27_32 - 939A785GMH/128M - Athlon 64 4000+ - 2Go RAM /&/ F27_32 Gnome-Shell - EeePC 701 - 2Go RAM

Hors ligne

#16 15/11/2017 11:34:06

Davdux
Membre
Inscription : 20/03/2017
Messages : 203
Site Web

Re : [Résolu] «Le système n’est pas prêt pour la mise à niveau» (au secours)

Voici (et merci!)

[davdux@linux ~]$ sudo rpm -qa selinux\*
selinux-policy-3.13.1-260.13.fc26.noarch
[davdux@linux ~]$ sudo sestatus
SELinux status:                 disabled

Fedora 26 -  XPS 13 9360 - BIOS version: 1.2.3
Mes aventures de néo-linuxien: http://www.davduf.net/+-linux-+

Hors ligne

#17 15/11/2017 11:44:28

Nicosss
Membre
Lieu : Isère
Inscription : 05/03/2007
Messages : 3 845
Site Web

Re : [Résolu] «Le système n’est pas prêt pour la mise à niveau» (au secours)

Tu as vu de le sudo où dans mes commandes ? Peut-être pour ça que tu plantes les systèmes si tu ne suis pas les recommandations.

# dnf install selinux-policy-targeted
# fixfiles -F onboot

Ensuite redémarre sans les options rhgb et quiet et voit ce que ça donne. Tu ne dois pas ajouter l'option selinux=0, ce sera seulement pour te dépanner si le démarrage échoue.
Un ré-étiquetage SELinux va s'effectuer puis un autre redémarrage où il faudra aussi retirer les options afin de suivre le démarrage.


F28_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5570 Fanless - 8Go RAM /&/ F27_64 Gnome-Shell - GA-M55S-S3 - Athlon 64 X2 4200+ - GeminII - Ati HD5750 Fanless - 3Go RAM
F27_32 - 939A785GMH/128M - Athlon 64 4000+ - 2Go RAM /&/ F27_32 Gnome-Shell - EeePC 701 - 2Go RAM

Hors ligne

#18 15/11/2017 11:59:52

Davdux
Membre
Inscription : 20/03/2017
Messages : 203
Site Web

Re : [Résolu] «Le système n’est pas prêt pour la mise à niveau» (au secours)

Merci merci !

[davdux@linux ~]$ rpm -qa selinux\*
selinux-policy-targeted-3.13.1-260.13.fc26.noarch
selinux-policy-3.13.1-260.13.fc26.noarch
[davdux@linux ~]$ sestatus
SELinux status:                 enabled
SELinuxfs mount:                /sys/fs/selinux
SELinux root directory:         /etc/selinux
Loaded policy name:             targeted
Current mode:                   enforcing
Mode from config file:          enforcing
Policy MLS status:              enabled
Policy deny_unknown status:     allowed
Max kernel policy version:      31

Donc, ça redemarre (mais pas en xorg)


Fedora 26 -  XPS 13 9360 - BIOS version: 1.2.3
Mes aventures de néo-linuxien: http://www.davduf.net/+-linux-+

Hors ligne

#19 15/11/2017 12:29:32

Nicosss
Membre
Lieu : Isère
Inscription : 05/03/2007
Messages : 3 845
Site Web

Re : [Résolu] «Le système n’est pas prêt pour la mise à niveau» (au secours)

Tu as un intérêt à démarrer sous Xorg ?

$ rpm -qa gnome-session\*

F28_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5570 Fanless - 8Go RAM /&/ F27_64 Gnome-Shell - GA-M55S-S3 - Athlon 64 X2 4200+ - GeminII - Ati HD5750 Fanless - 3Go RAM
F27_32 - 939A785GMH/128M - Athlon 64 4000+ - 2Go RAM /&/ F27_32 Gnome-Shell - EeePC 701 - 2Go RAM

Hors ligne

#20 15/11/2017 12:56:52

Davdux
Membre
Inscription : 20/03/2017
Messages : 203
Site Web

Re : [Résolu] «Le système n’est pas prêt pour la mise à niveau» (au secours)

Oui, à cause de AutoKey (les accents ne fonctionnent pas sous Wayland, point #15)

[davdux@linux ~]$ rpm -qa gnome-session\*
gnome-session-3.24.2-1.fc26.x86_64
gnome-session-xsession-3.24.2-1.fc26.x86_64
gnome-session-wayland-session-3.24.2-1.fc26.x86_64

Merci !


Fedora 26 -  XPS 13 9360 - BIOS version: 1.2.3
Mes aventures de néo-linuxien: http://www.davduf.net/+-linux-+

Hors ligne

#21 15/11/2017 13:14:29

Nicosss
Membre
Lieu : Isère
Inscription : 05/03/2007
Messages : 3 845
Site Web

Re : [Résolu] «Le système n’est pas prêt pour la mise à niveau» (au secours)

Et depuis le GDM, tu peux choisir ton type de session via la roue dentée ?

$ rpm -qa gdm\*

F28_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5570 Fanless - 8Go RAM /&/ F27_64 Gnome-Shell - GA-M55S-S3 - Athlon 64 X2 4200+ - GeminII - Ati HD5750 Fanless - 3Go RAM
F27_32 - 939A785GMH/128M - Athlon 64 4000+ - 2Go RAM /&/ F27_32 Gnome-Shell - EeePC 701 - 2Go RAM

Hors ligne

#22 15/11/2017 13:25:37

Davdux
Membre
Inscription : 20/03/2017
Messages : 203
Site Web

Re : [Résolu] «Le système n’est pas prêt pour la mise à niveau» (au secours)

Gnome
Gnome Classic
Gnome Xorg (mais qui ne s'ouvre pas)

[davdux@linux ~]$ rpm -qa gdm\*
gdm-3.24.3-1.fc26.x86_64

merci

Dernière modification par Davdux (15/11/2017 13:29:19)


Fedora 26 -  XPS 13 9360 - BIOS version: 1.2.3
Mes aventures de néo-linuxien: http://www.davduf.net/+-linux-+

Hors ligne

#23 15/11/2017 13:30:19

Nicosss
Membre
Lieu : Isère
Inscription : 05/03/2007
Messages : 3 845
Site Web

Re : [Résolu] «Le système n’est pas prêt pour la mise à niveau» (au secours)

Désolé je me suis trompé sur la commande, mais tu n'as pas répondu à la question.

$ rpm -qa xorg\*

F28_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5570 Fanless - 8Go RAM /&/ F27_64 Gnome-Shell - GA-M55S-S3 - Athlon 64 X2 4200+ - GeminII - Ati HD5750 Fanless - 3Go RAM
F27_32 - 939A785GMH/128M - Athlon 64 4000+ - 2Go RAM /&/ F27_32 Gnome-Shell - EeePC 701 - 2Go RAM

Hors ligne

#24 15/11/2017 15:17:29

Davdux
Membre
Inscription : 20/03/2017
Messages : 203
Site Web

Re : [Résolu] «Le système n’est pas prêt pour la mise à niveau» (au secours)

Voici:

En espérant que ça t"aide

[davdux@linux ~]$ rpm -qa xorg\*
xorg-x11-server-Xwayland-1.19.3-4.fc26.x86_64
xorg-x11-xauth-1.0.9-5.fc24.x86_64
xorg-x11-proto-devel-7.7-22.fc26.noarch
xorg-x11-server-common-1.19.3-4.fc26.x86_64
xorg-x11-xinit-1.3.4-14.fc26.x86_64
xorg-x11-fonts-Type1-7.5-17.fc26.noarch
xorg-x11-xkb-utils-7.7-19.fc26.x86_64
xorg-x11-font-utils-7.5-33.fc26.x86_64
xorg-x11-server-utils-7.7-21.fc26.x86_64

Sinon comme je disais, j'ai acces depuis la roue dentée:

Gnome
Gnome Classic
Gnome Xorg (mais qui ne s'ouvre pas)

Merci !!!


Fedora 26 -  XPS 13 9360 - BIOS version: 1.2.3
Mes aventures de néo-linuxien: http://www.davduf.net/+-linux-+

Hors ligne

#25 15/11/2017 16:55:33

Nicosss
Membre
Lieu : Isère
Inscription : 05/03/2007
Messages : 3 845
Site Web

Re : [Résolu] «Le système n’est pas prêt pour la mise à niveau» (au secours)

Les messages se sont croisés.

# dnf install xorg-x11-server-Xorg

J'ai l'impression que ton installation revient de loin, il y a dû y avoir un sacré coup de machette.


F28_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5570 Fanless - 8Go RAM /&/ F27_64 Gnome-Shell - GA-M55S-S3 - Athlon 64 X2 4200+ - GeminII - Ati HD5750 Fanless - 3Go RAM
F27_32 - 939A785GMH/128M - Athlon 64 4000+ - 2Go RAM /&/ F27_32 Gnome-Shell - EeePC 701 - 2Go RAM

Hors ligne

Pied de page des forums