Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora 29 tire sa révérence

#1 21/07/2015 09:04:03

shnoulle
FreePoste Addict
Lieu : Roubaix
Inscription : 07/07/2006
Messages : 1 353
Site Web

[Résolu] [XFCE] Applications préféré Web : Firefox, mais midori revient

Bonjour,

Sur un XFCE Fedora 22, j'ai passé firefox pour la navigateur préféré via l'interface GUI.
Si je clic sur navigateur web, c'est bien Fedora qui se lance.
Si je fait
* exo-open --launch WebBrowser : firefox
* exo-open http://www.fedora-fr.org/ : nouvel onglet avec fedora-fr
* exo-open https://bugzilla.redhat.com : nouvel onglet avec le bugzilla

Mais : si je clic sur un lien dans thunderbird ou dans pidgin : c'est midori qui s'ouvre, comme si les applications n'étaient pas à jour .....

Je ne vois pas ou modifier le lanceur par défaut d'autre ?

Merci

Dernière modification par shnoulle (21/07/2015 09:04:27)


En train de lire FAQ - DOC

Hors ligne

#2 23/07/2015 18:38:06

CabSud
Membre
Lieu : Cyber Espace
Inscription : 25/08/2010
Messages : 408

Re : [Résolu] [XFCE] Applications préféré Web : Firefox, mais midori revient

Salut,

Ça m'était arrivé avec une logiciel en cli et j'avais réglé le problème en passant par le fichier de config.
Dans le man pidgin j'ai vu qu'il y a une option browser ça devrait donc rouler .
Thunderbird n'étant pas installé chez moi je ne peux pas dire mais avec un peu de chance il doit y avoir une option dans le même genre .

Hors ligne

#3 23/07/2015 19:14:33

shnoulle
FreePoste Addict
Lieu : Roubaix
Inscription : 07/07/2006
Messages : 1 353
Site Web

Re : [Résolu] [XFCE] Applications préféré Web : Firefox, mais midori revient

Bon ouai,

Mais c'est pas top .... Mais je vais regarder du coté de XDG-open semble t'il. J'ai mes fichier odt/ods qui s'ouvre par défaut avec calibre .... (alors que avant la mise à jour : RAS ).
Et les PDF avec calibre ...

Denis

---
ta bien un truc au niveau xdg semble t'il :

$ exo-open Conditions-générales.pdf 

: m'ouvre bien evince comme je lui ai demandé après réinstallation (passage de la 21 à la 22)
Mais

$ xdg-mime query default application/pdf
inkscape.desktop

Comme c'était juste après la mise à jour

Mais bon :
$ xdg-open http://fedora-fr.org m'ouvre bien fedora-fr dans un nouvel onglet ....

Dernière modification par shnoulle (23/07/2015 19:27:10)


En train de lire FAQ - DOC

Hors ligne

#4 24/07/2015 00:33:39

CabSud
Membre
Lieu : Cyber Espace
Inscription : 25/08/2010
Messages : 408

Re : [Résolu] [XFCE] Applications préféré Web : Firefox, mais midori revient

Ça m'a permis de me rendre compte que alternatives, que j'avais déjà vu sous Debian, existe également sur Fedora, donc c'est bien pratique tout ça :)

Tu peux essayer ceci pour voir si ça solutionne tes problèmes:

# update-alternatives --install /usr/bin/x-www-browser x-www-browser /usr/bin/firefox 100
# update-alternatives --install /usr/bin/x-www-browser x-www-browser /usr/bin/midori 80

Et si un jour tu as envie de changer Firefox pour Midori :

# update-alternatives --config x-www-browser
Il existe 2 programmes qui fournissent « x-www-browser ».

  Sélection    Commande
  -----------------------------------------------
  *+ 1           /usr/bin/firefox
     2           /usr/bin/midori
     
     Entrez pour garder la sélection courante [+] ou saisissez le numéro de type de sélection :

Si ça fonctionne pour le navigateur tu peux peut-être appliquer cette méthode également pour tes fichiers type odt,pdf,etc.. en ajoutant les différentes applications pouvant lire les fichiers en question mais avec une priorité différente.

Sinon tu as toujours la méthode simple du 'clique droit' -> 'propriété' -> 'ouvrir avec' ,mais je pense que tu as déjà essayé ça ^^

PS:
Il existe aussi une GUI pour alternatives qui s'appelle Galternatives mais je ne l'ai pas testé.

Hors ligne

#5 24/07/2015 09:03:27

shnoulle
FreePoste Addict
Lieu : Roubaix
Inscription : 07/07/2006
Messages : 1 353
Site Web

Re : [Résolu] [XFCE] Applications préféré Web : Firefox, mais midori revient

Salut,

Cela ne semble pas avoir réglé le soucis.

Mais je crois qu'il y a quelquechose de plus profond, non ?

Je viens de tester (oui je sais c'est affreux ...)

[root@ehlana ~]# xdg-settings --list
Known properties:
  default-url-scheme-handler    Default handler for URL scheme
  default-web-browser           Default web browser
[root@ehlana ~]# xdg-open http://fedora-fr.org

C'est midori qui s'ouvre (pourtant alterantives est bien réglé sur Firefox).

Donc, il faut que je trouve au sont gérés les mime-types globalement ....

Pas pas de /etc/default/mimetypes ou autre ....

Denis


En train de lire FAQ - DOC

Hors ligne

#6 25/07/2015 17:02:14

CabSud
Membre
Lieu : Cyber Espace
Inscription : 25/08/2010
Messages : 408

Re : [Résolu] [XFCE] Applications préféré Web : Firefox, mais midori revient

Ah quand ça veut pas , ça veut pas !!

Alors j'ai jeté un coup d’œil sur xdg pour essayer de comprendre comment ça fonctionne, et à première vue ça semble abordable car il existe plusieurs moyen d'arriver à ses fins, même si c'est jamais gagné d'avance ^^
EXO s'occupe de l'environnement XFCE, alors que XDG est plus générique il fonctionne pour tous les environnements.

En premier tu vérifies tes réglages actuels :

xdg-settings get default-web-browser
xdg-settings get default-url-scheme-handler 

Si ça n'est pas bon tu configures:

xdg-settings set default-web-browser firefox.desktop

Tu peux également aussi configurer default-url-scheme-handler, je pense que ce qui permettra à Thunderbird d'utiliser le navigateur choisi:

xdg-settings set default-url-scheme-handler firefox.desktop

Ensuite tu vérifies à nouveau:

xdg-settings get default-web-browser 
xdg-settings get default-url-scheme-handler

Arrive l'heure de vérité , tu testes et si cela ne fonctionne pas tu peux tenter le mode debug :

sh -x /usr/bin/xdg-open http://forums.fedora-fr.org

On va déjà voir ce que ça dit à ce stade déjà, on avisera ensuite ... enfin si je suis toujours capable de faire avancer le schmilblick.

Hors ligne

#7 27/07/2015 09:26:45

shnoulle
FreePoste Addict
Lieu : Roubaix
Inscription : 07/07/2006
Messages : 1 353
Site Web

Re : [Résolu] [XFCE] Applications préféré Web : Firefox, mais midori revient

Salut,

xdg est déjà OK sur mon utilisateur :

$ xdg-settings get default-web-browser
firefox.desktop
$ xdg-settings get default-url-scheme-handler 
xdg-settings: default-url-scheme-handler not implemented for xfce
$sh -x /usr/bin/xdg-open http://forums.fedora-fr.org

m'ouvre irefox.

Mais pour root :

$ xdg-settings get default-web-browser
firefox.desktop

Je teste de le régler pour root, on verra bien : mais à mon avis : cela va régler /root/.local ....

Mais pas au global ....

xdg va sans doute trouver le navigateur par défaut si il n'est pas réglé quelquepart, Thunderbird va le chercher sans se servir de xdg-open autre part ....


En train de lire FAQ - DOC

Hors ligne

#8 27/07/2015 15:37:02

CabSud
Membre
Lieu : Cyber Espace
Inscription : 25/08/2010
Messages : 408

Re : [Résolu] [XFCE] Applications préféré Web : Firefox, mais midori revient

shnoulle a écrit :
$ xdg-settings get default-url-scheme-handler 
xdg-settings: default-url-scheme-handler not implemented for xfce

Essayes ça plutôt à la place :

 xdg-mime default firefox.desktop x-scheme-handler/http
 xdg-mime default firefox.desktop x-scheme-handler/https

Tous les mimes pré-configurés de ton système sont listés ici:

/usr/share/applications/mimeinfo.cache

Par utilisateur ils sont ici :

~/.config/mimeapps.list

Au final tu peux :
_ soit éditer à la main le fichier ~/.config/mimeapps.list .
_ utiliser la GUI xfce4-mime-settings pour modifier (mais sans possibilité de créer) .
_ utiliser XDG ou EXO en ligne de commande .

Dernière modification par CabSud (27/07/2015 16:00:40)

Hors ligne

#9 27/07/2015 17:22:22

shnoulle
FreePoste Addict
Lieu : Roubaix
Inscription : 07/07/2006
Messages : 1 353
Site Web

Re : [Résolu] [XFCE] Applications préféré Web : Firefox, mais midori revient

Bon :)

Pour au global : modifier manuellement /usr/share/applications/mimeinfo.cache fonctionne (en fait midori est en premier, AMHA cela devrait être default-web-browser ou quelquechose comme ça, faudrait que je regarde sur un 21 ce qu'il ya ), j'ai placé firefox en premier.

xdg et exo-open dans le répertoire perso ne changeait rien ....

Denis


En train de lire FAQ - DOC

Hors ligne

#10 27/07/2015 19:07:57

CabSud
Membre
Lieu : Cyber Espace
Inscription : 25/08/2010
Messages : 408

Re : [Résolu] [XFCE] Applications préféré Web : Firefox, mais midori revient

Ha ben ça avance un peu , c'est déjà ça .
Maintenant quand tu ouvres une url depuis thunderbird c'est firefox qui se lance ou pas ?

C'est bizarre que les modifications du fichier ~/.config/mimeapps.list ne fonctionne pas .

Chez moi si je fais :

cat ~/.config/mimeapps.list |grep  "x-scheme"
x-scheme-handler/http=exo-web-browser.desktop
x-scheme-handler/https=exo-web-browser.desktop

Peut-être que pour toi c'est exo qui s’emmêle les pinceaux .
Sinon tu peux essayer de remplacer exo-web-browser.desktop par firefox.desktop tout simplement .

Hors ligne

#11 27/07/2015 19:24:28

shnoulle
FreePoste Addict
Lieu : Roubaix
Inscription : 07/07/2006
Messages : 1 353
Site Web

Re : [Résolu] [XFCE] Applications préféré Web : Firefox, mais midori revient

Je n'avais poas fait vi mimelist hammer

Donc:

$ cat ~/.config/mimeapps.list |grep  "x-scheme"
x-scheme-handler/trash=exo-file-manager.desktop
x-scheme-handler/mailto=mozilla-thunderbird.desktop;
x-scheme-handler/mailto=mozilla-thunderbird.desktop

J'ajoute les 2 pour exo-web-browser.desktop :). Mais au global ? Cela ne devrait pas être différent et direct ?

Dans le genre :
on cherche:
La navigateur par défaut de l'utilisateur en cours pour son bureau en cours (je sais pas pour gnome/kde, mais exo-web-browser.desktop donc pour XFCE) ?
si non trouvé
xdg-open : default-web-browser
si non trouvé :
N'importe lequel ....


En train de lire FAQ - DOC

Hors ligne

Pied de page des forums