Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Assemblée Générale Ordinaire de Borsalinux-fr de 2023

#1 27/07/2015 01:27:16

lyann
Membre
Inscription : 04/07/2010
Messages : 172

desactiver pave tactile

Bonjour,

Je reviens vers vous car je n'arrive pas a déasactiver le touchpad de mon ordi, je précise que l'utilise lxQt comme DE, une carte graphique nvidia 285M avec les pilotes proprios, et que j'ai essayé plusieurs solutions trouvé sur internet .

J'ai d'abord essayé  après avoir enlevé ma souris filaire usb dont je me sers habituellement:

[root@localhost ~]# xinput list
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ FSPPS/2 Sentelic FingerSensingPad         id=13   [slave  pointer  (2)]
⎜   ↳ MCE IR Keyboard/Mouse (ite-cir)           id=14   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ BisonCam, NB Pro                          id=10   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]
    ↳ ITE8708 CIR transceiver     

puis ceci :

[root@localhost ~]# xinput --set-prop "Virtual core XTEST pointer" "Device Enabled" 0

X Error of failed request:  BadAccess (attempt to access private resource denied)
  Major opcode of failed request:  131 (XInputExtension)
  Minor opcode of failed request:  57 ()
  Serial number of failed request:  20
  Current serial number in output stream:  21

Même après un reboot cela n'a rien changé.

J'ai aussi essayé

[root@localhost ~]# syndaemon -i 1 -d
Unable to find a synaptics device.

Ainsi malgré que j'ai un touchpad actif aucun de ces deux programmes ne semblent le voir et pouvoir le désactiver ...
Auriez-vous une piste, parce que je ne sais pas ou cherhcer d'autres ?

Merci d'avance

Hors ligne

#2 27/07/2015 07:29:28

chepioq
FEDORA FOR EVER
Lieu : a l'est de marseille
Inscription : 07/06/2006
Messages : 7 441

Re : desactiver pave tactile

Tu n'as pas, sur ton ordi (je suppose que c'est un portable) un bouton ou une combinaison de touches qui permette de désactiver ton touch-pad ?


Tout est dans tout... et réciproquement...
C'est quoi un chalumeau??? C'est un dromaludaire à deux bosses...
Quand le sage montre la lune l'imbécile regarde le doigt...

Hors ligne

#3 27/07/2015 09:01:51

oulala
Membre
Inscription : 06/02/2015
Messages : 27

Re : desactiver pave tactile

bonjour,
perso j'use de

/usr/bin/synclient TouchpadOff=1

( même mis cela au lancement en testant si souris présente )

ou alors

xinput ( pour voir id=??? )
  Virtual core pointer             id=2 [master pointer  (3)]
  ...
  SynPS/2 Synaptics TouchPad   	id=9 [slave  pointer  (2)]

suivi de

xinput set-prop 9 "Device Enabled" 0 ( 1 pour activer )

ça devait peu-être baigner avec «FSPPS/2 Sentelic FingerSensingPad id=13»

xinput set-prop 13 "Device Enabled" 0

@+

Dernière modification par oulala (27/07/2015 11:00:29)

Hors ligne

#4 31/07/2015 05:17:51

lyann
Membre
Inscription : 04/07/2010
Messages : 172

Re : desactiver pave tactile

Désolé pour la réponse tardive.

Merci pour les réponses et la solution y a-t-il quelque chose a faire pour conserver le réglage a chaque reboot ?

Merci  encore.

Hors ligne

#5 31/07/2015 06:30:37

oulala
Membre
Inscription : 06/02/2015
Messages : 27

Re : desactiver pave tactile

par exemple, avec lxde
dans /home/«utilisateur»/.config/lxsession/LXDE/autostart

@/usr/bin/synclient TouchpadOff=1

moi j'ai,
dans /home/«utilisateur»/.config/lxsession/LXDE/autostart

@/home/«utilisateur»/bin/sysinit

et dans ce sysinit, entre-autres :

/usr/bin/synclient TouchpadOff=$(ls /dev/input/by-id/*|grep -i event-mouse|wc -l) &

qui invalide donc le touchpad si une souris est présente

Hors ligne

Pied de page des forums