Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora 31 prêt à être utilisé !

#1 30/06/2015 15:21:45

DiezeM
Membre
Inscription : 30/06/2015
Messages : 3

Steam sur F22

Bonjour , ayant suivi la documentation sur steam pour pouvoir l'installer sur Fedora 22
Steam ne s'ouvre pas ..
Y-a-t-il des problémes que vous connaissiez ?
Je suis novice sur linux roll
Merci a vous smile

Hors ligne

#2 30/06/2015 16:05:47

Raily
Skateur Fedorien
Lieu : Lille, France.
Inscription : 14/11/2005
Messages : 346

Re : Steam sur F22

Bonjour,
Essaye de lancer steam en passant par un terminal et colle ici ce que raconte le terminal.
Et dans des balises code

comme ceci

de préférence pour la lisibilité sur le forum. :)


C'est en tombant que l'on apprend à marcher.
Un noyau pour les compiler tous et dans des RPM les packager. o/
Fedora 26 sur : AMD Phenom II X4 965BE / GPU: Radeon HD 6770 / RAM: 4 X 2Go 1333 / CM:ASUS M4A87TD / SSD SanDisk 128Go + HDD WD Blue 500Go

Hors ligne

#3 30/06/2015 17:13:18

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 17 743
Site Web

Re : Steam sur F22

Oui il faut chercher un minimum sur le forum, on en parle souvent.

C'est un souci de bibliothèques à supprimer dans un certain répertoire.

Et puis il y a aussi la doc qui en parle : http://doc.fedora-fr.org/wiki/Steam


AMD Ryzen 7 2700X, MSI Gaming Pro Carbon X470, 32Go DDR4 3200@3333Mhz Gskill Trident Z RBG CL14, Radeon RX 5700XT MSI Mech OC + RX590 Sapphire Nitro+ SE 8Go GDDR5
SSD Samsung : 1x 970 NVME 500Go + 1x 850 EVO 250Go + 2x500Go 860 EVO, 2x1To 860 QVO, HDD 1x2To WD black 64Mo, 1x4to WD Black 128Mo, 3To WD Red, Boitier GMT Bequiet Dark 900-Lepa 800W 80+gold
AMD A6 9500, MSI A320, 16Go DDR4 2400Mhz Gskill AEGIS, 1x500GO WD black, 3x 2To RAID 5 WD Blue, Alim Corsair 350W-Boitier Cube Chieftec CI-01B-OP

Hors ligne

#4 03/07/2015 01:47:45

Pazns
Membre
Inscription : 22/03/2010
Messages : 30

Re : Steam sur F22

Je suis à la lettre la procédure de votre doc' et il s'avère pour commencer que les deux commandes rm tapent dans le vide.
La suite aboutit à Steam me demandant de définir la variable d'environnement "LD_LIBRARY_PATH".
Cause du STEAM_RUNTIME=0 .

Arbitrairement, je lui donne /usr/lib/, cela semble lui aller, il télécharge tout son bazar, puis ensuite il réclame "libbz2.so.1.0" 32b qu'il dit ne pas trouver.
À juste titre, la chaine de liens symboliques entre les versions de libbz2.so dans /usr/lib/ manque d'une étape.
J'intercale un lien.


Steam avance de quelques pas, puis s'arrête, notifiant qu'il ne trouve pas le module "vgui2_s.so".

Hors ligne

#5 03/07/2015 02:15:46

Pazns
Membre
Inscription : 22/03/2010
Messages : 30

Re : Steam sur F22

Rectification.

En suivant ce fil, j'ai pu appliqué la solution suivante :
Laisser le runtime en paix et simplement lancer :

LD_PRELOAD='/usr/$LIB/libstdc++.so.6' steam

Dernière modification par Pazns (03/07/2015 02:16:20)

Hors ligne

#6 03/07/2015 10:40:11

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 17 743
Site Web

Re : Steam sur F22

Perso je préfère utiliser celles présente sur le système et mis à jour par lui.


AMD Ryzen 7 2700X, MSI Gaming Pro Carbon X470, 32Go DDR4 3200@3333Mhz Gskill Trident Z RBG CL14, Radeon RX 5700XT MSI Mech OC + RX590 Sapphire Nitro+ SE 8Go GDDR5
SSD Samsung : 1x 970 NVME 500Go + 1x 850 EVO 250Go + 2x500Go 860 EVO, 2x1To 860 QVO, HDD 1x2To WD black 64Mo, 1x4to WD Black 128Mo, 3To WD Red, Boitier GMT Bequiet Dark 900-Lepa 800W 80+gold
AMD A6 9500, MSI A320, 16Go DDR4 2400Mhz Gskill AEGIS, 1x500GO WD black, 3x 2To RAID 5 WD Blue, Alim Corsair 350W-Boitier Cube Chieftec CI-01B-OP

Hors ligne

#7 03/07/2015 11:37:26

titijhajha
Membre
Lieu : Digne-les-Bains
Inscription : 23/06/2011
Messages : 992
Site Web

Re : Steam sur F22

Bonjour , ayant suivi la documentation sur steam pour pouvoir l'installer sur Fedora 22

Bonjour,
Je ne pense pas qu'il soit nécessaire de l'installer ainsi. Le problème se posait à la sortie de F22 quand Steam n'était pas encore dans les dépôts RPMFusion et donc inaccessible via dnf ou "Logiciels".
à présent un simple "dnf install steam" installe le tout proprement. Cela dit cela n'a peut-être pas de rapport avec le fait qu'il ne démarre pas.
Je crois que Vindicators avait donner une astuce ici, mais je ne sais pas tu es exactement de ce cas.


« Si tu ne trouves pas la vérité à l'endroit où tu es, où espères-tu la trouver? » - Eihei Dōgen
Desktop :  Ubuntu 15.10 - Portable :  Fedora 23 - Portable Asus de madame: Linux Mint 17.2

Hors ligne

#8 03/07/2015 21:56:46

Pazns
Membre
Inscription : 22/03/2010
Messages : 30

Re : Steam sur F22

VINDICATORs a écrit :

Perso je préfère utiliser celles présente sur le système et mis à jour par lui.

Que ce soit en suivant scrupuleusement la page du wiki ou en adaptant légèrement je n'arrivais à rien.
Seul l'ajout d'un LD_PRELOAD aura fait quelque chose, on dirait. Et sans désactiver le runtime de steam, par contre.
C'est plutôt bizarre.

Dernière modification par Pazns (03/07/2015 21:57:48)

Hors ligne

#9 05/07/2015 00:13:28

DiezeM
Membre
Inscription : 30/06/2015
Messages : 3

Re : Steam sur F22

Salut avec un peu de retard désolé neutral
Voila ce que sa m'affiche l'orsque je lance steam sur terminal :

$ steam
Running Steam on fedora 22 64-bit
STEAM_RUNTIME is disabled by the user
/home/romain/.local/share/Steam/steam.sh: ligne 710: LD_LIBRARY_PATH : variable sans liaison 

Hors ligne

#10 05/07/2015 00:44:28

DiezeM
Membre
Inscription : 30/06/2015
Messages : 3

Re : Steam sur F22

DiezeM a écrit :

Salut avec un peu de retard désolé neutral
Voila ce que sa m'affiche l'orsque je lance steam sur terminal :

$ steam
Running Steam on fedora 22 64-bit
STEAM_RUNTIME is disabled by the user
/home/romain/.local/share/Steam/steam.sh: ligne 710: LD_LIBRARY_PATH : variable sans liaison 

Probléme résolu en faisant cette commande la :

 STEAM_RUNTIME=1 

Mais au redémarage de Steam , je suis obligé de retaper cette même commande ..
Comment faire pour que se soit permanent ?
Merci big_smile

Hors ligne

#11 05/07/2015 15:13:55

pierrotlalune
Membre
Lieu : Estal (46)
Inscription : 31/10/2011
Messages : 679

Re : Steam sur F22

DiezeM a écrit :

Probléme résolu en faisant cette commande la :

 STEAM_RUNTIME=1 

Mais au redémarage de Steam , je suis obligé de retaper cette même commande ..
Comment faire pour que se soit permanent ?
Merci big_smile

Bonjour DiezeM,
tu pourrais utiliser un éditeur de menu pour modifier ou créer la commande correspondante.
Personnellement, j'utilise lxmed.
Bien amicalement.
pll

Hors ligne

#12 06/07/2015 18:13:30

Nobrakal
Membre FedoraProject
Membre FedoraProject
Lieu : Yvelines
Inscription : 12/02/2013
Messages : 34

Re : Steam sur F22

DiezeM a écrit :
DiezeM a écrit :
$ steam
Running Steam on fedora 22 64-bit
STEAM_RUNTIME is disabled by the user
/home/romain/.local/share/Steam/steam.sh: ligne 710: LD_LIBRARY_PATH : variable sans liaison 

Pour que le changement soit permanent, il suffit d'ajouter une ligne contenant "export STEAM_RUNTIME=1" dans le fichier ~/.bashrc (ou, si tu as suivi la doc, de supprimer la ligne "export STEAM_RUNTIME=0".

Alexandre


Fedora user & ambassador

Hors ligne

#13 17/10/2015 13:59:08

Snutin
Membre
Lieu : BZH
Inscription : 07/04/2015
Messages : 24

Re : Steam sur F22

Pazns a écrit :

Rectification.

En suivant ce fil, j'ai pu appliqué la solution suivante :
Laisser le runtime en paix et simplement lancer :

LD_PRELOAD='/usr/$LIB/libstdc++.so.6' steam

J'avais le même problème et c'est ce qui a résolu le problème...
Par contre je ne comprend pas vraiment comment fonctionne le bashrc et ce qu'il faut y mettre pour que ce soit permanent (et que je puisse lancer steam sans passer par le terminal)

Dernière modification par Snutin (17/10/2015 17:52:59)

Hors ligne

Pied de page des forums