Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Venez tester la Fedora 33 Beta

#1 21/10/2013 22:55:47

wiki
Membre
Inscription : 21/10/2013
Messages : 3

probleme acces serveur web local suite a installation

Bonjour à tous,

Je suis nouveau sur le forum, et je me trouve devant un problème épineux. Je viens juste d'installer une fedora 19 avec le DVD , installation basique, sans interface graphique, juste le système minimal, avec une IP fixe. J'ai ensuite installé openssh pour pouvoir travailler tranquillement à partir d'un PC avec putty, aucun problème pour se connecter à distance. J'ai suivis l'excellent tuto du site howtoforge pour installer un serveur LAMP . Tout se passe très bien, jusqu'au test de fonctionnement du serveur apache ,après installation et démarrage, je suis sensé entrer dans mon navigateur préféré l'adresse IP du serveur fraichement installé , et là mon navigateur me renvoie un "la connexion a échouée". Par acquis de conscience, j'ai vérifié la présence des fichiers de configuration de apache, tout va bien, j'ai fais un redémarrage du serveur web, et toujours rien, je ne comprends pas, tout se passe bien, je suis le tuto à la lettre , et tout se passe comme prévu, j'ai réessayé plusieurs fois d'installer le serveur , et toujours la meme chose, je précise que le serveur et le PC d'ou je travaille sont sur le même réseau local, et le même sous-réseau, merci pour votre aide,

Hors ligne

#2 22/10/2013 03:52:24

didierg
Modérateur
Modérateur
Inscription : 11/07/2005
Messages : 5 335

Re : probleme acces serveur web local suite a installation

Pour commencer il y a de la doc spécifique à Fedora sur ce site:

http://doc.fedora-fr.org/wiki/Installat … d%27Apache
http://doc.fedora-fr.org/wiki/Installat … ion_de_PHP
http://doc.fedora-fr.org/wiki/Installat … n_de_MySQL

Après tu essaie d'accéder à ton serveur en local ou à partir d'une autre machine ?

Si c'est à partir d'une autre machine, le firewall a été réglé ? stoppé ?

Dernière modification par didierg (22/10/2013 03:53:31)

Hors ligne

#3 22/10/2013 11:28:49

Refuznik
Membre
Inscription : 31/01/2007
Messages : 7 730

Re : probleme acces serveur web local suite a installation

Bon déja ne sachant pas quel type de tuto. ni ce que tu veux faire (et bien sur demander de l'aide sans donner les fichiers de conf.).

La 1er chose à faire c'est de te connecter sur ton site en local avec son adresse 127.0.0.1.
S'il réponds correctement essaie avec son adresse IP.
Si son adresse ip ou son nom ne fonctionne pas c'est un mauvais paramétrage d'apache.

Hors ligne

#4 23/10/2013 22:44:52

wiki
Membre
Inscription : 21/10/2013
Messages : 3

Re : probleme acces serveur web local suite a installation

Bonsoir à tous,

Désolé pour cette réponse tardive. Merci pour toutes vos réponses. Concernant le tuto que j'ai suivi, je pensais sincèrement que le site howtoforge était sérieux. J'ai donc regardé les liens proposés par didierg, merci à toi, et je me suis retrouvé dans la même situation, à savoir une installation minimale de fedora 19, uniquement avec le shell, et l'invite de commande, un seul utilisateur configuré, à savoir root, openssh pour travailler sous putty , installation en ligne de commande de httpd. Je démarre le service httpd, et là , à partir de mon pc de travail, qui n'est pas le pc sur lequel est installé le serveur web, je tente d'accéder à la page d'accueil d'apache en entrant dans mon navigateur l'adresse ip du serveur web, et là "la connexion a échouée". Je souhaite visualiser le fichier de configuration httpd.conf , et surprise, ce fichier n'existe pas, le repertoire httpd par contre existe. J'ai aussi tenté d'accéder au répertoire apache2, inexistant.
Je tiens à préciser que les deux machines, le serveur web sous fedora, et mon pc de travail sous ubuntu, sont sur le même réseau local, donc aucun firewall , et sont sur le même sous-réseau, à savoir des adresse de type 192.168.2....., donc il se reconnaisse , d'ailleurs, je peux sans problème me connecter au serveur web par putty, ce qui necessite une adresse ip valide.

Je ne comprends rien, merci pour votre aide

Hors ligne

#5 24/10/2013 11:33:51

elbelo69
Membre
Lieu : Lyon
Inscription : 03/09/2007
Messages : 358

Re : probleme acces serveur web local suite a installation

Salut,

Wiki a écrit :

Je souhaite visualiser le fichier de configuration httpd.conf , et surprise, ce fichier n'existe pas

C'est sur que ca va beaucoup moins bien marché ! big_smile

Tu es certain que httpd est correctement installé ?
Que renvoie

rpm -ql `rpm -qa | grep httpd`

Hors ligne

#6 25/10/2013 02:34:04

didierg
Modérateur
Modérateur
Inscription : 11/07/2005
Messages : 5 335

Re : probleme acces serveur web local suite a installation

Sur la machine ou tu as installé ton serveur, tu peux aussi tester en local sans interface graphique avec la commande wget

wget localhost
wget 127.0.0.1

Ca te permettra déjà de tester si ton serveur httpd fonctionne en t'affranchissant des problèmes réseau et firewalld

Pour t'aider:

$ sudo systemctl stop httpd.service

$ sudo systemctl status httpd.service
httpd.service - The Apache HTTP Server
   Loaded: loaded (/usr/lib/systemd/system/httpd.service; disabled)
   Active: inactive (dead)

oct. 25 02:11:59 pc20.home systemd[1]: Starting The Apache HTTP Server...
oct. 25 02:11:59 pc20.home systemd[1]: Started The Apache HTTP Server.
oct. 25 02:17:34 pc20.home systemd[1]: Stopping The Apache HTTP Server...
oct. 25 02:17:35 pc20.home systemd[1]: Stopped The Apache HTTP Server.

$ wget 127.0.0.1
--2013-10-25 02:18:13--  http://127.0.0.1/
Connexion vers 127.0.0.1:80...échec: Connexion refusée.     >>>> le serveur httpd est INactif
$ sudo systemctl start httpd.service

$ sudo systemctl status httpd.service
httpd.service - The Apache HTTP Server
   Loaded: loaded (/usr/lib/systemd/system/httpd.service; disabled)
   Active: active (running) since ven. 2013-10-25 02:18:21 CEST; 4s ago
 Main PID: 4231 (httpd)
   Status: "Processing requests..."
   CGroup: name=systemd:/system/httpd.service
           ├─4231 /usr/sbin/httpd -DFOREGROUND
           ├─4232 /usr/sbin/httpd -DFOREGROUND
           ├─4233 /usr/sbin/httpd -DFOREGROUND
           ├─4234 /usr/sbin/httpd -DFOREGROUND
           ├─4235 /usr/sbin/httpd -DFOREGROUND
           └─4236 /usr/sbin/httpd -DFOREGROUND

oct. 25 02:18:21 pc20.home systemd[1]: Started The Apache HTTP Server.

$ wget 127.0.0.1
--2013-10-25 02:18:29--  http://127.0.0.1/
Connexion vers 127.0.0.1:80...connecté.     >>>> le serveur httpd est actif
requête HTTP transmise, en attente de la réponse...403 Forbidden     
2013-10-25 02:18:29 ERREUR 403: Forbidden.

Après il te reste juste à paramétrer ton serveur dans /etc/httpd/conf.d, ouvrir le port 80 dans firewalld, ....

Dernière modification par didierg (25/10/2013 02:38:06)

Hors ligne

#7 25/10/2013 22:55:42

wiki
Membre
Inscription : 21/10/2013
Messages : 3

Re : probleme acces serveur web local suite a installation

Bonsoir à tous,

Merci à tous les intervenants pour l'intérêt que vous avez porté à mon problème. Comme l'a suggéré didierg, le problème vient bien de firewalld , qui bloque tout trafic sur le serveur web, j'ai testé en désactivant firewalld et miracle la page d'accueil apache est apparue , donc depuis le début, c'éatait le parefeu qui posait problème, merci encore, en ouvrant les ports concernés, aucun souci. Merci encore à tous, et particulièrement à didierg, j'étais habitué à l'environnement debian, mais fedora m'a convaincu,

Hors ligne

Pied de page des forums