Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : La nouvelle version de Fedora dite 33 est sortie

#1 20/03/2013 23:50:53

cuncta
Membre
Inscription : 20/03/2013
Messages : 2

Icompatibilité Drupal 6 avec PHP5.4

Bonjour à la communauté,

J'ai un petit soucis avec Drupal 6 qui ne veut pas tourner avec PHP5.4 sous Fedora 18. Selon mes recherches, ma version de PHP à quelques petits soucis avec les anciennes version Drupal telle que la 6. Il faut garder à l'esprit est que ma contrainte est de travailler sur ce Drupal 6.

J'aimerais donc solliciter votre aide (hehe) pour trouver un moyen de downgrade mon PHP en 5.4 en 5.3 voire 5.2 ! J'ai commencé par désinstaller PHP5.4 pour télécharger une vieille archive PHP5.3 mais j'ai des problèmes à la configuration du paquet. J'ai visiblement des problèmes de dépenences avec libxml2. Petit paquet que j'ai pris soin de vérifier s'il était installer.

checking libxml2 install dir... no
checking for xml2-config path... 
configure: error: xml2-config not found. Please check your libxml2 installation.

Je m'arrache un peu les cheveux hammer

Merci d'avance pour votre aide !

Dernière modification par cuncta (20/03/2013 23:53:33)

Hors ligne

#2 21/03/2013 11:18:58

remi
Crazy PHP packages monkey... !
Rédacteur Wiki
Lieu : Champagne...
Inscription : 16/10/2004
Messages : 5 579
Site Web

Re : Icompatibilité Drupal 6 avec PHP5.4

Le plus simple serait d'utiliser uns distribution fournissant encore php 5.3 (Fedora 16, mais EOL, ou Enterprise Linux 6)

Hors ligne

#3 21/03/2013 11:43:12

cuncta
Membre
Inscription : 20/03/2013
Messages : 2

Re : Icompatibilité Drupal 6 avec PHP5.4

Je ne peux envisager la migration vers une autre distribution. J'ai de nombreux autres projets en court qui fonctionne à merveille sur mon système. Revoir la configuration de tous ces éléments seraient bien trop long.

Bien entendu, si cette méthode s'avère être la seule solution viable pour faire trouner Drupal 6 alors je ferais l'effort de créer une machine virtuelle.

J'ai lu sur ton site (il me semble que c'est bien le tiens) que tu propose le paquet PHP5.3.18. Ça m'intéresse grandement ne serait-ce que pour tester si j'ai les mêmes problèmes de dépendances à satisfaire.

Dernière modification par cuncta (21/03/2013 11:50:54)

Hors ligne

#4 21/03/2013 12:09:24

pingou
Fedora Addict
Lieu : Toulouse
Inscription : 30/03/2006
Messages : 3 843
Site Web

Re : Icompatibilité Drupal 6 avec PHP5.4

Drupal 6

Although PHP 5.3 is supported by Drupal 6, some contributed modules may not be compatible with PHP 5.3, and some PHP 5.3 configurations still show warnings with Drupal 6.14. Work is ongoing to resolve the latter in #360605: PHP 5.3 Compatibility. Most Drupal 6 contributed modules throw E_STRICT errors on PHP 5.3 and many are practically unusuable on 5.4.

Source: http://drupal.org/requirements/php


On a pas inventé l'électricité en cherchant à améliorer la bougie...
-- Si c'est pas sur le bugzilla, c'est pas un bug ! --

Hors ligne

#5 21/03/2013 12:10:25

remi
Crazy PHP packages monkey... !
Rédacteur Wiki
Lieu : Champagne...
Inscription : 16/10/2004
Messages : 5 579
Site Web

Re : Icompatibilité Drupal 6 avec PHP5.4

Le plus propre serait de reconstruire les RPM (cf documentation sur ce site) en partant du .src.rpm de f16.

Hors ligne

Pied de page des forums