Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora Linux 37 est disponible !

#1 04/03/2013 21:58:52

elbelo69
Membre
Lieu : Lyon
Inscription : 03/09/2007
Messages : 358

x-systemd.automount et Session Gnome

Bonjour,

J'utilisais beaucoup autofs sur F17, mais suite à une discussion sur ce forum et certains articles j'ai décidé de basculé sur x-systemd.automount qui fonctionne parfaitement mais uniquement quand j'ai du réseau !!
Et c'est bien le problème.

Quand je suis connecté sur mon réseau (filaire ou Wifi peut importe) pas de problème, ma session gnome s'ouvre en 3/4 secondes.

Quand je ne suis pas sur mon réseau la session mais entre 3/4 minutes pour s'ouvrir et en plus, comme j'ai demandé via Tweak tools que mon bureau sois gérer par le gestionnaire de fichier je n'ai plus aucunes de mes icônes. Le seul moyen pour réussir à ouvrir une session gnome en moins de 5 minutes consiste à basculer sur TTY2, se logger, commenter la ligne dans fstab et envoyer un HUP au serveur X.

Trois questions :

  • Est ce que quelqu'un utilise x-systemd.automoun et à le même comportement

  • Ou trouver les log gnome

  • Comment régler le problème

synology.home.canoppe-si.fr:/volume1/Temp            /home/vincent/storage/Temp              nfs x-systemd.automount,x-systemd.device-timeout=2  0 0

J'ai essayé 0 comme timeout ca ne change rien.

Pour l'instant les seuls log que j'ai trouvé sont dans messages et ça va pas loin :

Erreur quand pas connecté

Mar  4 08:34:50 vfx systemd[1]: home-vincent-storage-Temp.mount mounting timed out. Stopping.

Quand je suis connecté :

Mar  4 19:33:20 vfx systemd[1]: Mounting /home/vincent/storage/Temp...

Hors ligne

#2 05/03/2013 10:23:35

ptitdernier
Membre
Lieu : de retour en occitanie
Inscription : 19/09/2006
Messages : 1 255

Re : x-systemd.automount et Session Gnome

j'utilise cette méthode avec F18 et pas de problème si je n'ai pas de réseau avec

# automount de QNAP
192.168.0.xxx:/Multimedia  /mnt/Multimedia  nfs  x-systemd.automount,wsize=8192,rsize=8192,async 0 0
192.168.0.xxx:/Public  /mnt/Public  nfs  x-systemd.automount,wsize=8192,rsize=8192,async 0 0

ton problème doit se situer ailleurs ; as-tu cherché une éventuelle erreur avec dmesg ?


MSI GE60 2PE Apache Pro - 16 Go - Intel core i7 4720 2,6 GHz - nVidia GTX860M - Cinnamon
CM ASUS PRIME B250M-K - Intel core I5-7500 3,4 Ghz - 8 Go DDRA Corsair vengence LPX 2400Mhz

Hors ligne

#3 05/03/2013 15:14:25

elbelo69
Membre
Lieu : Lyon
Inscription : 03/09/2007
Messages : 358

Re : x-systemd.automount et Session Gnome

Salut,
Merci pour ta réponse.
Oui j'ai déjà regardé, je n'ai strictement aucun message avec dmesg.

Mais je suis sur que ca viens de là : quand je comment la ligne dans /etc/fstab je me logge directement sans latence.
J'ai testé sur un autre ordinateur en F18, même chose !

Hors ligne

#4 05/03/2013 15:26:04

ptitdernier
Membre
Lieu : de retour en occitanie
Inscription : 19/09/2006
Messages : 1 255

Re : x-systemd.automount et Session Gnome

Bizarre, bizarre ! Chez moi cela fonctionne bien dans tous les cas de figure, même sans connexion réseau filaire ou wifi.
As-tu regardé /var/log/boot.log ?


MSI GE60 2PE Apache Pro - 16 Go - Intel core i7 4720 2,6 GHz - nVidia GTX860M - Cinnamon
CM ASUS PRIME B250M-K - Intel core I5-7500 3,4 Ghz - 8 Go DDRA Corsair vengence LPX 2400Mhz

Hors ligne

#5 05/03/2013 15:29:17

elbelo69
Membre
Lieu : Lyon
Inscription : 03/09/2007
Messages : 358

Re : x-systemd.automount et Session Gnome

Non, je vais regardé mais je n'y crois pas trop.
Le boot ce passe bien, c'est vraiment l'ouverture de session gnome qui prend des plombes !

Hors ligne

#6 05/03/2013 15:34:28

ptitdernier
Membre
Lieu : de retour en occitanie
Inscription : 19/09/2006
Messages : 1 255

Re : x-systemd.automount et Session Gnome

Tu verras si l'automount s'est bien passé en tout début du log (vers les 5-6ème lignes).

As-tu essayé de virer

x-systemd.device-timeout=2

dans fstab ?

Dernière modification par ptitdernier (05/03/2013 15:37:04)


MSI GE60 2PE Apache Pro - 16 Go - Intel core i7 4720 2,6 GHz - nVidia GTX860M - Cinnamon
CM ASUS PRIME B250M-K - Intel core I5-7500 3,4 Ghz - 8 Go DDRA Corsair vengence LPX 2400Mhz

Hors ligne

Pied de page des forums