Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Venez tester la Fedora 33 Beta

#1 27/08/2012 18:22:35

biscotte
Membre
Lieu : Lille
Inscription : 09/03/2012
Messages : 188

[Résolu] [LXDE]Tous les icones du menu démarrer ont disparu

Bonjour j'essaie en vain d'envoyer mes posts sur le forums général de LXDE mais ça  ne marche jamais.Je me tourne vers vous pour trouver une solution à de petits pbs.
J'essaie de personnaliser simplement mon bureau et bien entendu y'a quelques couacs.Le dernier en date je venais de modifier l'apparence du curseur (c pas fini faut remettre tous les liens vers les curseurs par défauds j'vous dis pas le boulot qui m'attend tongue ) et après redémarrage pour prendre en compte la modif tous les icones du menu démarrer ont disparus.Sur le site de LXDE ils disent qu'on peut rafraichir le menu à l'aide de ce script :

#!/bin/bash

killall lxpanel
find ~/.cache/menus -name '*' -type f -print0 | xargs -0 rm
lxpanel -p LXDE &

Où dois placer ces lignes?Dans un fichier .desktop déjà éxistant?Dans un nouveau fichier lancé au démarrage?Comment le faire car ce n'est pas une appli?
Quelqu'un peut-il m'expliquer la procédure car là je butte.


CM Gigabyte A75-D3H procésseur AMD A4-3300 APU with Radéon HD 6410 --- DD WD 500Go SATA --- Ram Kingston 4Go --- Lecteur TSST SH-222AB SATA ---  Fédora 22 4.4.6-200.fc22.x86_64/LXDE

"Chercher à comprendre, c'est commencer à désobéir."

Hors ligne

#2 28/08/2012 01:41:24

DarthWound
Membre
Lieu : Bastia, Corsica
Inscription : 29/03/2011
Messages : 172
Site Web

Re : [Résolu] [LXDE]Tous les icones du menu démarrer ont disparu

Rappel de base :
Regarde l'en-tête : #!/bin/bash
Cela t'indique que c'est un script bash (.sh)

Tu ouvres donc un nouveau document vide, avec Leafpad je crois sous LXDE.
Tu fait un copier-coller de ces lignes dans le document, puis tu l'enregistres "nomduscript.sh".
nomduscript -> tu mets ce que tu veux, par contre le ".sh" est obligatoire.

Faut ensuite lui donner les permissions d'éxécution, soit par un clic droit sur le fichier créé, dans propriétés tu coches "autoriser l'éxécution" ou un truc comme ça, sinon dans le terminal :
chmod +x /chemin/vers/ton/script.sh

Et y'a plus qu'à lancer le script (de préférence dans le terminal).

Note : tu peux aussi rentrer chaque ligne dans ton terminal directement, ça aura le même effet.
L'utilité du script est d'automatiser cette tâche, mais pour trois lignes... à toi de voir :)


Modérateur global de la communauté Steam
AMD Ryzen 5.1600 + AMD Radeon RX580

Hors ligne

#3 28/08/2012 19:28:17

biscotte
Membre
Lieu : Lille
Inscription : 09/03/2012
Messages : 188

Re : [Résolu] [LXDE]Tous les icones du menu démarrer ont disparu

re-re-salut lol
j'ai créer le script et l'ai lancé mais ça n'a rien changé.J'vais voir après redémarrage.Pour info je sais un peu utiliser la console (édition-suppression de fichier/droits d'accès je connais) donc tu n'es pas obligé de tout détaillé à chaque fois.C'est un peu fastidieux pour toi.Mais j'aime la pédagogie donc j'apprécie le geste.C'est juste pour éviter que tu ne perdes du temps vu que tu surfes tard wink
J'vais envoyer un mail dans la faq de LXPanel.Au plaisir.


CM Gigabyte A75-D3H procésseur AMD A4-3300 APU with Radéon HD 6410 --- DD WD 500Go SATA --- Ram Kingston 4Go --- Lecteur TSST SH-222AB SATA ---  Fédora 22 4.4.6-200.fc22.x86_64/LXDE

"Chercher à comprendre, c'est commencer à désobéir."

Hors ligne

#4 29/08/2012 01:13:08

DarthWound
Membre
Lieu : Bastia, Corsica
Inscription : 29/03/2011
Messages : 172
Site Web

Re : [Résolu] [LXDE]Tous les icones du menu démarrer ont disparu

Vu les nuits blanches que j'ai passé à rédiger des wikis ou des articles, je suis plus à quelques lignes x)
Et même si pour toi c'est ok, on sait jamais si quelqu'un passe par là et ne sais pas comment faire, bah ça lui servira.

Dernière modification par DarthWound (29/08/2012 01:13:45)


Modérateur global de la communauté Steam
AMD Ryzen 5.1600 + AMD Radeon RX580

Hors ligne

#5 29/08/2012 15:36:48

biscotte
Membre
Lieu : Lille
Inscription : 09/03/2012
Messages : 188

Re : [Résolu] [LXDE]Tous les icones du menu démarrer ont disparu

tout juste on ne peut pas connaitre d'avance le niveau de celui à qui on répond.J'vais continuer mes recherches pour cette histoire d'icones.


CM Gigabyte A75-D3H procésseur AMD A4-3300 APU with Radéon HD 6410 --- DD WD 500Go SATA --- Ram Kingston 4Go --- Lecteur TSST SH-222AB SATA ---  Fédora 22 4.4.6-200.fc22.x86_64/LXDE

"Chercher à comprendre, c'est commencer à désobéir."

Hors ligne

Pied de page des forums