Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora 30 est mort ce soir

#1 23/04/2012 16:18:00

PapsOu
Developpeur PHP7 Symfony3
Rédacteur Wiki
Lieu : Quimper
Inscription : 27/11/2009
Messages : 1 849
Site Web

[Résolu] Installation de Wine impossible

Bonjour à tous,

Je rencontre un petit soucis lorsque je veux installer Wine.
Les libs du pilote graphique libre AMD rentrent en conflit avec celles demandée par wine :

[root@Salon ~]# yum install wine
Modules complémentaires chargés : auto-update-debuginfo, langpacks, presto,
                                : refresh-packagekit
Résolution des dépendances
--> Lancement de la transaction de test
---> Le paquet wine.x86_64 0:1.5.1-1.fc16 sera installé
--> Traitement de la dépendance : wine-wow(x86-64) = 1.5.1-1.fc16 pour le paquet : wine-1.5.1-1.fc16.x86_64
--> Traitement de la dépendance : wine-twain(x86-64) = 1.5.1-1.fc16 pour le paquet : wine-1.5.1-1.fc16.x86_64
--> Traitement de la dépendance : wine-twain(x86-32) = 1.5.1-1.fc16 pour le paquet : wine-1.5.1-1.fc16.x86_64
--> Traitement de la dépendance : wine-pulseaudio(x86-64) = 1.5.1-1.fc16 pour le paquet : wine-1.5.1-1.fc16.x86_64
--> Traitement de la dépendance : wine-pulseaudio(x86-32) = 1.5.1-1.fc16 pour le paquet : wine-1.5.1-1.fc16.x86_64
                                                    [---]
---> Le paquet libXi.i686 0:1.4.5-1.fc16 sera installé
---> Le paquet sqlite.i686 0:3.7.7.1-1.fc16 sera installé
--> Traitement de la dépendance : libtinfo.so.5 pour le paquet : sqlite-3.7.7.1-1.fc16.i686
--> Traitement de la dépendance : libreadline.so.6 pour le paquet : sqlite-3.7.7.1-1.fc16.i686
--> Traitement de la dépendance : libncurses.so.5 pour le paquet : sqlite-3.7.7.1-1.fc16.i686
--> Lancement de la transaction de test
---> Le paquet ncurses-libs.i686 0:5.9-2.20110716.fc16 sera installé
---> Le paquet readline.i686 0:6.2-2.fc16 sera installé
--> Résolution des dépendances terminée
Erreur : protection contre les différentes versions de bibliothèques : mesa-dri-filesystem-7.11.2-3.fc16.i686 != mesa-dri-filesystem-7.12-0.6.fc17.x86_64
Erreur : protection contre les différentes versions de bibliothèques : llvm-libs-2.9-10.fc16.i686 != llvm-libs-3.0-1.fc17.x86_64
Erreur : protection contre les différentes versions de bibliothèques : mesa-libGLU-7.11.2-3.fc16.i686 != mesa-libGLU-7.12-0.6.fc17.x86_64
Erreur : protection contre les différentes versions de bibliothèques : mesa-libGL-7.11.2-3.fc16.i686 != mesa-libGL-7.12-0.6.fc17.x86_64
Erreur : protection contre les différentes versions de bibliothèques : mesa-dri-drivers-7.11.2-3.fc16.i686 != mesa-dri-drivers-7.12-0.6.fc17.x86_64

J'ai installé à la main mesa 7.12 pour raison de soucis avec blender. Mais je ne vois pas pourquoi l'installation de wine réclame les libs 32 bit alors que je suis en 64 ?
Est-il possible d'installer deux versions différentes d'un même paquet ? ex : 7.11.i686 <-> 7.12.x86_64

Merci d'avance pour votre coup de main.

PS : Je préfèrerai ne pas désinstaller mesa 7.12 étant donnée que ça fonctionne nickel de ce côté là.

Hors ligne

#2 23/04/2012 16:28:11

PapsOu
Developpeur PHP7 Symfony3
Rédacteur Wiki
Lieu : Quimper
Inscription : 27/11/2009
Messages : 1 849
Site Web

Re : [Résolu] Installation de Wine impossible

Je rajoute des infos :

# uname -r
3.3.2-1.fc16.x86_64

# rpm -qa mesa\*
mesa-libGLU-7.12-0.6.fc17.x86_64
mesa-debuginfo-7.12-0.6.fc17.x86_64
mesa-libGL-7.12-0.6.fc17.x86_64
mesa-dri-filesystem-7.12-0.6.fc17.x86_64
mesa-dri-drivers-7.12-0.6.fc17.x86_64

[edit] : un yum clean all && yum update ne change rien au problème.

[edit 2] : un yum distro-sync veut bien entendu downgrader mes paquets mesa, ce que je préfèrerais ne pas faire...

Une solution, un tuyau ?

Dernière modification par PapsOu (23/04/2012 16:33:48)

Hors ligne

#3 23/04/2012 17:31:30

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 22 419

Re : [Résolu] Installation de Wine impossible

Est-il possible d'installer deux versions différentes d'un même paquet ? ex : 7.11.i686 <-> 7.12.x86_64

Oui pour faire tourner des programmes 32 bits sur un système 64 bits


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#4 23/04/2012 17:47:01

PapsOu
Developpeur PHP7 Symfony3
Rédacteur Wiki
Lieu : Quimper
Inscription : 27/11/2009
Messages : 1 849
Site Web

Re : [Résolu] Installation de Wine impossible

nouvo09 a écrit :

Est-il possible d'installer deux versions différentes d'un même paquet ? ex : 7.11.i686 <-> 7.12.x86_64

Oui pour faire tourner des programmes 32 bits sur un système 64 bits

Dommage ça ne s'applique pas sur ces paquets là :

# yum install mesa-dri-filesystem-7.11.2-3.fc16.i686
Modules complémentaires chargés : auto-update-debuginfo, langpacks, presto,
                                : refresh-packagekit
Résolution des dépendances
--> Lancement de la transaction de test
---> Le paquet mesa-dri-filesystem.i686 0:7.11.2-3.fc16 sera installé
--> Résolution des dépendances terminée
Erreur : protection contre les différentes versions de bibliothèques : mesa-dri-filesystem-7.11.2-3.fc16.i686 != mesa-dri-filesystem-7.12-0.6.fc17.x86_64

Hors ligne

#5 23/04/2012 18:00:29

Refuznik
Membre
Inscription : 31/01/2007
Messages : 7 619

Re : [Résolu] Installation de Wine impossible

Est-il possible d'installer deux versions différentes d'un même paquet ? ex : 7.11.i686 <-> 7.12.x86_64

Non chez moi pour du nvidia j'ai les versions 32 et 64 mais il faut que ce soit la même version.

Hors ligne

#6 23/04/2012 20:32:14

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 22 419

Re : [Résolu] Installation de Wine impossible

Clairement dans l'exemple ce n'est pas le même paquet.


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#7 23/04/2012 20:41:55

chepioq
FEDORA FOR EVER
Lieu : a l'est de marseille
Inscription : 07/06/2006
Messages : 7 334

Re : [Résolu] Installation de Wine impossible

Juste une question :
Comment se fait-il que tu ai des paquets fc17 sur ta Fedora 16 ?


Tout est dans tout... et réciproquement...
C'est quoi un chalumeau??? C'est un dromaludaire à deux bosses...
Quand le sage montre la lune l'imbécile regarde le doigt...
1277887812.gif

Hors ligne

#8 23/04/2012 23:14:02

PapsOu
Developpeur PHP7 Symfony3
Rédacteur Wiki
Lieu : Quimper
Inscription : 27/11/2009
Messages : 1 849
Site Web

Re : [Résolu] Installation de Wine impossible

chepioq a écrit :

Juste une question :
Comment se fait-il que tu ai des paquets fc17 sur ta Fedora 16 ?

J'ai installé ces paquets pour résoudre un soucis du pilote (mesa : voir le sujet « tester mesa 7.12 ») et c'est pour cela que je voudrai ne pas revenir à une version antérieure...

Hors ligne

#9 24/04/2012 07:39:23

chepioq
FEDORA FOR EVER
Lieu : a l'est de marseille
Inscription : 07/06/2006
Messages : 7 334

Re : [Résolu] Installation de Wine impossible

En regardant sur koji, je vois que mesa 7.12 n'est empaqueté que pour F17.

Je vois plusieurs solutions à ton problème :
-- Faire une demande sur le bugzilla pour que les devs fassent les paquets pour F16, mais cela risque de prendre du temps, vu que pour le moment ils sont plutôt focalisés sur F17 et sa sortie prochaine.

--tu peux aussi installer les paquets qui te manquent (mesa-dri-filesystem-7.12-0.6.fc17.i686, llvm-libs-3.0-1.fc17.i686, mesa-libGLU-12-0.6.fc17.i686, mesa-libGL-12-0.6.fc17.i686 et mesa-dri-drivers-12-0.6.fc17.i686, à récupérer sur koji, par exemple ), en espérant qu'ils ne demanderont pas d'autres dépendances...

-- Tu peux aussi récupérer ces paquets et les reconstruire pour F16 avec rpmbuild ou encore mieux avec mock

Dernière modification par chepioq (24/04/2012 07:45:37)


Tout est dans tout... et réciproquement...
C'est quoi un chalumeau??? C'est un dromaludaire à deux bosses...
Quand le sage montre la lune l'imbécile regarde le doigt...
1277887812.gif

Hors ligne

#10 24/04/2012 11:07:51

PapsOu
Developpeur PHP7 Symfony3
Rédacteur Wiki
Lieu : Quimper
Inscription : 27/11/2009
Messages : 1 849
Site Web

Re : [Résolu] Installation de Wine impossible

Ok je tente l'installation des paquets 32bits pour voir si ça résout le souci.

Résolu ! Super merci chepioq !

A plus !

Dernière modification par PapsOu (24/04/2012 11:13:26)

Hors ligne

Pied de page des forums