Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora 34 n'est plus maintenu

#1 26/09/2009 08:25:53

pmarion
Pacsé avec le forum
Lieu : 95000 CERGY
Inscription : 14/11/2006
Messages : 8 032

ffmpeg mp3 libmp3lame buffer too small (j'ai presque tout dit)

Bonjour,
Voulant encoder un fichier mpg en avi (DivX/mp3) j'utilise

ffmpeg -i fichier_source -sameq -vcodec libxvid -acodec libpm3lame fichier.avi

J'obtiens le message

[libmp3lame @ 0x2180b70]lame: output buffer too small (buffer index: 9600, free bytes: 192)

Le fichier est bien encodé en mp3 (voir file nom_fichier), mais il est désespérément muet.

file xxxxxxx.avi
xxxxxxx.avi:   RIFF (little-endian) data, AVI, 720 x 576, 25.00 fps, video: XviD, audio: MPEG-1 Layer 3 (stereo, 48000 Hz)

Est-ce que quelqu'un peut me préciser où se trouve le paramétrage de la taille de ce buffer ?

Si j'encode l'audio en mp2 je n'ai pas de problème.

RIFF (little-endian) data, AVI, 320 x 240, ~30 fps, video: XviD, audio: MPEG-1 Layer 1 or 2 (stereo, 44100 Hz)

Dernière modification par pmarion (26/09/2009 08:55:06)

Hors ligne

#2 26/09/2009 09:37:35

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 23 701

Re : ffmpeg mp3 libmp3lame buffer too small (j'ai presque tout dit)

Tu es sur qu'il ne manque pas un paramètre à libmp3lame et qu'il aurait de ce fait un comportement erratique ?

D'ailleurs je me demande si on ne doit pas invoquer lame avec des options plutôt que directement sa bibliothèque libmp3lame.


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#3 26/09/2009 10:38:11

pmarion
Pacsé avec le forum
Lieu : 95000 CERGY
Inscription : 14/11/2006
Messages : 8 032

Re : ffmpeg mp3 libmp3lame buffer too small (j'ai presque tout dit)

Merci pour ta réponse, je débute (depuis dix ans !) dans les problèmes de conversion, mais c'est la première fois que je dois encoder du son mp3 dans un AVI.
J'ai installé le paquet lame-libs-3.98.2-3.fc11.x86_64, mais curieusement
avec
ffmpeg -formats list | grep -i mp3

..............
--enable-libmp3lame
.....
 D A    mp3             MP3 (MPEG audio layer 3)
 D A    mp3adu          ADU (Application Data Unit) MP3 (MPEG audio layer 3)
 D A    mp3on4          MP3onMP4
........

on pourrait penser que le codec mp3 est accessible mais avec
ffmpeg -i source ............ -acodec mp3 destination
j'obtiens

Unknown encoder 'mp3'

En faisant une recherche sur Unknown encoder 'mp3' j'ai vu que l'on pouvait utiliser «-acodec libmp3lame»  (d'ailleurs pour le codec video xvid on utilise vcodec libxvid, donc on attaque bien la lib).

Comment fais-tu pour encoder en mp3 ?

Dernière modification par pmarion (26/09/2009 10:39:34)

Hors ligne

#4 26/09/2009 12:04:00

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 23 701

Re : ffmpeg mp3 libmp3lame buffer too small (j'ai presque tout dit)

Comment fais-tu pour encoder en mp3 ?

Je n'ai pas ta patience alors j'utilise MediaCoder (la honte...).

Mais je persiste à penser qu'il peut(doit) manquer une option ce qui fait qu'à défaut la valeur est 0 et que ca doit influer sur le résultat. On peut d'ailleurs envisager de mettre derriere libmp3lame les options de lame, de la même façon ce qui figure dans le man:

Example:

                   ffmpeg -i file.mpg -vcodec copy -acodec ac3 -ab 384k test.mpg -acodec mp2 -ab 192k -newaudio


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#5 26/09/2009 12:18:46

pmarion
Pacsé avec le forum
Lieu : 95000 CERGY
Inscription : 14/11/2006
Messages : 8 032

Re : ffmpeg mp3 libmp3lame buffer too small (j'ai presque tout dit)

Je pense que le «b» de l'option «-ab» permet de spécifier un débit bit/seconde mais pas un buffer.
Je ne vois comment spécifier une taille de buffer dans ffmpeg.

J'ai essayé avec différentes valeurs de «-ab 128k», «-ab 256k», ... , j'ai toujours une erreur de buffer.

Hors ligne

#6 26/09/2009 12:52:04

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 23 701

Re : ffmpeg mp3 libmp3lame buffer too small (j'ai presque tout dit)

Non non ce que je veux dire c'est qu'il y a sans doute des options à indiquer après libmp3lame.

Lesquelles ? J'ignore mais on trouve plein de choses dans man lame et aussi dans /usr/share/docs/lame-xxx


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#7 26/09/2009 13:04:28

MarbolanGos
Rédacteur Wiki
Rédacteur Wiki
Lieu : Fontenay-aux-Roses
Inscription : 11/02/2007
Messages : 4 879
Site Web

Re : ffmpeg mp3 libmp3lame buffer too small (j'ai presque tout dit)

pmarion a écrit :

Merci pour ta réponse, je débute (depuis dix ans !) dans les problèmes de conversion, mais c'est la première fois que je dois encoder du son mp3 dans un AVI.
J'ai installé le paquet lame-libs-3.98.2-3.fc11.x86_64, mais curieusement
avec
ffmpeg -formats list | grep -i mp3

..............
--enable-libmp3lame
.....
 D A    mp3             MP3 (MPEG audio layer 3)
 D A    mp3adu          ADU (Application Data Unit) MP3 (MPEG audio layer 3)
 D A    mp3on4          MP3onMP4
........

on pourrait penser que le codec mp3 est accessible mais avec
ffmpeg -i source ............ -acodec mp3 destination
j'obtiens

Unknown encoder 'mp3'

En faisant une recherche sur Unknown encoder 'mp3' j'ai vu que l'on pouvait utiliser «-acodec libmp3lame»  (d'ailleurs pour le codec video xvid on utilise vcodec libxvid, donc on attaque bien la lib).

Comment fais-tu pour encoder en mp3 ?

Quand j'ai vu le premier post fait regardé si je trouvais pas une solution rapide mais j'ai trouvé un post d'un gars qui disait que l'option -acodec mp3 permettait de décoder alors que le libmp3lame permettait d'encoder.


Fedora 19 : 1 Dell XPS M1330, 1 fixe custom et 1 Dell Latitude 6430u

Hors ligne

#8 26/09/2009 13:21:42

pmarion
Pacsé avec le forum
Lieu : 95000 CERGY
Inscription : 14/11/2006
Messages : 8 032

Re : ffmpeg mp3 libmp3lame buffer too small (j'ai presque tout dit)

j'ai trouvé un post d'un gars qui disait que l'option -acodec mp3 permettait de décoder alors que le libmp3lame permettait d'encoder.

Je n'ai jamais utilisé d'option de décodage avec ffmpeg (il détecte très bien tout seul le ou les codecs de décodage).
Je ne sais même pas à quel endroit il faudrait spécifier le «-acodec», devant le -i «input_file» comme d'autres options du fichiers source .
ffmpeg -acodec mp3 truc.avi -sameq truc.mpg
Unknown encoder 'mp3'


J'ignore mais on trouve plein de choses dans man lame et aussi dans /usr/share/docs/lame-xxx

Dans le man de «lame» :

man lame a écrit :

....
Lame ain't an MP3 encoder
.....................

yum info lame-libs

Description :LAME MP3 encoding library.

Mais je ne vois pas de lien entre les options possibles de «lame» et celles de «ffmpeg».  Comment spécifier via les options de ffmpeg des options éventuelles de libmp3lame.
Quant à un man sur libmp3lame ?

Dernière modification par pmarion (26/09/2009 13:34:34)

Hors ligne

#9 26/09/2009 14:01:37

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 23 701

Re : ffmpeg mp3 libmp3lame buffer too small (j'ai presque tout dit)

Il n'y a pas à proprement parler de man sur libmp3lame. Mais lorsqu'on regarde le man lame qui fait appel à cette bibliothèque, on voit qu'on a un tas d'options

Je ne serais pas surpris qu'elles trouvent à s'appliquer après l'appel de libmp3lame en ligne de commande.
Accessoirement l'affirmation hypocrite selon laquelle lame ne serait pas un encodeur est démentie par la version actuelle du man !

lame(1)                      LAME audio compressor                     lame(1)

moi je tenterais un

ffmpeg -i fichier_source -sameq -vcodec libxvid -acodec libpm3lame -option1 - option2 fichier.avi

regarde là

file:///usr/share/doc/lame-3.98.2/switchs.html

Dernière modification par nouvo09 (26/09/2009 14:07:40)


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#10 26/09/2009 14:22:32

pmarion
Pacsé avec le forum
Lieu : 95000 CERGY
Inscription : 14/11/2006
Messages : 8 032

Re : ffmpeg mp3 libmp3lame buffer too small (j'ai presque tout dit)

Je viens de faire une extraction uniquement du son dans un fichier mp3
ffmpeg -i truc.mpg -sameq -vn -acodec libmp3lame truc.mp3
Pas de video et encodage avec «libmp3lame»

[libmp3lame @ 0x13a8d00]lame: output buffer too small (buffer index: 9404, free bytes: 388)
Audio encoding failed

Mais dans ce cas j'obtiens un magnifique fichier mp3 audible
file truc.mp3

Audio file with ID3 version 2.4.0, contains: MPEG ADTS, layer III, v1,  64 kbps, 44.1 kHz, JntStereo

Ceci confirmerait que le message «output buffer too small» n'empêche pas de transcoder (merci google).

Mais si j'essaie de fusionner deux fichiers (l'un ne contenant que de la vidéo, et l'autre ne contenant que le son en mp3) 
ffmpeg -i -source_video -i source_son -sameq -acodec copy -vcodec libxvid truc.avi
au bout d'un certain temps :

[NULL @ 0x1085d80]error, non monotone timestamps 57600 >= 576001370.9kbits/s   
av_interleaved_write_frame(): Error while opening file

Il semble que seule la moitié du fichier y soit mais j'ai bien
file truc.avi

RIFF (little-endian) data, AVI, 640 x 352, 23.98 fps, video: XviD, audio: MPEG-1 Layer 3 (stereo, 44100 Hz)

De plus, le fichier avi est lisible avec kaffeine mais illisible par vlc
vlc truc.avi

avi demux error: avi module discarded (invalid file)
[NULL @ 0x7fc654c4f850]illegal chroma format
[NULL @ 0x7fc654c4f850]N-bit not supported
[NULL @ 0x7fc654c4f850]quant precision 10
Marker bit missing in complexity estimation part 2

Hors ligne

#11 26/09/2009 15:33:45

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 23 701

Re : ffmpeg mp3 libmp3lame buffer too small (j'ai presque tout dit)

Alors prends virtualdubmode sous wine ?


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#12 28/09/2009 19:17:44

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 23 701

Re : ffmpeg mp3 libmp3lame buffer too small (j'ai presque tout dit)

Tu t'en es sorti ?


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#13 28/09/2009 21:43:42

bob031
Membre
Inscription : 17/12/2007
Messages : 137

Re : ffmpeg mp3 libmp3lame buffer too small (j'ai presque tout dit)

Bonjour,

d'après google, peut-être faudrait-il voir quelle est la version de ffmpeg et lame et soit downgrader, soit upgrader :

This has been fixed in r9786. You should upgrade ffmpeg.

source : http://archives.free.net.ph/message/200 … 74.en.html


Downgrading to lame v3.97 sure worked. Thanks

source : http://drupal.org/node/376012



de la doc :

http://howto-pages.org/ffmpeg/

http://web.njit.edu/all_topics/Prog_Lan … ation.html


si ça peut aider ....

Dernière modification par bob031 (28/09/2009 21:47:35)


Un penguin sur la banquise.

Hors ligne

#14 29/09/2009 08:08:41

pmarion
Pacsé avec le forum
Lieu : 95000 CERGY
Inscription : 14/11/2006
Messages : 8 032

Re : ffmpeg mp3 libmp3lame buffer too small (j'ai presque tout dit)

@nouv09
Merci pour ton conseil avec virtualdubmode que j'ai eu du mal à installer sous Window$ Seven (sous F11+VirtualBox).  J'obtiens biend des xxxx.avi mais beaucoup plus volumineux que l'original en mpg, chose surprenante.

En plus,  je veux voudrais  :
- Etre si possible en OpenSource
- Travailler en mode commande pour automatiser mes traitements/

@bob031
Merci pour tes informations mais avant de lire ton message j'ai passé hier beaucoup de temps avec mencoder .

De plus pour mp3 «output buffer too small», c'est un message d'alerte mais qui n'interromps pas la conversion et la bande son est correcte (à mon sens auditif) 
Le problème que j'ai surtout c'est que la conversion en xvid + mp3 pose des problèmes avec vlc (mais pas à kaffeine) .
Si j'utilise xvid+mp2, pas de problème, si j'utilise DIVX+mp3, pas de problème, donc j'abandonne plus ou moins ffmpeg.

J'ai finalement trouvé un solution (provisoire? ) .

mencoder -oac mp3lame -ovc xvid -xvidencopts bitrate=900 -o truc.avi truc.mpg

Mais je me permets de vous demander à tous si vous préférez
- ffmpeg
- mencoder

Jusqu'à présent j'utilisais surtout ffmpeg plus simple à mon avis (avec des options comme -sameq) et je ne chechais pas de codec précis, je faisais confiance à ffmpeg pour le choix des codecs et les valeurs par défaut d'une destination .mpg, .avi me convenaient jusque à ce jour où j'ai voulu eu besoin de faire du xvid+mp3.

J'espionne aussi (ps -ef) ce que fait kino lors d'une exportation, et j'ai appris beaucoup avec cela sans y comprendre grand chose car c'est bien la le problème avec la vidéo, c'est comprendre ce qui se passe.

Dernière modification par pmarion (29/09/2009 08:17:59)

Hors ligne

#15 29/09/2009 11:00:53

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 23 701

Re : ffmpeg mp3 libmp3lame buffer too small (j'ai presque tout dit)

pmarion a écrit :

@nouv09
Merci pour ton conseil avec virtualdubmode que j'ai eu du mal à installer sous Window$ Seven (sous F11+VirtualBox).  J'obtiens biend des xxxx.avi mais beaucoup plus volumineux que l'original en mpg, chose surprenante.

En plus,  je veux voudrais  :
- Etre si possible en OpenSource
- Travailler en mode commande pour automatiser mes traitements/

Apparemment la question de la taille des fichiers de sortie dépend des réglages du codec, et là j'ai du tâtonner pas mal pour trouver le bon compromis entre taille/qualité. J'utilise actuellement un débit d'environ 1000 ko/sec.

Par ailleurs, j'ai regardé la doc de Virtualdubmod, et il s'utilise aussi en ligne de commande, j'ai vu ca dans le fichier d'aide.

Pour ce qui est du message d'erreur que tu signalais au début, il semble que ce soit un bug de sortie de traitement. Je l'ai eu hier en testant ffmpeg sur un fichier de 400Mo, tout à la fin. Ou alors il y a eu un léger décalage de son, que je n'ai pas constaté, et qui a pu faire que le buffer en question était vide. Il me semble que c'est plutôt un défaut de finition.


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#16 29/09/2009 11:11:14

pmarion
Pacsé avec le forum
Lieu : 95000 CERGY
Inscription : 14/11/2006
Messages : 8 032

Re : ffmpeg mp3 libmp3lame buffer too small (j'ai presque tout dit)

Il me semble que c'est plutôt un défaut de finition.

Je le pense aussi, mais il reste que l'association xvid + mp3 pose des problèmes alors que xvid + mp2 n'en pose pas, donc si l'on désire un résultat correct mencoder est mieux placé.

Pour en revenir au monde (complexe! ! !)  des fichiers vidéos et de leurs soit-disants standard, existe-t-il une commande plus poussée que file pour tout savoir sur le contenu d'un fichier.
Pour moi chaque fichier (ou tout du moins chaque origine de fichier video) est un nouveau problème (historiquement j'ai eu 3 APN et trois types de vidéos totalement différents sans parler des camescopes)
Car avec file j'obtiens bien un résultat identique à d'autres fichiers corrects, mais vlc refuse (par exemple un mp3 avec «0 channel») alors que le même fichier passe avec un son correct dans kaffeine.
Ce «0 channel» me laisse rêveur d'ailleurs mais dans ce cas je force (avec «-ac 2») mais sans vraiment comprendre.

Je pense que je vais ouvrir un autre post plus général pour mes question générales.

Hors ligne

#17 29/09/2009 12:24:32

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 23 701

Re : ffmpeg mp3 libmp3lame buffer too small (j'ai presque tout dit)

Pour en revenir au monde (complexe! ! !)  des fichiers vidéos et de leurs soit-disants standard, existe-t-il une commande plus poussée que file pour tout savoir sur le contenu d'un fichier.

J'utilise Gspot dont auquel je ne connais pas d'équivalent sous linux .

Dernière modification par nouvo09 (29/09/2009 12:24:51)


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#18 29/09/2009 13:04:16

Pikachu_2014
Retraité
Lieu : Boulogne-Billancourt
Inscription : 16/06/2005
Messages : 11 334
Site Web

Re : ffmpeg mp3 libmp3lame buffer too small (j'ai presque tout dit)

pmarion a écrit :

Pour en revenir au monde (complexe! ! !)  des fichiers vidéos et de leurs soit-disants standard, existe-t-il une commande plus poussée que file pour tout savoir sur le contenu d'un fichier.

Les solutions ne manquent pas sous Linux en ligne de commande :
- totem-video-indexer (livré avec totem ; celui que je préfère dans cette liste) ;
- "mplayer -nosound -vo null -really-quiet -identify fichier" ;
- midentify/tcprobe (livrés avec transcode) ;
- sans oublier ffmpeg qui, à défaut parait-il de faire son boulot correctement, affiche les info. du fichier qu'on lui passe en entrée avant d'effectuer le moindre traitement...
Google est très loquace sur le sujet, d'ailleurs.


« …elle excitait si puissamment le désir, que je devins alors très incrédule sur sa vertu. »
À propos de Fœdora, dans la Peau de Chagrin (Balzac) roll

Hors ligne

#19 29/09/2009 13:23:27

pmarion
Pacsé avec le forum
Lieu : 95000 CERGY
Inscription : 14/11/2006
Messages : 8 032

Re : ffmpeg mp3 libmp3lame buffer too small (j'ai presque tout dit)

@pikachu
Merci de tes réponses, mais cela ne m'avance pas beaucoup. Bien sûr je connaissais l'affichage de ffmpeg mais qui donne un peu plus de renseignements que file ou totem-video-indexer mais ne garantit pas une bonne information.
Exemple :
totem-video-indexer xxxx.avi

TOTEM_INFO_DURATION=115
TOTEM_INFO_HAS_VIDEO=True
TOTEM_INFO_VIDEO_WIDTH=720
TOTEM_INFO_VIDEO_HEIGHT=576
TOTEM_INFO_VIDEO_CODEC=ISO MPEG-4 (XviD) (ffmpeg)
TOTEM_INFO_FPS=25
TOTEM_INFO_HAS_AUDIO=True
TOTEM_INFO_AUDIO_CODEC=MPEG layer 2/3

file xxxxx.avi

xxxxx.avi: RIFF (little-endian) data, AVI, 720 x 576, 25.00 fps, video: XviD, audio: MPEG-1 Layer 3 (stereo, 48000 Hz)

A part la durée («duration») je n'ai pas plus d'information par exemple sur la fréquence d'échantillonage ni sur le nombre de canaux audio dans le cas ou vlc refuse de lire certains fichiers avec le message
avi demux error: avi module discarded (invalid file)
ou
Could not find codec parameters (Audio: mp3, 0 channels, s16)
ou
header damaged 25 fois par seconde

j'en passe et des meilleures.
C'est peut-être un bug de vlc mais bug dans ffmpeg + bug dans vlc cela fait beaucoup .

Ce qui me sidère, c'est qu'avec toutes les manipulations ffmpeg ou mencoder dans certains cas j'ai des fichiers qui passent ou d'autres qui ne passent pas avec le même «file» ou le même «totem-video-indexer».


Autre exemple avec un fichier xxxxxx.ts (en provenance d'une freebox V5)
totem-video-indexer xxxxxx.ts
TOTEM_INFO_DURATION=412
TOTEM_INFO_HAS_VIDEO=True
TOTEM_INFO_HAS_AUDIO=True

file xxxxx.ts

xxxxxx.ts:  data

alors que ce fichier est parfaitement lisible avec vlc, kaffeine

Même fichier avec ffmpeg
ffmpeg -i truc.ts -sameq truc.mpg

Input #0, mpegts, from 'truc.ts':
  Duration: 00:25:11.73, start: 36701.118833, bitrate: 1744 kb/s
  Program 1 
    Stream #0.0[0x44]: Video: mpeg2video, yuv420p, 544x576 [PAR 32:17 DAR 16:9], 104857 kb/s, 25 tbr, 90k tbn, 50 tbc
    Stream #0.1[0x45](fra): Audio: mp2, 48000 Hz, stereo, s16, 192 kb/s
Output #0, mpeg, to 'truc.mpg':
    Stream #0.0: Video: mpeg1video, yuv420p, 544x576 [PAR 32:17 DAR 16:9], q=2-31, 200 kb/s, 90k tbn, 25 tbc
    Stream #0.1(fra): Audio: mp2, 0 channels, s16, 64 kb/s
Stream mapping:
  Stream #0.0 -> #0.0
  Stream #0.1 -> #0.1
[mp2 @ 0x113ce60]encoding 0 channel(s) is not allowed in mp2
Error while opening codec for output stream #0.1 - maybe incorrect parameters such as bit_rate, rate, width or height

Dans ce cas ffmpeg est le plus performant sur le plan des informations.

Dernière modification par pmarion (29/09/2009 13:36:51)

Hors ligne

#20 29/09/2009 13:49:23

pmarion
Pacsé avec le forum
Lieu : 95000 CERGY
Inscription : 14/11/2006
Messages : 8 032

Re : ffmpeg mp3 libmp3lame buffer too small (j'ai presque tout dit)

mplayer -nosound -vo null -really-quiet -identify truc.avi

mplayer: could not connect to socket
mplayer: No such file or directory
ID_VIDEO_ID=0
ID_AUDIO_ID=1
ID_CLIP_INFO_NAME0=Software
ID_CLIP_INFO_VALUE0=MEncoder 29092-4.4.0
ID_CLIP_INFO_N=1
ID_FILENAME=truc.avi
ID_DEMUXER=avi
ID_VIDEO_FORMAT=XVID
ID_VIDEO_BITRATE=3544976
ID_VIDEO_WIDTH=720
ID_VIDEO_HEIGHT=576
ID_VIDEO_FPS=25.000
ID_VIDEO_ASPECT=1.3647
ID_LENGTH=115.00
ID_SEEKABLE=1
ID_CHAPTERS=0
ID_VIDEO_CODEC=ffodivx
ID_VIDEO_ASPECT=1.3647

mplayer -nosound -vo null -really-quiet -identify truc.ts >/tmp/trace 2>&1

mplayer: could not connect to socket
mplayer: No such file or directory
PROGRAM_ID=1 (0x01), PMT_PID: 66(0x42)
ID_VIDEO_ID=68
ID_VIDEO_ID=68
ID_VIDEO_ID=68
ID_VIDEO_ID=68
ID_VIDEO_ID=68
.....
........

plus de 8000 fois cette ligne «ID_VIDEO_ID=68»
puis enfin

D_FILENAME=truc.ts
ID_DEMUXER=mpegts
ID_VIDEO_FORMAT=0x10000002
ID_VIDEO_BITRATE=0
ID_VIDEO_WIDTH=544
ID_VIDEO_HEIGHT=576
ID_VIDEO_FPS=25.000
ID_VIDEO_ASPECT=0.0000
ID_LENGTH=0.00
ID_SEEKABLE=1
ID_CHAPTERS=0
ID_VIDEO_CODEC=mpegpes

Ce n'est pas (encore?) la commande idéale que je recherche.

Dernière modification par pmarion (29/09/2009 13:51:36)

Hors ligne

#21 29/09/2009 13:56:15

Pikachu_2014
Retraité
Lieu : Boulogne-Billancourt
Inscription : 16/06/2005
Messages : 11 334
Site Web

Re : ffmpeg mp3 libmp3lame buffer too small (j'ai presque tout dit)

Tu as testé "D.I.Y." ? L'API de ffmpeg est très riche, quoique celle de transcode n'ait pas à rougir non plus, pour récupérer les différents paramètres dont tu as besoin. Tu pourrais objecter qu'il n'y a pas de binding en Perl dans les dépôts, mais c'est un détail que tu sauras dépasser. Ou pas.


« …elle excitait si puissamment le désir, que je devins alors très incrédule sur sa vertu. »
À propos de Fœdora, dans la Peau de Chagrin (Balzac) roll

Hors ligne

#22 29/09/2009 13:59:10

pmarion
Pacsé avec le forum
Lieu : 95000 CERGY
Inscription : 14/11/2006
Messages : 8 032

Re : ffmpeg mp3 libmp3lame buffer too small (j'ai presque tout dit)

tcprobe -i truc.ts

[probe_ffmpeg.c] critical: unable to open 'truc.ts' (libavformat failure)
[tcprobe] critical: failed to probe source

tcprobe -i truc.avi

[tcprobe] RIFF data, AVI video
[tcprobe] summary for truc.avi, (*) = not default, 0 = not detected
import frame size: -g 640x352 [720x576] (*)
       frame rate: -f 23.976 [25.000] frc=1 (*)
      audio track: -a 0 [0] -e 44100,0,2 [48000,16,2] -n 0x55 [0x2000] (*)
                   bitrate=265 kbps
           length: 4321 frames, frame_time=41 msec, duration=0:03:00.221

Rien sur l'encodage video ni audio

Ce n'est pas (encore?) la commande idéale que je recherche.

Hors ligne

Pied de page des forums