Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora Linux 37 est disponible !

#1 24/09/2008 19:00:48

Nightwatcher
Membre
Inscription : 05/03/2007
Messages : 112
Site Web

[Résolu] Ma webcam - et GSPCA

Bonjour

j'ai réinstallé Fedora Core 9 suite à un crash HD.
Tout s'est pas trop mal passé...

La je veux installer ma cam C'est une Connectland MC-009
la voila quand je fais une lsusb : Bus 004 Device 002: ID 0ac8:301b Z-Star Microelectronics Corp. ZC0301 WebCam

Comme j'avais deja galèré au départ lors de ma dernière installation, je me souvenais qu'elle nécessite le module gspca pour fonctionner

Yum est mon ami ;) Je lui ai donc soufflé à l'oreille (en root of course)
yum install gspca kmd-gspca

hors voilà ce qu'il me dit l'effronté :
--> Résolution des dépendances terminée
kmod-gspca-2.6.25.14-108.fc9.i686-1.00.20-16.lvn9.i686 de livna a des problèmes de dépendances
  --> Dépendance manquante : kernel-uname-r = 2.6.25.14-108.fc9.i686 est requis par le paquetage kmod-gspca-2.6.25.14-108.fc9.i686-1.00.20-16.lvn9.i686 (livna)
Erreur : Dépendance manquante : kernel-uname-r = 2.6.25.14-108.fc9.i686 est requis par le paquetage kmod-gspca-2.6.25.14-108.fc9.i686-1.00.20-16.lvn9.i686 (livna)


Voila mon noyau :
[root@Papa ~]# uname -r
2.6.26.3-29.fc9.i686

Qu'est ce que je peux faire? revenir sur le noyau précédent et essayer d'installer le module?


Aiutoooooooooooooooo

Hors ligne

#2 24/09/2008 19:02:08

Pikachu_2014
Retraité
Lieu : Boulogne-Billancourt
Inscription : 16/06/2005
Messages : 11 334
Site Web

Re : [Résolu] Ma webcam - et GSPCA

Bonjour,

installe plutôt akmod-gspca, et reboote ^^.


« …elle excitait si puissamment le désir, que je devins alors très incrédule sur sa vertu. »
À propos de Fœdora, dans la Peau de Chagrin (Balzac) roll

Hors ligne

#3 24/09/2008 19:16:11

Nightwatcher
Membre
Inscription : 05/03/2007
Messages : 112
Site Web

Re : [Résolu] Ma webcam - et GSPCA

J'ai tenté mais ca ne fonctionne pas

Hors ligne

#4 24/09/2008 19:18:01

Pikachu_2014
Retraité
Lieu : Boulogne-Billancourt
Inscription : 16/06/2005
Messages : 11 334
Site Web

Re : [Résolu] Ma webcam - et GSPCA

Nightwatcher a écrit :

J'ai tenté mais ca ne fonctionne pas

Mais encore ?


« …elle excitait si puissamment le désir, que je devins alors très incrédule sur sa vertu. »
À propos de Fœdora, dans la Peau de Chagrin (Balzac) roll

Hors ligne

#5 24/09/2008 19:57:20

Nightwatcher
Membre
Inscription : 05/03/2007
Messages : 112
Site Web

Re : [Résolu] Ma webcam - et GSPCA

ben ma cam n'est toujours aps reconnue sous camstream

Lors du premier reboot j'ai eu un message d'avertissement concernant le module.
J'ai aussi tenté avec le noyau récédent masi c'est pas mieux

Je vois pas trop...

Hors ligne

#6 24/09/2008 20:00:39

Nightwatcher
Membre
Inscription : 05/03/2007
Messages : 112
Site Web

Re : [Résolu] Ma webcam - et GSPCA

J'ai regardé au dmesg : j'ai ca qui revient de façon continue :
Unable to turn cooling device [df812f18] 'on'

est ce ma cam? un autre peripherique?
comment savoir....

Quand je branche ma cam "a chaud" j'ai ca au dmesg :
ACPI: Unable to turn cooling device [df812f18] 'on'
usb 4-1: new full speed USB device using uhci_hcd and address 3
usb 4-1: configuration #1 chosen from 1 choice
usb 4-1: ZC0301[P] Image Processor and Control Chip detected (vid/pid 0x0AC8:0x301B)
usb 4-1: PB-0330 image sensor detected
ACPI: Unable to turn cooling device [df812f18] 'on'
usb 4-1: Initialization succeeded
usb 4-1: V4L2 device registered as /dev/video0
usb 4-1: New USB device found, idVendor=0ac8, idProduct=301b
usb 4-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 4-1: Product: PC Camera
usb 4-1: Manufacturer: Vimicro Corp.

Dernière modification par Nightwatcher (24/09/2008 20:01:35)

Hors ligne

#7 24/09/2008 20:08:15

ambroizine
Membre
Inscription : 24/09/2008
Messages : 1

Re : [Résolu] Ma webcam - et GSPCA

fr.wikipedia.org/wiki/Free

Hors ligne

#8 24/09/2008 20:12:10

Nightwatcher
Membre
Inscription : 05/03/2007
Messages : 112
Site Web

Re : [Résolu] Ma webcam - et GSPCA

et??? ca m'aide pas bcp

Hors ligne

#9 24/09/2008 20:13:37

Pikachu_2014
Retraité
Lieu : Boulogne-Billancourt
Inscription : 16/06/2005
Messages : 11 334
Site Web

Re : [Résolu] Ma webcam - et GSPCA

Nightwatcher a écrit :

J'ai regardé au dmesg : j'ai ca qui revient de façon continue :
Unable to turn cooling device [df812f18] 'on'

est ce ma cam? un autre peripherique?
comment savoir....

Quand je branche ma cam "a chaud" j'ai ca au dmesg :
ACPI: Unable to turn cooling device [df812f18] 'on'
usb 4-1: new full speed USB device using uhci_hcd and address 3
usb 4-1: configuration #1 chosen from 1 choice
usb 4-1: ZC0301[P] Image Processor and Control Chip detected (vid/pid 0x0AC8:0x301B)
usb 4-1: PB-0330 image sensor detected
ACPI: Unable to turn cooling device [df812f18] 'on'
usb 4-1: Initialization succeeded
usb 4-1: V4L2 device registered as /dev/video0
usb 4-1: New USB device found, idVendor=0ac8, idProduct=301b
usb 4-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 4-1: Product: PC Camera
usb 4-1: Manufacturer: Vimicro Corp.

Ça a l'air très bon signe, ça. As-tu testé avec cheese ? Que renvoie au passage la commande suivante ?

$ ls -l /dev/video0

« …elle excitait si puissamment le désir, que je devins alors très incrédule sur sa vertu. »
À propos de Fœdora, dans la Peau de Chagrin (Balzac) roll

Hors ligne

#10 24/09/2008 20:22:36

Nightwatcher
Membre
Inscription : 05/03/2007
Messages : 112
Site Web

Re : [Résolu] Ma webcam - et GSPCA

voila :

crw-rw---- 1 root root 81, 0 sep 24 20:09 /dev/video0

Hors ligne

#11 24/09/2008 20:24:24

Pikachu_2014
Retraité
Lieu : Boulogne-Billancourt
Inscription : 16/06/2005
Messages : 11 334
Site Web

Re : [Résolu] Ma webcam - et GSPCA

Installe cheese et teste avec ce dernier, comme indiqué plus haut.


« …elle excitait si puissamment le désir, que je devins alors très incrédule sur sa vertu. »
À propos de Fœdora, dans la Peau de Chagrin (Balzac) roll

Hors ligne

#12 24/09/2008 20:27:53

Nightwatcher
Membre
Inscription : 05/03/2007
Messages : 112
Site Web

Re : [Résolu] Ma webcam - et GSPCA

avec cheese je n'ai aps d'image
peut etre un probleme de droit sur le periph?

enfin je sais pas

-------------------

j'ai testé cette commande :
chmod 666 /dev/video0

quand j'ouvre amsn et que je vais dans mes préférences, il semble trouver une webcam :
c'est ecrit v4l2: ZC0301 etc...
mais l'onglet de dessous, canal video est vide.. J'ai donc pas d'image

Encore plus etrange d'autant que dans camstream je n'ai toujours pas d'aimges ni de webcam détectée...

je continue mes recherches...

Rien non plus dans cheese....

Dernière modification par Nightwatcher (24/09/2008 21:17:57)

Hors ligne

Pied de page des forums