Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Arrêt de maintenance pour Fedora 28

#1 18/02/2007 17:09:03

Flying Hermes
Membre
Inscription : 13/02/2007
Messages : 333

Problème pour monter un disque avec ntfs-3g

Bonjour les experts,

Je souhaite accèder à mon dique dur amovible ntfs depuis linux
J'ai donc opté pour la solution ntfs-3g dont l'installation est décrit en détail sur le tuto ntfs-3g de ce forum. Je n'arrive cependant toujours pas à accèder à mon disque ntfs. Voici mes opérations :

1) J'ai téléchargé et installer les rpm requis

[root@localhost ~]# yum install fuse ntfs-3g

en vérifiant que les logiciel sont bien prises en compte

[root@localhost ~]# lsmod | grep fuse
fuse                   50261  0

2) J'ai définit un point d'accès

[root@localhost ~]# mkdir  /windows

3) J'ai modifié le fichier fstab en ajoutant la ligne :

/dev/sda1               /windows               ntfs-3g  silent,umask=0002,utf8=true

en ayant préalablement repéré mon disque

[root@localhost ~]# fdisk -l

Disk /dev/hda: 102.9 GB, 102935347200 bytes
255 heads, 63 sectors/track, 12514 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1          13      104391   83  Linux
/dev/hda2              14       12514   100414282+  8e  Linux LVM

Disk /dev/sda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1       14593   117218241    7  HPFS/NTFS

Cependant, malgès ces opérations, le disque ne se monte toujours pas

[root@localhost ~]# mount -a
$LogFile indicates unclean shutdown (0, 0). Please report to ntfs-3g-devel@lists.sf.net!
Failed to mount '/dev/sda1': Opération non supportée
Mount is denied because NTFS logfile is unclean. Choose one action:
   Boot Windows and shutdown it cleanly, or if you have a removable
   device then click the 'Safely Remove Hardware' icon in the Windows
   taskbar notification area before disconnecting it.
Or
   Run 'ntfsfix' on Linux unless you have Vista, then mount NTFS with
   the 'force' option read-write, or with the 'ro' option read-only.
Or
   Mount the NTFS volume with the 'ro' option in read-only mode.

J'ai bien basculer SELinux en mode permissif pour éviter qu'il rentre en conflit avec fuse. Par ailleurs, j'ai bien vérifier la compatibilité de mon kernel et de mon ntfs-3g

[root@localhost ~]# uname -a
Linux localhost.localdomain 2.6.19-1.2911.fc6 #1 SMP Sat Feb 10 15:51:47 EST 2007 i686 i686 i386 GNU/Linux
[root@localhost ~]# yum list installed ntfs-3g
Loading "installonlyn" plugin
Installed Packages
ntfs-3g.i386                             2:0-0.9.20070118.fc6   installed

J'ai vu que bon nombre de personne sont eu le même problème sur le forum. Ils ont tous réussit à le résoudre plus ou moins facilement donc le problème doit être tout bête. Mais là, je bloque !!!

Une petite aide serai donc la bienvenu messieurs les pros (et mesdames...pas de discriminations !!! wink)

En vous remerçiant.....Flying Hermes

Hors ligne

#2 18/02/2007 17:54:47

herrib
Retraité
Lieu : Rennes
Inscription : 04/12/2004
Messages : 3 736

Re : Problème pour monter un disque avec ntfs-3g

La réponse est indiquée:

 Mount is denied because NTFS logfile is unclean. Choose one action:
   Boot Windows and shutdown it cleanly, or if you have a removable
   device then click the 'Safely Remove Hardware' icon in the Windows
   taskbar notification area before disconnecting it.
Or
   Run 'ntfsfix' on Linux unless you have Vista, then mount NTFS with
   the 'force' option read-write, or with the 'ro' option read-only.

En d'autres termes, la partition ntfs que tu essaies de monter comporte des erreurs ou tout au moins, est marquée comme telle. Tu dois donc:

* lancer ntfsfix (voir: http://doc.fedora-fr.org/Ntfs-3g#Diffic … 3.A9ments), mais il te faudra probablement relancer Windows ensuite pour que chkdsk se lance;
* ou forcer l'ensemble en ajoutant --force à la ligne fstab (mais ce n'est pas réellement recommandé);
* ou directement relancer XP pour que chkdsk s'exécute à l'amorce.

Il n'y a rien de dramatique, en l'état.


Solaris 11, Scientific Linux 6.1. FC15 en virtualisation.

Hors ligne

#3 18/02/2007 18:20:02

Flying Hermes
Membre
Inscription : 13/02/2007
Messages : 333

Re : Problème pour monter un disque avec ntfs-3g

Merci de ta réponse.

J'ai téléchargé la parckage ntfsprogs, puis j'ai executé l'instruction ntfsfix.
Il y avait un message d'erreur concernant un problème lors du montage du disque.
J'ai donc fait comme tu as dit en lancant mon disque sur une machine windows en démontant proprement le disque dur amovible deux fois.

De retour sous linux avec mon disque j'ai alors :

[root@localhost ~]# ntfsfix /dev/sda1
Mounting volume... OK
Processing of $MFT and $MFTMirr completed successfully.
NTFS volume version is 3.1.
Setting required flags on partition... OK
Going to empty the journal ($LogFile)... OK
NTFS partition /dev/sda1 was processed successfully.

Tout semble donc fonctionner. Pourtant, j'obtient :

[root@localhost ~]# mount -a
Volume is scheduled for check.
Please boot into Windows TWICE, or use the 'force' mount option.

Le message me dit de refaire l'opération que je viens de faire (ce que j'ai fait) ou d'utiliser l'option "force", ce que, sous ton conseil, je ne préfère pas faire.

Ai-je raté une étape ou quelque chose ?

Hors ligne

#4 18/02/2007 18:28:56

herrib
Retraité
Lieu : Rennes
Inscription : 04/12/2004
Messages : 3 736

Re : Problème pour monter un disque avec ntfs-3g

Ntfsfix force généralement un chkdsk qui ne peut être exécuté qu'au lancement de Windows (ce que le tutorial expliquait).

Tu as procédé comme indiqué: ntfsfix -> reboot Windows avec chkdsk -> démontage correct. Mais comme le message l'indiquait, tu devais relancer Windows deux fois (Please boot into Windows TWICE): la première réalise le chkdsk, la seconde fois élimine le flag forçant la vérification.

Tu as  lancé à nouveau ntfsfix et dès lors, tu dois encore entrer dans le cycle décrit précédemment ...

Cela dit, la vérification a été opérée et tu peux utiliser l'option --force.


Nota: dans le tutorial, j'avais oublié le coup du double démarrage. Il m'avait étonné en son époque mais bon; on fait deux tours, on claque dans les mains, on crache en l'air et ça marche ... Je corrige le tuto en conséquence. Désolé pour cette imprécision. Cela dit, tu n'aurais pas du relancer ntfsfix après le boot Windows! Les choix étaient exclusifs.

Dernière modification par herrib (18/02/2007 18:32:40)


Solaris 11, Scientific Linux 6.1. FC15 en virtualisation.

Hors ligne

#5 18/02/2007 19:41:47

Flying Hermes
Membre
Inscription : 13/02/2007
Messages : 333

Re : Problème pour monter un disque avec ntfs-3g

Oui, j'ai booté 2 fois mon pc windows avec le disque dur avant de le mettre sous linux ms le problème persiste. A chaque fois, j'ai démonté le disque dur "proprement".

Est-ce vraiment cette opération qu'il faut faire ?

1) Brancher le disque dur sur le pc windows
2) Redémarrer le PC
3) Démonter le disque proprement
4) Puis répéter l'opération

Lorsque je tente de monter le disque sous linux j'ai le même message que dans mon post précédent. Dois-j utiliser l'option "force" ?

Désolé je bloque sur un détail

Hors ligne

#6 18/02/2007 19:51:19

herrib
Retraité
Lieu : Rennes
Inscription : 04/12/2004
Messages : 3 736

Re : Problème pour monter un disque avec ntfs-3g

Tente de ne pas démonter le disque et de re démarrer.

Si ça ne marche toujours pas, passe à l'option --force.

Dernière modification par herrib (18/02/2007 19:51:58)


Solaris 11, Scientific Linux 6.1. FC15 en virtualisation.

Hors ligne

#7 21/02/2007 00:14:16

Flying Hermes
Membre
Inscription : 13/02/2007
Messages : 333

Re : Problème pour monter un disque avec ntfs-3g

salut,

Peut-tu m'expliciter la ligne de commande à ajouter dans /etc/stab avec la commande force stp

Merci

Dernière modification par Flying Hermes (21/02/2007 00:16:21)

Hors ligne

#8 21/02/2007 11:39:07

herrib
Retraité
Lieu : Rennes
Inscription : 04/12/2004
Messages : 3 736

Re : Problème pour monter un disque avec ntfs-3g

Le forum support ntfs-3g indique les modalités d'utilisation de l'option.

Dans ton cas, la ligne serait:

/dev/hda1               /windows               ntfs-3g  umask=0002,utf8=true,force

Dernière modification par herrib (21/02/2007 11:40:24)


Solaris 11, Scientific Linux 6.1. FC15 en virtualisation.

Hors ligne

#9 21/02/2007 14:07:37

Flying Hermes
Membre
Inscription : 13/02/2007
Messages : 333

Re : Problème pour monter un disque avec ntfs-3g

Ne serait-ce pas

/dev/sda1               /windows               ntfs-3g  umask=0002,utf8=true,force

plutot

Hors ligne

#10 21/02/2007 14:12:16

herrib
Retraité
Lieu : Rennes
Inscription : 04/12/2004
Messages : 3 736

Re : Problème pour monter un disque avec ntfs-3g

oui!


Solaris 11, Scientific Linux 6.1. FC15 en virtualisation.

Hors ligne

Pied de page des forums