Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Clap de fin pour Fedora Linux 35 !

#1 19/11/2022 12:51:31

thierryR
Membre
Lieu : Chalons en Champagne
Inscription : 31/01/2011
Messages : 1 932

Smplayer en panne

Bonjour. J'avais smplayer en panne avec la 36. J'ai installer la 37 mais le problème persiste:

/usr/bin/mplayer -noquiet -slave -identify -nofs -sub-fuzziness 1 -vo xv,x11, -nodr -double -nomouseinput -input nodefault-bindings:conf=/dev/null -nokeepaspect -wid 5 -monitorpixelaspect 1 -osdlevel 0 -subfont-osd-scale 3 -progbar-align 80 -ass -embeddedfonts -ass-line-spacing 0 -ass-font-scale 1 -noflip-hebrew -ass-styles /home/thierry/.config/smplayer/styles.ass -subcp ISO-8859-1 -subpos 100 -volume 100 -vf-add screenshot=/home/thierry/Images/smplayer_screenshots/shot -noslices -af-add scaletempo -softvol -softvol-max 110 /tmp/pid-1836/Sandra Berset.mp4

MPlayer SVN-r38369-12 (C) 2000-2022 MPlayer Team
do_connect: could not connect to socket
connect: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /tmp/pid-1836/Sandra Berset.mp4.
libavformat version 59.27.100 (external)
libavformat file format detected.
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x7f188e077820]Protocol name not provided, cannot determine if input is local or a network protocol, buffers and access patterns cannot be configured optimally without knowing the protocol
ID_VIDEO_ID=0
[lavf] stream 0: video (h264), -vid 0
ID_AUDIO_ID=0
[lavf] stream 1: audio (aac), -aid 0, -alang und
VIDEO:  [H264]  340x424  24bpp  29.970 fps  305.2 kbps (37.3 kbyte/s)
X11 error: BadMatch (invalid parameter attributes)
Opening video filter: [ass auto=1]
[ass] auto-open
Opening video filter: [screenshot=/home/thierry/Images/smplayer_screenshots/shot]
[ass] libass API version: 0x1600000
[ass] libass source: tarball: 0.16.0
[ass] Shaper: FriBidi 1.0.12 (SIMPLE) HarfBuzz-ng 5.2.0 (COMPLEX)
[ass] Using font provider fontconfig
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
libavcodec version 59.37.100 (external)
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
ID_VIDEO_CODEC=ffh264
Clip info:
 major_brand: isom
ID_CLIP_INFO_NAME0=major_brand
ID_CLIP_INFO_VALUE0=isom
 minor_version: 512
ID_CLIP_INFO_NAME1=minor_version
ID_CLIP_INFO_VALUE1=512
 compatible_brands: isomiso2avc1mp41
ID_CLIP_INFO_NAME2=compatible_brands
ID_CLIP_INFO_VALUE2=isomiso2avc1mp41
 title: Sandra Berset
ID_CLIP_INFO_NAME3=title
ID_CLIP_INFO_VALUE3=Sandra Berset
 encoder: Lavf58.29.100
ID_CLIP_INFO_NAME4=encoder
ID_CLIP_INFO_VALUE4=Lavf58.29.100
ID_CLIP_INFO_N=5
Load subtitles in /tmp/pid-1836/
ID_FILENAME=/tmp/pid-1836/Sandra Berset.mp4
ID_DEMUXER=lavfpref
ID_VIDEO_FORMAT=H264
ID_VIDEO_BITRATE=305208
ID_VIDEO_WIDTH=340
ID_VIDEO_HEIGHT=424
ID_VIDEO_FPS=29.970
ID_VIDEO_ASPECT=0.0000
ID_AUDIO_FORMAT=MP4A
ID_AUDIO_BITRATE=48016
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=2
ID_START_TIME=0.00
ID_LENGTH=187.46
ID_SEEKABLE=1
ID_CHAPTERS=0
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 48000 Hz, 2 ch, floatle, 48.0 kbit/1.56% (ratio: 6002->384000)
ID_AUDIO_BITRATE=48016
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=2
Selected audio codec: [ffaac] afm: ffmpeg (FFmpeg AAC (MPEG-2/MPEG-4 Audio))
==========================================================================
AO: [pulse] 48000Hz 2ch floatle (4 bytes per sample)
ID_AUDIO_CODEC=ffaac
[Mixer] No hardware mixing, inserting volume filter.
Starting playback...
Movie-Aspect is 0.80:1 - prescaling to correct movie aspect.
ID_VIDEO_ASPECT=0.8000
[swscaler @ 0x7f188e227ac0]bicubic scaler, from yuv420p to rgb24 using MMXEXT
[swscaler @ 0x7f188e227ac0]using unscaled yuv420p -> rgb24 special converter
VO: [xv] 340x424 => 340x424 Planar YV12 
X11 error: BadWindow (invalid Window parameter)
X11 error: BadWindow (invalid Window parameter)
X11 error: BadDrawable (invalid Pixmap or Window parameter)
X11 error: BadWindow (invalid Window parameter)
X11 error: BadDrawable (invalid Pixmap or Window parameter)
X11 error: BadWindow (invalid Window parameter)
X11 error: BadDrawable (invalid Pixmap or Window parameter)
X11 error: BadWindow (invalid Window parameter)

X11 error: BadDrawable (invalid Pixmap or Window parameter)
X11 error: BadDrawable (invalid Pixmap or Window parameter)
X11 error: BadWindow (invalid Window parameter)


MPlayer interrupted by signal 8 in module: filter video
ID_SIGNAL=8
- MPlayer crashed by bad usage of CPU/FPU/RAM.
  Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
  disassembly. Details in DOCS/HTML/en/bugreports_what.html#bugreports_crash.
- MPlayer crashed. This shouldn't happen.
  It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
  gcc version. If you think it's MPlayer's fault, please read
  DOCS/HTML/en/bugreports.html and follow the instructions there. We can't and
  won't help unless you provide this information when reporting a possible bug.

201119024340877569.gifChalons en Champagne: Au nord, un peu avant la banquise (Ah ben non... Elle a fondu)
Kernel: 6.0.12-300.fc37.x86_64 arch: x86_64 bits: 64 Desktop: KDE Plasma v: 5.26.4
Type: Desktop Mobo: ASRock model: X470 Gaming-ITX/ac  UEFI: CPU: Topology: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP L2 cache: 4096 KiB

Hors ligne

#2 19/11/2022 12:53:27

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 19 090
Site Web

Re : Smplayer en panne

Tu as quoi comme carte graphique?


AMD R7 5800x X470 64Go DDR4 3.6Ghz, RX5700XT + AMD R7 2700x A320 + 32Go DDR4 3.2Ghz, rx6500xt 4Go
AMD R5 5600g B550 itx, 32Go +AMD R5 2600 A320,1030GT, 16Go + AMD A6 9500 A320, 8Go
Rpi4 4go

Hors ligne

#3 19/11/2022 12:54:45

thierryR
Membre
Lieu : Chalons en Champagne
Inscription : 31/01/2011
Messages : 1 932

Re : Smplayer en panne

inxi -G
Graphics:
  Device-1: AMD Cedar [Radeon HD 5000/6000/7350/8350 Series] driver: radeon
    v: kernel
  Display: wayland server: X.org v: 1.20.14 with: Xwayland v: 22.1.5
    compositor: kwin_wayland driver: X: loaded: radeon
    unloaded: fbdev,modesetting,vesa dri: r600 gpu: radeon
    resolution: 1920x1080
  OpenGL: renderer: AMD CEDAR (DRM 2.50.0 / 6.0.8-300.fc37.x86_64 LLVM
    15.0.0) v: 3.3 Mesa 22.2.3

201119024340877569.gifChalons en Champagne: Au nord, un peu avant la banquise (Ah ben non... Elle a fondu)
Kernel: 6.0.12-300.fc37.x86_64 arch: x86_64 bits: 64 Desktop: KDE Plasma v: 5.26.4
Type: Desktop Mobo: ASRock model: X470 Gaming-ITX/ac  UEFI: CPU: Topology: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP L2 cache: 4096 KiB

Hors ligne

#4 19/11/2022 12:57:50

VINDICATORs
RédactWikix and the graphicatorix!
Modérateur
Lieu : Toulouse(31) France
Inscription : 23/11/2004
Messages : 19 090
Site Web

Re : Smplayer en panne

Bon même problème sur RX5700XT.

J'ai le son mais la vidéo... Et même en modifiant le pilote de sortie...

A voir avec VLC.

Édit : aucun problème même avec l'accélération vidéo (utilisation des paquets mesa-va/vdpau-freeworld que ce soit de Rpmfusion, que Mesa-Git).

Dernière modification par VINDICATORs (19/11/2022 12:59:35)


AMD R7 5800x X470 64Go DDR4 3.6Ghz, RX5700XT + AMD R7 2700x A320 + 32Go DDR4 3.2Ghz, rx6500xt 4Go
AMD R5 5600g B550 itx, 32Go +AMD R5 2600 A320,1030GT, 16Go + AMD A6 9500 A320, 8Go
Rpi4 4go

Hors ligne

#5 19/11/2022 12:58:08

thierryR
Membre
Lieu : Chalons en Champagne
Inscription : 31/01/2011
Messages : 1 932

Re : Smplayer en panne

La vidéo fonctionne avec VLC, dragon player, kaffeine


201119024340877569.gifChalons en Champagne: Au nord, un peu avant la banquise (Ah ben non... Elle a fondu)
Kernel: 6.0.12-300.fc37.x86_64 arch: x86_64 bits: 64 Desktop: KDE Plasma v: 5.26.4
Type: Desktop Mobo: ASRock model: X470 Gaming-ITX/ac  UEFI: CPU: Topology: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP L2 cache: 4096 KiB

Hors ligne

#6 19/11/2022 13:08:08

thierryR
Membre
Lieu : Chalons en Champagne
Inscription : 31/01/2011
Messages : 1 932

Re : Smplayer en panne

Smplayer fonctionne sur kdeneon donc l'appli semble bonne au départ. Il doit manquer un truc dans fedora.


201119024340877569.gifChalons en Champagne: Au nord, un peu avant la banquise (Ah ben non... Elle a fondu)
Kernel: 6.0.12-300.fc37.x86_64 arch: x86_64 bits: 64 Desktop: KDE Plasma v: 5.26.4
Type: Desktop Mobo: ASRock model: X470 Gaming-ITX/ac  UEFI: CPU: Topology: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP L2 cache: 4096 KiB

Hors ligne

#7 09/12/2022 22:55:55

thierryR
Membre
Lieu : Chalons en Champagne
Inscription : 31/01/2011
Messages : 1 932

Re : Smplayer en panne

La série continue. Kafféine beug après environ 2 minutes de vision.
Ça va mal pour ces logiciels. Heureusement VLC fonctionne.


201119024340877569.gifChalons en Champagne: Au nord, un peu avant la banquise (Ah ben non... Elle a fondu)
Kernel: 6.0.12-300.fc37.x86_64 arch: x86_64 bits: 64 Desktop: KDE Plasma v: 5.26.4
Type: Desktop Mobo: ASRock model: X470 Gaming-ITX/ac  UEFI: CPU: Topology: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP L2 cache: 4096 KiB

Hors ligne

Pied de page des forums