Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora 37 Beta est disponible

#1 16/05/2022 22:12:35

RayComet
Membre
Inscription : 28/08/2017
Messages : 290

Nombreux paquets en conflit

Suite à un "dnf update", je reçois ce message :

Test de la transaction
La vérification de la transaction a réussi.
Lancement de la transaction de test
Les paquets téléchargés ont été mis en cache jusqu’à la prochaine transaction réussie.
Vous pouvez supprimer les paquets en cache en exécutant « dnf clean packages ».
Erreur : Erreur de la transaction de test :
  le fichier /usr/share/gcc-12/python/libstdcxx/__pycache__/__init__.cpython-310.opt-1.pyc de l'installation de libstdc++-12.1.1-1.fc36.i686 entre en conflit avec le fichier du paquet libstdc++-12.0.1-0.16.fc36.x86_64
  le fichier /usr/share/gcc-12/python/libstdcxx/__pycache__/__init__.cpython-310.pyc de l'installation de libstdc++-12.1.1-1.fc36.i686 entre en conflit avec le fichier du paquet libstdc++-12.0.1-0.16.fc36.x86_64
  le fichier /usr/share/gcc-12/python/libstdcxx/v6/__pycache__/__init__.cpython-310.opt-1.pyc de l'installation de libstdc++-12.1.1-1.fc36.i686 entre en conflit avec le fichier du paquet libstdc++-12.0.1-0.16.fc36.x86_64
  le fichier /usr/share/gcc-12/python/libstdcxx/v6/__pycache__/__init__.cpython-310.pyc de l'installation de libstdc++-12.1.1-1.fc36.i686 entre en conflit avec le fichier du paquet libstdc++-12.0.1-0.16.fc36.x86_64
  le fichier /usr/share/gcc-12/python/libstdcxx/v6/__pycache__/printers.cpython-310.opt-1.pyc de l'installation de libstdc++-12.1.1-1.fc36.i686 entre en conflit avec le fichier du paquet libstdc++-12.0.1-0.16.fc36.x86_64
  le fichier /usr/share/gcc-12/python/libstdcxx/v6/__pycache__/printers.cpython-310.pyc de l'installation de libstdc++-12.1.1-1.fc36.i686 entre en conflit avec le fichier du paquet libstdc++-12.0.1-0.16.fc36.x86_64
  le fichier /usr/share/gcc-12/python/libstdcxx/v6/__pycache__/xmethods.cpython-310.opt-1.pyc de l'installation de libstdc++-12.1.1-1.fc36.i686 entre en conflit avec le fichier du paquet libstdc++-12.0.1-0.16.fc36.x86_64
  le fichier /usr/share/gcc-12/python/libstdcxx/v6/__pycache__/xmethods.cpython-310.pyc de l'installation de libstdc++-12.1.1-1.fc36.i686 entre en conflit avec le fichier du paquet libstdc++-12.0.1-0.16.fc36.x86_64
  le fichier /usr/share/gcc-12/python/libstdcxx/v6/printers.py de l'installation de libstdc++-12.1.1-1.fc36.i686 entre en conflit avec le fichier du paquet libstdc++-12.0.1-0.16.fc36.x86_64
  le fichier /usr/share/locale/en@boldquot/LC_MESSAGES/elfutils.mo de l'installation de elfutils-libelf-0.187-4.fc36.i686 entre en conflit avec le fichier du paquet elfutils-libelf-0.186-3.fc36.x86_64
  le fichier /usr/share/locale/en@quot/LC_MESSAGES/elfutils.mo de l'installation de elfutils-libelf-0.187-4.fc36.i686 entre en conflit avec le fichier du paquet elfutils-libelf-0.186-3.fc36.x86_64
  le fichier /usr/share/locale/es/LC_MESSAGES/elfutils.mo de l'installation de elfutils-libelf-0.187-4.fc36.i686 entre en conflit avec le fichier du paquet elfutils-libelf-0.186-3.fc36.x86_64
  le fichier /usr/share/locale/ja/LC_MESSAGES/elfutils.mo de l'installation de elfutils-libelf-0.187-4.fc36.i686 entre en conflit avec le fichier du paquet elfutils-libelf-0.186-3.fc36.x86_64
  le fichier /usr/share/locale/pl/LC_MESSAGES/elfutils.mo de l'installation de elfutils-libelf-0.187-4.fc36.i686 entre en conflit avec le fichier du paquet elfutils-libelf-0.186-3.fc36.x86_64
  le fichier /usr/share/locale/uk/LC_MESSAGES/elfutils.mo de l'installation de elfutils-libelf-0.187-4.fc36.i686 entre en conflit avec le fichier du paquet elfutils-libelf-0.186-3.fc36.x86_64
  le fichier /usr/share/doc/gnutls/AUTHORS de l'installation de gnutls-3.7.4-1.fc36.i686 entre en conflit avec le fichier du paquet gnutls-3.7.3-2.fc36.x86_64
  le fichier /usr/share/doc/gnutls/NEWS de l'installation de gnutls-3.7.4-1.fc36.i686 entre en conflit avec le fichier du paquet gnutls-3.7.3-2.fc36.x86_64
  le fichier /usr/share/doc/gnutls/README.md de l'installation de gnutls-3.7.4-1.fc36.i686 entre en conflit avec le fichier du paquet gnutls-3.7.3-2.fc36.x86_64
  le fichier /usr/share/locale/ms/LC_MESSAGES/gnutls.mo de l'installation de gnutls-3.7.4-1.fc36.i686 entre en conflit avec le fichier du paquet gnutls-3.7.3-2.fc36.x86_64
  le fichier /usr/share/doc/glib2/NEWS de l'installation de glib2-2.72.1-1.fc36.i686 entre en conflit avec le fichier du paquet glib2-2.72.0-2.fc36.x86_64
  le fichier /usr/share/locale/bg/LC_MESSAGES/glib20.mo de l'installation de glib2-2.72.1-1.fc36.i686 entre en conflit avec le fichier du paquet glib2-2.72.0-2.fc36.x86_64
  le fichier /usr/share/locale/ca/LC_MESSAGES/glib20.mo de l'installation de glib2-2.72.1-1.fc36.i686 entre en conflit avec le fichier du paquet glib2-2.72.0-2.fc36.x86_64
  le fichier /usr/share/locale/id/LC_MESSAGES/glib20.mo de l'installation de glib2-2.72.1-1.fc36.i686 entre en conflit avec le fichier du paquet glib2-2.72.0-2.fc36.x86_64
  le fichier /usr/share/locale/it/LC_MESSAGES/glib20.mo de l'installation de glib2-2.72.1-1.fc36.i686 entre en conflit avec le fichier du paquet glib2-2.72.0-2.fc36.x86_64
  le fichier /usr/share/locale/lt/LC_MESSAGES/glib20.mo de l'installation de glib2-2.72.1-1.fc36.i686 entre en conflit avec le fichier du paquet glib2-2.72.0-2.fc36.x86_64
  le fichier /usr/share/locale/pl/LC_MESSAGES/glib20.mo de l'installation de glib2-2.72.1-1.fc36.i686 entre en conflit avec le fichier du paquet glib2-2.72.0-2.fc36.x86_64
  le fichier /usr/share/locale/pt/LC_MESSAGES/glib20.mo de l'installation de glib2-2.72.1-1.fc36.i686 entre en conflit avec le fichier du paquet glib2-2.72.0-2.fc36.x86_64
  le fichier /usr/share/locale/ru/LC_MESSAGES/glib20.mo de l'installation de glib2-2.72.1-1.fc36.i686 entre en conflit avec le fichier du paquet glib2-2.72.0-2.fc36.x86_64
  le fichier /usr/share/locale/sl/LC_MESSAGES/glib20.mo de l'installation de glib2-2.72.1-1.fc36.i686 entre en conflit avec le fichier du paquet glib2-2.72.0-2.fc36.x86_64
  le fichier /usr/share/locale/sv/LC_MESSAGES/glib20.mo de l'installation de glib2-2.72.1-1.fc36.i686 entre en conflit avec le fichier du paquet glib2-2.72.0-2.fc36.x86_64
  le fichier /usr/share/locale/tr/LC_MESSAGES/glib20.mo de l'installation de glib2-2.72.1-1.fc36.i686 entre en conflit avec le fichier du paquet glib2-2.72.0-2.fc36.x86_64
  le fichier /usr/share/locale/uk/LC_MESSAGES/glib20.mo de l'installation de glib2-2.72.1-1.fc36.i686 entre en conflit avec le fichier du paquet glib2-2.72.0-2.fc36.x86_64
  le fichier /usr/share/man/man1/gapplication.1.gz de l'installation de glib2-2.72.1-1.fc36.i686 entre en conflit avec le fichier du paquet glib2-2.72.0-2.fc36.x86_64
  le fichier /usr/share/man/man1/gdbus.1.gz de l'installation de glib2-2.72.1-1.fc36.i686 entre en conflit avec le fichier du paquet glib2-2.72.0-2.fc36.x86_64
  le fichier /usr/share/man/man1/gio-querymodules.1.gz de l'installation de glib2-2.72.1-1.fc36.i686 entre en conflit avec le fichier du paquet glib2-2.72.0-2.fc36.x86_64
  le fichier /usr/share/man/man1/gio.1.gz de l'installation de glib2-2.72.1-1.fc36.i686 entre en conflit avec le fichier du paquet glib2-2.72.0-2.fc36.x86_64
  le fichier /usr/share/man/man1/glib-compile-schemas.1.gz de l'installation de glib2-2.72.1-1.fc36.i686 entre en conflit avec le fichier du paquet glib2-2.72.0-2.fc36.x86_64
  le fichier /usr/share/man/man1/gsettings.1.gz de l'installation de glib2-2.72.1-1.fc36.i686 entre en conflit avec le fichier du paquet glib2-2.72.0-2.fc36.x86_64
  le fichier /usr/share/doc/freetype/README de l'installation de freetype-2.12.1-1.fc36.i686 entre en conflit avec le fichier du paquet freetype-2.11.1-2.fc36.x86_64
  le fichier /usr/share/doc/libgomp/ChangeLog.bz2 de l'installation de libgomp-12.1.1-1.fc36.i686 entre en conflit avec le fichier du paquet libgomp-12.0.1-0.16.fc36.x86_64
  le fichier /usr/share/doc/pango/NEWS de l'installation de pango-1.50.7-1.fc36.i686 entre en conflit avec le fichier du paquet pango-1.50.6-1.fc36.x86_64
  le fichier /usr/share/man/man1/pango-view.1.gz de l'installation de pango-1.50.7-1.fc36.i686 entre en conflit avec le fichier du paquet pango-1.50.6-1.fc36.x86_64
  le fichier /usr/share/doc/libxml2/NEWS de l'installation de libxml2-2.9.14-1.fc36.i686 entre en conflit avec le fichier du paquet libxml2-2.9.13-1.fc36.x86_64

Que dois-je faire ? Attendre les prochains correctifs ? Mon ordinateur semble fonctionner normalement...
Merci !

Hors ligne

#2 16/05/2022 23:19:01

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 23 739

Re : Nombreux paquets en conflit

Pour quelle raison tu as des paquets en i686 ?

essaie de les virer pour voir sauf s'ils entrainent trop de dépendances.


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#3 17/05/2022 07:20:57

xylphute
Membre
Inscription : 22/12/2021
Messages : 93

Re : Nombreux paquets en conflit

bonjour,

as tu essayé

# dnf upgrade --allowerasing

(juste pour la culture, dnf update est une commande dépreciée, mais ça fait le même résultat que dnf upgrade)

Dernière modification par xylphute (17/05/2022 07:22:45)

Hors ligne

Pied de page des forums