Fedora-Fr - Communauté francophone Fedora - Linux

Communauté francophone des utilisateurs de la distribution Linux Fedora.

  

Dernière news : Fedora 34 n'est plus maintenu

#1 16/02/2022 10:58:42

sptaule
Membre
Inscription : 16/02/2022
Messages : 6

Nvidia akmod désactivé après update

Bonjour,

je suis nouveau dans le monde de Fedora et je rencontre un petit souci.
Lorsque je dois faire des mises à jour système et que ce dernier les installe au redémarrage, à chaque fois il réactive le pilote 'nouveau'.
Donc à chaque fois que je suis embêté je tape dans la console

sudo dnf update akmod-nvidia

mais généralement il y a pas de màj.
Je tape ensuite

sudo akmods --force

et je n'obtiens aucune erreur :

Checking kmods exist for 5.16.8-200.fc35.x86_64            [  OK  ]

A ce moment là, je n'ai qu'à redémarrer mon pc et tout revient dans l'ordre.

Auriez-vous une idée pourquoi à chaque màj système je doive faire cette manipulation ? Merci ! smile

Hors ligne

#2 16/02/2022 11:55:28

Nicosss
Rédacteur Wiki
Rédacteur Wiki
Lieu : Isère
Inscription : 05/03/2007
Messages : 7 371
Site Web

Re : Nvidia akmod désactivé après update

Bienvenue parmi nous.

Quel est ta carte et comment as-tu installé le pilote Nvidia ?
Qu'est-ce qui te fait dire que le pilote nouveau est chargé ?


F35_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F36_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F35_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

#3 16/02/2022 12:02:14

sptaule
Membre
Inscription : 16/02/2022
Messages : 6

Re : Nvidia akmod désactivé après update

Bonjour et merci,

Ma carte est la nvidia GTX 1050 et j'ai suivi le tuto sur https://rpmfusion.org/Howto/NVIDIA

Ce qui me fait dire que le pilote nouveau est chargé c'est qu'au démarrage, c'est beaucoup plus lent que d'habitude, le loading screen de Fedora est en mauvaise résolution par rapport à mon écran, qu'à la fin du chargement, j'ai très rapidement le message "NVIDIA kernel module missing. Falling back to nouveau" qui s'affiche, et gnome n'est pas très fluide dans ses actions et il y a beaucoup de saccades.
Après j'ai bien l'impression que le pilote akmod est correctement installé mais je ne comprends pas pour quelle raison lors d'une màj système il pose problème..

Hors ligne

#4 16/02/2022 13:12:29

Refuznik
Membre
Inscription : 31/01/2007
Messages : 8 079

Re : Nvidia akmod désactivé après update

Le tuto est correct par contre ils ont oublié le blocage de nouveau dans grub.
Exemple :

rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1

L'as tu fait ?

Hors ligne

#5 16/02/2022 13:17:06

Nicosss
Rédacteur Wiki
Rédacteur Wiki
Lieu : Isère
Inscription : 05/03/2007
Messages : 7 371
Site Web

Re : Nvidia akmod désactivé après update

Je n'utilise pas de carte Nvidia. Par contre je me demande pourquoi cela est aléatoire concernant le pilote nouveau.

Sur une prochaine mise à jour de kernel, tu pourrais donner le retour de la commande suivante après la mise  à jour et suite à ta manipulation... même si je pense que qu'elle n'a pas d'impact et peut-être qu'un simple redémarrage suffit.

$ dmesg

F35_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F36_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F35_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

#6 16/02/2022 13:41:28

sptaule
Membre
Inscription : 16/02/2022
Messages : 6

Re : Nvidia akmod désactivé après update

Merci à vous pour vos réponses

effectivement, je n'ai pas du tout pensé au blocage du pilote nouveau
je vous tiendrais au courant de mon avancée !

Hors ligne

#7 16/02/2022 13:54:05

Nicosss
Rédacteur Wiki
Rédacteur Wiki
Lieu : Isère
Inscription : 05/03/2007
Messages : 7 371
Site Web

Re : Nvidia akmod désactivé après update

Tu as quoi dans ton fichier /etc/default/grub ?

$ cat /etc/default/grub

Tu peux toujours donner un premier retour de dmesg aussi.


F35_64 Gnome-Shell - GA-990FXA-UD3 - Phenom II X6 1100T - NH-D14 - Ati HD 5750 Fanless - 16Go RAM /&/ F36_64 Gnome-Shell - Toshiba Satellite C660D-19X - 8Go RAM
F35_64 - ASRock 960GC-GS FX - AMD FX(tm)-8300 - 16Go RAM

Hors ligne

#8 16/02/2022 15:51:25

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 23 628

Re : Nvidia akmod désactivé après update

Perso je pense que akmods ne construit pas le nouveau module au moment de la mise à jour, pour une raison que j'ignore, mais qu'il le fait soit à la fermeture soit lors du redémarrage suivant.


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#9 16/02/2022 16:29:04

chepioq
FEDORA FOR EVER
Lieu : a l'est de marseille
Inscription : 07/06/2006
Messages : 7 440

Re : Nvidia akmod désactivé après update

nouvo09 a écrit :

Perso je pense que akmods ne construit pas le nouveau module au moment de la mise à jour, pour une raison que j'ignore, mais qu'il le fait soit à la fermeture soit lors du redémarrage suivant.

Désolé de te contredire, mais akmods construit le module nvidia dès qu'il y a un nouveau kernel installé.
C'est ce qui se passe chez moi, par contre il faut être patient, car non seulement il construit, mais en plus il l'installe, et il faut attendre que ce soit terminé avant de fermer dnf.


Tout est dans tout... et réciproquement...
C'est quoi un chalumeau??? C'est un dromaludaire à deux bosses...
Quand le sage montre la lune l'imbécile regarde le doigt...

Hors ligne

#10 16/02/2022 17:56:22

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 23 628

Re : Nvidia akmod désactivé après update

Alors je pensais mal. Désolé.


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#11 17/02/2022 11:12:14

sptaule
Membre
Inscription : 16/02/2022
Messages : 6

Re : Nvidia akmod désactivé après update

Bonjour, voici le contenu de /etc/default/grub
Manifestement, le blocage du pilote nouveau à l'air d'être en place

GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=true
GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX="rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1"
GRUB_DISABLE_RECOVERY="true"
GRUB_ENABLE_BLSCFG=true

Voici aussi le log dmesg : https://gist.github.com/sptaule/008313f … be7a818f78

Hors ligne

#12 17/02/2022 11:59:42

Refuznik
Membre
Inscription : 31/01/2007
Messages : 8 079

Re : Nvidia akmod désactivé après update

Pourrais je savoir pourquoi tu as le blocage en double sur la ligne ?
Le dmesg est correct. Petite question tu es sur que ton boot n'est pas en uefi ce qui sous entendrais qu'il n'utilise pas ce grub ?

Hors ligne

#13 17/02/2022 12:10:14

sptaule
Membre
Inscription : 16/02/2022
Messages : 6

Re : Nvidia akmod désactivé après update

Honnêtement j'en ai pas la moindre idée ! Si ça ne pose pas de problème je vais éliminer le doublon..
Comment puis-je savoir si mon boot est en uefi ou non ?
Merci

Hors ligne

#14 17/02/2022 12:26:57

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 23 628

Re : Nvidia akmod désactivé après update

Comment puis-je savoir si mon boot est en uefi ou non ?

Où se trouve ton fichier grub.cfg ?


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#15 17/02/2022 12:33:34

sptaule
Membre
Inscription : 16/02/2022
Messages : 6

Re : Nvidia akmod désactivé après update

Il me semble qu'il est ici :

/boot/efi/EFI/fedora/grub.cfg

search --no-floppy --fs-uuid --set=dev d8d4dc7f-012a-4c6c-bcc0-26d37b05358c
set prefix=($dev)/grub2

export $prefix
configfile $prefix/grub.cfg

Hors ligne

#16 17/02/2022 13:11:40

nouvo09
Accro à Fedo !
Lieu : Paris
Inscription : 22/09/2005
Messages : 23 628

Re : Nvidia akmod désactivé après update

Voilà tu as la réponse alors.


C'est pas parce que c'est difficile qu'on n'ose pas,
c'est parce qu'on ose pas que c'est difficile !

Hors ligne

#17 17/02/2022 15:45:23

pierrotlalune
Membre
Lieu : Sousceyrac (46)
Inscription : 31/10/2011
Messages : 846

Re : Nvidia akmod désactivé après update

sptaule a écrit :

Comment puis-je savoir si mon boot est en uefi ou non ?
Merci

Bonjour sptaule,
en lançant en tant que "user" ceci:

[ -d /sys/firmware/efi ] && echo "Session EFI" || echo "Session non-EFI"

a+
pll

Hors ligne

Pied de page des forums